Změna, odstranění a vkládání záznamů ve zobrazení dat

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Po vytvoření zobrazení dat se zdrojem dat v podobě knihovny nebo seznamu služby SharePoint, databáze SQL nebo souboru XML lze snadno přidat odkazy pro úpravu, odstranění nebo vkládání položek do zdroje dat pomocí webového prohlížeče.

Příklad: Společnost Northwind Traders zabývající se distribucí lahůdek sleduje své skladové zásoby v souboru XML. Když jsou zásoby nízké, zavolá člen týmu dodavatele daného produktu a zadá objednávku. Navrhuje se, aby byly přidány odkazy pro úpravu zobrazení dat, pomocí nichž by mohl člen týmu zadávající objednávku ihned aktualizovat množství objednaného zboží. Do zobrazení dat je rovněž možné přidat odkazy na vložení a odstranění záznamu, pomocí nichž mohou členové týmu přidávat nebo odebírat jednotlivé položky. Pomocí tohoto systému bude mít společnost Northwind Traders vždy nejnovější informace o stavu svých skladů.

Tento článek ukazuje, jak přidat, upravit, odstranění a vkládání odkazů do stávajícího zobrazení dat. Vytvoření ukázkových dat a zobrazení dat, které se používají v příkladu nebo Další informace o zobrazení dat naleznete v článku Vytvoření zobrazení dat.

V tomto článku

Než začnete

Přidání odkazů na změna, odstranění a vkládání záznamů v zobrazení dat

Změna, odstranění a vkládání položky pomocí prohlížeče

Přizpůsobení šablony upravit nebo vložení

Než začnete

V aplikaci Microsoft Office SharePoint Designer 2007 jsou k dispozici dvě funkce umožňující uživatelům úpravu dat ve zobrazení dat pomocí webového prohlížeče.

  • Přidání odkazů do stávajícího zobrazení dat.     Do stávajícího zobrazení dat lze přidat odkazy a umožnit tak uživatelům upravovat, odstraňovat nebo vkládat záznamy do zdroje dat. Položky lze převést do režimu úprav klepnutím na odkaz pro úpravy. Přidáte-li odkazy do zobrazení dat vloženého jako formulář, nahradí tyto odkazy tlačítka formuláře. Jestliže přidáte odkazy do zobrazení dat vloženého jako formulář, nebude toto zobrazení dat nadále ve výchozím nastavení zobrazovat pole formuláře, ale pouze data.

  • Vložení zobrazení dat jako formuláře     Při vytváření zobrazení dat, můžete vložit jako formulář s jednou položkou nebo víc položkami. Formulář je vždy v režimu úprav a zobrazí jednu nebo více záznamů. Uživatelé mohou upravovat stávající záznamy pomocí prohlížeče, ale nelze vložit nebo odstranit záznamy. Můžete zvolit formulář s více položkami, pokud budou uživatelé chcete rychle upravit data v mnoha záznamů najednou. Další informace naleznete v článku Vložení zobrazení dat jako formuláře.

Formáty dat

V tomto příkladu se jako zdroj dat používá soubor XML. Vzhledem k tomu, že soubor XML je soubor ve formátu prostého textu, nelze přesně určit typ hodnot, které by měla jednotlivá pole obsahovat. Příklad: Neexistuje omezení zabraňující zadání textu do pole, ve kterém mají být uvedena čísla, například pole ObjednánoJednotek.

Jestliže je však zdroj dat databáze nebo seznam nebo knihovna služby SharePoint, je při jeho vytváření možné zadat povolené typy hodnot pro jednotlivá pole. V takovém případě, jestliže do formuláře zadáte do číselného pole text a klepnete na tlačítko Uložit, se v okně prohlížeče zobrazí chybová zpráva vysvětlující, že kontrola zdroje dat nemohla provést aktualizaci. To se stane, protože do daného pole chcete zadat hodnotu, kterou zdroj dat nemůže přijmout.zadáváte. Jestliže se tato chybová zpráva zobrazí, klepněte v prohlížeči na tlačítko Zpět. Poté buď ve formuláři klepněte na tlačítko Storno a zrušte veškeré změny nebo zadejte hodnotu, která je pro zdroj dat přijatelná.

Při návrhu formulářů je v záhlaví každého sloupce vhodné uvést informace o případném požadavku na typ dat pro daná pole.

Začátek stránky

Přidání odkazů pro změnu, odstranění nebo vkládání položek do zobrazení dat

Tyto odkazy lze přidat do kteréhokoli zobrazení dat bez ohledu na to, zda je toto zobrazení vloženo jako zobrazení nebo jako formulář. Jestliže však tyto odkazy přidáte do zobrazení dat vloženého jako formulář, nahradí tyto odkazy tlačítka formuláře. Přidáte-li odkazy do zobrazení dat vloženého jako formulář, nebude zobrazení dat nadále zobrazovat pole formuláře, ale pouze data. Zobrazení dat, ve kterém jsou zobrazena tlačítka i odkazy této funkce, není dostupné.

  1. Otevřete stránku obsahující zobrazení dat, pro které chcete přidat odkazy.

    Pokud chcete sledovat v tomto příkladu, použijte zobrazení dat jste vytvořili v tématu Vytvoření zobrazení dat.

    Soubor Products.xml tak, jak se zobrazí v zobrazení dat

  2. Klikněte na zobrazení dat, klikněte na šipku Obrázek tlačítka v pravém horním rohu zobrazte seznam Běžné úkoly zobrazení dat a potom klikněte na Vlastnosti zobrazení dat. Kliknutím na šipku znovu skrýt seznam.

    Tip : Nebo můžete klepnout na zobrazení dat pravým tlačítkem myši a poté v místní nabídce vybrat příkaz Zobrazit běžné úkoly řízení.

  3. V dialogovém okně Vlastnosti zobrazení dat klepněte na kartu Úpravy.

  4. Na kartě Úpravy v oddílu Možnosti odkazu proveďte jednu nebo několik z následujících akcí:

    • Chcete-li přidat odkaz pro úpravu položky, zaškrtněte políčko Zobrazit odkazy pro úpravu položek.

    • Chcete-li přidat odkaz pro odstranění položky, zaškrtněte políčko Zobrazit odkazy pro odstranění položek.

    • Chcete-li přidat odkaz pro vložení nové položky, zaškrtněte políčko Zobrazit odkazy pro vložení položek.

      Pro potřeby našeho příkladu zaškrtněte políčka Zobrazit odkazy pro úpravu položek, Zobrazit odkazy pro odstranění položek a Zobrazit odkazy pro vložení položek.

      Karta Úpravy dialogového okna Vlastnosti zobrazení dat

      Poznámka : Předešlý příklad se týká pouze souborů XML. Při práci s databázemi SQL poskytuje karta Úpravy dialogového okna Vlastnosti zobrazení dat také možnost Možnosti příkazů automatické synchronizace. Po výběru této možnosti budou příkazy aktualizace, odstranění a vložení ze zdroje dat SQL synchronizovány s ovládacími prvky úpravy, odstranění a vkládání v zobrazení dat.

  5. Klepněte na tlačítko OK.

    Každý záznam v zobrazení dat nyní předchází odkaz pro Úpravy a odkaz pro Odstranění. V dolním rohu zobrazení dat se nachází odkaz pro Vložení nové položky.

    Zobrazení dat s více položkami s odkazy pro vložení, úpravu a odstranění

  6. V nabídce Soubor klikněte na příkaz Uložit jako.

  7. V dialogovém okně Uložit jako do pole Název souboru zadejte požadovaný název souboru Uložit.

Začátek stránky

Změna, odstranění nebo vložení položky pomocí prohlížeče

Po uložení stránky obsahující formulář lze zobrazit náhled formuláře v prohlížeči a provést v něm změny dat.

Náhled zobrazení dat v prohlížeči

  • V aplikaci Office SharePoint Designer 2007 v nabídce Soubor vyberte položku Náhled v prohlížeči a poté vyberte požadovaný typ prohlížeče a velikost okna.

    Klávesová zkratka: klikněte na stránku, kterou chcete zobrazit náhled v seznamu složek a stiskněte F12.

    Zobrazení dat s odkazy se zobrazí v okně prohlížeče.

    Zobrazení dat s odkazy zobrazené v okně prohlížeče

Úpravy záznamu

  1. Klepněte na odkaz Úpravy u položky, kterou chcete upravit.

    V našem příkladu, klikněte na Upravit odkaz Štursová. Zobrazení dat obsahující datový formulář, který Štursová položka zobrazí.

    Jedna položka v zobrazení dat v režimu úprav

    Poznámky : 

    • Pracujete-li se seznamy nebo knihovnami služby SharePoint, nejsou ovládací prvky textová pole, ale ovládací prvky polí formuláře služby SharePoint.

    • Pracujete-li s poli s atributem jen pro čtení, například identifikátor v seznamu služby SharePoint nebo databáze SQL, zobrazí se pole jako text a nelze jej upravit.

    Nyní je možné upravit libovolné informace, které se zobrazí v Štursová záznamu.

  2. Upravte požadovaná data dané položky a poté klepněte na tlačítko Uložit, chcete-li změny uložit, nebo na tlačítko Storno, chcete-li změny zrušit a vrátit se do zobrazení dat.

    V našem příkladu, v dialogovém okně ve sloupci zdroje zadejte 40a klikněte na tlačítko Uložit do levé části Štursová záznamu.

    Zobrazí se zobrazení dat s aktualizovanou položkou.

    Položka s hodnotou Objednaných jednotek

Odstranění záznamu

  • Klepněte na odkaz Odstranit vlevo od položky, kterou chcete odstranit.

    Důležité : Po odstranění položky pomocí prohlížeče se nezobrazí žádný dotaz s otázkou, zda si jste jisti, že chcete danou položku odstranit, a tedy neexistuje žádný způsob vrácení odstraněné položky.

    V našem příkladu, klikněte na Odstranit odkaz nalevo od Chang v seznamu ProductName . Zobrazení dat, která obsahuje pouze čtyři záznamy zobrazené.

    V zobrazení dat jsou pouze 4 položky

Vložení položky

  1. Klepněte na odkaz Vložit v levém dolním rohu zobrazení dat.

    Zobrazí se položka s prázdnými poli formuláře.

    Položka s prázdnými poli formuláře, která se zobrazí po klepnutí na odkaz Vložit

    Můžete vložit novou položku.

  2. Zadejte požadovaná data dané položky a poté klepněte na tlačítko Uložit, chcete-li změny uložit, nebo na tlačítko Storno, chcete-li změny zrušit a vrátit se do zobrazení dat.

    V našem příkladu, do pole ve sloupci NázevProduktu zadejte Šířit na odchod babičky Boysenberry. V dialogovém okně ve sloupci Podrobnosti zadejte 120. V dialogovém okně ve sloupci zdroje zadejte hodnotu 0. V dialogovém okně ve sloupci dat zadejte 25. Klikněte na Uložit. Zobrazí se zobrazení dat s novým záznamem.

    Nově vložená položka se zobrazí v zobrazení dat

Začátek stránky

Přizpůsobení šablon pro úpravu nebo vložení

Použití zobrazení dat pro vkládání nebo úpravu položek pracuje odlišně od, například, přidávání nebo úpravy položek v seznamu služby SharePoint pomocí formulářů seznamu, například NewForm.aspx nebo EditForm.aspx. Seznam nebo knihovna zobrazují různé stránky při přidávání a úpravě položek, zobrazení dat zobrazí jiný režim. Každý režim však má šablonu, kterou je možné přizpůsobit. Příklad: Jestliže přizpůsobíte šablonu Úpravy, uživatelům se provedená přizpůsobení zobrazí pouze pokud klepnou na odkaz pro úpravy a přepnou tak zobrazení dat do režimu úprav.

Šablony režimů je vhodné přizpůsobit například chcete-li uživatelům poskytnout konkrétní instrukce pro vkládání nebo úpravu položek. Pod nadpisy jednotlivých sloupců lze snadno vkládat nové řádky a do nich pak lze zadat požadovaný text s instrukcemi o typu dat v každém sloupci nebo o požadovaném formátu dat (čísla, text atd.).

  1. Klikněte na zobrazení dat a potom klikněte na šipku Obrázek tlačítka v pravém horním rohu zobrazte seznam Běžné úkoly zobrazení dat.

    Tip : Nebo můžete klepnout na zobrazení dat pravým tlačítkem myši a poté v místní nabídce vybrat příkaz Zobrazit běžné úkoly řízení.

  2. V seznamu Náhled zobrazení dat vyberte možnosti Upravit šablonu nebo Vložit šablonu.

    V zobrazení dat se zobrazí šablona daného režimu. Vzhled a atmosféru lze přizpůsobit změnou použitého písma, formátování nebo rozložení.

  3. Pokud chcete změny uložit, klepněte v nabídce Soubor na příkaz Uložit.

  4. Chcete-li zobrazit náhled šablony v okně prohlížeče, vyberte v nabídce Soubor položku Náhled v prohlížeči a poté vyberte požadovaný typ prohlížeče a velikost okna.

    Klávesová zkratka: klikněte na stránku, kterou chcete zobrazit náhled v seznamu složek a stiskněte F12.

Po otevření zobrazení dat v prohlížeči a po klepnutí na příkazy Upravit nebo Vložit se zobrazí vytvořená přizpůsobená šablona.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×