Zamknutí listu

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Pokud chcete zabránit uživatelům v tom, aby mohli neúmyslně nebo záměrně změnit, přesunout nebo odstranit důležitá data, můžete některé prvky List nebo sešitu zamknout s použitím nebo bez použití Heslo. Tuto ochranu můžete z listu podle potřeby odebrat.

Důležité : Zamknutí prvků sešitu a listu byste neměli zaměňovat se zabezpečením pomocí hesla na úrovni sešitu. Zamknutím prvků v sešitu nezajistíte ochranu sešitu před kyberzločinci. Pokud chcete zajistit vyšší úroveň zabezpečení, měli byste pomocí hesla chránit celý sešit. Zobrazovat a upravovat data potom budou moct jenom oprávnění uživatelé.

Je nezbytné, abyste si svoje heslo pamatovali. Pokud heslo zapomenete, společnost Microsoft je nemůže obnovit. Poznamenaná hesla si uložte na bezpečném místě, jinde, než jsou informace, které tato hesla pomáhají chránit.

Zamknutí prvků listu

  1. Vyberte list, který chcete zamknout.

  2. Pokud chcete odemknout buňky nebo oblasti, u kterých chcete uživatelům umožnit provádění změn, postupujte takto:

    1. Vyberte všechny buňky nebo oblasti, které chcete odemknout.

    2. Klikněte na Domů > Formát > Formát buněk.
      Skupina Buňky na kartě Domů

    3. Na kartě Zámek zrušte zaškrtnutí políčka Uzamknout a potom klikněte na OK.

  3. Pokud chcete skrýt vzorce, které nechcete zobrazovat, postupujte takto:

    1. V listu vyberte buňky obsahující vzorce, které chcete skrýt.

    2. Klikněte na Domů > Formát > Formát buněk.

    3. Na kartě Zámek zaškrtněte políčko Skrýt vzorce a potom klikněte na OK.

  4. Pokud chcete odemknout grafické objekty (jako jsou obrázky, kliparty, obrazce nebo obrázky SmartArt), u kterých chcete uživatelům umožnit provádění změn, postupujte takto:

    1. Podržte stisknutou klávesu Ctrl a klikněte na jednotlivé grafické objekty, které chcete odemknout.

      Tím se zobrazí Nástroje obrázku nebo Nástroje kreslení s přidanou kartou Formát.

      Tip : Pokud chcete rychle vybrat všechny grafické objekty v listu, můžete taky použít příkaz Přejít na. Na kartě Domů ve skupině Úpravy klikněte na Najít a vybrat a potom na Přejít na. Klikněte na Jinak a potom na Objekty.

    2. Klikněte na Formát > ikona pro otevření dialogového okna Obrázek tlačítka vedle položky Velikost ve skupině Velikost.

    3. Na kartě Vlastnosti zrušte zaškrtnutí políčka Uzamčeno a potom klikněte na OK.

      Pokud uživatelům chcete umožnit použití tlačítek a ovládacích prvků, není potřeba tlačítka a ovládací prvky odemknout. Odemknout můžete vložené grafy, textová pole a jiné objekty vytvořené pomocí nástrojů pro kreslení, u kterých chcete uživatelům povolit provádění změn.

  5. Klikněte na Revize > Zamknout list ve skupině Změny.

    Skupina Změny na kartě Revize

  6. V seznamu Akce povolené všem uživatelům listu vyberte prvky, u kterých chcete uživatelům povolit provádění změn.

    Další informace o prvcích, které jde vybrat

    Prvky listu

    Zrušení zaškrtnutí políčka

    Akce, které uživatelé nebudou moci provádět

    Vybrat uzamčené buňky

    Přesunutí ukazatele na buňky, pro které je na kartě Zámek v dialogovém okně Formát buněk zaškrtnuté políčko Uzamčeno. Ve výchozím nastavení uživatelé uzamčené buňky vybírat můžou.

    Vybrat odemknuté buňky

    Přesunutí ukazatele na buňky, pro které není na kartě Zámek v dialogovém okně Formát buněk zaškrtnuté políčko Uzamčeno. Ve výchozím nastavení můžou uživatelé vybírat odemknuté buňky a můžou se klávesou TAB přesouvat mezi odemknutými buňkami na uzamčeném listě.

    Formátovat buňky

    Změna některé možnosti v dialogových oknech Formát buněk nebo Podmíněné formátování. Použijete-li podmíněné formátování před uzamknutím listu a uživatel zadá hodnotu splňující jinou podmínku, bude se formátování i nadále měnit.

    Formátovat sloupce

    Použití libovolného příkazu pro formátování sloupců, včetně změny šířky sloupce nebo skrytí sloupců (karta Domů, skupina Buňky, tlačítko Formát)

    Formátovat řádky

    Použití libovolného příkazu pro formátování řádků, včetně změny výšky řádku nebo skrytí řádků (karta Domů, skupina Buňky, tlačítko Formát)

    Vložit sloupce

    Vkládání sloupců

    Vložit řádky

    Vkládání řádků

    Vložit hypertextové odkazy

    Vkládání nových hypertextových odkazů, a to i do odemčených buněk

    Odstranit sloupce

    Odstranění sloupců

    Poznámka : Pokud je políčko Odstranit sloupce zaškrtnuté a políčko Vložit sloupce zaškrtnuté není, může uživatel sloupce vkládat, ale nemůže je odstranit.

    Odstranit řádky

    Odstranění řádků

    Poznámka : Pokud je políčko Odstranit řádky zaškrtnuté a políčko Vložit řádky zaškrtnuté není, může uživatel řádky vkládat, ale nemůže je odstranit.

    Seřadit

    Použití některého z příkazů pro řazení dat (karta Data, skupina Seřadit a filtrovat)

    Poznámka : Uživatelé nemohou řadit oblasti, které obsahují uzamčené buňky na uzamčeném listu, a to bez ohledu na toto nastavení.

    Použít automatický filtr

    Použití šipek rozevíracího seznamu ke změně filtru pro oblasti, jsou-li použity automatické filtry

    Poznámka : Uživatelé nemohou použít ani odebrat automatické filtry z uzamčeného listu, a to bez ohledu na toto nastavení.

    Použít sestavy kontingenčních tabulek

    Formátování, změna rozložení, aktualizace nebo jiná úprava sestav kontingenčních tabulek, nebo vytváření nových sestav

    Upravit objekty

    Provedení některé z následujících akcí:

    • Změny v grafických objektech včetně map, vložených grafů, obrazců, textových polí a ovládacích prvků, které jste před uzamknutím listu neodemkli (pokud například list obsahuje tlačítko, které spouští makro, můžete makro spustit kliknutím na toto tlačítko, ale tlačítko nemůžete odstranit)

    • Změny (například formátování) ve vloženém grafu (pokud se změní zdrojová data, graf se bude dál aktualizovat)

    • Přidání nebo úpravy komentářů

    Upravit scénáře

    Zobrazení skrytých scénářů, provádění změn ve scénářích, u kterých jste provádění změn zakázali, a odstranění těchto scénářů. Uživatelé mohou měnit hodnoty v měněných buňkách (v případě, že buňky nejsou uzamčeny) a přidávat nové scénáře.

    Prvky listu s grafem

    Zaškrtnutí políčka

    Akce, které uživatelé nebudou moci provádět

    Obsah

    Provádění změn v položkách, které jsou součástí grafu, jako jsou například datové řady, osy a legendy; graf bude i nadále odrážet změny provedené ve zdrojových datech

    Objekty

    Provádění změn v grafických objektech (včetně obrazců, textových polí a ovládacích prvků), které jste před uzamknutím listu neodemkli

  7. Do textového pole Heslo k odemknutí listu zadejte heslo pro list, klikněte na tlačítko OK a poté heslo opětovným zadáním potvrďte.

Zamknutí prvků sešitu

  1. Klikněte na Revize > Zamknout sešit ve skupině Změny.

    Skupina Změny na kartě Revize

  2. Ve skupině V sešitu zamknout proveďte jednu nebo víc z následujících akcí:

    • Pokud chcete zamknout strukturu sešitu, zaškrtněte políčko Struktura.

    • Pokud chcete zachovat stejnou velikost a stejné umístění oken při každém otevření sešitu, zaškrtněte políčko Okna.

      Další informace o prvcích, které jde vybrat

      Prvky sešitu

      Zaškrtnutí políčka

      Akce, které uživatelé nebudou moci provádět

      Struktura

      • Zobrazení listů, které jste skryli

      • Přesunutí, odstranění, skrytí nebo změna názvů listů

      • Vložení nových listů nebo listů s grafem

        Poznámka : Uživatelé budou moct vložit Vložený graf do stávajícího listu.

      • Přesunutí nebo kopírování listů do jiného sešitu

      • Zobrazení zdroje dat pro buňku v datové oblasti v sestavách kontingenčních tabulek nebo zobrazení stránkového pole v samostatných listech

      • Vytvoření zprávy scénáře

      • Použití analytických nástrojů v rámci doplňku Analytické nástroje, které umožňují vložení výsledků do nového listu

      Windows

      • Změna velikosti a umístění oken v otevřeném sešitu

      • Přesunutí, změna velikosti nebo zavření oken

        Poznámka : Uživatelé budou moct skrýt okna nebo zrušit jejich skrytí.

      Poznámka : Pokud spustíte makro obsahující operaci, kterou nejde provést v zamknutém sešitu, zobrazí se zpráva a makro se zastaví.

  3. Jestliže chcete ostatním uživatelům zabránit v odebrání uzamčení sešitu, zadejte heslo do pole Heslo (nepovinné), klikněte na tlačítko OK a poté heslo opětovným zadáním potvrďte.

    Poznámka : Zadání hesla je volitelné. Pokud heslo nezadáte, budou moct všichni uživatelé sešit odemknout a změnit zamknuté prvky. Ujistěte se, že jste zvolili heslo, které si zapamatujete. Jestliže heslo zapomenete, nebude možné k zamknutým prvkům v sešitu získat přístup.

Zamknutí prvků ve sdíleném sešitu

Pokud se sešit už sdílí a chcete přiřazením hesla sdílení zamknout, je potřeba sdílení sešitu nejdřív zrušit takto:

  1. Všichni ostatní uživatelé by měli sdílený sešit uložit a zavřít, aby předešli ztrátě své práce.

  2. Otevřete sešit.

  3. Chcete-li uchovat kopii s informacemi o Historie změn, k jejichž ztrátě dojde po zrušení sdílení sešitu, postupujte následujícím způsobem:

    1. Klikněte na Revize > Sledování změn ve skupině Změny > Zvýraznit změny.

      Skupina Změny na kartě Revize

    2. V seznamu Kdy vyberte Vše. Zrušte zaškrtnutí políček Kdo a Kde.

    3. Zaškrtněte políčko Zobrazit změny na novém listu a potom klikněte na OK.

    4. Proveďte jednu nebo obě následující akce:

    5. Pokud chcete vytisknout list Historie, klikněte na Tisk Print button .

    6. Pokud chcete historii zkopírovat do jiného sešitu, vyberte buňky, které chcete zkopírovat, klikněte na tlačítko Kopírovat  Obrázek tlačítka na kartě Domů ve skupině Schránka, přejděte do jiného sešitu, klikněte na místo, kam chcete kopírovaná data vložit, a klikněte na tlačítko Vložit  Obrázek tlačítka na kartě Domů ve skupině Schránka.

      Poznámka : Data této historie nebudou pravděpodobně platná pro pozdější verze sešitu, a proto je vhodné uložit nebo vytisknout aktuální verzi sešitu. Například umístění buněk, včetně čísel řádků, již nemusí být ve zkopírované historii aktuální.

  4. Ve sdíleném sešitu klikněte na Revize > Zamknout a sdílet sešit ve skupině Změny.

  5. Na kartě Úpravy se přesvědčte, že jste jediným uživatelem v seznamu Tento sešit nyní používají následující uživatelé.

  6. Zrušte zaškrtnutí políčka Povolit úpravy více uživatelům najednou; tato možnost rovněž povoluje slučování sešitů.

    Poznámky : Pokud není toto políčko dostupné, je potřeba nejdřív odemknout sešit. Postupujte takto:

    1. Kliknutím na OK zavřete dialogové okno Sdílení sešitu.

    2. Klikněte na Revize > Odemknout sdílený sešit ve skupině Změny.

    3. Jestliže se zobrazí výzva, zadejte Heslo a klikněte na OK.

    4. Klikněte na Revize > Sdílet sešit ve skupině Změny.

    5. Na kartě Úpravy zrušte zaškrtnutí políčka Povolit úpravy více uživatelům najednou; tato možnost rovněž povoluje slučování sešitů.

    6. Po zobrazení zprávy o účincích na jiné uživatele klikněte na Ano.

    7. V případě potřeby přidělte určitým uživatelům přístup k oblastem, zamkněte listy, zamkněte prvky sešitu a nastavte hesla pro prohlížení a úpravy. Postupujte takto:

      1. Klikněte na Revize > Sdílet sešit ve skupině Změny.

      2. Zaškrtněte políčko Sdílení se sledováním změn.

      3. Pokud chcete, aby jiní uživatelé museli zadat heslo před vypnutím historie změn nebo vyjmutím sešitu ze sdíleného používání, zadejte heslo do pole Heslo (nepovinné), klikněte na OK a potom heslo opětovným zadáním potvrďte.

      4. Pokud se zobrazí výzva, sešit uložte.

Zrušení zamknutí listu

  1. Na kartě Revize klikněte ve skupině Změny na tlačítko Odemknout list.
    Vzhled pásu karet aplikace Excel

    Poznámka : Možnost Zamknout list se po zamknutí listu změní na Odemknout list.

  2. Pokud se zobrazí výzva, odemkněte list zadáním hesla.

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Sdílení Facebook Facebook Twitter Twitter E-mail E-mail

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×