Přihlásit se

Začínáme s aplikací SharePoint Designer 2010

Důležité : Tento článek je určený strojový překlad najdete v tématu zřeknutí se záruk. O potřebu najdete anglické verzi tohoto článku tady .

Microsoft SharePoint Designer 2010 je webové a návrhové aplikace pro aplikaci použít k návrhu, vytvoření, přizpůsobení webů spuštěna SharePoint Foundation 2010 a Microsoft SharePoint Server 2010. S SharePoint Designer 2010 můžete vytvořit dat ve formátu RTF webových stránek, vytvářet výkonné pracovního postupu s podporou řešení a návrh vzhled webu.

Další informace o SharePoint Designer 2010 prostřednictvím články, videa a výukové materiály pro ostatní pomocí těchto odkazů. Pomocí postupů budou převedeny na další informace o základní úkoly, které můžete dělat v SharePoint Designer 2010.

Logo Začínáme

K čemu je sítě wan t

Kde se má g o

Potřebujete zjistit, co se změnilo?   

Zjistit, co je v této verzi nového a jak nové funkce maximálně využít

Novinky v aplikaci SharePoint Designer 2010

Hledáte nabídky a příkazy z verze 2007?   

Zobrazit tabulku nabídek a příkazů panelů nástrojů ve verzi 2007 a zjistit jejich nová umístění pomocí tohoto sešitu s jejich mapou

Průvodce aplikacemi systému Microsoft Office s mapami

Bez zkušeností s aplikací SharePoint Designer?   

Zjistěte, jaké SharePoint Designer 2010 je celé o tom a jak maximálně využít ho ve vaší organizaci.

Úvod do aplikace SharePoint Designer 2010

Hledáte možnosti výuky pro vás a váš tým?   

Efektivnější práci v této verzi školení na SharePoint Designer 2010.

Školení k Microsoft Office

Základní úkoly v SharePoint Designer 2010

Otevírání a vytváření webů služby SharePoint

Vytváření seznamů, knihoven a připojení ke zdrojům dat

Vytváření vlastních zobrazení a formulářů

Vytváření vlastních pracovních postupů

Navrhování stránek webu, stránek předlohy a rozložení stránek

Uložení jako šablony

Otevírání a vytváření webů služby SharePoint

V SharePoint Designer 2010 můžete otevřít existující Sharepointových webů na server a začněte jejich přizpůsobování a budete moct vytvářet nové weby na základě šablony Sharepointového webu nebo nové, prázdné weby, které můžete přizpůsobit zcela.

Otevírání webů

Chcete-li otevřít existující web, klikněte na kartu Soubor, zvolte příkaz Weby a proveďte jednu z následujících akcí:

  • Klikněte na možnost Otevřít web a vyhledejte dostupné weby na serveru.

  • Kliknutím na možnost Upravit osobní web otevřete svůj osobní web, který můžete dále přizpůsobit.

  • V části Naposledy otevřené weby vyberte web, se kterým jste dříve pracovali.

Vytváření webů

Chcete-li vytvořit nový web, klikněte na kartu Soubor, zvolte příkaz Weby a proveďte jednu z následujících akcí:

  • Kliknutím na možnost Nový prázdný web vytvořte prázdný web služby SharePoint.

  • Kliknutím na možnost Přidat podřízený web k osobnímu webu vytvořte nový web pod svým osobním webem.

  • V části Šablony webů vyberte šablonu pro vytvoření nového webu založené na šabloně SharePoint.

Poznámka : Kromě otevírání a vytváření webů z v rámci SharePoint Designer 2010, můžete otevření Sharepointového webu pomocí prohlížeče a otevřete tento web v SharePoint Designer 2010 pomocí dostupných odkazů v na nabídku Akce webu, na pásu karet a jiných místech ve službě SharePoint.

Začátek stránky

Vytváření seznamů, knihoven a připojení ke zdrojům dat

V SharePoint Designer 2010 můžete vytvořit seznamů a knihoven, které obvykle slouží jako zdroj dat pro weby služby SharePoint, a vytvoříte připojení ke zdrojům dat soubory ve formátu XML, externí databáze a webové služby.

Knihovny a seznamy služby SharePoint

Chcete-li vytvořit seznam nebo knihovnu služby SharePoint, klikněte na položku Seznamy a knihovny v navigačním podokně a na kartě Seznamy a knihovny vyberte jednu z následujících možností:

  • Kliknutím na možnost Vlastní seznam vytvořte zcela nový prázdný seznam.

  • Kliknutím na možnost Seznam služby SharePoint vytvořte seznam založený na šabloně seznamu služby SharePoint.

  • Kliknutím na možnost Knihovna dokumentů vytvořte knihovnu založenou na šabloně knihovny služby SharePoint.

  • Kliknutím na možnost Externí seznam vytvořte externí seznam založený na typu externího obsahu. (Typy externího obsahu jsou vysvětleny níže.)

  • Kliknutím na možnost Seznam z tabulky vytvořte seznam založený na importované tabulce.

Připojení ke zdrojům dat

Chcete-li vytvořit připojení ke zdroji dat, klikněte na položku Zdroje dat v navigačním podokně a na kartě Zdroje dat vyberte jednu z následujících možností:

  • Kliknutím na možnost Propojený zdroj dat vytvořte datové připojení k více zdrojům dat.

  • Kliknutím na možnost Připojení databáze vytvořte datové připojení k databázi podporující protokol OLE DB nebo ODBC.

  • Kliknutím na možnost Připojení služby SOAP vytvořte připojení k webové službě XML pomocí protokolu SOAP (Simple Object Access Protocol).

  • Kliknutím na možnost Připojení ke službě REST vytvořte připojení ke skriptu na straně serveru pomocí služby REST (Representational State Transfer).

  • Kliknutím na možnost Připojení k souboru XML vytvořte připojení ke zdrojovému souboru XML.

Typy externího obsahu

Pomocí typů externího obsahu se můžete připojit k externím zdrojům obchodních dat a integrovat je se svým webem služby SharePoint a podporovanými klientskými aplikacemi. Jakmile vytvoříte typ externího obsahu, můžete vytvořit externí seznamy, které uživatelům umožní interakci s daty, jako by se jednalo o jakýkoli jiný seznam nebo knihovnu služby SharePoint.

Chcete-li vytvořit typ externího obsahu, proveďte tyto kroky.

  1. Klikněte na položku Typy externího obsahu v navigačním podokně.

  2. Na kartě Typy externího obsahu klikněte na možnost Typ externího obsahu a potom pro daný typ externího obsahu navrhněte operace, pole apod.

Začátek stránky

Vytváření vlastních zobrazení a formulářů

V SharePoint Designer 2010 můžete vytvořit vlastní zobrazení a formuláře pro zdroje dat, které Opravdu se stanou rozhraní pro čtení a zápis dat k těmto zdrojům dat.

zobrazení,

Zobrazení je živou přizpůsobitelná zobrazení zdroje dat, který můžete přidat na libovolnou stránku služby SharePoint. V SharePoint Designer 2010 můžete vytvořit zobrazení seznamů, (které pomocí transformací XSLT seznamu webové části) a zobrazení dat, (které použijte webovou část Datový formulář). Proveďte jednu z následujících kroků můžete vytvořit zobrazení seznamu nebo data.

  • V navigačním podokně klikněte na položku Seznamy a knihovny, vyberte seznam, pro který chcete vytvořit zobrazení, a potom na kartě Nastavení seznamu klikněte na možnost Zobrazení seznamu.

    Poznámka : Tím se vytvoří zobrazení přidružené k danému seznamu nebo knihovně. Výsledkem je, že uživatelé toto zobrazení uvidí a budou je moci přizpůsobit pomocí skupiny Spravovat zobrazení na pásu karet služby SharePoint.

  • V navigačním podokně klikněte na položku Stránky webu, upravte stránku, na které chcete vytvořit zobrazení, na kartě Vložení zvolte možnost Zobrazení dat a potom zvolte seznam nebo knihovnu služby SharePoint, které chcete pro zobrazení použít.

Formuláře

Formulář je přizpůsobitelná zobrazení zdroje dat, který slouží k odeslání nebo odepsat ke zdroji dat. SharePoint Designer 2010 můžete vytvářet formuláře seznamů a datových formulářů (které použijte webovou část Datový formulář). Proveďte jednu z následujících kroků můžete vytvořit formulář seznamu nebo data.

  • V navigačním podokně klikněte na položku Seznamy a knihovny, vyberte seznam, pro který chcete vytvořit formulář, a potom na kartě Nastavení seznamu klikněte na možnost Formulář seznamu.

  • V navigačním podokně klikněte na položku Stránky webu, upravte stránku, na které chcete vytvořit formulář, na kartě Vložení zvolte možnost Formulář nové položky, Formulář pro úpravy položky nebo Formulář pro zobrazení položky a zvolte zdroj dat, který chcete pro formulář použít.

Poznámka : Kromě použití nástroje návrhu formuláře v SharePoint Designer 2010, můžete vytvořit a přizpůsobit formuláře SharePoint pomocí Microsoft InfoPath 2010.

Začátek stránky

Vytváření vlastních pracovních postupů

V SharePoint Designer 2010 můžete spravovat obchodních procesů pomocí vysoce přizpůsobený pracovní postupy. Pracovní postupy můžete použít ke správě procesů aplikací, jakož i lidské týmovou prací. Máte několik možností při vytváření pracovních postupů.

Vytváření pracovních postupů v SharePoint Designer 2010

Lze vytvořit pracovní postup založený na seznamu nebo knihovně služby SharePoint; můžete vytvořit znovu použitelný pracovní postup, který lze použít u libovolného seznamu nebo knihovny; a lze vytvořit pracovní postup webu, který bude fungovat na úrovni webu.

Chcete-li vytvořit tyto pracovní postupy, klikněte na položku Pracovní postupy v navigačním podokně a potom na kartě Pracovní postupy proveďte jeden z následujících kroků:

  • Klikněte na položku Pracovní postup seznamu a zvolte seznam, ke kterému chcete pracovní postup přidružit.

  • Kliknutím na položku Opakovaně použitelný pracovní postup vytvořte znovu použitelný pracovní postup, který lze přidružit k libovolnému seznamu nebo knihovně.

  • Kliknutím na položku Pracovní postup webu vytvořte pracovní postup, který lze použít na úrovni webu.

Po vytvoření pracovního postupu použijte nástroj pro navrhování pracovního postupu ke strukturování podmínek, akcí a kroků v pracovním postupu. Pomocí nástroje pro navrhování úloh můžete spravovat události přidružené ke každé z úloh.

Import z Microsoft Visio 2010 pracovních postupů

Kromě vytváření pracovních postupů v SharePoint Designer 2010, můžete importovat pracovní postup navržený Microsoft Visio 2010 pomocí předaném pracovního postupu vzorníky a šablony.

Chcete-li importovat pracovní postup, klikněte na položku Pracovní postupy v navigačním podokně a potom na kartě Pracovní postupy proveďte následující kroky:

  1. Klikněte na položku Importovat z aplikace Visio a potom ve svém systému souborů nebo knihovně dokumentů služby SharePoint vyhledejte soubor VWI (Visio Workflow Interchange).

  2. Rozhodněte se, zda chcete pracovní postup přidružit k seznamu, nebo zda se má vytvořit jako opakovatelně použitelný pracovní postup, a klikněte na tlačítko Dokončit.

  3. Začněte upravovat pracovní postup v aplikaci SharePoint Designer.

Začátek stránky

Navrhování stránek webu, stránek předlohy a rozložení stránek

V SharePoint Designer 2010 můžete vytvořit a přizpůsobit stránky webu, stránky předlohy a rozložení stránek. Při každé z těchto stránek slouží k jinému účelu, na stránce Možnosti úprav je podobný. Můžete přidat a odebrat text, obrázky, odkazy, tabulek, webové části, serverové ovládací prvky a další. Použití stylu definice a šablony stylů CSS ke stránkám předlohy a rozložení stránek na Změna vzhledu webu nebo označit ji odpovídají vaší firemní identitě.

Stránky webu

Chcete-li vytvořit stránku webu, klikněte na položku Stránky webu v navigačním podokně a potom na kartě Stránky proveďte jeden z následujících kroků:

  • Kliknutím na položku Stránka webové části vytvořte stránku, která bude obsahovat webové části pro záhlaví a hlavní část a kromě toho bude přidružena k stránce předlohy webu.

  • Klikněte na položku Stránka a volbou možnosti ASPX nebo HTML vytvořte prázdnou stránku webu, která nebude přidružena k stránce předlohy webu.

Stránky předlohy

  • Klikněte na položku Stránky předlohy v navigačním podokně a potom na kartě Stránky předlohy klikněte na možnost Prázdná stránka předlohy.

Rozložení stránky

  • Klikněte na položku Rozložení stránek v navigačním podokně, potom na kartě Rozložení stránek klikněte na možnost Nové rozložení stránky a zvolte skupinu a název typu obsahu, na kterém chcete rozložení stránky založit.

Poznámka : Stránky předlohy a rozložení stránek jsou zakázány ve výchozím nastavení pro všechny uživatele kromě správci kolekce webů. Pokud nevidíte možnost zobrazit nebo upravit stránky předlohy a rozložení stránek v SharePoint Designer 2010, požádejte správce webu o povolení tyto možnosti.

Začátek stránky

Uložení jako šablony

Jakmile budete s přizpůsobením webu hotovi, můžete jej nebo jeho části uložit jako šablonu, kterou budou jiní uživatelé ve vaší organizaci moci použít k vytváření seznamů, zobrazení, pracovních postupů, stránek webu a spousty dalšího obsahu.

Šablonu můžete rovněž použít k dalšímu přizpůsobení webu v jiném prostředí nebo ze strany jiných uživatelů, například v prohlížeči nebo v aplikaci Microsoft Visual Studio.

Vyhledejte možnost Uložit jako šablonu v SharePoint Designer 2010 využít tuto funkci.

Začátek stránky

Poznámka : Zřeknutí se záruk strojového překladu: Tento článek přeložená počítačovému systému bez zásahu člověka. Společnost Microsoft nabízí tyto strojového překladu pomůže neanglickém řeči uživatelé moct užít dobrý pocit obsahu o produktech společnosti Microsoft, služby a technologií pro server. Protože je v článku strojový překlad, může obsahovat chyby ve slovníku, syntaxi ani gramatiky.



Byly tyto informace užitečné?

Jak ji můžeme vylepšit?

Jak ji můžeme vylepšit?

Pokud si chcete chránit soukromí, nedávejte do zpětné vazby kontaktní informace. Ohodnoťte aplikaci zásady ochrany osobních údajů.

Děkujeme vám za zpětnou vazbu.