Základní úlohy pro desktopovou databázi Accessu

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Desktopové databáze Accessu můžete ukládat a sledovat téměř jakéhokoli typu informací, například zásob, kontakty nebo obchodních procesů. Podívejme se procházení seznamu cesty, kterými můžete k vytvoření desktopové databáze Accessu, přidat data k němu a pak další informace o další kroky k přizpůsobení a používání nové databáze.

Poznámka : Pokud vás zajímá v aplikacích pro Access určená pro web, přečtěte si postup Vytvoření aplikace pro Access a Další informace o základní úlohy aplikace pro Access.

V tomto článku

Volba šablony

Accessové šablony obsahují předdefinované tabulky, dotazy, formuláře a sestavy, které jsou připravené k okamžitému použití. Nabídka šablon je první věc, které si všimnete po spuštění Accessu. Další šablony najdete na internetu.

Zobrazení šablon na úvodní obrazovce v Accessu

  1. V Accessu klikněte na Soubor > Nový.

  2. Vyberte šablonu databáze plochy a zadejte název databáze podle Názvu souboru.(Pokud se nezobrazuje šablony, které pro vás vhodná; použítHledat online šablonypolíčko.)

  3. Můžete buď použít výchozí umístění, které Access zobrazí pod polem Název souboru, nebo kliknout na ikonu složky a vybrat vlastní umístění.

  4. Klikněte na Vytvořit.

Vytvořte accessovou databázi ze šablony.

Podle toho, jakou šablonu vyberete, budete možná na začátku muset provést některé z následujících úloh:

  • Jestliže Access zobrazí dialogové okno přihlásit s prázdným seznamem uživatelů:

    1. Klikněte na nového uživatele.

    2. Vyplňte formulář Podrobnosti uživatele.

    3. Klikněte na Uložit a zavřít.

    4. Vyberte uživatelské jméno, který jste právě zadané a klikněte na přihlášení.

  • Jestliže Access zobrazí zpráva Upozornění zabezpečení na panelu zpráv a zabezpečení zdroje šablony, klikněte na Povolit obsah. Pokud databáze vyžaduje přihlášení, přihlaste se znova.

Další informace najdete v článku Vytvoření accessové databáze ze šablony.

Vytvoření databáze od začátku

Jestliže vašim potřebám nevyhovuje žádná šablona, můžete začít prázdnou databází.

  1. V Accessu klikněte na Nový > Prázdná databáze.

  2. Zapište název databáze do pole Název souboru.

  3. Můžete buď použít výchozí umístění, které Access zobrazí pod polem Název souboru, nebo kliknout na ikonu složky a vybrat vlastní umístění.

  4. Klikněte na Vytvořit.

Přidání tabulky

V databázi vaše informace uložené v několika souvisejících tabulek. Vytvoření tabulky:

  1. Při otevření databáze poprvé, zobrazí se prázdné tabulky v zobrazení Datový list kterého můžete přidávat data. Pokud chcete přidat další tabulku, klikněte na kartu vytvořit > Tabulka. Můžete začít zadávat data do prázdného pole (buňka) nebo vložení dat z jiného zdroje, jako je sešit aplikace Excel.

  2. Pokud chcete některý sloupec (pole) přejmenovat, poklikejte na záhlaví sloupce a zadejte nový název.

Tip :  Doporučujeme používat smysluplné názvy, abyste věděli, co které pole obsahuje, aniž byste se museli dívat na jeho obsah.

  1. Klikněte na Soubor > Uložit.

  • Pokud chcete přidat další pole, začněte psát do sloupce Kliknutím přidat.

  • Pokud chcete sloupec přesunout, vyberte ho kliknutím do jeho záhlaví a poté ho přetáhněte tam, kde ho chcete mít. Vybrat můžete i několik sloupců vedle sebe a pak je přetáhnout do jiného umístění.

Více informací najdete v tématu Úvod do tabulek.

Kopírování a vkládání dat

Data můžete kopírovat z jiných programů (třeba Excelu nebo Wordu) a vkládat je do accessové tabulky. Prakticky bez chyb to ale bude fungovat jen v případě, kdy jsou data rozdělená do sloupců. Pokud jsou data umístěná v textovém editoru, například ve Wordu, buď je rozdělte do sloupců pomocí značek, nebo je před zkopírováním převeďte na tabulku.

  1. Jestli data potřebují napřed upravit, třeba oddělit křestní jména od příjmení, proveďte to ještě ve zdrojovém programu.

  2. Otevřete zdrojový program a zkopírujte data (Ctrl+C).

  3. Otevřete accessovou tabulku, v zobrazení Datový list vyberte místo, kam se mají data vložit, a vložte je (Ctrl+V).

  4. Poklikejte na záhlaví každého sloupce a zadejte smysluplné názvy.

  5. Klikněte na soubor > Uložit a zadejte název nové tabulky.

    Poznámka : Access nastaví pro každý sloupec datový typ na základě informací, které vložíte do prvního řádku sloupce, proto dávejte pozor, aby informace v následujících řádcích byly stejného typu jako ty v prvním řádku.

Import nebo propojení dat

Data můžete do Accessu buď importovat z jiného zdroje, nebo je propojit odkazem, aniž by bylo nutné přesouvat informace z původního zdroje. Propojování pomocí odkazů se hodí v případech, kdy vaše data upravuje několik uživatelů a vy chcete mít jistotu, že vidíte vždy nejaktuálnější verzi, nebo když chcete ušetřit místo na disku. U většiny formátů si můžete vybrat, jestli chcete data importovat, nebo propojit odkazem.

Karta s možnostmi externích dat v Accessu

Postup se pro jednotlivé zdroje dat mírně liší, pomocí následujících pokynů se však můžete na import připravit:

  1. V Externí Data tabulátor, klikněte na formát dat můžete budete import nebo propojení na. Pokud nevidíte vhodný formát, klikněte na Další.

Poznámka : Pokud ani potom nevidíte vhodný formát, možná budete muset data napřed exportovat do souboru s formátem, který Access podporuje (třeba do Textový soubor s oddělovači).

  1. Postupujte podle pokynů dialogové okno Načíst externí Data.

Při propojování jsou některé formáty dostupné jen v režimu pouze pro čtení. Následuje seznam externích zdrojů, ze kterých je možné importovat nebo propojit data:

Import

Odkaz

Aplikace Microsoft Excel

Ano

Ano
(pouze pro čtení)

Microsoft Access

Ano

Ano

Databáze ODBC (třeba SQL Server)

Ano

Ano

Textové soubory nebo textové soubory s oddělovači (CSV)

Ano

Ano
(jen přidávání nových záznamů)

Sharepointový seznam

Ano

Ano

XML

Ano

Datové služby

Ano
(pouze pro čtení)

Dokument HTML

Ano

Ano

Outlooková složka

Ano

Ano

Více informací najdete v tématech Import dat do accessové databáze a Import dat z accessové databáze.

Uspořádání dat pomocí analýzy tabulky

Průvodce analýzou tabulky slouží k rychlému určení nadbytečných dat. Průvodce na závěr nabídne jednoduchý způsob uspořádání dat v samostatných tabulkách. Access uchová zálohy původních tabulek.

  1. Otevřete accessovou databázi obsahující tabulku, kterou chcete analyzovat.

  2. Klikněte na Databázové nástroje > Analýza tabulky.

    Na prvních dvou stránkách průvodce najdete stručný návod s příklady. Jestliže vidíte zaškrtávací políčko Zobrazovat úvodní stránky, zaškrtněte ho a pak poklikejte na Zpět, abyste zobrazili úvodní stránky. Jestliže už znovu tyto stránky vidět nechcete, zrušte zaškrtnutí políčka Zobrazovat úvodní stránky

Začátek stránky

Další kroky

Další postup už záleží na tom, co chcete s databází dělat, ale dá se očekávat, že budete vytvářet také dotazy, formuláře, sestavy a makra. Třeba vám přijdou vhod tyto články:

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Byly tyto informace užitečné?

Jak ji můžeme vylepšit?

Jak ji můžeme vylepšit?

Pokud si chcete chránit soukromí, nedávejte do zpětné vazby kontaktní informace. Ohodnoťte aplikaci zásady ochrany osobních údajů.

Děkujeme vám za zpětnou vazbu.