Získání externích dat pomocí aplikace Microsoft Query

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Aplikace Microsoft Query slouží k načtení dat z externích zdrojů. Pomocí aplikace Microsoft Query k načtení dat z podnikových databází a soubory, nemusíte znovu zadávat data, která chcete analyzovat v aplikaci Excel. Můžete taky aktualizovat sestavy aplikace Excel a souhrny automaticky na základě původní zdrojové databáze při každé aktualizaci databáze nové informace.

Pomocí aplikace Microsoft Query, můžete připojení k externím zdrojům dat, vyberte dat z externích zdrojů, tato data importovat do listu a aktualizujete data v případě potřeby zachovat synchronizuje s dat z externích zdrojů dat na listu.

Typy databází, které dostanete     Načtení dat z několika typů databází, včetně aplikace Microsoft Office Access, Microsoft SQL Server a služby Microsoft SQL Server OLAP. Můžete taky data načtete z Excelových sešitů a od soubory ve formátu RTF.

Microsoft Office jsou ovladače, které slouží k načtení dat z následujících zdrojů dat:

  • Microsoft SQL Server Analysis Services (Zprostředkovatel OLAP )

  • Sledování a sdílení

  • dBASE

  • Microsoft FoxPro

  • Aplikace Microsoft Office Excel

  • Oracle

  • Paradox

  • Databáze textových souborů

Můžete taky ovladačů ODBC nebo ovladače zdrojů dat od jiných výrobců načítat informace ze zdroje dat, které zde nejsou uvedeny, včetně dalších typů databáze OLAP. Informace o instalaci ovladač ODBC nebo ovladač zdroje dat, který není uvedený tady najdete v dokumentaci k databázi nebo dodavatele databáze.

Výběr dat z databáze     Data načtete z databáze vytvořením dotazu, což je otázku, na kterou se zeptejte se data uložená v externí databázi. Pokud vaše data uložena v databázi aplikace Access, budete chtít zjistit hodnoty prodeje pro určitý produkt podle oblasti. Část dat, můžete získat tak, že vyberete jen tu část dat pro určitý produkt a oblasti, která chcete analyzovat.

Pomocí aplikace Microsoft Query můžete vybrat sloupce dat a tato data importovat do Excelu.

Aktualizace listu v jednom kroku     Až budete mít externích dat v Excelovém sešitu, kdykoli změny databáze, můžete provést tyto akce Aktualizovat data, která chcete aktualizovat analýzy, aniž by bylo nutné znovu vytvořit souhrnné sestavy a grafy. Můžete například vytvořit souhrn měsíční prodeje a aktualizace každý měsíc, kdy použít nové hodnoty prodeje.

Jak aplikace Microsoft Query použije zdroje dat     Po nastavení zdroje dat pro konkrétní databázi můžete kdykoli budete chtít k vytvoření dotazu pro výběr a načtení dat z databáze, aniž by bylo nutné znovu zadávat všechny informace o připojení. Aplikace Microsoft Query používá zdroje dat pro připojení k databázi externí a zobrazíte, jaká data je k dispozici. Po vytvoření dotazu a vrátit data do Excelu, poskytuje aplikace Microsoft Query Excelový sešit s informací o zdroji dotazu a data tak, aby k databázi můžete znovu připojit a aktualizovat data.

Použití zdrojů dat v aplikaci Microsoft Query

Použití aplikace Microsoft Query k importu dat    externích dat do Excelu mohli importovat pomocí aplikace Microsoft Query, postupujte podle těchto základních kroků, které se podrobněji píše v následujících částech.

Co je zdroj dat?     Zdroj dat je uložená sada informací, které umožňuje aplikace Excel a Microsoft Query připojení k databázi externí. Po nastavení zdroje dat pomocí aplikace Microsoft Query, název zdroje dat a potom zadejte název a umístění databáze na serveru, typ databáze a informace o přihlášení a heslo. Informace o obsahuje taky název ovladač ODBC nebo ovladač zdroje dat, což je program, který slouží k propojení určitý typ databáze.

Nastavení zdroje dat pomocí aplikace Microsoft Query:

  1. Na kartě Data ve skupině Načíst externí Data klikněte na Z jiných zdrojů a potom klikněte na tlačítko Z aplikace Microsoft Query.

  2. Proveďte jednu z následujících akcí:

    • Chcete-li zdroj dat pro databáze, textový soubor nebo Excelového sešitu, klikněte na kartu databází.

    • Chcete-li datové krychle OLAP, klikněte na kartu Datové krychle OLAP. Tato karta je dostupná jenom v případě, že spuštění aplikace Microsoft Query z aplikace Excel.

  3. Poklikejte na < nový zdroj dat >.

    – nebo –

    Klikněte na < nový zdroj dat > a potom klikněte na OK.

    Dialogové okno Vytvořit nový zdroj dat se zobrazí.

  4. V kroku 1 zadejte název pro identifikaci zdroje dat.

  5. V kroku 2 klepněte na ovladač typu databáze, kterou použijete jako zdroj dat.

    Poznámky : 

    • Pokud ovladače ODBC, které jsou instalovány spolu aplikace Microsoft Query nepodporuje externí databázi, které chcete mít přístup a pak budete muset získat a nainstalovat ovladač ODBC kompatibilní se službou Microsoft Office od jiných dodavatelů, například výrobce databáze. Požádejte prodejcem databáze pokyny k instalaci.

    • Databáze OLAP nevyžadují ovladače ODBC. Při instalaci aplikace Microsoft Query ovladače nainstalovaných pro databáze vytvořené pomocí Microsoft SQL Server Analysis Services. Připojit k jiné databáze OLAP, budete muset nainstalovat zdroje dat software ovladač a klienta.

  6. Klikněte na Připojit a potom zadejte informace, které je potřeba k připojení ke zdroji dat. Databáze, Excelových sešitů a soubory ve formátu RTF informace, které jste zadali závisí na typu zdroje dat, který jste vybrali. Můžete být vyzváni k zadání přihlašovací jméno, heslo, verzi databáze, kterou používáte, umístění databáze nebo jiné informace specifické pro typ databáze.

    Důležité : 

    • Používejte silná hesla kombinující malá a velká písmena, čísla a symboly. Slabá hesla obsahují jenom některé z těchto znaků. Příklad silného hesla: Y6dh!et5. Příklad slabého hesla: Domek27. Hesla by měla obsahovat minimálně 8 znaků. Ještě vhodnější jsou hesla obsahující 14 nebo víc znaků.

    • Je velice důležité, abyste si své heslo zapamatovali. Pokud je zapomenete, společnost Microsoft je nemůže odnikud načíst. Pokud si heslo zapíšete, uložte je na bezpečném místě odlišném od místa uložení informací, které heslo pomáhá chránit.

  7. Po zadání požadovaných informací klikněte na OK nebo Dokončit vraťte do dialogového okna Vytvořit nový zdroj dat.

  8. Pokud databáze obsahuje tabulky a chcete určitou tabulku automaticky zobrazily v Průvodci dotazu, klikněte na rozevírací seznam kroku 4 a potom klikněte na tabulku, která chcete.

  9. Pokud nechcete zadejte své přihlašovací jméno a heslo při použití zdroje dat, zaškrtněte políčko Uložit uživatelské ID a heslo v definice zdroje dat. Není zašifrovaných uložené heslo. Pokud je zaškrtávací políčko není k dispozici, kontaktujte správce databáze a zjistit, jestli tato možnost může být k dispozici.

    Poznámka zabezpečení : Vyhněte se ukládání přihlašovacích údajů při připojování ke zdrojům dat. Tyto informace mohou být uloženy jako prostý text a informací o k narušení zabezpečení zdroje dat může přístupu se zlými úmysly.

Po dokončení těchto kroků název zdroje dat se zobrazí v dialogovém okně Vybrat zdroj dat.

Použití Průvodce dotazem u většiny dotazů     Průvodce dotazem usnadňuje vyberte a shromažďování dat z různých tabulek a polí v databázi. Pomocí Průvodce dotazem, můžete zvolit tabulek a polí, které chcete zahrnout. Vnitřní spojení (operace dotazu, která určuje, že se slučují řádků ze dvou tabulek na základě hodnoty shodné polí) se vytvoří automaticky při průvodce rozpozná polem primárního klíče v jedné tabulky a pole se stejným názvem v druhé tabulce.

Můžete také Průvodce můžete řadit sadu výsledků a provádět jednoduché filtrování. V posledním kroku průvodce můžete vrátit data do Excelu nebo dál upřesňovat dotazu v aplikaci Microsoft Query. Po vytvoření dotazu, můžete ji spustit v aplikaci Excel nebo v aplikaci Microsoft Query.

Spusťte Průvodce dotazem, proveďte následující kroky.

  1. Na kartě Data ve skupině Načíst externí Data klikněte na Z jiných zdrojů a potom klikněte na tlačítko Z aplikace Microsoft Query.

  2. V dialogovém okně Vybrat zdroj dat Ujistěte se, že je zaškrtnuté políčko použít Průvodce dotazem k vytvoření a úpravy dotazů.

  3. Poklikejte na položku zdroj dat, který chcete použít.

    – nebo –

    Klikněte na zdroj dat, který chcete použít a klikněte na OK.

Práce přímo v aplikaci Microsoft Query neobsahují další typy dotazů     Pokud chcete vytvořit složitější dotaz než Průvodce dotazem umožňuje, můžete pracovat přímo v aplikaci Microsoft Query. Aplikace Microsoft Query slouží k zobrazení a změna dotazů začnete vytvářet Průvodce dotazem, zda vytvoříte nové dotazy bez použití průvodce. Pracujte přímo v aplikaci Microsoft Query, když budete chtít vytvořit dotazy, které následujícím způsobem:

  • Výběr určitých dat z polí     Ve velké databázi můžete vybrat některá data v poli a vynechat dat, kterou nepotřebujete. Například v případě potřeby dat pro dva produktů v poli s informacemi o mnoha produktů můžete Kritéria výběr dat pro pouze dva produkty, které chcete.

  • Načtení dat podle různých kritérií při každém spuštění dotazu     Pokud je potřeba vytvořit stejnou Excelovou sestavu nebo souhrn pro několik oblastí v okně stejné externí data – třeba samostatném výkaz o prodeji pro každou oblast – můžete vytvořit Parametrický dotaz. Po spuštění parametrického dotazu se výzva k zadání hodnoty pro jako kritéria při výběru záznamů. Například výzvu k zadání konkrétní oblasti a můžete znovu použít tohoto dotazu k vytvoření každé místní sestav prodeje.

  • Připojení dat různé způsoby     Vnitřní spojení, které vytvoří Průvodce dotazem jsou nejběžnější typ spojení použít při vytváření dotazů. Někdy ale chcete použít jiný typ spojení. Například pokud máte tabulku produktů s informacemi o prodeji a tabulku s informacemi o zákaznících, vnitřní spojení (typ vytvořené pomocí Průvodce dotazem) zabrání načítání záznamy o zákazníkovi pro zákazníky, kteří neprovedli k nákupu. Pomocí aplikace Microsoft Query, se můžete připojit v této tabulce tak, aby všechny záznamy zákazníků načtením spolu s data o prodeji pro zákazníky, kteří mají nezakoupili.

Spuštění aplikace Microsoft Query, proveďte následující kroky.

  1. Na kartě Data ve skupině Načíst externí Data klikněte na Z jiných zdrojů a potom klikněte na tlačítko Z aplikace Microsoft Query.

  2. V dialogovém okně Vybrat zdroj dat zkontrolujte, že je zaškrtnutí políčka použít Průvodce dotazem k vytvoření a úpravy dotazů.

  3. Poklikejte na položku zdroj dat, který chcete použít.

    – nebo –

    Klikněte na zdroj dat, který chcete použít a klikněte na OK.

Sdílení dotazů a opakované použití     Průvodce dotazem i v aplikaci Microsoft Query můžete uložit jako DQY soubor, který lze upravovat, znovu použít a sdílet svoje dotazy. Excel umí otevírat soubory DQY přímo, které umožňuje vy nebo jiní uživatelé vytvářet další oblasti externích dat ze stejného dotazu.

Otevření uloženého dotazu z Excelu:

  1. Na kartě Data ve skupině Načíst externí Data klikněte na Z jiných zdrojů a potom klikněte na tlačítko Z aplikace Microsoft Query. Dialogové okno Vybrat zdroj dat se zobrazí.

  2. V dialogovém okně Vybrat zdroj dat klikněte na kartu dotazy.

  3. Poklikejte na uložený dotaz, který chcete otevřít. Dotaz se zobrazí v aplikaci Microsoft Query.

Pokud chcete otevřít uložený dotaz a aplikace Microsoft Query, už otevřené, klikněte na nabídku aplikace Microsoft Query soubor a potom klikněte na Otevřít.

Poklikejte na položku příponou Excel otevře, spustí dotaz a výsledky se vloží do nového listu.

Pokud chcete sdílet souhrn nebo aplikace Excel sestavu, která je založená na externích datech, možnost poskytnout jiným uživatelům sešit, ve kterém oblasti externích dat nebo můžete vytvořit Šablona. Šablony umožňuje uložit souhrn nebo sestavu bez uložení externích dat, aby tento soubor je menší. Při otevření šablony sestavy je načíst externí data.

Po vytvoření dotazu na Průvodce dotazem nebo aplikace Microsoft Query můžete vrátit data do listu aplikace Excel. Data se stane poté Oblast externích dat nebo Kontingenční tabulka, kterou můžete formátovat aktualizace.

Formátování načíst data     V aplikaci Excel můžete použít nástroje, například grafy nebo automatických souhrnů, můžete prezentovat a shrnutí data načtená v aplikaci Microsoft Query. Formátování dat a formátování se zachovají, když aktualizujete externí data. Můžete použít vlastní popisky sloupců místo názvy polí a automaticky přidat čísla řádků.

Aplikace Excel automaticky formátovat nová data zadaná na konci oblasti podle předchozího řádky. Aplikace Excel můžete zkopírovat také automaticky vzorce, které byly opakovat v předchozím řádky a rozšiřuje na další řádky.

Poznámka : Pokud chcete prodloužit pro nový řádek v oblasti formáty a vzorce musí být alespoň ve třech z pěti řádků.

Můžete zapnout možnost (nebo zase vypnout) kdykoli:

  1. Klikněte na Soubor > Možnosti > Upřesnit.

    V Excel 2007: klikněte na Tlačítko Microsoft Office Obrázek tlačítka , klikněte na Možnosti aplikace Excel a pak klikněte na kategorii Upřesnit.

  2. V části Možnosti úprav zaškrtněte políčko rozšířit dat v rozsahu formáty a vzorce. Vypnout automatické formátování datové oblasti znovu, zrušte zaškrtnutí políčka.

Aktualizace externích dat     Aktualizace externích dat spustíte dotaz načíst novými a upravenými dat, které odpovídají zadaným kritériím. Budete moct aktualizovat dotazu v aplikaci Microsoft Query i v aplikaci Excel. Aplikace Excel nabízí několik možností pro aktualizaci dotazech, včetně aktualizace dat při každém otevření sešitu a automatické aktualizace v nastavených časových intervalech. Můžete pokračovat v práci v aplikaci Excel a během aktualizace dat, můžete taky zkontrolovat stav během aktualizace dat je. Další informace najdete v tématu aktualizace připojených (importovaných) dat..

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×