Základní informace o připojování k datům a jejich importu

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Tenhle článek popisuje import a připojení data. Dozvíte se o úlohami, například import, aktualizace, zabezpečení a správa dat.

V tomto článku

Práce s připojením k externím datům

Aktualizace dat

Import dat ze zdroje dat

Lepší zabezpečení přístup k datům

Problémy s o připojování k datům

Práce s externími datovými připojeními

Následující oddíly popisují, jak fungují externí datová připojení a jak lze najít, upravit, spravovat a sdílet informace o připojení s jinými aplikacemi a uživateli.

Začátek stránky

Základní principy datových připojení

Data v sešitě aplikace Excel mohou pocházet ze dvou různých míst. Data mohou být uložena přímo v sešitě nebo mohou být uložena v externím zdroji dat, například v textovém souboru, databázi nebo datové krychli OLAP (Online Analytical Processing). Externí zdroj dat je připojen k sešitu prostřednictvím datového připojení, což je sada informací popisujících, jak externí zdroj dat najít, přihlásit se k němu a získat k němu přístup.

Hlavní výhodou připojení k externím datům je, že tato data můžete pravidelně analyzovat, aniž by je bylo nutné opakovaně kopírovat do sešitu, což může být zdlouhavá operace náchylná k chybám. Po připojení k externím datům můžete své sešity aplikace Excel také automaticky aktualizovat z původního zdroje dat, kdykoli je tento zdroj dat aktualizován na základě nových informací.

Informace o připojení jsou uloženy v sešitu a mohou také být uloženy v souboru připojení, například v souboru datového připojení systému Office (s příponou ODC) nebo v souboru typu Název zdroje dat (s příponou DSN).

Externí data přenést do aplikace Excel, musíte mít přístup k datům. Nejsou-li externí Zdroj dat, která chcete mít přístup na místním počítači, budete asi muset kontaktovat správce databáze pro heslo, uživatelská oprávnění nebo Další informace o připojení. Pokud je zdroj dat databáze, ujistěte se, že není otevřít databázi ve výhradním režimu. Pokud je zdroj dat textového souboru nebo tabulce, přesvědčte se, že jiný uživatel nemá ho otevřít pro výhradní přístup.

Mnoho zdrojů dat vyžaduje také ovladač ODBC nebo zprostředkovatele OLE DB za účelem koordinace toku dat mezi aplikací Excel, souborem připojení a zdrojem dat.

Následující diagram shrnuje klíčové body datových připojení.

Připojování k externím zdrojům dat

1. jsou různých zdrojů dat, které se můžete připojit k: služby Analysis Services serveru SQL Server, aplikace Microsoft Access, jiné OLAP a relační databáze, tabulky a soubory ve formátu RTF.

2. hodně zdrojů dat mít přidružené ovladač ODBC nebo zprostředkovatele OLE DB.

3. soubor připojení definuje všechny informace, které je potřeba k přístupu a načtení dat ze zdroje dat.

4 informace o připojení ze souboru připojení zkopírována do sešitu, a informace o připojení můžete snadno možné jej upravit.

5. Data se kopírují do sešitu, abyste je mohli použít stejným způsobem jako data uložená přímo v sešitu.

Začátek stránky

Hledání připojení

K hledání souborů připojení použijte dialogové okno Existující připojení. (Na kartě Data klikněte ve skupině Načíst externí data na možnost Existující připojení.) Pomocí tohoto dialogového okna můžete zobrazit následující typy připojení:

  • Připojení v sešitu   

    Tento seznam zobrazuje všechna aktuální připojení v sešitě. Tento seznam je tvořen již definovanými připojeními vytvořenými pomocí dialogového okna Vybrat zdroj dat v Průvodci datovým připojením a připojeními, která jste dříve vybrali jako připojení z tohoto dialogového okna.

  • Připojení souborů na počítači   

    Tento seznam je vytvořen ze složky Zdrojedat, která je obvykle uložena ve složce Dokumenty.

  • Připojení souborů v síti   

    Tento seznam může být tvořen z následujících položek:

    • Sada složek v místní síti, jejichž umístění může být nasazeno po celé síti jako součást nasazení zásad skupiny systému Microsoft Office.

    • Excel Services datové připojení knihovny (DCL) na webu SharePoint Foundation. Další informace o DCL naleznete v části publikování služby Excel Services bezpečnému.

Začátek stránky

Úpravy vlastností připojení

Aplikaci Excel můžete použít také jako editor souborů připojení a vytvářet a upravovat v ní připojení k externím zdrojům dat, jež jsou uložena v sešitě nebo v souboru připojení. Pokud nenajdete požadované připojení, můžete vytvořit nové tak, že kliknete na tlačítko Vyhledat další, čímž zobrazíte dialogové okno Vybrat zdroj dat. V něm pak kliknutím na tlačítko Nový zdroj spustíte Průvodce datovým připojením.

Po vytvoření připojení můžete použít dialogové okno Vlastnosti spojení (na kartě Data ve skupině Načíst externí Data klikněte na Vlastnosti.) řídit různá nastavení pro připojení k externím zdrojům dat a jak používat, znovu připojit nebo přepínání souborů připojení.

Pokud k připojení ke zdroji dat použijete soubor připojení, zkopíruje aplikace Excel informace o připojení ze souboru připojení do sešitu aplikace Excel. Při provádění změn pomocí dialogového okna Vlastnosti připojení budete upravovat informace o datovém připojení uložené v aktuálním sešitě aplikace Excel, nikoli původní soubor datového připojení, jehož pomocí bylo připojení vytvořeno (název tohoto souboru je zobrazen ve vlastnosti Soubor připojení na kartě Definice). Po upravení informací o připojení (s výjimkou vlastností Název připojení a Popis připojení) bude odkaz na soubor připojení odebrán a hodnota vlastnosti Soubor připojení bude vymazána.

Chcete-li zajistit, aby byl při aktualizaci zdroje dat vždy použit soubor připojení, zaškrtněte na kartě Definice políčko Vždy aktualizovat data pomocí tohoto souboru. Toto zaškrtávací políčko zajišťuje, aby se aktualizace tohoto souboru připojení vždy použily ve všech sešitech, které ho používají, přičemž v nich rovněž musí být nastavena tato možnost.

Začátek stránky

Správa připojení

Pomocí dialogového okna Připojení sešitu můžete snadno spravovat tato připojení, včetně jejich vytváření, úprav a odstraňování. (Na kartě Data klikněte ve skupině Načíst externí data na možnost Připojení.) Pomocí tohoto dialogového okna můžete provést následující akce:

  • Vytvořit, upravit, aktualizovat a odstranit připojení používaná v sešitě

  • Ověřit zdroj externích dat (vhodné v případě, že připojení bylo definováno jiným uživatelem)

  • zobrazení, kde se každé připojení v aktuálním sešitě používá;

  • diagnostikování chybové zprávy o připojeních k externím datům;

  • přesměrování připojení na jiný server či zdroj dat nebo nahrazení souboru připojení pro existující připojení;

  • Snadno vytvořit a sdílet soubory připojení s uživateli

Začátek stránky

Sdílení připojení

Soubory připojení jsou zvláště užitečné pro konzistentní sdílení připojení. Připojení lze díky nim snadněji vyhledat, pomáhají vylepšit zabezpečení připojení a zjednodušují správu zdrojů dat. Nejlepším způsobem pro sdílení souborů připojení je uložit je do zabezpečeného a důvěryhodného umístění, například do síťové složky nebo do knihovny služby SharePoint, kde uživatelé mohou soubor číst, ale pouze určení uživatelé jej mohou upravit.

Použití souborů ODC

Soubory datového připojení systému Office (s příponou ODC) můžete vytvořit tak, že se připojíte k externím datům prostřednictvím dialogového okna Vybrat zdroj dat nebo se pomocí Průvodce datovým připojením připojíte k novým zdrojům dat. Soubor ODC používá k ukládání informací o připojení vlastní značky HTML a XML. Obsah tohoto souboru můžete snadno zobrazit nebo upravit v aplikaci Excel.

Soubory připojení můžete sdílet s jinými uživateli, kterým tak můžete poskytnout stejný přístup k externímu zdroji dat, jako máte vy. Jiní uživatelé nemusí nastavit zdroj dat, aby mohli soubor připojení otevřít, ale možná budou muset do svých počítačů nainstalovat ovladač ODBC nebo zprostředkovatele OLE DB, který je požadován pro přístup k externím datům.

Soubory ODC představují doporučenou metodu pro připojování k datům a sdílení dat. Tradiční soubory připojení (DSN, UDL a soubory dotazu) můžete snadno převést na soubor ODC tak, že soubor připojení otevřete a potom kliknete v dialogovém okně Vlastnosti připojení na kartě Definice na tlačítko Exportovat soubor připojení.

Použití souborů dotazu

Soubory dotazu jsou textové soubory, které obsahují informace o zdroji dat, včetně názvu serveru, na kterém jsou data umístěna, a informací o připojení, které zadáte při vytváření zdroje dat. Soubory dotazu představují tradiční způsob sdílení dotazů s jinými uživateli aplikace Excel.

Použití souborů DQY dotazů    Pomocí aplikace Microsoft Query můžete uložit DQY soubory, které obsahují dotazy na data z relační databáze nebo soubory ve formátu RTF. Když otevřete tyto soubory v aplikaci Microsoft Query, můžete zobrazit data vrácená dotazem a upravte dotaz vracet různé výsledky. Můžete uložit příponou pro dotaz, který vytvoříte pomocí Průvodce dotazem nebo přímo v aplikaci Microsoft Query.

Použití kontingenční dotazu    Můžete uložit kontingenční chcete připojit k datům v databázi OLAP na serveru nebo v soubor offline datové krychle (CUB). Pokud použijete Průvodce připojením vícerozměrné v aplikaci Microsoft Query k vytvoření zdroje dat pro databáze OLAP nebo datové krychle, automaticky se vytvoří soubor OQY. Protože databáze OLAP se seřazenými do záznamů nebo tabulky, nelze vytvořit dotazy nebo DQY soubory do těchto databáze Accessu.

Použití souborů RQY dotazů    Excel umí otevírat soubory dotazu v RQY podpora ovladače zdrojů dat OLE DB, které tento formát použijte. Další informace najdete v dokumentaci pro ovladač.

Použití souborů QRY dotazů    Aplikace Microsoft Query můžete otevřít a uložit ve formátu QRY pro použití s předchozími verzemi aplikace Microsoft Query, které se nedají otevřít soubory DQY soubory dotazů. Pokud máte otevřený soubor dotazu ve formátu QRY, který chcete použít v aplikaci Excel, otevřete soubor v aplikaci Microsoft Query a pak ho uložte jako příponou. Informace o ukládání souborů DQY najdete v nápovědě k aplikaci Microsoft Query.

Používání souborů IQY webového dotazu    Excel umí otevírat soubory dotazu Web IQY k načtení dat z webu.

Začátek stránky

Použití oblastí externích dat a jejich vlastnosti

Oblast externích dat (označovaná také jako tabulka dotazů) je definovaný název nebo název tabulky, který definuje umístění dat přenesených do listu. Při připojení k externím datům aplikace Excel automaticky vytvoří oblast externích dat. Jedinou výjimkou je sestava kontingenční tabulky připojená ke zdroji dat, která oblast externích dat nevytváří. V aplikaci Excel lze oblast externích dat formátovat, upravit její rozložení nebo ji použít ve výpočtech stejným způsobem jako jakákoli jiná data.

Aplikace Excel automaticky pojmenovává oblasti externích dat následujícím způsobem:

  • Oblasti externích dat ze souborů datového připojení systému Office (ve formátu ODC) dostávají stejný název, jako je název souboru.

  • Oblasti externích dat z databáze jsou s názvem s názvem dotaz. Ve výchozím nastavení jako Dotaz_z_zdroje je název zdroje dat, který jste použili k vytvoření dotazu.

  • Oblasti externích dat z textových souborů dostávají název podle názvu textového souboru.

  • Oblasti externích dat z webové dotazy jsou s názvem s názvem webovou stránku, ze kterého byla data načíst.

Pokud list obsahuje více než jednu oblast externích dat ze stejného zdroje, jsou oblasti číslovány, například Text, Text_1, Text_2 atd.

Oblast externích dat má další vlastnosti (nezaměňovat s vlastnostmi připojení), které lze použít ke správě dat, jako je například zachování formátování buněk a šířky sloupců. Tyto vlastnosti oblasti externích dat můžete změnit po kliknutí na tlačítko Vlastnosti ve skupině Připojení na kartě Data. Potom proveďte požadované změny v dialogovém okně Vlastnosti oblasti externích dat nebo Vlastnosti externích dat.

Poznámka : Pokud chcete sdílet souhrn nebo sestavu, která je založená na externích datech, než ostatní můžete dát sešit, ve kterém oblasti externích dat nebo vytvoření šablony sestavy. Šablona sestavy umožňuje uložit souhrn nebo sestavu bez uložení externích dat, aby tento soubor je menší. Při otevření šablony sestavy je načíst externí data.

Začátek stránky

Principy podpory zdrojů dat v aplikaci Excel a službách Excel Services

Existuje několik datových objektů (například oblast externích dat a sestava kontingenční tabulky), jejichž pomocí se můžete připojit k různým zdrojům dat. Typy zdrojů dat, ke kterým se můžete připojit, se však u jednotlivých datových objektů liší. Připojená data můžete také používat a aktualizovat ve službách Excel Services, ale jsou zde určitá omezení, o kterých byste měli vědět.

Podpora datových objektů a zdrojů dat v aplikaci Excel

Následující tabulka shrnuje, které zdroje dat jsou podporovány u jednotlivých datových objektů v aplikaci Excel.

Podporovaný zdroj dat

Excel
dat
objektu

Vytvoří
externí
dat
oblasti?

OLE
odpis.ZRYCH

ROZHRANÍ ODBC

Text
souboru

HTML
souboru

XML
souboru

Sdílet -
čárky
seznamu

Průvodce importem textu

Ano

Ne

Ne

Ano

Ne

Ne

Ne

Sestava kontingenční tabulky
(jiná než OLAP)

Ne

Ano

Ano

Ano

Ne

Ne

Ano

Sestava kontingenční tabulky
(OLAP)

Ne

Ano

Ne

Ne

Ne

Ne

Ne

Tabulka aplikace Excel

Ano

Ano

Ano

Ne

Ne

Ano

Ano

Mapování XML

Ano

Ne

Ne

Ne

Ne

Ano

Ne

Webový dotaz

Ano

Ne

Ne

Ne

Ano

Ano

Ne

Průvodce datovým připojením

Ano

Ano

Ano

Ano

Ano

Ano

Ano

Aplikace Microsoft Query

Ano

Ne

Ano

Ano

Ne

Ne

Ne

Poznámka : Tyto soubory, textové soubory importované pomocí Průvodce importem textu, soubory XML importované pomocí mapování XML a soubory HTML a XML importované pomocí webového dotazu nepoužívají pro připojení ke zdroji dat ovladač ODBC ani zprostředkovatele OLE DB.

Podpora zdrojů dat ve službách Excel Services

Pokud chcete zobrazit sešit aplikace Excel ve službách Excel Services (jedná se vlastně o aplikaci Excel ve webovém prohlížeči), můžete se připojit k datům a aktualizovat je, ale je třeba použít sestavu kontingenční tabulky. Služby Excel Services nepodporují oblasti externích dat, což znamená, že nepodporují tabulky aplikace Excel připojené ke zdroji dat, webovému dotazu, mapování XML nebo aplikaci Microsoft Query.

Toto omezení lze však obejít tak, že pro připojení ke zdroji dat použijete kontingenční tabulku a potom upravíte její návrh a rozložení tak, aby se jednalo o dvourozměrnou tabulku bez úrovní, skupin a souhrnů a aby byly zobrazeny všechny požadované hodnoty řádků a sloupců. Další informace najdete v odkazech v části Viz také.

Začátek stránky

Principy rozhraní Microsoft Data Access Components

Data Access Components (MDAC) 2,8 je součástí systému Microsoft Windows Server 2003 a systému Windows XP s aktualizací SP2. S MDAC můžete připojení k a použít data z nejrůznějších zdrojů relačních a nonrelational data. Můžete se připojit k mnoha různých zdrojů dat pomocí ovladače připojení ODBC (Open Database) nebo OLE DB poskytovatelů, které jsou vytvořené a vyřízeny společností Microsoft nebo vyvinutý různých třetích stran. Při instalaci systému Microsoft Office Další ovladače ODBC a zprostředkovatele OLE DB se přidají do svého počítače.

Systémy Windows Vista a Windows 7 používají rozhraní Windows Data Access Components (Windows DAC).

Chcete-li zobrazit úplný seznam zprostředkovatelů OLE DB nainstalovaných v počítači, zobrazte dialogové okno Vlastnosti Data Link ze souboru Data Link a potom klikněte na kartu Zprostředkovatel.

Pokud chcete zobrazit úplný seznam zprostředkovatelů ODBC nainstalovaných v počítači, zobrazte dialogové okno Správce databáze ODBC a potom klepněte na kartu Ovladače.

Můžete použít také ovladače ODBC a zprostředkovatele OLE DB od jiných výrobců k získání informací od jiných datových zdrojů než od společnosti Microsoft, včetně jiných typů databází ODBC a OLE DB. Informace o instalaci těchto ovladačů ODBC nebo zprostředkovatelů OLE DB získáte v dokumentaci k databázi nebo se obraťte na dodavatele databáze.

Začátek stránky

Připojení ke zdrojům dat pomocí technologie ODBC

Následující části podrobněji popisují rozhraní ODBC (Open Database Connectivity).

Architektura ODBC

V architektuře ODBC se aplikace (například Excel) připojí ke Správci ovladačů ODBC, který pak použije určitý ovladač ODBC (například ovladač ODBC systému Microsoft SQL) pro připojení ke zdroji dat (například k databázi systému Microsoft SQL Server).

Definování informací o připojení

Chcete-li se připojit ke zdrojům dat ODBC, proveďte následující kroky:

  1. Přesvědčte se, zda je v počítači, který obsahuje zdroj dat, nainstalován příslušný ovladač ODBC.

  2. Definujte název zdroje dat (DSN) pomocí Správce zdrojů dat ODBC (který uloží informace o připojení do registru nebo souboru DSN) nebo pomocí připojovacího řetězce v jazyce Microsoft Visual Basic (který předá informace o připojení přímo Správci ovladačů ODBC).

    Chcete-li definovat zdroj dat, klikněte v systému Windows Vista na tlačítko Start a na příkaz Ovládací panely. Klikněte na odkaz Systém a údržba a potom na odkaz Nástroje pro správu. V systémech Windows XP a Windows Server klikněte na tlačítko Start a na příkaz Ovládací panely. Klikněte na odkaz Výkon a údržba a potom na odkaz Nástroje pro správu. Potom klikněte na položku Zdroje dat (ODBC). Další informace o různých možnostech můžete získat kliknutím na tlačítko Nápověda v jednotlivých dialogových oknech.

Zdroje dat počítače

Zdroje dat počítače obsahují informace o připojení v registru na počítači s názvem uživatelem definovaných. Zdroje dat počítače můžete použít pouze v počítači, které jsou definovány. Existují dva typy zdrojů dat počítače – uživatele a systémem. Uživatelské zdroje dat lze použít pouze aktuálním uživatelem a jsou viditelné jenom tomuto uživateli. Systémové zdroje dat se všem uživatelům v počítači a může používat všechny uživatele v počítači.

Zdroje dat počítače jsou užitečné zvláště v případě, že chcete zvýšit zabezpečení, protože pomáhají zajistit, aby zdroj dat počítače mohli zobrazit pouze přihlášení uživatelé. Zdroje dat počítače rovněž nemohou být zkopírovány do jiného počítače vzdáleným uživatelem.

Souborové zdroje dat

Souborové zdroje dat (také nazývané soubory DSN) ukládají informace o připojení do textového souboru, nikoli do registru, a jejich použití je obecně flexibilnější než v případě zdrojů dat počítače. Souborový zdroj dat můžete například zkopírovat do libovolného počítače se správným ovladačem ODBC, aby aplikace mohla spoléhat na konzistentní a přesné informace o připojení ve všech počítačích, které používá. Můžete také umístit souborový zdroj dat na jediný server, sdílet jej mezi mnoha počítači v síti a snadno udržovat informace o připojení na jednom místě.

Souborový zdroj dat může být také nesdílitelný. Nesdílitelný souborový zdroj dat se nachází v jednom počítači a odkazuje na zdroj dat počítače. Pomocí nesdílitelných souborových zdrojů dat můžete přistupovat k existujícím zdrojům dat počítače ze souborových zdrojů dat.

Začátek stránky

Připojení ke zdrojům dat pomocí architektury OLE DB

Následující části podrobněji popisují architekturu Object Linking and Embedding Database (OLE DB).

Architektura OLE DB

V architektuře OLE DB se aplikace přistupující k datům nazývá spotřebitel dat (například aplikace Excel) a program, který umožňuje nativní přístup k datům, se nazývá zprostředkovatel databáze (například Zprostředkovatel Microsoft OLE DB pro SQL Server).

Definování informací o připojení

Soubor Universal Data Link (UDL) obsahuje informace, které spotřebitel dat použije pro přístup ke zdroji dat pomocí zprostředkovatele OLE DB tohoto zdroje dat. Informace o připojení můžete vytvořit jedním z následujících způsobů:

  • V Průvodci datovým připojením pomocí dialogové okno Vlastnosti spojení dat definovat propojení dat pro zprostředkovatele OLE DB. Další informace naleznete v části Import dat pomocí Průvodce datovým připojením.

  • Vytvořte prázdný textový soubor s příponou UDL a potom upravte soubor, který zobrazuje dialogové okno Vlastnosti Data Link.

Začátek stránky

Aktualizace dat

Jste-li připojeni k externímu zdroji dat, můžete také pomocí operace aktualizace načíst aktualizovaná data. Po aktualizaci dat se vždy zobrazí poslední verze dat, včetně všech změn, které byly v datech provedeny od poslední aktualizace.

Z následujícího obrázku je patrný základní proces toho, co se děje, když provedete aktualizaci dat připojených k externímu zdroji dat.

Základní proces aktualizace externích dat

1. Operace aktualizace získá aktuální data.

2. soubor připojení definuje všechny informace, které je potřeba k přístupu a načtení dat z externího zdroje dat.

3. jsou různých zdrojů dat, které můžete aktualizovat: OLAP, SQL Server, Access, OLE DB, ODBC, tabulky a textové soubory.

4. Aktuální data budou přidána do právě otevřeného sešitu.

Aplikace Excel poskytuje mnoho možností aktualizace importovaných dat včetně aktualizace dat při každém otevření sešitu a automatické aktualizace v časovaných intervalech. Během aktualizace dat můžete pokračovat v práci v aplikaci Excel a můžete také kontrolovat stav aktualizace.

Pokud zdroji externích dat vyžaduje heslo k získání přístupu k datům, můžete nastavíte, že zadáte heslo pokaždé, když Oblast externích dat aktualizovat, postupujte takto.

Začátek stránky

Import dat ze zdrojů dat

Systémy Windows XP, Windows Vista a Microsoft Office poskytují ovladače ODBC a zprostředkovatele OLE DB, jejichž pomocí můžete načíst data z následujících běžných zdrojů dat: aplikace Microsoft Access, soubory HTML na webu, textové soubory, systém Microsoft SQL Server, služba SQL Server Analysis Services a soubory XML. Pomocí Průvodce datovým připojením a aplikace Microsoft Query můžete získat přístup k mnoha dalším zdrojům dat, které mají příslušné zprostředkovatele OLE DB a ovladače ODBC, včetně sešitů aplikace Excel a databází Microsoft FoxPro, dBASE, Paradox, Oracle a DB2.

Začátek stránky

Import dat z databáze aplikace Access

Data lze mezi aplikacemi Microsoft Access a Microsoft Excel vyměňovat několika způsoby.

  • Chcete-li přenést data do aplikace Excel z aplikace Access, můžete je zkopírovat z datového listu aplikace Access a vložit do listu aplikace Excel, propojit databázi aplikace Access s listem aplikace Excel nebo exportovat data aplikace Access do listu aplikace Excel.

  • Chcete-li přenést data do aplikace Access z aplikace Excel, můžete data zkopírovat z listu aplikace Excel a vložit je do datového listu aplikace Access, importovat list aplikace Excel do tabulky aplikace Access nebo propojit list aplikace Excel s tabulkou aplikace Access.

Poznámka : Word pro import obsahuje dva různé význam mezi Excelem a Accessem. V aplikaci Excel import znamená trvalé připojení k datům, která se dají aktualizovat. V Accessu k importu znamená, že pro načítání dat do aplikace Access jednou, ale bez datového připojení.

Práce s daty aplikace Access v aplikaci Excel

Může se stát, že budete chtít pracovat s daty aplikace Access v sešitě aplikace Excel, abyste mohli využít výhod funkcí analýz dat a vytváření grafů, flexibility uspořádání a rozložení dat nebo dalších funkcí aplikace Excel, které nejsou v aplikaci Access k dispozici.

Připojení k datům aplikace Access z aplikace Excel

Chcete-li přenést aktualizovatelná data aplikace Access do aplikace Excel, můžete vytvořit připojení k databázi aplikace Access a načíst všechna data z tabulky nebo dotazu. Můžete například aktualizovat souhrnnou sestavu rozpočtu vytvořenou v aplikaci Excel, kterou rozesíláte každý měsíc, aby obsahovala data z aktuálního měsíce.

Export dat aplikace Access do aplikace Excel

Pomocí Průvodce exportem v aplikaci Access můžete exportovat databázový objekt aplikace Access (například tabulku, dotaz či formulář) nebo vybrané záznamy v zobrazení do sešitu aplikace Excel. Při provádění operace exportu v aplikaci Access můžete uložit návrh této operace pro budoucí použití nebo naplánovat automatické spouštění operace exportu v určených intervalech.

Zde jsou běžné scénáře exportu dat z aplikace Access do aplikace Excel:

  • Ve vašem oddělení nebo pracovní skupině je k práci s daty používána aplikace Access i aplikace Excel. Data ukládáte do databází, ale k analýze dat a distribuci jejích výsledků používáte aplikaci Excel. Váš tým nyní exportuje data do aplikace Excel podle potřeby, chtěli byste však tento proces zefektivnit.

  • Jste dlouhodobými uživateli aplikace Access, váš vedoucí však dává přednost zobrazení sestav v aplikaci Excel. V pravidelných intervalech kopírujete data do aplikace Excel, rádi byste však tento proces automatizovali a ušetřili si tak čas.

Další informace o exportu dat z aplikace Access do aplikace Excel naleznete v systému nápovědy aplikace Access.

Práce s daty aplikace Excel v aplikaci Access

S daty aplikace Excel můžete chtít pracovat v databázi aplikace Access, pokud chcete využít výhod funkcí správy dat, zabezpečení nebo přístupu více uživatelů, které aplikace Access nabízí. Přestože aplikace Access obsahuje mnoho užitečných funkcí, zejména dvě z nich mohou být pro uživatele dat aplikace Excel obzvlášť užitečné:

  • Sestavy    Pokud jste zběhlí v navrhování sestav aplikace Access a chcete shrnout a uspořádat data aplikace Excel v tomto typu sestavy, můžete vytvořit sestavu aplikace Access. Můžete například vytvořit flexibilnější sestavy jako jsou skupinové a souhrnné sestavy, tištěné štítky a grafické sestavy.

  • Formuláře    Pokud chcete pomocí formuláře, Hledat a zobrazení dat v aplikaci Excel, můžete vytvořit formulář aplikace Access. Například vytvoření formuláře Accessu a zobrazte pole v jiném pořadí oproti pořadí sloupců v listu nebo dlouhé řádek dat můžete zobrazit snadněji na jednu obrazovku.

Další informace o práci s formuláři a sestavami aplikace Access naleznete v systému nápovědy aplikace Access.

Propojení dat aplikace Excel z aplikace Access

Oblast aplikace Excel můžete propojit do databáze aplikace Access jako tabulku. Tento postup je výhodný tehdy, když chcete oblast dat dále udržovat v aplikaci Excel, ale zároveň chcete, aby data byla dostupná z aplikace Access. Tento typ propojení lze vytvořit z databáze aplikace Access, nikoli však z aplikace Excel.

Při propojení s listem nebo pojmenovanou oblastí aplikace Excel je v aplikaci Access vytvořena nová tabulka, která je propojena se zdrojovými buňkami. Všechny změny provedené ve zdrojových buňkách v aplikaci Excel se projeví v propojené tabulce. Obsah příslušné tabulky ale nelze upravovat v aplikaci Access. Chcete-li přidat, změnit nebo odstranit data, je nutné změny provést ve zdrojovém souboru aplikace Excel.

Obvyklé scénáře propojení listu aplikace Excel z aplikace Access:

  • Chcete nadále uchovávat data v listech aplikace Excel, ale chcete využívat výkonných funkcí vytváření dotazů a sestav aplikace Access.

  • Vaše oddělení nebo pracovní skupina používá aplikaci Access, avšak data z externích zdrojů, která používáte, jsou uložena v listech aplikace Excel. Nechcete udržovat kopie externích dat, ale chcete být schopni pracovat s těmito daty v aplikaci Access.

Další informace o propojení dat z aplikace Access do aplikace Excel naleznete v systému nápovědy aplikace Access.

Import dat aplikace Excel do aplikace Access

Chcete-li uložit data z aplikace Excel do databáze aplikace Access a nadále potom používat a spravovat data v aplikaci Access, můžete data importovat do aplikace Access. Při importu aplikace Access uloží data do nové nebo existující tabulky, aniž by změnila data v aplikaci Excel. Během operace importu lze najednou importovat vždy jen jeden list. Chcete-li importovat data z více listů, opakujte import pro každý list.

Obvyklé scénáře importu dat aplikace Excel do aplikace Access:

  • Jste dlouhodobým uživatelem aplikace Excel, ale postupem času chcete pro práci s těmito daty používat aplikaci Access. Data na listech aplikace Excel chcete přesunout do jedné nebo více nových databází aplikace Access.

  • Vaše oddělení nebo pracovní skupina používá aplikaci Access, ale občas obdrží data ve formátu aplikace Excel, která je nutné sloučit s databází aplikace Access. Jakmile tyto listy aplikace Excel obdržíte, chcete je naimportovat do databáze.

  • Aplikaci Access používáte ke správě dat, ale týdenní zprávy získané od ostatních členů týmu jsou v podobě sešitů aplikace Excel. Rádi byste proces importu zefektivnili, abyste zajistili, že data se budou do databáze importovat každý týden v určenou dobu.

Další informace o importu dat z aplikace Excel do aplikace Access naleznete v systému nápovědy aplikace Access.

Začátek stránky

Import dat z webu

Webové stránky často obsahují informace, které jsou velmi vhodné pro analýzu v aplikaci Excel. Kurzy akcií například můžete v aplikaci Excel analyzovat pomocí informací přímo z webové stránky. V závislosti na svých potřebách můžete načíst aktualizovatelná data (tedy data, která lze v aplikaci Excel aktualizovat načtením nejnovějších dat z dané webové stránky) nebo jednorázově načíst data z webové stránky a pracovat s nimi na listu jako se statickými daty.

Pomocí webového dotazu můžete načítat data uložená v místní síti intranet nebo v Internetu, například jednu tabulku, více tabulek nebo veškerý text na webové stránce, a tato data poté můžete analyzovat pomocí nástrojů a funkcí aplikace Excel. Jedním kliknutím na tlačítko můžete data snadno aktualizovat nejnovějšími informacemi z dané webové stránky. Můžete například načíst a aktualizovat kurzy akcií z veřejné webové stránky nebo načíst a aktualizovat tabulku s informacemi o prodeji z webové stránky společnosti.

Import dat, který pochází z webové stránky pomocí dialogovém okně Nový dotaz Web. (Na kartě Data ve skupině Načíst externí Data klikněte na Z webu.) Musíte mít přístup k webu prostřednictvím podnikové síti intranet nebo modemu na počítači nebo v síti nebo dotazu může být před HTML nebo XML soubory, které jsou uložené v počítači.

Začátek stránky

Import textových souborů

Pomocí aplikace Excel lze importovat data z textového souboru do sešitu. (Na kartě Data klikněte ve skupině Načíst externí data na položku Z textu.) Průvodce importem textu prozkoumá textový soubor, který importujete, a pomůže vám zajistit, aby data byla importována tak, jak chcete.

Pomocí aplikace Excel můžete data z textového souboru importovat dvěma způsoby: Můžete otevřít daný textový soubor v aplikaci Excel (čímž nebude vytvořeno připojení k textovému souboru), nebo můžete textový soubor importovat jako oblast externích dat (čímž připojení k textovému souboru vytvořeno bude).

Existují dva běžně používané formáty textových souborů:

  • Textové soubory s oddělovači (soubory ve formátu TXT), ve kterých je každé pole textu obvykle odděleno tabulátorem (kód znaku ASCII 009)

  • Textové soubory s hodnotami oddělenými čárkami (soubory ve formátu CSV), ve kterých je každé pole textu obvykle odděleno čárkou (,)

Znak oddělovače v souborech s oddělovači i v textových souborech CSV lze změnit. Může to být nutné k tomu, aby operace importu nebo exportu proběhla požadovaným způsobem.

Začátek stránky

Import dat ze systému Microsoft SQL Server

Microsoft SQL Server je komplexní relační databázová aplikace navržená pro celopodniková datová řešení, která vyžadují optimální výkon, dostupnost, škálovatelnost a zabezpečení. Připojení k databázi systému Microsoft SQL Server je v aplikaci Excel velmi jednoduché: Na kartě Data klikněte ve skupině Načíst externí data na tlačítko Z jiných zdrojů a na příkaz Ze serveru SQL Server.

Při připojování k databázi systému Microsoft SQL Server zobrazí Průvodce datovým připojením tři stránky:

  • Stránka 1: připojení k databázovému serveru    Na této stránce můžete zadat databázový server a tak, aby se přihlásit k serveru.

  • Stránka 2: Vyberte databázi a tabulku    Použijte tuto stránku a určete databázi, tabulku nebo dotaz obsahující data, která chcete.

  • Stránka 3: uložení dat souborů a připojení    Na této stránce můžete zadat a popisují věty připojení souborů a vyhledávání pro vyhledání souboru.

Začátek stránky

Import dat ze služby Microsoft SQL Server Analysis Services

Služby Analysis Services (součást Microsoft SQL Server), které podporuje funkce business intelligence a se základem systémy analýzu zpracování OLAP (Online Analytical), přehledy výkonnostních metrik klíčový ukazatel výkonu (KPI), dolování dat a vykazování systémy řídicího panelu. V aplikaci Excel, můžete snadno připojit k databáze Analysis Services OLAP pomocí zprostředkovatel OLAP. (Na kartě Data ve skupině Načíst externí Data klikněte na Z jiných zdrojů a potom klikněte na Ze služby Analysis Services.) Zprostředkovatel OLAP je sada software, který umožňuje přístup k určitý typ databáze OLAP. Tento software může obsahovat ovladač zdroje dat a dalších klientský software, který je nezbytné k připojení k databázi. Připojení k zprostředkovatel OLAP musíte pomocí sestavy kontingenční tabulky.

Můžete taky zpřístupníte data OLAP: když nejste připojeni ze zdroje dat OLAP. soubor offline datové krychle je soubor s příponou CUB, který ukládá část Zdrojová data z databáze na serveru OLAP. Pomocí souboru offline datové krychle můžete pokračovat ke změnám kontingenčních tabulek a grafů, když server je k dispozici nebo po odpojení ze sítě.

Při připojování ke službě Analysis Services zobrazí Průvodce datovým připojením tři stránky:

  • Stránka 1: připojení k databázovému serveru     Na této stránce můžete zadat serveru a tak, aby se přihlásit k databázovému serveru.

  • Stránka 2: Vyberte databázi a tabulku    Na této stránce můžete určit databáze a datové krychle.

  • Stránka 3: uložení dat souborů a připojení    Na této stránce můžete zadat a popisují věty připojení souborů a vyhledávání pro vyhledání souboru.

Začátek stránky

Import dat XML

Excel usnadňuje importovat data jazyk XML (Extensible Markup), která se vytvoří z jiné databáze a aplikací, mapování XML elementů z schéma XML do buněk listu a export upravených dat XML pro interakci s ostatními databází a aplikacemi. Představte si tyto nové funkce XML jako převádění Generátor XML dat soubor s známém uživatelském rozhraní aplikace Excel.

Pomocí mapování XML můžete v dokumentech aplikace Excel snadno přidat, identifikovat a extrahovat konkrétní obchodní informace. Například faktura obsahující jméno a adresu zákazníka nebo sestava obsahující finanční výsledky za poslední čtvrtletí již nejsou pouhými statickými sestavami. Tyto informace můžete snadno importovat z databází a aplikací, upravit je a exportovat je do původních či jiných databází a aplikací.

Hlavní scénáře použití dat XML

Níže jsou uvedeny hlavní příklady situací, které funkce jazyka XML pomáhají řešit:

  • Rozšíření funkcí existujících šablon aplikace Excel mapováním prvků XML na existující buňky. Tím se zjednoduší vložení dat XML do šablon a jejich vyjmutí z šablon, aniž by bylo nutné data změnit.

  • Použití dat XML jako vstupů pro stávající modely výpočtů mapováním elementů XML na existující tabulky

  • Import souborů dat XML do nového sešitu.

  • Import dat XML z webové služby do listu aplikace Excel.

  • Export dat v mapovaných buňkách do datových souborů XML nezávisle na jiných datech v sešitu.

Základní proces použití dat XML v aplikaci Excel

Následující diagram zobrazuje, jak spolupracují různé soubory a operace při použití dat XML v aplikaci Excel. V podstatě se jedná o pět fází.

Přehled, jak Excel pracuje s daty XML

Popisek 1 Přidání souboru schématu XML (.xsd) do sešitu.

Popisek 2 Mapování prvků schématu XML k jednotlivým buňkám nebo seznamy XML.

Popisek 3 Import datového souboru XML (.xml) a vytvoření vazby elementů XML k mapovaným buňkám.

Krok 4 Zadání dat, přesunutí mapovaných buněk a využití Excelových funkcí při zachování struktury a definicí XML.

Krok 5 Export upravených dat z mapovaných buněk do datového souboru XML.

Použití dat XML

Při importu obsahu datového souboru XML do existujícího mapování XML v sešitu vytváříte vazbu dat ze souboru na mapování XML uložené v sešitu. To znamená, že každý datový element v datovém souboru XML má odpovídající element ve schématu XML, který jste namapovali ze souboru schématu XML nebo odvozeného schématu. Každé mapování XML může mít pouze jednu vazbu s daty XML, přičemž vazba dat XML je svázaná s každým mapováním, které bylo vytvořeno z jednoho mapování XML.

Můžete zobrazit dialogové okno Vlastnosti mapování XML (na kartě Vývojář klikněte ve skupině XML na položku Vlastnosti mapování), ve kterém se nacházejí tři možnosti (ve výchozím možnosti všechny zapnuté), jejichž pomocí lze řídit chování vazby dat XML:

  • Ověření dat na základě jejich schématu pro import a export    Určuje, pokud Excel při importu dat ověřuje data před mapování XML. Pokud chcete zajistit, že data XML, které importujete odpovídá schéma XML, nastavte tuhle možnost.

  • Přepsat existující data novými    Určuje, pokud datový přepsáno při importu dat. Nastavte tuto možnost, pokud chcete aktuální data nová data, například při nahradit aktuální data jsou obsaženy v nový datový soubor XML.

  • Připojit nová data k existující XML seznamy    Určuje, pokud obsah zdroje dat je připojen k existujícím datům na listu. Nastavte tuto možnost, například když jsou sloučení dat z několika podobné datových souborů XML do seznamu XML nebo nechcete přepsat obsah buňky, která obsahuje funkci.

Začátek stránky

Import dat pomocí Průvodce datovým připojením

Pomocí Průvodce datovým připojením se lze připojit k již definovanému externímu zdroji dat OLE DB nebo ODBC. Chcete-li spustit Průvodce datovým připojením, klikněte na kartě Data ve skupině Načíst externí data na tlačítko Z jiných zdrojů a na příkaz Z Průvodce datovým připojením.

Pokud jako zdroj dat v Průvodci datovým připojením zvolíte možnost Upřesnit jiný, můžete zobrazit seznam dostupných zprostředkovatelů OLE DB v dialogovém okně Vlastnosti Data Link. Zprostředkovatel Microsoft OLE DB Provider for ODBC Drivers kromě toho umožňuje také přístup ke zdrojům dat ODBC. Další informace o použití jednotlivých karet v tomto dialogovém okně získáte kliknutím na tlačítko Nápověda v dialogovém okně Vlastnosti Data Link.

Obecně se informace o připojení v dialogovém okně Vlastnosti Data Link definují následujícími kroky:

  • Klikněte na kartu Zprostředkovatel, vyberte zprostředkovatele OLE DB a klikněte na tlačítko Další. Zobrazí se karta Připojení, na které můžete zadat konkrétní informace o připojení pro daného zprostředkovatele OLE DB.

    Každý zprostředkovat OLE DB definuje specifické informace o připojení. Zprostředkovatel Microsoft OLE DB Provider for SQL Server například vyžaduje název serveru, umístění serveru a uživatelské jméno. Můžete také definovat další informace, například heslo, a určit, zda chcete používat integrované zabezpečení systému Microsoft Windows.

  • Klikněte na kartu Upřesnění a zadejte další informace, například nastavení sítě a přístupová oprávnění.

  • Klikněte na kartu Vše a nadefinujte inicializační vlastnosti pro daného zprostředkovatele OLE DB.

Poznámka : V Průvodci datovým připojením nelze data filtrovat ani spojovat.

Začátek stránky

Import dat pomocí aplikace Microsoft Query

Aplikace Microsoft Query můžete taky importovat data. (Na kartě Data ve skupině Načíst externí Data klikněte na Z jiných zdrojů a potom klikněte na tlačítko Z aplikace Microsoft Query ) Nastavení zdrojů dat ODBC získání dat pomocí aplikace Microsoft Query. V aplikaci Microsoft Query Průvodce dotazem můžete použít k vytvoření jednoduchého Dotaz nebo pomocí rozšířených kritérií v dotazu můžete vytvářet složitější dotaz a postupujte takto:

  • Filtrovat řádky nebo sloupce dat před importem do aplikace Excel

  • Vytvoření Parametrický dotaz.

  • Seřadit data před importem do aplikace Excel

  • Spojit více tabulek

Aplikace Microsoft Query poskytuje jednoduché rozhraní, které je snadno přístupné z aplikace Excel, pro provádění těchto specializovaných úkolů s dotazy.

Začátek stránky

Programový import dat a import dat pomocí funkcí

Pokud pracujete jako vývojář, můžete import dat do aplikace Excel pojmout několika způsoby:

  • Získat přístup k externímu zdroji dat můžete Visual Basic for Applications. V závislosti na zdroj dat můžete ActiveX Data Objects nebo Data Access Objects k načtení dat. Můžete taky definujete připojovacího řetězce v kódu, který obsahuje informace o připojení. Použití připojovací řetězec je užitečné, třeba když budete chtít nesnažte se požadovat správce systému nebo uživatel nejdřív vytvořit soubor připojení a zjednodušení instalaci aplikace.

  • Pokud importujete data z databáze systému SQL Server, zvažte možnost použít Nativního klienta systému SQL, což je samostatné rozhraní API (Application Programming Interface) pro přístup k datům, které se používá pro technologie OLE DB i ODBC. Kombinuje zprostředkovatele OLE DB systému SQL a ovladač ODBC systému SQL do jedné nativní dynamické knihovny DLL a poskytuje rovněž nové funkce nezávislé na rozhraní MDAC (Microsoft Data Access Components). Pomocí Nativního klienta systému SQL můžete vytvářet nové aplikace nebo vylepšovat stávající aplikace, které budou moci využít novější funkce systému SQL Server, jako jsou funkce více aktivních sad výsledků (MARS), uživatelsky definované typy a podpora datového typu XML.

  • Funkce RTD načte data reálného času z programu podporujícího automatizaci modelu COM.. Doplněk modelu COM RTD automatizaci musí být vytvořené a registrována na místním počítači.

  • Tento kód SQL. Funkce žádost o připojení k externímu zdroji dat a spustí dotaz z listu. Tento kód SQL. Žádost o funkce vrátí výsledek jako pole bez nutnosti programování maker. Pokud tato funkce není k dispozici, musíte nainstalovat Microsoft Excel ODBC doplněk programu (XLODBC.) XLA). Doplněk si můžete nainstalovat z Office.com.

Další informace o vytváření kódu v jazyce Visual Basic for Applications najdete v nápovědě k programu Visual Basic Editor.

Začátek stránky

Zvýšení zabezpečení při přístupu k datům

Při připojování k externímu zdroji dat nebo při aktualizaci dat je důležité si uvědomit potenciální problémy se zabezpečením a je třeba vědět, co v případě takových problémů se zabezpečením můžete dělat. Použijte následující pokyny a doporučené postupy pro zvýšení zabezpečení dat.

Začátek stránky

Ukládání datových připojení do důvěryhodných umístění

Soubor datového připojení často obsahuje jeden nebo více dotazů používaných k aktualizaci externích dat. Nahrazením tohoto souboru může uživatel se zlými úmysly vytvořit dotaz, pomocí kterého získá přistup k důvěrným informacím, a tyto informace pak bude distribuovat mezi další uživatele nebo vás může poškodit jiným způsobem. Je proto důležité ujistit se, zda platí následující podmínky:

  • Soubor připojení byl napsán spolehlivým uživatelem.

  • Soubor připojení je zabezpečený a je uložen v důvěryhodném umístění.

Za účelem zvýšení zabezpečení můžete v počítači zakázat připojení k externím datům. Pokud se budete chtít připojit k datům po otevření sešitu, bude nutné aktivovat datová připojení pomocí panelu Centrum zabezpečení nebo uložením sešitu do důvěryhodného umístění. Další informace najdete v odkazech v části Viz také.

Začátek stránky

Používání pověření bezpečným způsobem

Při přístupu k externím zdrojům dat jsou obvykle vyžadována pověření (například uživatelské jméno a heslo), jež se používají k ověření uživatele. Dbejte na to, aby vám tyto informace byly předány bezpečným způsobem a abyste je omylem nevyzradili ostatním uživatelům.

Důležité : Použití silných hesel, kombinující malá a velká písmena, čísel a symboly. Slabých hesel Nemíchejte tyto prvky. Silné heslo: Y6dh! et5. Slabý heslo: House27. Hesla by měl být 8 nebo víc znaků. Heslo, které používá 14 nebo více znaků, je lepší. Je důležité si zapamatovat heslo. Pokud je zapomenete, Microsoft nelze obnovit. Ukládání hesel, které zapisovat bezpečné místo od informace, které pomáhají chránit.

Při připojení ke zdrojům dat neukládejte přihlašovací informace. Tyto informace mohou být uloženy jako prostý text v sešitu a v souboru připojení a uživatel se zlými úmysly může k těmto informacím získat přístup a ohrozit zabezpečení zdroje dat.

Kdykoli je to možné, používejte ověřování systému Windows (také nazývané jako důvěryhodné připojení), které pro připojení k systému SQL Server používá uživatelský účet systému Windows. Když se uživatel připojuje prostřednictvím uživatelského účtu systému Windows, použije SQL Server k ověření názvu účtu a hesla informace operačního systému Windows. Chcete-li používat ověřování systému Windows, musí správce serveru nakonfigurovat SQL Server na používání tohoto režimu ověřování. Není-li ověřování systému Windows k dispozici, vyhněte se ukládání uživatelských přihlašovacích informací do sešitu nebo souboru připojení. V takovém případě je pro uživatele bezpečnější zadat přihlašovací informace při každém přihlašování.

Začátek stránky

Zabezpečené publikování do služeb Excel Services

Při připojování ke zdroji dat můžete pomocí dialogového okna Nastavení ověření služeb Excel Services zvolit metodu ověřování při získávání přístupu ke zdroji dat ve službě Excel Services. Můžete vybrat jednu z následujících možností pro přihlášení ke zdroji dat:

  • Ověřování systému Windows:    Tuto možnost vyberte v případě, že chcete použít uživatelské jméno a heslo systému Windows aktuálního uživatele. Jde o nejbezpečnější metodu, v případě velkého počtu uživatelů však může negativně ovlivnit výkon.

  • SSS    Tato možnost slouží k použití služby Zabezpečené úložiště a pak zadejte odpovídající identifikační řetězec do textového pole ID služby Zabezpečené úložiště. Správce webu můžete nakonfigurovat webem služby SharePoint k používání služby Zabezpečené úložiště databáze, kde mohou být uloženy uživatelské jméno a heslo. Tento postup může být nejefektivnější kdy jsou většího počtu uživatelů.

  • Žádná    Tato možnost slouží k uložení uživatelské jméno a heslo v poli soubor připojení.

Poznámka : Toto nastavení ověřování je používáno pouze službami Excel Services, nikoli aplikací Microsoft Excel. Chcete-li, aby byl při otevření sešitu v aplikaci Excel i ve službách Excel Services zajištěn přístup ke stejným datům, použijte v aplikaci Excel stejné nastavení ověřování.

Zvýšení zabezpečení připojení pomocí datového připojení knihovny (knihovna). Knihovna je speciální knihovna dokumentů služby SharePoint, který je to možné definovat jako důvěryhodné umístění knihovny a který usnadňuje ukládat, zabezpečené, sdílet a spravovat soubory ODC. Například správce muset přesunout databázi ze serveru test provozní server nebo aktualizační dotaz, který má přístup k data. Pomocí jeden soubor ODC uložené ve knihovna Správa těchto informací jednodušší a přístup uživatelů k datům je lepší, protože všechny sešity používají stejný soubor připojení a operace aktualizace (jestli na počítači klienta nebo serveru) získá aktuální změny na tento soubor připojení. Můžete dokonce nastavit serveru SharePoint Server a uživatel v klientském počítači automaticky zjišťovat změny připojení souboru a potom použijte nejnovější verzi tohoto souboru připojení. Další informace najdete v tématu Microsoft SharePoint Foundation 2010 nápovědy Centra pro správu.

Začátek stránky

Problémy při připojování k datům

Následující odstavce popisují několik problémů, se kterými se můžete střetnout při připojování k externím datům.

Začátek stránky

Problém: Při pokusu o import dat není dostatek místa na disku.

Pokud při připojení k externím datům není dostatek místa na disku, zvažte následující možnosti:

Kontrola a zvýšení dostupné místo na disku    Uvolnit místo na pevném disku, zkuste vyprázdnění koše, zálohování nepotřebných souborů a pak je odstranit z disku nebo odebrání součástí systému Windows, které nepoužíváte. Podrobnosti o uvolnit místo na pevném disku najdete v článku nápovědy systému Windows.

Strategie, které můžete zkusit, když se omezí na disku    Pokud máte omezené množství volného místa na disku, zkuste toto:

Aplikace Microsoft Query    Proveďte některou z následujících akcí:

  • Zjednodušení dotazu    Ujistěte se, zahrnout jenom tabulek a polí, které jsou potřebné pro dotaz. Pokud dotaz obsahuje nepotřebných tabulek a polí, odstraňte je z dotazu zmenšit velikost souboru dočasné dotazu.

  • Použít kritéria ke zmenšení velikosti výsledek nastavení    Použijte kritéria ke načíst pouze konkrétních záznamů nikoli všech záznamů z databáze. Další informace najdete v nápovědě k aplikaci Microsoft Query.

  • Nastavení omezení počtu zobrazených záznamů vracená dotazem    Omezení počtu zobrazených záznamů, které vrátí dotaz. V aplikaci Microsoft Query klikněte na Možnosti v nabídce Úpravy, omezit počet vrácených záznamů zaškrtněte políčko v části Nastavení uživatele a zadejte maximální počet záznamů se vrátíte do pole záznamy.

Průvodce datovým připojením    Přestože nemůžete omezí data pomocí Průvodce datovým připojením, možná budete moct omezit data ze zdroje dat definování dotazu ve zdroji dat. Pokud nemáte možnost nebo oprávnění k vytvoření dotazu na zdroj dat, kontaktujte svého správce data.

Začátek stránky

Problém: Kde se nachází Průvodce datovou krychlí OLAP?

Průvodce datovou krychlí OLAP, který vytvářel datovou krychli OLAP z databáze Jet, již v aplikaci Excel nadále není k dispozici.

Začátek stránky

Problém: Co se stalo se službami načítání dat?

Počínaje systémem Microsoft Office 2003 používají služby načítání dat pro přístup k webovým službám a dotazy na různé zdroje dat soubor univerzálního datového připojení (UDC) s příponou UDCX.

V Průvodci datovým připojením na stránce Vítá vás Průvodce datovým připojením můžete vybrat možnosti zdroje dat Microsoft Business Solutions nebo služby načítání dat. Možnosti služby načítání dat můžete zvolit dvě služby načítání dat: seznamy služby Windows SharePoint Services, která načte data ze seznamů a knihoven dokumentů na serveru SharePoint Foundation a Microsoft SQL Server, který načítá data z Microsoft SQL Server 2000 nebo novější.

Průvodce datovým připojením již sice nadále nepodporuje úpravy souborů připojení UDC, ale aplikace Excel nadále podporuje existují připojení pomocí služeb načítání dat a přes tato připojení lze nadále aktualizovat data.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×