Vytvoření nebo změna zobrazení

Pomocí zobrazení lze v seznamu nebo knihovně zobrazovat položky, které jsou pro vás nejdůležitější nebo které nejlépe vyhovují konkrétnímu účelu. Můžete například vytvořit zobrazení souborů, které byly vytvořeny v poslední době, položek seznamu týkajících se konkrétního oddělení nebo souborů vytvořených konkrétní osobou. Vytvořené zobrazení je pak kdykoli k dispozici v seznamu nebo v knihovně.

V tomto článku:

Přehled

Typy zobrazení

Vytvoření zobrazení

Práce s mobilními zobrazeními

Přidání sloupců

Změna nastavení sloupce

Odstranění sloupce

Výběr jiného zobrazení nebo změna zobrazení

Všechny seznamy nebo knihovny poskytují minimálně jedno zobrazení podle toho, o jaký typ se jedná, a podle toho, jaké nastavení bylo použito. Některé seznamy a knihovny poskytují další předdefinovaná zobrazení. Můžete také vytvářet vlastní zobrazení. Seznam úkolů poskytuje několik zobrazení, například pouze úkoly s termínem splnění spadajícím na dnešní den, pouze úkoly přiřazené vám, všechny úkoly atd.

Různá zobrazení seznamu úkolů

Je možné vytvářet osobní zobrazení a veřejná zobrazení. Osobní zobrazení máte v seznamu nebo v knihovně k dispozici pouze vy. Veřejné zobrazení je v seznamu nebo knihovně k dispozici všem uživatelům. Abyste mohli vytvořit veřejné zobrazení, je nutné, abyste měli oprávnění ke změně návrhu seznamu nebo knihovny. Veřejné zobrazení lze nastavit jako výchozí zobrazení seznamu nebo knihovny.

Navíc platí, že když vy nebo jiný uživatel navrhne web, můžete vytvořit propojení na další zobrazení nebo vytvořit návrh stránek pomocí Webová část využívajících jiná zobrazení.

Pokud chcete, aby byly vaše seznamy či knihovny univerzálnější, můžete přidat další sloupce. Můžete vytvořit více zobrazení, ve kterých jsou skryty nebo zobrazeny konkrétní sloupce, a to v závislosti na účelu zobrazení. Lze například nastavit, aby se uživatelům zobrazovaly pouze soubory pro jejich oddělení nebo soubory seřazené podle čísla projektu.

Pokud se jedná o rozsáhlý seznam nebo knihovnu (například v případě, že skupina pracuje na více projektech nebo na stejném projektu pracuje více skupin) mohou zobrazení pomoci přispěvatelům, aby mohli zobrazovat data, která jsou pro ně v dané situaci nejpotřebnější.

Můžete vybrat, kolik položek se v každém zobrazení najednou zobrazí. Uživatelé mohou například procházet seznam v sadách 25 nebo 100 položek seznamu na stránku, a to v závislosti na jejich předvolbách a rychlosti jejich připojení.

Zobrazení také umožňují lépe spravovat způsob, jakým jsou seznamy a knihovny zobrazovány na mobilních zařízeních. Na některých zařízeních může být omezen počet znaků zobrazených ve sloupci.

Zobrazení nabízejí několik způsobů, jak seznamy a knihovny zefektivnit. Následuje několik způsobů, jak lze zobrazení používat:

  • filtrování podle sady kritérií, například podle názvu oddělení nebo jména osoby;

  • řazení v konkrétním pořadí, například aby se zobrazily soubory, které byly změněny naposledy;

  • skrytí nebo zobrazení sloupců, například aby byly zobrazeny pouze některé požadované informace;

  • seskupování informací na základě dat seznamu, například podle oddělení;

  • zobrazení mezisoučtů sloupců, například počtu dokumentů smluv;

  • zobrazení kalendáře seznamu s počátečním a koncovým datem;

  • zobrazení seznamu v databázovém programu, který umožňuje analýzu dat;

  • zobrazení všech položek na stejné úrovni (beze složek).

Začátek stránky

Typy zobrazení

Při vytváření vlastního zobrazení v rámci služby Windows SharePoint Services 3.0 začněte tak, že zvolíte jeden z typů zobrazení, který určuje, jak se budou zobrazovat položky seznamu. Můžete například položky seznamu zobrazit v lineárním seznamu (jako na linkovaném papíru) nebo lze informace zobrazit vizuálnějším způsobem (například zobrazení dat v měsíčním kalendáři). Nové zobrazení lze také založit na stávajícím zobrazení, čímž lze ušetřit čas.

  • Standardní.    V tomto zobrazení se zobrazí položky seznamu nebo soubory na webové stránce v podobě klasického seznamu. Standardní zobrazení je výchozí pro většinu typů seznamů a knihoven a můžete ho různými způsoby přizpůsobit svým požadavkům.

  • Kalendář.    V tomto zobrazení jsou položky kalendáře zobrazeny ve vizuálním formátu, který je podobný stolnímu nebo nástěnnému kalendáři. V tomto formátu můžete použít denní, týdenní nebo měsíční zobrazení. Můžete například vytvořit kalendář ke sledování termínů dokončení práce týmu pro projekt nebo svátků, které se ve společnosti dodržují.

    Týdenní zobrazení vybrané v kalendáři

    1. Kalendáře mají různá zobrazení.

    2. Celodenní události se zobrazí v horní části kalendáře podle data; ostatní události se zobrazí podle data a času.

  • Datový list.    V tomto zobrazení jsou data prezentována ve formátu, který lze upravovat, například jako tabulku v databázovém programu nebo tabulkovém procesoru. Toto zobrazení může být užitečné v případě, že je třeba provést rozsáhlé úpravy, nebo vyexportovat data do tabulkového procesoru či databázového programu. Zobrazení datového listu vyžaduje ovládací prvek nebo program kompatibilní se službou Windows SharePoint Services, například aplikaci Office Access 2007 a podporu Ovládací prvek ActiveX.

  • Ganttův diagram.    Toto zobrazení nabízí vizuální zobrazení dat s pruhy ke sledování průběhu pro data založená na časovém intervalu. Ganttův diagram umožňuje lépe spravovat projekty a zobrazit rychlý přehled dat. Pomocí tohoto zobrazení lze například zobrazit, které úkoly se překrývají, a vizualizovat jejich celkový průběh.

    Část Ganttova diagramu

Poznámka : Pro váš seznam nebo knihovnu mohou být k dispozici jiné typy zobrazení.

Začátek stránky

Vytvoření zobrazení

Při zobrazení seznamu nebo knihovny můžete dočasně setřídit nebo filtrovat soubory tím, že přejdete na název sloupce a klepnete na šipku vedle názvu. To je užitečné v případě, že chcete občas soubory zobrazit určitým způsobem, ale je nutné kroky zopakovat při příštím zobrazení seznamu nebo knihovny.

Seřazení položek v seznamu nebo knihovně

Pokud myslíte, že budete chtít informace zobrazit určitým způsobem často, můžete vytvořit zobrazení. Toto zobrazení můžete použít vždy, když budete pracovat se seznamem nebo knihovnou. Vytvořené zobrazení je přidáno do nabídky Zobrazit Nabídka Zobrazení seznamu nebo knihovny. V nabídce Zobrazit jsou zobrazení seskupena do částí: výchozí zobrazení, všechna osobní zobrazení, další veřejná zobrazení nebo zobrazení vztahující se ke schvalování obsahu (například Schválit či zamítnout). K dispozici jsou také příkazy pro úpravu a vytváření zobrazení.

Než začnete

Než začnete vytvářet zobrazení, můžete přidat další sloupce, abyste mohli položky flexibilněji řadit, seskupovat a filtrovat. Další informace o vytváření sloupců naleznete v tomto článku v části Přidání sloupců.

Pokud vytváříte zobrazení pro mobilní zařízení, měli byste vzít do úvahy omezení používaných mobilních zařízení. Další informace týkající se toho, jak tato omezení zjistit, naleznete v části Práce s mobilními zobrazeními dále v tomto článku.

Vytvoření zobrazení

  1. Pokud seznam nebo knihovna nejsou dosud otevřené, klikněte na jejich název na panelu Snadné spuštění.

    Pokud se název vašeho seznamu nebo knihovny nezobrazuje, klikněte na tlačítko Zobrazit veškerý obsah webu a potom na název daného seznamu nebo knihovny.

  2. V nabídce Zobrazení Nabídka Zobrazení klikněte na příkaz Vytvořit zobrazení.

  3. V části Zvolte formát zobrazení klepněte na typ zobrazení, který chcete vytvořit. Ve většině situací v knihovnách můžete klepnout na možnost Standardní zobrazení, pro konkrétní situace však můžete zvolit i jiná zobrazení.

  4. Do pole Název zobrazení zadejte název zobrazení, například Seřazeno podle příjmení.

  5. Pokud chcete, aby bylo toto zobrazení nastaveno jako výchozí, zaškrtněte políčko Nastavit jako výchozí zobrazení.

    Toto zobrazení můžete nastavit jako výchozí pouze tehdy, pokud je to veřejné zobrazení a vy máte oprávnění ke změnám návrhu seznamu.

  6. V oblasti Cílová skupina v části Cílová skupina zobrazení vyberte, zda chcete vytvořit osobní zobrazení, které můžete použít pouze vy, nebo veřejné zobrazení přístupné ostatním uživatelům.

  7. V oblasti Sloupce můžete zobrazit nebo skrýt sloupce zaškrtnutím příslušných políček. Vedle názvu sloupce zadejte číslo určující pořadí sloupce v zobrazení.

  8. V části Řadit zvolte, zda a jak se mají informace řadit. K řazení můžete použít dva sloupce, například nejdříve podle autora a potom podle názvu souboru pro každého autora.

  9. V části Filtr zvolte, zda a jak chcete soubory filtrovat. Filtrované zobrazení zobrazuje menší výběr, například pouze položky vytvořené konkrétním oddělením nebo se stavem Schváleno.

  10. V oblasti Seskupit podle lze seskupit položky stejné hodnoty do vlastního oddílu, například do rozbalitelného oddílu dokumentů podle určitého autora.

  11. V oblasti Souhrny můžete počítat počet položek ve sloupcích, například celkový počet problémů. Někdy lze zjišťovat další informace, například průměry.

  12. V oblasti Styl vyberte požadovaný styl zobrazení, například stínovaný seznam, v němž je každý druhý řádek stínován.

  13. Pokud seznam nebo knihovna obsahuje složky, můžete vytvořit zobrazení, které je neobsahuje (někdy označované jako nestrukturované zobrazení). Chcete-li zobrazit všechny položky seznamu na stejné úrovni, klepněte na možnost Zobrazit všechny položky bez složek.

  14. Pokud jsou seznamy nebo knihovny rozsáhlé, můžete omezit, kolik souborů lze v seznamu nebo v knihovně zobrazit nebo kolik souborů lze zobrazit na stejné stránce. V části Omezení počtu položek vyberte požadované možnosti.

  15. Pokud budete chtít seznam nebo knihovnu zobrazit na mobilním zařízení, vyberte požadované možnosti v části Mobilní.

  16. Klikněte na tlačítko OK.

Začátek stránky

Práce s mobilními zobrazeními

V produktu Windows SharePoint Services 3.0 můžete zobrazit a aktualizovat některé seznamy nebo knihovny v mobilních zařízeních, například v zařízeních PDA (personal digital assistant) nebo v mobilním telefonu.

Délka nebo velikost některých částí seznamu nebo knihovny jsou na mobilních zařízeních omezeny, a to z důvodu šířky displeje a možných potíží s výkonem. Pro mobilní zařízení můžete vytvářet zobrazení, která těmto omezením vyhovují.

Některé typy seznamů, například diskusní vývěsky, nejsou v mobilních zařízeních k dispozici. Některé typy sloupců, například sloupce Měna, Ano/Ne a Osoba nebo skupina, nejsou v mobilních zařízeních k dispozici. V případě, že je dosaženo limitu, je nezobrazený obsah označen v mobilním zobrazení třemi tečkami (…).

Pokud uživatelé ve vaší skupině prohlížejí seznamy nebo knihovny pomocí obou typů mobilních zařízení, měli byste počítat s omezeními platnými pro mobilní telefon.

Následují omezení zobrazení seznamů a knihoven v mobilních zařízeních.

Položka

Omezení

Znaky v názvu webu seznamu nebo knihovny

20

Znaky v názvu seznamu nebo knihovny

20

Počet mobilních zobrazení

10

Počet položek v zobrazení

100

Znaky v názvu položky seznamu

20

Znaky v názvu sloupce

20

Typ pole jednořádkového textu

256

Typ pole víceřádkového textu

256

Každá volba v poli typu volby

10

Počet možností v poli typu volby

10

Znaky v každé položce ve vyhledávacím poli

20

Počet možností ve vyhledávacím seznamu

20

Znaky v poli s hypertextovým odkazem nebo v poli s obrázkem

20

Znaky v názvu souboru přílohy

20

Počet zobrazených příloh (položek seznamu)

3

Znaky ve vypočteném poli

20


Začátek stránky

Přidání sloupců

Pomocí sloupců může skupina lépe uspořádat informace, jako například název oddělení nebo číslo projektu, do kategorií a sledovat je. U typu sloupce, který vytváříte, je k dispozici několik možností, k nimž patří jeden řádek textu, rozevírací seznam možností, číslo vypočtené z jiných sloupců nebo jméno a obrázek osoby na webu.

Poznámka : Následující postup začíná na stránce seznamu nebo knihovny, na kterou chcete přidat sloupec. Pokud seznam nebo knihovna není ještě otevřen, klepněte na příslušný název na panelu Snadné spuštění. Pokud se název seznamu nebo knihovny nezobrazí, klepněte na možnost Zobrazit veškerý obsah webu a potom klepněte na název seznamu nebo knihovny.

  1. V nabídce Nastavení Settings menu klikněte na příkaz Vytvořit sloupec.

  2. V oblasti Název a typ zadejte do pole Název sloupce požadovaný název.

  3. V seznamu Typ informací v tomto sloupci vyberte typ informací, které chcete zobrazit ve sloupci.

  4. V oblasti Další nastavení sloupce zadejte do pole Popis popis, který uživatelům usnadní porozumění účelu sloupce a druhu dat, která by měl obsahovat. Tento popis je nepovinný.

  5. V závislosti na vybraném typu sloupce se v oblasti Další nastavení sloupce mohou zobrazit další možnosti. Vyberte požadované další nastavení.

  6. Chcete-li sloupec přidat do výchozího zobrazení, které uživatelé vašeho webu automaticky uvidí při prvním otevření seznamu nebo knihovny, klikněte na možnost Přidat do výchozího zobrazení.

  7. Klikněte na tlačítko OK.

Začátek stránky

Změna nastavení sloupce

Nastavení sloupce, například název sloupce, můžete změnit. V závislosti na typu sloupce a typu seznamu můžete provádět další změny. Můžete například změnit typ dat, která některé sloupce obsahují, nebo omezit počet znaků, které mohou obsahovat. Pokud změníte nastavení, přesvědčte se, zda stávající data odpovídají novému nastavení, které chcete použít.

  1. Pokud seznam nebo knihovna nejsou dosud otevřené, klikněte na jejich název na panelu Snadné spuštění.

    Pokud se název vašeho seznamu nebo knihovny nezobrazuje, klikněte na tlačítko Zobrazit veškerý obsah webu a potom na název daného seznamu nebo knihovny.

  2. V části Sloupce klepněte na název sloupce, který chcete změnit.

  3. Podle potřeby změňte nastavení a klepněte na tlačítko OK.

Poznámka : Můžete zadat, aby byl sloupec indexován, což umožňuje rychleji přepínat zobrazení seznamů nebo knihoven z více složek. Chcete-li zobrazit nastavení seznamu nebo knihovny, klepněte na možnost Indexované sloupce. Vyberte sloupec, který chcete indexovat, a klepněte na tlačítko OK.

Začátek stránky

Odstranění sloupce

Důležité : Tímto postupem odstraníte sloupec a všechna data v něm.

  1. Pokud seznam nebo knihovna nejsou dosud otevřené, klikněte na jejich název na panelu Snadné spuštění.

    Pokud se název vašeho seznamu nebo knihovny nezobrazuje, klikněte na tlačítko Zobrazit veškerý obsah webu a potom na název daného seznamu nebo knihovny.

    Proveďte některou z následujících akcí:

    • V nabídce Nastavení Settings menu klikněte na příkaz Nastavení seznamu nebo na požadovanou možnost nastavení.

    • Na webu webového deníku klikněte v oblasti Odkazy pro správu na odkaz Spravovat vystavené položky – zobrazí se seznam vystavených položek. V nabídce Nastavení klikněte na příkaz Nastavení seznamu.

  2. V části Sloupce klepněte na název sloupce, který chcete odstranit.

  3. Klepněte na tlačítko Odstranit.

    Pokud nebude tlačítko Odstranit zobrazeno, bude pravděpodobně potřeba stránku posunout.

  4. Až se zobrazí dotaz s upozorněním, klepněte v případě, že jste si jisti, že chcete sloupec odstranit, na tlačítko OK.

Poznámka : Seznamy a knihovny obsahují určité povinné sloupce, které nelze odstranit, například sloupec Nadpis nebo Název. Jestliže sloupec nelze odstranit, není tlačítko Odstranit k dispozici. Pokud sloupec nelze odstranit a nechcete jej zobrazit, můžete ho skrýt. V části Viz také naleznete odkazy na další informace o skrývání sloupců.

Začátek stránky

Výběr jiného zobrazení nebo změna zobrazení

To, která zobrazení jsou k dispozici, závisí na nastavení seznamu nebo knihovny, a na tom, zda byla vytvořena další zobrazení. Řada seznamů a knihoven má více než jedno výchozí zobrazení. Například seznam úkolů má zobrazení pro úkoly, které máte přiřazeny, a pro všechny úkoly, které mají být splněny v konkrétní den.

  1. Pokud seznam nebo knihovna nejsou dosud otevřené, klikněte na jejich název na panelu Snadné spuštění.

    Pokud se název vašeho seznamu nebo knihovny nezobrazuje, klikněte na tlačítko Zobrazit veškerý obsah webu a potom na název daného seznamu nebo knihovny.

  2. Proveďte jednu z následujících akcí:

    • Chcete-li vybrat jiné zobrazení, klepněte v nabídce Zobrazit Nabídka Zobrazení na požadované zobrazení.

    • Chcete-li v zobrazení provést změny, klepněte na nabídku Zobrazit a potom klepněte na možnost Upravit toto zobrazení.

Začátek stránky

Sdílení Facebook Facebook Twitter Twitter E-mail E-mail

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×