Vytvoření nebo odstranění makra

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Chcete-li automatizovat opakované úkoly, můžete rychle uložit Makro v aplikaci Microsoft Office Excel. Makra můžete taky vytvořit pomocí Visual Basic Editor jazyka Microsoft Visual Basic napsat vlastní skript, makra nebo zkopírovat list nebo část makra do nového makra:. Po vytvoření makra, můžete přiřadit k objektu (například tlačítko na panelu nástrojů, grafickému prvku nebo ovládacího prvku) tak, aby ji můžete spustit klepnutím na objekt. Pokud už používáte makra, můžete ho odstranit.

Co chcete udělat?

Záznam makra

Vytvořit makro pomocí jazyka Microsoft Visual Basic

Zkopírovat část makra pro účely vytvoření jiného makra

Přiřazení makra k objektu, grafickému prvku nebo ovládacímu prvku

Odstranění makra

Záznam makra

Když zaznamenáváte makro, zaznamená program pro záznam makra všechny kroky nutné k provedení akcí, které má makro provést. Navigace na pásu karet není součástí těchto zaznamenaných kroků.

Poznámka : Pás karet je součástí rozhraní aplikace Fluent systému Microsoft Office.

  1. Není-li k dispozici karta Vývojář, zobrazte ji následujícím postupem:

    1. Klikněte na tlačítko Microsoft Office Obrázek tlačítka a potom klikněte na tlačítko Možnosti aplikace Excel.

    2. Ve skupině Nejpoužívanější možnosti při práci s aplikací Excel zaškrtněte v kategorii Oblíbené políčko Zobrazit na pásu kartu Vývojář a poté klikněte na tlačítko OK.

  2. Chcete-li dočasně nastavit úroveň zabezpečení tak, aby byla povolena všechna makra, postupujte následujícím způsobem:

    1. Na kartě Vývojář klepněte ve skupině Kód na tlačítko Zabezpečení maker.

      Skupina Kód na kartě Vývojář

    2. V části Nastavení maker klepněte na přepínač Povolit všechna makra (nedoporučuje se, mohlo by umožnit spuštění potenciálně nebezpečného kódu) a poté klepněte na tlačítko OK.

      Poznámka : Chcete-li zabránit spuštění potenciálně nebezpečného kódu, doporučujeme vrátit se k některému z nastavení, která zakazují všechna makra po dokončení práce s makry. Další informace o tom, jak změnit nastavení najdete v tématu Změna nastavení zabezpečení maker v aplikaci Excel.

  3. Na kartě Vývojář klepněte ve skupině Kód na položku Záznam makra.

  4. Do pole název makra zadejte název makra.

Poznámka : Prvním znakem názvu makra musí být písmeno. Další znaky mohou být písmena, čísla nebo podtržítka. V názvu makra nelze použít mezery, jako oddělovače slov lze použít podtržítka. Když použijete název makra, který je současně referencí na buňku, může se zobrazit chybová zpráva, že název makra není platný.

  1. Chcete-li spouštění makra přiřadit Klávesová zkratka používající klávesu CTRL, zadejte do pole Klávesová zkratka malé nebo velké písmeno, které chcete použít.

    Poznámka : Klávesová zkratka přednost před všemi stejnými výchozími Excel klávesovými při otevření sešitu, který obsahuje makro. Seznam CTRL kombinace klávesových zkratek, které již byly přiřazeny v Excelu najdete v tématu klávesové zkratky a funkční klávesy aplikace Excel.

  2. V rozevíracím seznamu Uložit makro do vyberte sešit, do kterého chcete makro uložit.

    Tip : Pokud chcete makro je k dispozici při práci aplikace Excel, vyberte Osobní sešit maker. Po výběru Osobní sešit maker Excel vytvoří skryté osobním sešitě maker (Personal.xlsb), pokud dosud neexistuje a ukládá makra v tomto sešitu. Ve Windows Vista je tento sešit uložený ve složce name\AppData\Local\Microsoft\Excel\XLStart C:\Users\user. V systému Microsoft Windows XP tento sešit uložený ve složce Data\Microsoft\Excel\XLStart C:\Documents and Settings\uživatelské ukládají. Sešity do složky XLStart jsou při každém spuštění Excelu automaticky neotevírají. Pokud chcete makro v osobním sešitě maker automatické spuštění v jiném sešitu, je nutné také uložit daný sešit do složky XLStart tak, že jsou tyto sešity otevřené při spuštění Excelu.

  3. Do pole Popis napište krátký popis makra.

  4. Chcete-li zahájit záznam, klikněte na tlačítko OK.

  5. Provedení akcí, které chcete zaznamenat.

  6. Na kartě Vývojář klikněte ve skupině Kód na tlačítko Zastavit záznam Obrázek tlačítka .

    Můžete také klepnout na tlačítko Zastavit záznam Obrázek tlačítka v levé části stavového řádku.

Začátek stránky

Vytvořit makro pomocí jazyka Microsoft Visual Basic

  1. Není-li k dispozici karta Vývojář, zobrazte ji následujícím postupem:

    1. Klikněte na tlačítko Microsoft Office Obrázek tlačítka a potom klikněte na tlačítko Možnosti aplikace Excel.

    2. Ve skupině Nejpoužívanější možnosti při práci s aplikací Excel zaškrtněte v kategorii Oblíbené políčko Zobrazit na pásu kartu Vývojář a poté klikněte na tlačítko OK.

  2. Chcete-li dočasně nastavit úroveň zabezpečení tak, aby byla povolena všechna makra, postupujte následujícím způsobem:

    1. Na kartě Vývojář klepněte ve skupině Kód na tlačítko Zabezpečení maker.

      Skupina Kód na kartě Vývojář

    2. V části Nastavení maker klepněte na přepínač Povolit všechna makra (nedoporučuje se, mohlo by umožnit spuštění potenciálně nebezpečného kódu) a poté klepněte na tlačítko OK.

      Poznámka : Aby se zabránilo spuštění potenciálně nebezpečného kódu, doporučujeme vrátit se po dokončení práce s makry k nastavení se zakázanými makry.

  3. Na kartě Vývojář klepněte ve skupině Kód na možnost Visual Basic.

  4. V případě potřeby klikněte v editoru jazyka Visual Basic v nabídce Insert (Vložit) na příkaz Module (Modul).

    Poznámka : Pro všechny listy v sešitu budou automaticky vytvořeny moduly.

  5. V okně kódu modulu zadejte nebo zkopírujte kód makra, který chcete použít.

  6. Chcete-li spustit makro z okna modulu, stiskněte klávesu F5.

  7. Po dokončení zápisu makra klikněte v editoru jazyka Visual Basic v nabídce File (Soubor) na položku Close and Return to Microsoft Excel (Zavřít a návrat do aplikace Microsoft Excel).

Začátek stránky

Vytvoření nového makra zkopírováním části jiného makra

  1. Není-li k dispozici karta Vývojář, zobrazte ji následujícím postupem:

    1. Klikněte na tlačítko Microsoft Office Obrázek tlačítka a potom klikněte na tlačítko Možnosti aplikace Excel.

    2. Ve skupině Nejpoužívanější možnosti při práci s aplikací Excel zaškrtněte v kategorii Oblíbené políčko Zobrazit na pásu kartu Vývojář a poté klikněte na tlačítko OK.

  2. Chcete-li dočasně nastavit úroveň zabezpečení tak, aby byla povolena všechna makra, postupujte následujícím způsobem:

    1. Na kartě Vývojář klepněte ve skupině Kód na tlačítko Zabezpečení maker.

      Skupina Kód na kartě Vývojář

    2. V části Nastavení maker klepněte na přepínač Povolit všechna makra (nedoporučuje se, mohlo by umožnit spuštění potenciálně nebezpečného kódu) a poté klepněte na tlačítko OK.

      Poznámka : Aby se zabránilo spuštění potenciálně nebezpečného kódu, doporučujeme vrátit se po dokončení práce s makry k nastavení se zakázanými makry.

  3. Otevřete sešit obsahující makro, které chcete kopírovat.

  4. Na kartě Vývojář klepněte ve skupině Kód na tlačítko Makra.

  5. V poli se seznamem Název makra klikněte na název makra, které chcete kopírovat.

  6. Klikněte na tlačítko Upravit.

  7. V okně kódu editoru jazyka Visual Basic vyberte řádky makra, které chcete zkopírovat.

Tip : Chcete-li kopírovat celé makro, musí být součástí výběru řádky Sub a End Sub.

  1. V nabídce Úpravy klepněte na příkaz Kopírovat.

    Také můžete na položku kliknout pravým tlačítkem myši a vybrat příkaz Copy nebo můžete stisknout kombinaci kláves CTRL+C.

  2. V poli procedury v okně klikněte na modul, kam chcete umístit kód.

  3. V nabídce Úpravy klepněte na příkaz Vložit.

    Také můžete na položku kliknout pravým tlačítkem myši a vybrat příkaz Edit nebo můžete stisknout kombinaci kláves CTRL+V.

Tip : Osobní sešit maker (Osobní.xlsb) nelze upravovat, protože se jedná o skrytý sešit, který je vždy otevřený. Nejprve je třeba ho zobrazit pomocí příkazu Zobrazit. Také ho můžete otevřít v editoru jazyka Visual Basic stisknutím kombinace kláves ALT+F11.

Začátek stránky

Přiřazení makra k objektu, grafickému prvku nebo ovládacímu prvku

  1. V sešitě klikněte na objekt, grafický prvek nebo ovládací prvek, ke kterému chcete přiřadit existující makro, pravým tlačítkem myši a potom klikněte na položku Přiřadit makro.

  2. V poli Název makra vyberte makro, které chcete přiřadit.

Začátek stránky

Odstranění makra

  1. Proveďte jeden z následujících kroků:

    • Otevřete sešit obsahující makro, které chcete odstranit.

    • Jestliže je makro, které chcete odstranit, uloženo v osobním sešitě maker (Osobní.xlsb) a tento sešit je skrytý, zobrazte ho následujícím způsobem:

      1. Na kartě Zobrazení klikněte ve skupině Okno na tlačítko Zobrazit.

      2. V části Zobrazit sešit klikněte na položku OSOBNÍ a potom na tlačítko OK.

  2. Není-li k dispozici karta Vývojář, zobrazte ji následujícím postupem:

    1. Klikněte na tlačítko Microsoft Office Obrázek tlačítka a potom klikněte na tlačítko Možnosti aplikace Excel.

    2. Ve skupině Nejpoužívanější možnosti při práci s aplikací Excel zaškrtněte v kategorii Oblíbené políčko Zobrazit na pásu kartu Vývojář a poté klikněte na tlačítko OK.

  3. Na kartě Vývojář klepněte ve skupině Kód na tlačítko Makra.

    Skupina Kód na kartě Vývojář

  4. V seznamu Makra v souboru vyberte sešit obsahující makro, které chcete odstranit. Klikněte například na položku Tento sešit.

  5. V textovém poli Název makra klepněte na název makra, které chcete odstranit.

  6. Klepněte na tlačítko Odstranit.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×