Vytvoření databáze aplikace Access pro sdílení na webu

Pomocí Accessu 2010 a služeb Access Services, které jsou součástí SharePointu, můžete vytvářet aplikace webových databází. To vám pomůže:

  • Zabezpečit a spravovat přístup k datům

  • Sdílet data v organizaci nebo po internetu

    Poznámka :  K použití webové databáze je nutný uživatelský účet. Anonymní přístup není podporován.

  • Vytvářet databázové aplikace, které nevyžadují použití Accessu

Tento článek obsahuje přehled návrhu webové databáze Accessu. Úvod k návrhu desktopové databáze popisují články Vytvoření desktopové databáze a Základy návrhu databáze.

V tomto článku

Základní informace

Vytvoření webové databáze

Publikování a synchronizace změn v aplikaci

Základní informace

Access 2010 a Access Services (volitelná součást SharePointu) poskytují platformu pro vytváření databází, které můžete používat na webu. Webovou databázi navrhujete a publikujete pomocí aplikace Access 2010 a SharePointu a lidé se sharepointovými účty tuto webovou databázi používají ve webovém prohlížeči.

Jak to funguje

Když publikujete webovou databázi, Access Services vytvoří sharepointový web, který tuto databázi obsahuje. Všechny databázové objekty a data se přesunou do sharepointových seznamů na tomto webu. Proces uvidíte na následující videu.

Váš prohlížeč nepodporuje video. Nainstalujte si Microsoft Silverlight, Adobe Flash Player nebo Internet Explorer 9.

Po publikování pak můžou návštěvníci SharePointu používat vaši databázi (pokud mají pro tento sharepointový web odpovídající oprávnění).

  • Úplné řízení:    Toto oprávnění umožňuje provádět změny dat a návrhu.

  • Přispívat:    Toto oprávnění umožňuje provádět změny dat, ale ne návrhu.

  • Číst:    Toto oprávnění umožňuje číst data, ale nedovoluje provádět žádné změny.

Webovou databázi můžete otevřít v Accessu, změnit její návrh a pak synchronizovat změny uložením na sharepointový web. Následující video ukazuje, jak dělat změny návrhu po publikování webové databáze.

Váš prohlížeč nepodporuje video. Nainstalujte si Microsoft Silverlight, Adobe Flash Player nebo Internet Explorer 9.

Taky můžete vaši databázi převést do offline režimu, používat offline verzi a potom synchronizovat změny dat a návrhu, až budete zase online.

Poznámka : Pokud chcete vytvořit webovou databázi, musíte mít na sharepointovém webu, na kterém ji chcete publikovat, oprávnění Úplné řízení. Další informace o oprávněních SharePointu najdete v části Viz také.

Formuláře a sestavy se spouštějí v prohlížeči

Formuláře, sestavy a většina maker běží v prohlížeči. Umožňují Accessu obnovit data na obrazovce bez nutnosti znovu zpracovat celou stránku.

Můžete vytvořit formulář, který pomůže uživatelům při navigaci v aplikaci. Nový ovládací prvek, Navigace, usnadňuje přidání standardních tlačítek navigace webového stylu k formuláři pro tento účel.

Poznámka : Navigační podokno (funkce používaná v Accessu k procházení objektů v databázi) není ve webovém prohlížeči k dispozici.

Data se ukládají v seznamech služby SharePoint

Ze všech tabulek se stanou seznamy služby SharePoint a ze záznamů se stanou položky seznamu. Díky tomu můžete pro řízení přístupu k webové databázi používat oprávnění služby SharePoint a využívat jiné funkce této služby.

Poznámka zabezpečení :  Připojovací řetězec pro propojené tabulky je nešifrovaný, včetně uživatelského jména a hesla, pokud tyto informace byly uložené (a cíl odkazu podporuje uživatelské účty). V databázi, která obsahuje odkaz na seznam SharePointu (pokud odkaz zahrnuje uživatelské jméno a heslo), by mohl kyberzločinec pomocí uložených přihlašovacích údajů změnit to, který seznam je cílem odkazu. I v případě, že přihlašovací údaje nejsou uložené v připojovacím řetězci, by mohl kyberzločinec změnit oprávnění na webu SharePointu s pomocí spolupracovníka, který již má dostatečná oprávnění. Při sdílení kopií databáze obsahující odkazy na seznamy v publikované webové databázi postupujte opatrně.

Dotazy a datová makra se spouštějí na serveru

Všechno zpracování jazyka SQL probíhá na serveru. Pomáhá to zlepšit výkon sítě díky omezení přenosu dat do sad výsledků dotazu.

Intranet nebo internet

Publikovat můžete na vlastní intranetový sharepointový server nebo na internet. Microsoft nabízí hostované sharepointové řešení s přístupem na internet.

Začátek stránky

Vytvoření webové databáze

Tato část popisuje hlavní nové funkce a obsahuje kroky pro základní úlohy návrhů, které musíte udělat, abyste vytvořili webovou databázi.

V této části

Než začnete

Mám použít šablonu?

Začínáme s prázdnou webovou databází

Návrh webové tabulky

Přidání počítaného pole

Nastavení pravidel pro ověření dat

Vytvoření relace mezi dvěma webovými tabulkami

Změna vyhledávacího pole v zobrazení Datový list

Použití datových maker k zachování integrity dat

Vytvoření webového dotazu

Vytvoření webového formuláře

Vytvoření webové sestavy

Vytvoření navigačního formuláře a jeho nastavení jako výchozího formuláře, který se zobrazí při spuštění

Než začnete

Než začnete s návrhem webové databáze, měli byste provést několik úkolů. Kromě toho existují rozdíly v návrhu webových databází a desktopových databází, o kterých byste měli vědět, zejména pokud jste zkušený vývojář aplikace Access.

  • Určení účelu databáze:    Mějte jasný plán, abyste se při práci na detailech návrhu mohli správně rozhodovat.

  • Vyhledání a uspořádání požadovaných informací:    Ve webové databázi nelze použít propojené tabulky. Veškerá data, která chcete použít a která nebudou pocházet z databáze, je třeba před publikováním importovat. Pokud si před zahájením návrhu připravíte všechna data, vyhnete se tomu, že bude nutné návrh opravit, aby se přizpůsobil neočekávaným problémům s daty.

  • Určení webu služby SharePoint, který použijete k publikování:    K publikování je nutná služba SharePoint. Jestliže chcete svůj návrh během vytváření otestovat v prohlížeči (což je dobrý nápad), musíte ho nejdříve publikovat.

  • Plánování zabezpečení:    Ke kontrole přístupu k webové databázi můžete využít zabezpečení služby SharePoint. Zabezpečení plánujte včas, abyste ho mohli zabudovat do svého návrhu.

Rozdíly v návrhu mezi desktopovými databázemi a webovými databázemi

Některé databázové funkce, které můžete použít v desktopové databázi (v klientském počítači), nejsou k dispozici v rámci služeb Access Services. Některé nové funkce ale podporují spoustu stejných scénářů jako desktopové funkce.

V následující tabulce jsou uvedeny výhradně desktopové funkce a nová funkce, která pomáhá podporovat stejný scénář.

Scénář

Výhradně desktopová funkce

Nová funkce

Návrhy databázových objektů

Návrhové zobrazení:

Zdokonalené zobrazení Datový list; zobrazení Rozložení

Kontrola souhrnů dat, jako jsou součty, průměry a skupiny

Skupinové funkce

Datová makra; skupinové funkce v sestavách

Programování událostí

VBA

Makra a datová makra; nový způsob návrhu maker pomocí technologie IntelliSense

Přechod k databázovému objektu

Navigační podokno; přepínací panely

Navigační ovládací prvek nebo jiný prvek formuláře

Důležité : Ve webové databázi se dá vytvářet spousta klientských objektů, ale nejde je použít v prohlížeči. Jsou ale součástí webové databáze a jdou použít v Accessu 2010 v počítači. Webovou databázi jde otevřít v Accessu a pak je možné klientské objekty použít. Je to efektivní způsob, jak sdílet databáze, který taky otevírá nové možnosti spolupráce přes web. Všechny problémy souběžnosti řeší SharePoint.

Výhradně desktopové funkce bez odpovídajících funkcí pro Access Services

Poznámka : Následující seznam není uzavřený.

  • Sjednocovací dotazy

  • Křížové dotazy

  • Překrývající se ovládací prvky ve formulářích

  • Relace tabulek

  • Podmíněné formátování

  • Různé akce a výrazy maker

Mám použít šablonu?

Po tom, co určíte, co musí aplikace dělat, zvažte, jestli by vám nepomohlo použít databázovou šablonu. Databázové šablony jsou předem připravené aplikace, které můžete buď použít přímo (tak, jak jsou), nebo si je upravit, aby vyhovovaly vašim konkrétním potřebám.

Dostupné šablony se zobrazují na kartě Nové v zobrazení Backstage. Další informace o šablonách dodávaných s aplikací Access 2010 najdete v článku Výběr a použití šablony aplikace Access.

Začínáme s prázdnou webovou databází

  • Na kartě Soubor klikněte na Nový.

    Karta Nový v zobrazení Backstage

Karta Soubor otevře zobrazení Backstage, novou součást rozhraní Accessu, kde najdete příkazy, které platí pro celou databázi, například Publikovat na serveru SharePoint Server.

V zobrazení Backstage jsou na kartě Nové příkazy k vytvoření databáze.

Funkce na kartě Nové v zobrazení Backstage

1. V části Dostupné šablony klikněte na Prázdná webová databáze.

2. Zkontrolujte navržený název souboru v poli Název souboru a cestu k souboru databáze uvedenou pod ním. Název souboru v poli Název souboru můžete změnit.

3. Pokud chcete změnit cestu, klikněte na ikonu složky vedle pole Název souboru a vyhledejte umístění, do kterého chcete soubor databáze uložit.

4. Klikněte na Vytvořit. Otevře se nová webová databáze a zobrazí se nová prázdná tabulka.

Návrh webové tabulky

K návrhu webové tabulky se používá zobrazení Datový list.

Při prvním vytvoření prázdné webové databáze vytvoří Access novou tabulku a otevře ji v zobrazení Datový list. Pomocí příkazů na kartách Pole a Tabulka můžete přidat pole, indexy, ověřovací pravidla a datová makra – to je nová funkce, která umožňuje měnit data na základě událostí.

Po úpravě a použití nové tabulky budete nejspíš chtít vytvořit další tabulky.

Vytvoření nové webové tabulky

S otevřenou webovou databází:

  • Na kartě Vytvoření klikněte ve skupině Tabulky na Tabulka.

Tabulka má při prvním vytvoření jedno pole: identifikační pole typu Automatické číslo. K ukládání informací požadovaných na základě předmětu tabulky můžete přidat nová pole. Je možné přidat třeba pole, které uloží datum, kdy jste začali sledovat určitou položku.

Přidání pole z galerie polí

V galerii polí si můžete vybrat z řady předem naformátovaných polí, která můžete přidat do svojí tabulky.

  • Na kartě Pole klikněte ve skupině Přidat a odstranit na typ pole, který chcete použít.

Přidání pole kliknutím na datový list

  1. Mějte otevřenou tabulku, klikněte na Kliknutím přidat a vyberte typ pole.

  2. Zadejte název pole, který vystihuje jeho obsah.

    Tip : Název existujícího pole můžete změnit poklikáním na název pole.

  3. Tento postup opakujte pro každé pole, které chcete vytvořit.

Změna vlastností pole

Formátování a vlastnosti určují, jak se pole chová – například jaký druh dat je v něm možné uložit. Toto nastavení můžete změnit tak, aby se pole chovalo podle vašich požadavků.

  1. Vyberte pole s formátováním a vlastnostmi, které chcete změnit.

  2. Na pásu karet klikněte na kartu Pole.

  3. Ke změně nastavení použijte příkazy ve skupinách Formátování a Vlastnosti.

Přidání počítaného pole

Můžete přidat pole, ve kterém se zobrazí hodnota počítaná z jiných dat ve stejné tabulce. Jako zdroj pro počítaná data nelze použít data z jiných tabulek. Některé výrazy počítaná pole nepodporují.

  1. Při otevřené tabulce klikněte na položku Kliknutím přidat.

  2. Přejděte na položku Počítané pole a klikněte na datový typ, který pro toto pole požadujete.

    Otevře se Tvůrce výrazů.

  3. Tvůrce výrazů slouží k vytvoření výpočtu pro pole. Nezapomeňte, že jako zdroje dat pro výpočet můžete použít jen jiná pole ze stejné tabulky. Nápovědu k použití Tvůrce výrazů najdete v článku Použití Tvůrce výrazů.

Nastavení pravidel pro ověření dat

K ověření zadání můžete u většiny polí použít výraz. Výraz můžete vhodně využít taky k ověření zadání u tabulky, když chcete ověřit zadání pro pole, které ověření nepodporuje, nebo tehdy, když chcete ověřit zadání v poli na základě hodnoty jiných polí v tabulce. Podrobnější popis ověření najdete v článku Omezení vstupu dat pomocí pravidla ověřování.

Můžete také zadat zprávu, která se zobrazí, když ověřovací pravidlo zabrání zadání dat. Nazývá se ověřovací zpráva.

Nastavení pravidla a zprávy pro ověření pole

  1. Vyberte pole, do kterého chcete přidat ověřovací pravidlo.

  2. Na pásu karet klikněte na kartu Pole.

  3. Ve skupině Ověření pole klikněte na tlačítko Ověření a potom na položku Ověřovací pravidlo pole.

    Otevře se Tvůrce výrazů.

  4. V Tvůrci výrazů vytvoříte ověřovací pravidlo. Nápovědu k použití Tvůrce výrazů najdete v článku Použití Tvůrce výrazů.

  5. Ve skupině Ověření pole klikněte na tlačítko Ověření a potom na položku Ověřovací zpráva pole.

  6. Zadejte zprávu, která se má zobrazit, když nejsou data zadání platná, a klikněte na tlačítko OK.

Nastavení pravidla a zprávy pro ověření záznamu

Ověřovacím pravidlem záznamu můžete zabránit duplicitním záznamům nebo požadovat, aby pro záznam platila určitá kombinace fakt, třeba podmínka, že [Počáteční datum] je větší než 1. ledna 2010 a zároveň menší než [Koncové datum].

  1. Otevřete tabulku, do které chcete přidat ověřovací pravidlo.

  2. Na pásu karet klikněte na kartu Pole.

  3. Ve skupině Ověření pole klikněte na tlačítko Ověření a potom na položku Ověřovací pravidlo záznamu.

    Otevře se Tvůrce výrazů.

  4. V Tvůrci výrazů vytvoříte ověřovací pravidlo. Nápovědu k použití Tvůrce výrazů najdete v článku Použití Tvůrce výrazů.

  5. Ve skupině Ověření pole klikněte na tlačítko Ověření a potom na položku Ověřovací zpráva záznamu.

  6. Zadejte zprávu, která se má zobrazit, když nejsou data zadání platná, a klikněte na tlačítko OK.

Vytvoření relace mezi dvěma webovými tabulkami

Pokud chcete vytvořit relaci ve webové databázi, použijte k vytvoření vyhledávacího pole průvodce vyhledáváním. Vyhledávací pole bude v tabulce, která je v relaci na straně N, a ukazuje do tabulky, která je v relaci na straně 1.

Vytvoření vyhledávacího pole v zobrazení Datový list

  1. Otevřete požadovanou tabulku na straně N relace.

  2. Klikněte na šipku vedle tlačítka Kliknutím přidat a klikněte na položku Vyhledávání a relace.

  3. Pomocí pokynů v Průvodci vyhledáváním vytvořte vyhledávací pole.

Změna vyhledávacího pole v zobrazení Datový list

  1. Otevřete tabulku obsahující vyhledávací pole, které chcete změnit.

  2. Proveďte jednu z následujících akcí:

    • Na kartě Pole klikněte ve skupině Vlastnosti na tlačítko Změnit vyhledávání.

    • Klikněte na vyhledávací pole pravým tlačítkem myši a pak klikněte na příkaz Změnit vyhledávání.

  3. Postupujte podle pokynů Průvodce vyhledáváním.

Použití datových maker k zachování integrity dat

Pomocí datových maker můžete implementovat kaskádové aktualizace a odstranění. K vytvoření vložených maker, která mění data, se používají příkazy na kartě Tabulka. Základní informace vidíte na následujícím videu.

Váš prohlížeč nepodporuje video. Nainstalujte si Microsoft Silverlight, Adobe Flash Player nebo Internet Explorer 9.

Další informace o vytváření datových maker najdete v článku Vytvoření datového makra.

Vytvoření webového dotazu

Dotaz lze použít jako zdroj dat pro formuláře a sestavy. Dotazy se spouštějí na serveru a napomáhají minimalizovat zatížení sítě.

Předpokládejme, že používáte webovou databázi například ke sledování charitativních příspěvků. Chcete se podívat, kdo během akce daroval peníze. Pomocí dotazu můžete vybrat požadovaná data a připravit je pro potřeby formulářů nebo sestav.

Poznámka : V tomto procesu se jako příklad používá šablona charitativních příspěvků. Můžete jej využít, pokud vytváříte novou databázi podle této databázové šablony.

  1. Na kartě Vytvoření ve skupině Dotazy klikněte na tlačítko Dotaz.

  2. V dialogovém okně Zobrazit tabulku poklikejte na každou tabulku, kterou chcete do dotazu zahrnout, a klikněte na tlačítko Zavřít.

    V tomto příkladu poklikejte na tabulku Sponzoři, Dary, Události a ÚčastníciUdálosti.

  3. Vytvořte libovolná spojení přetažením polí z jednoho objektu do druhého v okně návrhu dotazu.

    V uvedeném příkladu přetáhněte pole ID z tabulky Sponzoři do pole IDSponzora v tabulce Dary a pak přetáhněte pole IDSponzora z tabulky Dary do pole IDSponzora v tabulce ÚčastníciUdálosti.

  4. Přidejte pole, která chcete použít. Pole můžete přetáhnout do mřížky nebo přidat tak, že na ně poklikejte.

    V uvedeném příkladu přidejte pole Událost z tabulky Události, pole DatumDaru z tabulky Dary a pole Pozdrav, Jméno a Příjmení z tabulky Sponzoři.

  5. Přidejte libovolná kritéria, která chcete použít.

    V uvedeném příkladu chcete omezit datum daru tak, aby spadalo do termínu mezi datem zahájení a datem ukončení události. V mřížce návrhu dotazu na řádku Kritéria zadejte pod položkou DatumDaru >=[DatumZahájení] And <=[DatumUkončení].

Vytvoření webového formuláře

Formuláře představují hlavní způsob zadávání a úpravy dat ve webové databázi. Mohou také sloužit k prohlížení dat. Formuláře se spouštějí v prohlížeči, což pomáhá optimalizovat výkon. Při otevření formuláře načte prohlížeč požadovaná data ze serveru SharePoint. Data ve formuláři můžete filtrovat a řadit bez nutnosti jejich opětovného načítání ze serveru.

Tip : Nejlepších výsledků dosáhnete, když omezíte záznamy načítané hlavními formuláři a sestavami.

  1. Vyberte tabulku nebo dotaz, který chcete použít jako zdroj dat.

    Poznámka : Chcete-li vytvořit nevázaný formulář, tento krok přeskočte.

  2. Na kartě Vytvoření klikněte ve skupině Formuláře na jedno z následujících tlačítek:

    • Formulář:    Pomocí objektu vybraného jako zdroj dat můžete vytvořit jednoduchý formulář zobrazující vždy jeden záznam.

      Poznámka : Při vytváření nevázaného formuláře není toto tlačítko k dispozici.

    • Více položek:    Pomocí objektu vybraného jako zdroj dat můžete vytvořit formulář zobrazující více záznamů najednou.

      Poznámka : Při vytváření nevázaného formuláře není toto tlačítko k dispozici.

    • Prázdný formulář:    Můžete vytvořit formulář, který neobsahuje žádné položky.

    • Datový list:    Pomocí objektu vybraného jako zdroj dat můžete vytvořit formulář, který má stejný vzhled a chování jako datový list.

      Poznámka : Při vytváření nevázaného formuláře není toto tlačítko k dispozici.

Vytvoření webové sestavy

Sestavy představují hlavní způsob prohlížení nebo tisku dat z webové databáze. Sestavy se spouštějí v prohlížeči, což pomáhá optimalizovat výkon. Při otevření sestavy načte prohlížeč požadovaná data ze serveru SharePoint. Data v sestavě lze filtrovat a řadit bez nutnosti jejich opětovného načítání ze serveru.

Tip : Nejlepších výsledků dosáhnete, když omezíte záznamy načítané hlavními formuláři a sestavami.

  1. Vyberte tabulku nebo dotaz, který chcete použít jako zdroj dat.

  2. Na kartě Vytvoření ve skupině Sestavy klikněte na jedno z následujících tlačítek:

    • Sestava:    Pomocí objektu vybraného jako zdroj dat můžete vytvořit základní sestavu.

    • Prázdná sestava:    Můžete vytvořit sestavu, která neobsahuje žádné položky.

Vytvoření navigačního formuláře a jeho nastavení jako výchozího formuláře, který se zobrazí při spuštění

Uživatelé potřebují znát možnosti navigace ve vaší aplikaci. Nezapomeňte, že ve webovém prohlížeči není k dispozici navigační podokno. K tomu, aby uživatelé mohli používat vaše databázové objekty, je nutné jim dát prostředky. Můžete vytvořit navigační formulář a určit, aby se zobrazil vždy, když někdo vaši aplikaci spustí ve webovém prohlížeči. Pokud neurčíte formulář, který se má zobrazit při každém spuštění aplikace, žádný formulář se neotevře, což uživatelům velmi znesnadňuje používání aplikace.

Tip : Je vhodné navigační formulář vytvořit až nakonec, abyste do něj mohli přidat všechny potřebné objekty.

  1. Na pásu karet klikněte na kartu Vytvoření.

  2. Ve skupině Formuláře klikněte na položku Navigace a ze seznamu vyberte požadované rozložení navigace.

  3. Chcete-li přidat položku, přetáhněte ji z navigačního podokna do ovládacího prvku navigace.

    Poznámka : K ovládacímu prvku navigace je možné přidávat jen formuláře a sestavy.

  4. Přidejte k hlavní části navigačního formuláře všechny ostatní požadované ovládací prvky. Je například vhodné zpřístupnit funkci hledání ve všech formulářích tak, že k navigačnímu formuláři přidáte několik ovládacích prvků.

Nastavení navigačního formuláře jako výchozího formuláře ve webovém zobrazení

  1. Na kartě Soubor pod položkou Nápověda klikněte na tlačítko Možnosti.

  2. V dialogovém okně Možnosti aplikace Access klikněte na položku Aktuální databáze.

  3. V části Možnosti aplikace klikněte na položku Webový formulář pro zobrazení a vyberte ze seznamu požadovaný formulář.

    Poznámka :  Jako webový formulář pro zobrazení není nutné vybírat navigační formulář. Můžete určit libovolný webový formulář.

Začátek stránky

Publikování a synchronizace změn v aplikaci

Publikování webové databáze

Video k tomuto procesu najdete v části Základní informace.

  1. Na kartě Soubor klikněte na položku Uložit a publikovat a potom na položku Publikovat ve službách Access Services.

  2. Klikněte na možnost Spustit kontrolu kompatibility.
    Tlačítko Spustit kontrolu kompatibility v zobrazení Backstage aplikace Access
    Kontrola kompatibility pomůže zajistit, aby byla vaše databáze správně publikována. Pokud zjistí problém, měli byste se pokusit ho před publikováním odstranit.

    Poznámka : Zjištěné problémy ukládá aplikace Access do tabulky s názvem Problémy kompatibility s webem. Každý řádek v tabulce obsahuje odkaz na informace pro řešení potíží.

  3. V části Publikovat ve službách Access Services vyplňte tyto údaje:

    • Do pole Adresa URL serveru zadejte webovou adresu serveru SharePoint, na kterém chcete databázi publikovat, například http://Contoso/.

    • Do pole Název webu zadejte název své webové databáze. Připojením tohoto názvu k adrese URL serveru vznikne adresa URL vaší aplikace. Pokud je adresa URL serveru třebahttp://Contoso/ a název webu je CustomerService, bude adresa URL http://Contoso/CustomerService.

  4. Klikněte na položku Publikovat ve službách Access Services.

Synchronizace webové databáze

Po provedení změn návrhu a převedení databáze do offline režimu budete pravděpodobně chtít databázi synchronizovat. Synchronizace odstraňuje rozdíly mezi souborem databáze v počítači a webem služby SharePoint.

Video k tomuto procesu najdete v části Základní informace.

  1. Otevřete webovou databázi v Accessu a proveďte požadované změny návrhu.

  2. Po dokončení klikněte na kartu Soubor a potom na Synchronizovat vše.
    Tlačítko Synchronizovat vše v zobrazení Backstage Accessu

Začátek stránky

Sdílení Facebook Facebook Twitter Twitter E-mail E-mail

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×