Vytvoření zobrazení dat

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Vaše společnost shromažďuje a ukládá data – velké množství dat. Aby bylo možné k těmto datům snadno získat přístup a abyste mohli vy i váš tým s těmito daty snadno pracovat, budete chtít vytvořit aplikaci pro sledování nebo vykazování na webu Microsoft SharePoint vašeho týmu. Kde začít?

Pomocí aplikace Microsoft Office SharePoint Designer 2007 můžete rychle vytvořit přizpůsobené zobrazení dynamických dat, kterému říkáme Zobrazení dat. Zobrazení dat umožňuje zobrazit data z celé řady různých zdrojů, včetně databázových dotazů, dokumentů XML, webových služeb, seznamů SharePoint a knihoven a také serverových skriptů.

Zobrazení dat lze na stránku vložit dvěma způsoby: přetažením zdroje dat ze seznamu složek nebo knihovny zdrojů dat na novou nebo existující stránku na webu. Lze ho také vytvořit pomocí příkazu Vložit zobrazení dat. Potom ho můžete ihned začít upravovat vložením pouze polí, která chcete zobrazit, z podokna úloh Podrobnosti zdroje dat.

Tento článek je úvodem do zobrazení dat. Navíc ukazuje, jak vytvořit ukázkový soubor XML, který má být použit jako zdroj dat, a také jak vytvořit zobrazení dat na základě těchto dat – nejdříve přetažením a potom pomocí podokna úloh Podrobnosti zdroje dat. Tento článek používá jako zdroj dat soubor XML, aby bylo možné snadno vytvořit zdroj dat a pracovat s ním. Následující postup však lze použít s libovolným zdrojem dat – zejména s daty seznamu SharePoint, například s vaším nejběžnějším zdrojem dat pro vytváření zobrazení dat.

Důležité : Článek se zabývá vytvářením zobrazení dat v rámci webů SharePoint, které jsou umístěny na serverech se službou Windows SharePoint Services 3.0. Pokud však web není umístěn na serveru se službou Windows SharePoint Services 3.0, je možné, že nebudou k dispozici všechny funkce.

V tomto článku

Co je zobrazení dat?

Vytvoření souboru XML jako zdroje ukázkových dat

Zobrazení dat vytvoření přetažením zdroje dat na stránce

Vytvoření zobrazení dat pomocí podokna úloh Podrobnosti zdroje dat

Navrhované další kroky

Co je zobrazení dat?

Zobrazení dat je dynamické přizpůsobitelné zobrazení zdroje dat, který využívá technologii Microsoft ASP.NET. Office SharePoint Designer 2007 načte data ze zdroje dat v podobě z jazyk XML (Extensible Markup) a tato data zobrazí pomocí transformací XSLT Extensible Stylesheet Language (Transformations). Zobrazení dat můžete změnit pomocí Office SharePoint Designer 2007. Zobrazení dat můžete zobrazit data z nejrůznějších zdrojů, včetně databázových dotazů, dokumentů XML, webové služby, Sharepointových seznamů a knihoven a skripty na straně serveru. Můžete taky vytvořit zobrazení dat obsahující data z různých zdrojů.

Zobrazení dat načte data ze zdroje dat a tato data zobrazí pomocí transformací XSLT.

Zobrazení dat představují dynamická zobrazení dat, která lze filtrovat, řadit nebo seskupovat. Můžete také změnit rozložení, použít styly či podmíněné formátování zcela v režimu WYSIWYG.

Po vložení zobrazení dat na stránce můžete přidat nebo odebrat sloupce, změnit formátování písma nebo barvy pomocí WYSIWYG nástrojů v Office SharePoint Designer 2007. Při formátování zobrazení dat pomocí nástrojů WYSIWYG dostupných v Office SharePoint Designer 2007 jazyk XSL (Extensible Stylesheet) je vložen přímo do HTML. Když je možné upravit XSL přímo v zobrazení kódu, můžete v Office SharePoint Designer 2007 použít XSL rychle a snadno bez znalostí jazyka XSL nástroje pro formátování.

Začátek stránky

Vytvoření souboru XML jako ukázkového zdroje dat

Northwind Traders je společnost zabývající se distribucí lahůdek uchovávající seznam svých produktů ve formátu XML. Seznam produktů obsahuje také informace o skladových zásobách. V současné době váš tým sleduje skladové zásoby tak, že vytiskne sestavy a předá je ostatním týmům. Navrhnete, aby vytvořili zobrazení dat na jejich intranetovém webu, aby týmy ve společnosti mohly snadno a rychle získat přístup k informacím o skladových zásobách produktů a nebylo nutné tisknout sestavy skladových zásob.

V následujících postupech je nutné používat soubor XML jako zdroj dat. Pokud na serveru SharePoint nemáte soubor XML, je nejdříve potřeba vytvořit seznam produktů společnosti Northwind Traders. Po vytvoření seznamu můžete vytvořit zobrazení dat obsažené v seznamu, a to pomocí zobrazení dat.

Vytvoření souboru produkty.xml

  1. V nabídce Soubor klepněte na příkaz Otevřít web.

  2. V dialogovém okně Otevřít web vyhledejte a vyberte web SharePoint a klepněte na tlačítko Otevřít.

  3. Pokud se zobrazí dialogové okno Připojit k s dotazem na uživatelské jméno a heslo, zadejte je a klepněte na tlačítko OK.

  4. V nabídce Soubor klepněte na příkaz Nový.

  5. V dialogovém okně Nový poklepejte na položku Textový soubor.

    Na webu se otevře nový textový soubor.

  6. Zkopírujte následující řádky kódu do schránky (vyberte je a stiskněte klávesovou zkratku CTRL+C).

    <?xml version="1.0" encoding="utf-8"?>
    <ProductsRoot>
    <Products>
    <ProductID>1</ProductID>
    <ProductName>Chai</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>1</CategoryID>
    <QuantityPerUnit>10 boxes x 20 bags</QuantityPerUnit>
    <UnitPrice>18</UnitPrice>
    <UnitsInStock>39</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>10</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>2</ProductID>
    <ProductName>Chang</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>1</CategoryID>
    <QuantityPerUnit>24 - 12 oz bottles</QuantityPerUnit>
    <UnitPrice>19</UnitPrice>
    <UnitsInStock>17</UnitsInStock>
    <UnitsOnOrder>40</UnitsOnOrder>
    <ReorderLevel>25</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>3</ProductID>
    <ProductName>Aniseed Syrup</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>12 - 550 ml bottles</QuantityPerUnit>
    <UnitPrice>10</UnitPrice>
    <UnitsInStock>13</UnitsInStock>
    <UnitsOnOrder>70</UnitsOnOrder>
    <ReorderLevel>25</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>4</ProductID>
    <ProductName>Chef Anton's Cajun Seasoning</ProductName>
    <SupplierID>2</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>48 - 6 oz jars</QuantityPerUnit>
    <UnitPrice>22</UnitPrice>
    <UnitsInStock>53</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>0</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>5</ProductID>
    <ProductName>Chef Anton's Gumbo Mix</ProductName>
    <SupplierID>2</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>36 boxes</QuantityPerUnit>
    <UnitPrice>21.35</UnitPrice>
    <UnitsInStock>0</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>0</ReorderLevel>
    <Discontinued>1</Discontinued>
    </Products>
    </ProductsRoot>
  7. V aplikaci Office SharePoint Designer 2007 umístěte ukazatel myši do horní části stránky a potom stisknutím kombinace kláves CTRL+V vložte právě zkopírovaný kód na stránku.

  8. V nabídce Soubor klepněte na příkaz Uložit jako.

  9. V dialogovém Uložit jako v poli název souboru zadejte products.xml.

  10. Ze seznamu Typ souboru vyberte položku XML a pak klepněte na tlačítko Uložit.

Začátek stránky


Vytvoření zobrazení dat přetažením zdroje dat na stránku

Když přetáhnete na stránku zdroje dat, výsledkem je výchozí zobrazení dat s prvních pět polí ve zdroji dat v jednotlivých řádcích základní tabulka. Zobrazení dat je však zcela přizpůsobit. Po vložení zobrazení dat, můžete snadno přidat sloupce, které nebo odebrání sloupců v zobrazení dat nejlépe odpovídá vašim potřebám. Další informace naleznete v tématu Úprava sloupců v zobrazení dat.

Zobrazení dat jsou založena na technologii Microsoft ASP.NET 2.0. Chcete-li vytvořit zobrazení dat, je potřeba začít se stránkou ASP.NET (soubor ASPX). V tomto příkladě vytvoříte novou stránku ASP.NET a potom vytvoříte zobrazení dat přetažením zdroje dat na stránku.

  1. V nabídce Soubor klepněte na příkaz Nový.

  2. V dialogovém okně Nový poklepejte na položku ASPX.

    Otevře se nová stránka se značkou FORM.

    Značka form technologie ASP.NET

  3. Proveďte jednu z následujících akcí:

    • V seznamu Seznam složek vyhledejte zdroj dat (v tomto příkladě produkty.xml) a přetáhněte ho na stránku.

    • V nabídce Podokna úkolů klepněte na příkaz Knihovna zdrojů dat. V podokně úloh Knihovna zdrojů dat vyhledejte zdroj dat (v tomto příkladě produkty.xml) a přetáhněte ho na stránku.

      Zobrazení dat je nyní zobrazeno na stránce a otevře se podokno úloh Podrobnosti zdroje dat.

      Zobrazení dat vytvoření přetažením zdroje dat zobrazuje prvních pět polí.
      V rozložení Základní tabulka se zobrazí prvních pět polí.

Začátek stránky


Vytvoření zobrazení dat pomocí podokna úloh Podrobnosti zdroje dat

Při vytváření zobrazení dat pomocí podokna úloh Podrobnosti zdroje dat nejdříve vložíte zobrazení dat na stránku. Potom vyberete zdroj dat v podokně úloh Knihovna zdrojů dat umožňujícím spravovat dostupné zdroje dat pro server SharePoint. Jakmile vyberete zdroj dat, otevře se podokno úloh Podrobnosti zdroje dat. V podokně úloh Podrobnosti zdroje dat zvolíte pole, která chcete zobrazit, a potom je vložíte do zobrazení dat.

Zobrazení dat jsou založena na technologii ASP.NET 2.0. Chcete-li vytvořit zobrazení dat, je potřeba začít se stránkou ASP.NET (soubor ASPX). V tomto příkladě vytvoříte novou stránku ASP.NET a potom vytvoříte zobrazení dat pomocí podokna úloh Podrobnosti zdroje dat

  1. V nabídce Soubor klepněte na příkaz Nový.

  2. V dialogovém okně Nový poklepejte na položku ASPX.

    Otevře se nová stránka se značkou FORM.

    Značka form technologie ASP.NET

  3. V nabídce Zobrazení dat klepněte na příkaz Vložit zobrazení dat.

    Na stránce je nyní zobrazeno prázdné zobrazení dat a otevře se podokno úloh Knihovna zdrojů dat.

    Prázdné zobrazení dat

    Jakmile je vloženo zobrazení dat, je vše připraveno k přidání dat.

  4. V podokně úloh Knihovna zdrojů dat vyhledejte zdroj dat, klepněte na něj a potom klepněte na možnost Zobrazit data.

    V uvedeném příkladu klepněte v části Soubory XML na možnost produkty.xml a potom klepněte na možnost Zobrazit data. Pokud je záhlaví Soubory XML sbaleno, rozbalte ho klepnutím na znaménko plus (+).

  5. V podokně úloh Podrobnosti zdroje dat klepněte na pole, která chcete vložit do zobrazení dat.

    Tip : Chcete-li vybrat více polí, podržte při klepání na jednotlivá pole klávesu CTRL.

    V uvedeném příkladě klepněte ve složce ProductsRoot (Kořenová složka produktů) v části Products (Produkty) na možnost ProductName (Název produktu). Stiskněte a podržte klávesu CTRL a klepněte na možnosti UnitsInStock (Počet položek na skladě), UnitsOnOrder (Počet objednaných položek) a ReorderLevel (Úroveň pro doobjednání).

    Pole vybraná v podokně úloh Podrobnosti zdroje dat

  6. Klepněte na možnost Vložit vybraná pole jako a klepnutím na možnost Zobrazení více položek vložte vybraná data do zobrazení dat.

    Poznámka : Pomocí možnosti Zobrazení jedné položky lze v zobrazení dat zobrazit jediný záznam. Možnost Zobrazení více položek umožňuje zobrazit více záznamů s poli ve sloupcích a se záhlavím pro každý sloupec.

    Pole vybraná v podokně úloh Podrobnosti zdroje dat se nyní zobrazí v tabulce.

    Soubor Products.xml tak, jak se zobrazí v zobrazení dat

    Po vytvoření zobrazení dat můžete pomocí nástrojů WYSIWIG (například panel nástrojů Formátování) upravovat písmo, zarovnávat text nebo měnit barvy. Při použití nového formátování pro datový bod v zobrazení dat použije aplikace Office SharePoint Designer 2007 formátování pro všechna data na stejné úrovni v souboru XML úpravou šablony stylů XSLT připojené ke stránce. Pokud jste například v předchozí ukázce vybrali možnost Chai a potom klepnuli na možnost Tučné na panelu nástrojů Formátování, použije aplikace Office SharePoint Designer 2007 stejné formátování pro veškerý obsah, který se zobrazí v poli ProductName.

    Tučné formátování použité pro všechna data v poli ProductName

Začátek stránky


Navrhované další kroky

Zobrazení dat jsou velmi výkonná a zcela přizpůsobitelná zobrazení dynamických dat. Nyní již víte, jak vytvořit zobrazení dat, mohly by se vám proto hodit další informace:

  • Filtrování dat v zobrazení dat    Můžete snadno filtrování dat v zobrazení dat. Další informace najdete v tématu filtrování dat v zobrazení dat.

  • Řazení a seskupení dat v zobrazení dat     Můžete rychle řadit nebo seskupovat data v zobrazení dat. Další informace najdete v tématu řazení a seskupení dat v zobrazení dat.

  • Použití podmíněného formátování pro zobrazení dat    Můžete použít konkrétní formátování, do zobrazení dat Pokud data v zobrazení dat splňují určité podmínky. Další informace najdete v tématu použití podmíněného formátování pro zobrazení dat.

  • Vytvoření sloupce vzorce v zobrazení dat     Můžete vytvořit počítaný sloupec, který zobrazí výsledek výpočtu jiných sloupců v zobrazení dat, stejně jako v tabulce. Můžete třeba vynásobte Jednotková cena počtem jednotek na skladě a zobrazit celkové hodnoty položky do samostatného sloupce. Další informace najdete v tématu Vytvoření sloupce vzorce v zobrazení dat.

  • Úprava sloupců v zobrazení dat    Můžete rychle a snadno přidat, odebrat nebo uspořádání sloupců v zobrazení dat. Další informace najdete v tématu Úprava sloupců v zobrazení dat.

  • Zobrazení dat z různých zdrojů v jediném zobrazení dat     Můžete propojit dva nebo více související zdroje dat a zobrazení dat z těchto zdrojů v jediném zobrazení dat. Další informace najdete v tématu zobrazení dat z různých zdrojů v jediném zobrazení dat.

  • Zobrazení ukázkových dat v zobrazení dat     Ukázková data můžete snadno zobrazit v zobrazení dat. Další informace najdete v tématu Zobrazení ukázkových dat v zobrazení dat.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Sdílení Facebook Facebook Twitter Twitter E-mail E-mail

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×