Vytvoření vzorců s podmínkou

V úlohách se často zjišťuje pravdivost či nepravdivost podmínek a porovnávají se logické výrazy. K vytvoření vzorců s podmínkou slouží funkce A, NEBO, NENÍ a KDYŽ.

Funkce KDYŽ používá například následující argumenty.

vzorec s funkcí KDYŽ

Vzorec obsahující funkci KDYŽ

Obrázek tlačítka  podmínka: Podmínka, kterou chcete ověřit

Bublinový popisek 2  ano: Vrácená hodnota, jestliže je hodnota argumentu podmínka Pravda.

Obrázek tlačítka  ne: Vrácená hodnota, jestliže je hodnota argumentu podmínka Nepravda.

Další informace o vytváření vzorců najdete v článku Vytvoření a odstranění vzorce.

Co chcete udělat?

Vytvořit vzorec s podmínkou, jehož výsledkem je logická hodnota (PRAVDA nebo NEPRAVDA)

Vytvořit vzorec s podmínkou, jehož výsledkem je jiný výpočet nebo jiná hodnota než PRAVDA či NEPRAVDA

Vytvoření vzorce s podmínkou, jehož výsledkem je logická hodnota (PRAVDA nebo NEPRAVDA)

K vytvoření takového vzorce použijte funkce A, NEBO a NENÍ a operátory, jak vidíte v následujícím příkladu.

Příklad

Příklad snadněji pochopíte, pokud jej zkopírujete do prázdného listu.

Jak zkopírovat příklad?

  1. Vyberte příklad v tomto článku.

    Důležité informace: Nevybírejte záhlaví řádků ani sloupců.

    Výběr příkladu z nápovědy v Excelu 2013 pro Windows

    Výběr příkladu z nápovědy

  2. Stiskněte kombinaci kláves CTRL+C.

  3. V Excelu vytvořte prázdný sešit nebo list.

  4. Vyberte v listu buňku A1 a stiskněte klávesy CTRL+V.

Důležité informace: Chcete-li, aby příklad fungoval správně, je nutné jej v listu zkopírovat do buňky A1.

  1. Chcete-li přepnout mezi zobrazením výsledků a zobrazením vzorců, které vracejí tyto výsledky, stiskněte kombinaci kláves CTRL+` (čárka nad vlevo) nebo na kartě Vzorce ve skupinovém rámečku Závislosti vzorců klepněte na tlačítko Zobrazit vzorce.

Po zkopírování příkladu do prázdného listu můžete příklad upravit podle vlastních potřeb.

1

2

3

4

5

6

7



8



9


10


11



12

A

B

Data

15

9

8

Kolečka

Zařízení

Vzorec

Popis (výsledek)

=A(A2>A3;A2<A4)

Zjistí, zda hodnota v buňce A2 je větší než hodnota v buňce A3, a rovněž zda hodnota v buňce A2 je menší než hodnota v buňce A4. (NEPRAVDA)

=NEBO(A2>A3;A2<A4)

Zjistí, zda hodnota v buňce A2 je větší než hodnota v buňce A3 nebo zda hodnota v buňce A2 je menší než hodnota v buňce A4. (PRAVDA)

=NE(A2+A3=24)

Zjistí, zda součet hodnot v buňkách A2 a A3 není roven 24. (NEPRAVDA)

=NE(A5="Kolečka")

Zjistí, zda hodnota v buňce A5 není rovna řetězci Kolečka. (NEPRAVDA)

=NEBO(A5<>"Kolečka",A6 = "Zařízení")

Zjistí, zda hodnota v buňce A5 není rovna řetězci Kolečka nebo zda hodnota v buňce A6 je rovna řetězci Zařízení. (PRAVDA)

Další informace o způsobu použití těchto funkcí najdete v článcích Funkce A, Funkce NEBO a Funkce NE.

Začátek stránky

Vytvoření vzorce s podmínkou, jehož výsledkem je jiný výpočet nebo jiná hodnota než PRAVDA či NEPRAVDA

K vytvoření takového vzorce použijte funkce KDYŽ, A a NEBO a operátory tak, jak znázorňuje následující příklad.

Příklad

Příklad snadněji pochopíte, pokud jej zkopírujete do prázdného listu.

Jak zkopírovat příklad?

  1. Vyberte příklad v tomto článku.

Důležité informace: Nevybírejte záhlaví řádků ani sloupců.

Výběr příkladu z nápovědy v Excelu 2013 pro Windows

Výběr příkladu z nápovědy

  1. Stiskněte kombinaci kláves CTRL+C.

  2. V Excelu vytvořte prázdný sešit nebo list.

  3. Vyberte v listu buňku A1 a stiskněte klávesy CTRL+V.

Důležité informace: Chcete-li, aby příklad fungoval správně, je nutné jej v listu zkopírovat do buňky A1.

  1. Chcete-li přepnout mezi zobrazením výsledků a zobrazením vzorců, které vracejí tyto výsledky, stiskněte kombinaci kláves CTRL+` (čárka nad vlevo) nebo na kartě Vzorce ve skupinovém rámečku Závislosti vzorců klepněte na tlačítko Zobrazit vzorce.

Po zkopírování příkladu do prázdného listu můžete příklad upravit podle vlastních potřeb.

1

2

3

4

5

6

7


8



9



10



11




12



13



14




15



16

A

B

Data

15

9

8

Kolečka

Zařízení

Vzorec

Popis (výsledek)

=KDYŽ(A2=15;"Dobře";"Špatně")

Pokud je hodnota v buňce A2 rovna 15, bude vrácen řetězec Dobře. Jinak bude vrácen řetězec Špatně. (Dobře)

=KDYŽ(A2<>15, "Dobře", "Špatně")

Pokud hodnota v buňce A2 není rovna 15, bude vrácen řetězec Dobře. Jinak bude vrácen řetězec Špatně. (Špatně)

=KDYŽ(NENÍ(A2<=15), "Dobře", "Špatně")

Pokud není hodnota v buňce A2 menší nebo rovna 15, bude vrácen řetězec Dobře. Jinak bude vrácen řetězec Špatně. (Špatně)

=KDYŽ(A5<>"KOLEČKA", "Dobře", "Špatně")

Pokud hodnota v buňce A5 není rovna řetězci KOLEČKA, bude vrácen řetězec Dobře. Jinak bude vrácen řetězec Špatně. (Špatně)

=KDYŽ(A(A2>A3;A2<A4);"Dobře";"Špatně")

Pokud je hodnota v buňce A2 větší než hodnota v buňce A3 a současně je hodnota v buňce A2 menší než hodnota v buňce A4, bude vrácen řetězec Dobře. Jinak bude vrácen řetězec Špatně. (Špatně)

=KDYŽ(A(A2<>A3, A2<>A4), "Dobře", "Špatně")

Pokud hodnota v buňce A2 není rovna hodnotě v buňce A3 a současně hodnota v buňce A2 není rovna hodnotě v buňce A4, bude vrácen řetězec Dobře. Jinak bude vrácen řetězec Špatně. (Dobře)

=KDYŽ(NEBO(A2>A3;A2<A4);"Dobře";"Špatně")

Pokud hodnota v buňce A2 je větší než hodnota v buňce A3 nebo hodnota v buňce A2 je menší než hodnota v buňce A4, bude vrácen řetězec Dobře. Jinak bude vrácen řetězec Špatně. (Dobře)

=KDYŽ(NEBO(A5<>"Kolečka", A6<>"Zařízení"), "Dobře", "Špatně")

Pokud hodnota v buňce A5 není rovna řetězci Kolečka nebo hodnota v buňce A6 není rovna řetězci Zařízení, bude vrácen řetězec Dobře. Jinak bude vrácen řetězec Špatně. (Špatně)

=KDYŽ(NEBO(A2<>A3, A2<>A4), "Dobře", "Špatně")

Pokud hodnota v buňce A2 není rovna hodnotě v buňce A3 nebo hodnota v buňce A2 není rovna hodnotě v buňce A4, bude vrácen řetězec Dobře. Jinak bude vrácen řetězec Špatně. (Dobře)

Další informace o způsobu použití těchto funkcí najdete v článcích Funkce KDYŽ, Funkce A a Funkce NEBO.

Začátek stránky

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×