Vytvoření vlastního formuláře seznamu

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Většina seznamů a knihoven služby SharePoint ve výchozím nastavení obsahuje formuláře, které se zobrazí, když chcete přidat položku do seznamu či knihovny nebo když chcete položku upravit či zobrazit. Pomocí aplikace Microsoft Office SharePoint Designer 2007 můžete snadno nahradit libovolný z výchozích formulářů seznamu vlastním formulářem seznamu, který bude navržen tak, aby splňoval vaše specifické potřeby. Jakmile vlastní formulář seznamu (včetně požadovaných polí) vytvoříte, můžete jej nastavit jako výchozí pro daný seznam nebo knihovnu.

Po vytvoření vlastního formuláře seznamu slouží k přidání nebo odebrání sloupců, změnit formátování písma nebo barvy WYSIWYG nástroje v Office SharePoint Designer 2007. Po výběru jazyka XSL (Extensible Stylesheet) je vložen přímo do HTML. Přestože je možné upravit XSL přímo v zobrazení kódu, můžete také nástroje pro formátování v Office SharePoint Designer 2007 použít XSL rychle a snadno bez znalostí jazyka XSL.

Tento článek vysvětluje, jak je možné vyhledat výchozí formuláře seznamů, jak lze vytvořit novou stránku obsahující vlastní formulář seznamu a jak je následně možné přidružit tuto novou stránku k určitému seznamu.

V tomto článku

Vyhledejte výchozích formulářů seznamů

Vytvořte novou stránku, která obsahuje vlastního formuláře seznamu

Spojení nová stránka se seznamem

Vyhledání výchozích formulářů seznamů

Většina seznamů a knihoven služby SharePoint obsahuje formuláře seznamů sloužící k přidávání nových položek nebo úpravám či zobrazování položek v daném seznamu nebo knihovně. Formuláře seznamů jsou umístěny ve složce obsahující přidružený seznam.

Vlastní formulář seznamu můžete vytvořit i bez toho, že byste vyhledali výchozí formuláře. Může ale být užitečné, pokud víte, kde jsou výchozí formuláře uloženy, a uložíte vlastní formuláře seznamů do stejného umístění. Chcete-li najít výchozí formuláře seznamů pro seznam nebo knihovnu, postupujte následovně:

  1. Pokud není zobrazeno podokno úloh Seznam složek, klepněte v nabídce Zobrazit na příkaz Seznam složek.

    Klávesová zkratka: Pokud chcete otevřít Seznam složek, stisknutím kombinace kláves ALT + F1.

  2. V případě seznamu služby SharePoint vyhledejte v podokně úloh Seznam složek složku Lists (Seznamy). V případě knihovny služby SharePoint vyhledejte složku Shared Documents (Sdílené dokumenty). Je-li složka Lists (Seznamy) nebo Shared Documents (Sdílené dokumenty) sbalená, rozbalte ji klepnutím na znaménko plus (+).

  3. Vyhledejte seznam nebo knihovnu, pro které chcete vytvořit vlastní formulář seznamu. Pokud jsou seznam nebo knihovna sbalené, rozbalte je klepnutím na znaménko plus (+).

    Na následujícím obrázku je rozbalený seznam Announcements (Oznámení).

    Formuláře seznamů pro seznam služby SharePoint zobrazené v podokně úloh Seznam složek

Ve výchozím nastavení se ve složce zobrazí tři soubory stránek formuláře: DispForm.aspx (ZobrazitFormulář.aspx), EditForm.aspx (UpravitFormulář.aspx) a NewForm.aspx (NovýFormulář.aspx). Čtvrtý soubor s názvem AllItems.aspx (VšechnyPoložky.aspx) představuje výchozí zobrazení dat, které zobrazuje položky v seznamu jako na následujícím obrázku.

Stránka formuláře AllItems (VšechnyPoložky) zobrazená v prohlížeči

Poznámka : V závislosti na seznamu může být ve složce více stránek zobrazení dat nebo více stránek formuláře.

Pomocí aplikace Office SharePoint Designer 2007 můžete vytvořit vlastní formuláře, které nahradí výchozí formuláře Nová položka, Upravit položku nebo Zobrazit položku. Lze to provést tak, že nahradíte stávající webovou část pro zobrazení seznamu vlastní webovou částí formuláře.

Následující tři obrázky ukazují výchozí formuláře seznamů pro seznam Announcements (Oznámení).

  • Stránka NewForm.aspx (NovýFormulář.aspx) zobrazuje formulář Nová položka, který se zobrazuje při přidávání nové položky do seznamu.

    Stránka NewForm.aspx (NovýFormulář.aspx) zobrazená v prohlížeči

  • Stránka EditForm.aspx (UpravitFormulář.aspx) zobrazuje formulář Upravit položku, který se zobrazuje při úpravách položky v seznamu.

    Stránka EditForm.aspx (UpravitFormulář.aspx) zobrazená v prohlížeči

  • Stránka DispForm.aspx (ZobrazitFormulář.aspx) zobrazuje formulář Zobrazit položku, který se zobrazuje v situaci, kdy zobrazujete jednu položku ze seznamu.

    Stránka formuláře DispForm.aspx (ZobrazitFormulář.aspx) zobrazená v prohlížeči

Začátek stránky

Vytvoření nové stránky obsahující vlastní formulář seznamu

V rámci tohoto postupu nejprve vytvoříte novou stránku a pak na ni vložíte vlastní formulář seznamu. Po uložení stránky ji můžete přidružit k existujícímu seznamu.

  1. V nabídce Soubor klepněte na příkaz Nový.

  2. V dialogovém okně Nový klepněte na kartě Stránka na položku Obecné a potom poklepejte na položku ASPX.

  3. V nabídce Vložit přejděte na příkaz Ovládací prvky SharePoint a klepněte na příkaz Vlastní formulář seznamu.

    Otevře se dialogové okno Formulář seznamu nebo knihovny dokumentů.

    Dialogové okno Formulář seznamu nebo knihovny dokumentů

  4. V seznamu Seznam nebo knihovna dokumentů, které bude formulář používat zvolte seznam nebo knihovnu, pro které chcete vytvořit formulář. V našem příkladu klepněte na položku Announcements (Oznámení).

  5. V seznamu Typ obsahu pro formulář klepněte na typ obsahu, pro který chcete formulář použít. V našem příkladu klepněte na položku Announcements (Oznámení). Pravděpodobně to bude jediná dostupná volba, protože tento seznam má pouze jeden výchozí typ obsahu.

    Každý seznam nebo knihovnu lze nakonfigurovat tak, aby podporovaly více typů obsahu, které se následně v tomto dialogovém okně zobrazí v seznamu Typ obsahu pro formulář. Pro každý typ obsahu dostupný pro seznam nebo knihovnu můžete použít odlišnou sadu vlastních formulářů seznamů. Pokud například seznam podporuje typy seznamu Tisková zpráva a Novinky v oboru, můžete vytvořit dvě samostatné sady vlastních formulářů seznamů a používat každou z nich zvlášť pro jednotlivé typy obsahu.

    Výhodou používání samostatné sady vlastních formulářů seznamů pro každý typ obsahu je, že každý formulář seznamu může být navržen přesně tak, aby zobrazoval pouze ta pole, která jsou relevantní pro daný typ obsahu.

  6. V části Typ vytvářeného formuláře určete, zda chcete vytvořit Formulář nové položky, Formulář pro úpravy položky nebo Formulář pro zobrazení položky.

    V našem příkladu klepněte na možnost Formulář nové položky.

  7. Chcete-li do formuláře zahrnout panel nástrojů, zaškrtněte políčko Zobrazit standardní panel nástrojů.

    Vlastní formulář seznamu může obsahovat panel nástrojů, který uživatelům pomůže provádět s položkou běžné akce. Tlačítka na panelu nástrojů jsou závislé na typu formuláře. Panel nástrojů ve formuláři EditForm.aspx (UpravitFormulář.aspx) může například vypadat jako na následujícím obrázku.

    Panel nástrojů ve formuláři EditForm.aspx (UpravitFormulář.aspx)

    Naopak panel nástrojů ve formuláři DispForm.aspx (ZobrazitFormulář.aspx) může vypadat následovně.

    Panel nástrojů ve formuláři DispForm.aspx (ZobrazitFormulář.aspx)

  8. Klepněte na tlačítko OK. Formulář nové položky se zobrazí na stránce.

    Formulář nové položky se zobrazí na stránce.

    Poznámka : Obrázek je příkladem stránky ASPX, která není připojena ke stránce předlohy. Chcete-li použít vzhled a formátování webu služby SharePoint, připojte stránku ke stránce předlohy. V nabídce Formát přejděte na příkaz Stránka předlohy a klepněte na příkaz Připojit stránku předlohy. V dialogovém okně Vybrat stránku předlohy klepněte na možnost Výchozí stránka předlohy a na tlačítko OK. Zobrazí se dialogové okno Shoda regionů obsahu. Chcete-li nastavit shodu těla stránky se zástupcem obsahu PlaceHolderMain, klepněte na tlačítko OK.

    Ve výchozím nastavení zobrazuje vlastní formulář seznamu výchozí pole pro vybraný typ formuláře společně s výchozími ovládacími prvky pro každé pole. V případě seznamu Announcements (Oznámení) bude například u pole Konec platnosti ovládací prvek pro výběr kalendářního data. Povinná pole (pokud se nějaká vyskytují) budou automaticky označena hvězdičkou.

  9. Chcete-li nový vlastní formulář seznamu uložit, klepněte v nabídce Soubor na příkaz Uložit jako. Formulář můžete uložit také stisknutím kombinace kláves CTRL+S.

  10. V dialogovém okně Uložit jako přejděte do složky seznamu nebo knihovny, pro které jste vlastní formulář seznamu vytvořili.

    V našem příkladu, v dialogovém okně Uložit jako poklikejte na seznamy a potom poklikejte oznámení otevřete složku oznámení. Do pole Název souboru zadejte NewAnnouncementsa potom klikněte na Uložit.

    V našem příkladu, do pole Název souboru zadejte NewAnnouncementsa potom klikněte na Uložit.

    Stránka NewAnnouncements.aspx (NovýOznámení.aspx) se zobrazí v podokně úloh Seznam složek ve složce Announcements (Oznámení).

Začátek stránky

Přidružení nové stránky k seznamu

Jakmile vytvoříte vlastní formulář seznamu, můžete jej přidružit k seznamu, pro který byl vytvořen. Dokud vlastní formulář seznamu k seznamu nepřidružíte, nebude se zobrazovat uživatelům v prohlížeči při vytváření, zobrazování nebo úpravách položek v daném seznamu.

V předchozím příkladu jsme vytvořili stránku NewAnnouncements.aspx (NovýOznámení.aspx) pro seznam Announcements (Oznámení), takže dalším krokem je přidružení stránky NewAnnouncements.aspx (NovýOznámení.aspx) k seznamu Announcements (Oznámení).

  1. V podokně úloh Seznam složek klepněte pravým tlačítkem myši na seznam nebo knihovnu, ke kterému nebo ke které chcete vlastní formulář seznamu přidružit – v našem příkladu Announcements (Oznámení) – a v místní nabídce klepněte na příkaz Vlastnosti.

  2. V dialogovém okně Vlastnosti seznamu klepněte na kartu Podpůrné soubory.

  3. Pokud je seznam nakonfigurován tak, aby podporoval více typů obsahu, klepněte v seznamu Formuláře specifické pro typ obsahu na typ obsahu, pro který chcete vlastní formulář seznamu používat.

    Při každé změně typu obsahu se změní zobrazené seznamy formulářů a zobrazeny budou formuláře používané pro aktuální typ obsahu. Každý typ obsahu může používat samostatnou sadu vlastních formulářů seznamů.

  4. V části Formulář nové položky klepněte na tlačítko Procházet, vyhledejte a vyberte vlastní formulář seznamu – v tomto příkladu NewAnnouncements.aspx (NovýOznámení.aspx) – a klepněte na tlačítko OK.

    Cesta k vlastnímu formuláři seznamu se nyní zobrazí v poli Formulář nové položky.

  5. Klepněte na tlačítko OK.

Pokud jste postupovali podle našeho příkladu, můžete nyní nový vlastní formulář otestovat. V podokně úloh Seznam složek klepněte na stránku Default.aspx (Výchozí.aspx) a stisknutím klávesy F12 ji otevřete v prohlížeči. Klepnete-li v prohlížeči v části Oznámení na možnost Přidat nové oznámení, měl by se otevřít vlastní formulář pro novou položku.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×