Vytvoření vlastních nabídek a místních nabídek pomocí maker

Poznámka: Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady.

Pomocí maker aplikace Access můžete vytvářet vlastní místní nabídky, které se zobrazí po kliknutí pravým tlačítkem myši na formuláře, sestavy nebo jednotlivé ovládací prvky. Můžete také vytvořit vlastní nabídky, které se zobrazí na pásu karet pro určité formuláře nebo sestavy.

Pokud chcete vytvořit nabídku pomocí maker, udělejte tři hlavní kroky:

  1. Vytvořte objekt makra s podmakry, které obsahují příkazy nabídky.

  2. Vytvořte další objekt makra, který vytvoří nabídku.

  3. Připojte nabídku k ovládacímu prvku, formuláři, sestavě nebo databázi jako celku.

V následujících částech najdete podrobné pokyny.

Poznámka: Používáte Access 2007? Pokud ano, přejděte na oddíl Vytvoření vlastních místních nabídek v accessu 2007.

Tip: Informace o tom, jak vytvořit vlastní místní nabídky v Accessu pomocí kódu jazyka VBA (Visual Basic for Applications), najdete v článku Vytvoření místní nabídky pro formulář, ovládací prvek formuláře nebo sestavu.

Krok 1: vytvoření objektu makra s podmakry, které obsahují příkazy nabídky

V tomto kroku vytvoříte objekt makra s podmakry, jehož každé podmakry bude samostatný příkaz v místní nabídce.

Co je submakro?

Pomocí submakra v objektu makra můžete definovat sadu akcí makra. Submakra v objektu makra se dají volat nezávisle na různých událostech ovládacího prvku a objektu. Jednotlivá submakra v objektu makra mají jedinečný název a mohou obsahovat jednu nebo více akcí makra.

  1. Na kartě Vytvořit klikněte ve skupině Makra a kód na tlačítko Makro.

  2. Pro každý příkaz, který chcete použít ve vlastní místní nabídce:

    1. Přidejte do okna návrhu makra příkaz makro submakra a pojmenujte submakro, které chcete zobrazit v místní nabídce (například tisk nebo aktualizovat).

      Tip: Pokud chcete vytvořit přístupovou klávesu, abyste mohli vybrat příkaz pomocí klávesnice, zadejte do pole název příkazu znak ampersand (&) před písmeno, které chcete použít (například "&Refresh"). Tento dopis bude v nabídce podtržený.

    2. V rámci submakra vyberte první akci, kterou chcete provést po kliknutí na příkaz v místní nabídce.

    3. Pokud existují další akce, které chcete provést, když vyberete tento příkaz, přidejte ho jako samostatné akce makra ve stejném submakru.

  3. Objekt makra uložte a pojmenujte například mcrShortcutMenuCommands.

    Následující obrázek ukazuje příklad objektu makra se třemi podmakry pro vlastní nabídku nebo místní nabídku.

    Snímek obrazovky s oknem návrhu makra Accessu se třemi příkazy submakra

Krok 2: Vytvoření druhého objektu makra, který vytvoří nabídku

Tento krok vypadá jako nadbytečných, ale pokud chcete vytvořit místní nabídku z objektu makra, který jste vytvořili v kroku 1, musíte vytvořit druhý objekt makra, který bude obsahovat akci makra PřidatNabídku. Tato akce makra se někdy nazývá "makro nabídky".

  1. Na kartě Vytvořit klikněte ve skupině Makra a kód na tlačítko Makro.

  2. V poli se seznamem Přidat novou akci v okně návrh makra vyberte PřidatNabídku.

  3. Do pole argument název nabídky pro akci makra PřidatNabídku zadejte název nabídky (například příkazy formulářů). Tento argument není povinný, ale doporučuje se, když v kroku 3 plánujete přidat nabídku na kartu pásu karet (například kartu Doplňky ve formuláři nebo sestavě). Pokud je nabídka přidána jako místní nabídka v kroku 3, je argument název nabídky ignorován.

  4. Do pole argument název makra nabídky zadejte název objektu makra, který jste vytvořili v kroku 1.

  5. Tento druhý objekt makra uložte a pojmenujte, třeba mcrAddShortcutMenu.

    Na následujícím obrázku je příklad objektu makra nabídka, který vytvoří nabídku, kterou jsme vytvořili v kroku 1.

    Snímek obrazovky s objektem makra Accessu a akcí makra PřidatNabídku

Krok 3: připojení nabídky k ovládacímu prvku, formuláři, sestavě nebo databázi

Podle toho, kde se má nabídka Zobrazit, použijte některý z následujících postupů.

Přidání nabídky na kartu Doplňky ve formuláři nebo sestavě

Tento postup použijte, pokud se má nabídka Zobrazit na kartě Doplňky pro určitý formulář nebo sestavu.

  1. V navigačním podokně klikněte pravým tlačítkem myši na formulář nebo sestavu, kde se má nabídka Zobrazit, a potom klikněte na příkaz návrhové zobrazení.

  2. Na kartě Návrh klikněte ve skupině Nástroje na Seznam vlastností.

  3. Výběrem možnosti formulář nebo Sestava v horní části podokna úloh seznam vlastností vyberte celý objekt.

  4. Na kartě jiné v seznamu vlastností zadejte do pole vlastnost řádku nabídek název objektu makra, který jste vytvořili v kroku 2 (v tomto příkladu "mcrAddShortcutMenu").

  5. Změny ve formuláři nebo sestavě uložíte.

    Při příštím otevření formuláře nebo sestavy se na pásu karet zobrazí karta Doplňky . Kliknutím na kartu zobrazte nabídku, jak je znázorněno na následujícím obrázku:

    Snímek obrazovky s pásem karet doplňků v Accessu

    Další informace o způsobech přizpůsobení pásu karet, jako je přidání vlastních karet nebo skrytí výchozích karet, najdete v článku Vytvoření vlastního pásu karet v Accessu.

Přidání nabídky jako místní nabídky pro formulář, sestavu nebo ovládací prvek

Tento postup použijte, pokud chcete, aby se nabídka zobrazila po kliknutí pravým tlačítkem myši na určitý formulář, sestavu nebo ovládací prvek.

  1. V navigačním podokně klikněte pravým tlačítkem myši na formulář nebo sestavu, kde se má místní nabídka zobrazovat, a potom klikněte na návrhové zobrazení.

  2. Na kartě Návrh klikněte ve skupině Nástroje na Seznam vlastností.

  3. Vyberte ovládací prvek nebo objekt, ke kterému chcete připojit místní nabídku.

    Pokud chcete vybrat celý objekt, vyberte v seznamu v horní části podokna úloh seznam vlastností možnost formulář nebo Sestava .

  4. Na kartě jiné v seznamu vlastností zadejte do pole vlastností řádek místní nabídky název objektu makra, který jste vytvořili v kroku 2 (v tomto příkladu "mcrAddShortcutMenu").

  5. Ujistěte se, že je vlastnost místní nabídky nastavená na hodnotu Ano.

  6. Změny ve formuláři nebo sestavě uložíte.

    Při příštím otevření formuláře nebo sestavy a následném kliknutí pravým tlačítkem myši na formulář, sestavu nebo ovládací prvek se zobrazí vaše místní nabídka s příslušnými příkazy, jak je znázorněno na následujícím obrázku:

    Snímek obrazovky s místní nabídkou ve formuláři Accessu

Přidání nabídky jako globální místní nabídky

Tento postup nahradí všechny výchozí místní nabídky v aktuální databázi. Vlastní místní nabídky, které jste připojili ke konkrétním formulářům, sestavám nebo ovládacím prvkům, nebudou ovlivněny.

  1. Klikněte na Soubor > Možnosti.

  2. V dialogovém okně Možnosti aplikace Access klikněte na Aktuální databáze.

  3. V části Možnosti pásu karet a panelu nástrojůzadejte do pole místní řádek nabídek název makra, které jste vytvořili v kroku 2 (v tomto příkladu "mcrAddShortcutMenu").

  4. Kliknutím na OK uložte změny v dialogovém okně Možnosti aplikace Access .

  5. Změny se projeví až po zavření a opětovném otevření databáze.

Vlastní místní nabídky nahrazují výchozí místní nabídky pro objekty, ke kterým jsou připojené. Chcete-li, aby se v těchto nabídkách používaly některé příkazy pro Access, použijte k vložení příkazů do objektů maker v nabídkách akce makra SpustitPříkaz .

Vlastní místní nabídka připojená k ovládacímu prvku nahrazuje všechny další vlastní místní nabídky, které jsou definované v databázi. Vlastní místní nabídka připojená k formuláři nebo sestavě nahrazuje vlastní globální místní nabídku.

Když zadáte makro nabídky pro formulář nebo sestavu nebo databázi, Access spustí toto makro nabídky při otevření formuláře, sestavy nebo databáze. Pokud provedete změny v objektu makra nabídky nebo objektu makra, který definuje jeho příkazy v otevřeném formuláři, sestavě nebo databázi, musíte zavřít formulář, sestavu nebo databázi a znova ji otevřít, aby se změny projevily.

Pokud chcete vytvořit podnabídku v seznamu příkazů místní nabídky, postupujte podle kroků 1 a vytvořte samostatný objekt makra, který bude obsahovat jenom příkazy podnabídky, jak je znázorněno na následujícím obrázku:

Snímek obrazovky s makrem v Accessu se dvěma podmakry

Potom opakujte krok 1 a definujte příkazy pro objekt nabídky vyšší úrovně. Podnabídku přidejte jako položku v objektu makra vyšší úrovně pomocí akce makra PřidatNabídku . Následující obrázek ukazuje objekt makra pro nabídku, která obsahuje podnabídku. Třetí makro v tomto příkladu objektu makra vytvoří podnabídku exportovat do... (mcrShortcutSubMenuCommands).

Snímek obrazovky s makrem aplikace Access se čtyřmi podmakry

Následující obrázek znázorňuje výslednou místní nabídku s podnabídkou:

Snímek obrazovky s místní nabídkou a podnabídkou

Pomocí akcí makra PřidatNabídku v objektech maker v jednotlivých úrovních nabídky můžete vytvořit více úrovní podnabídek. Pro každou akci PřidatNabídku zadejte hodnotu pro argument název nabídky , jinak se podnabídka v nabídce vyšší úrovně zobrazí jako prázdný řádek.

Podmínky výrazu makra, které se používají v blocích if/then/else , jsou podporované jenom v nabídce na nejvyšší úrovni. Jinými slovy, výraz podmínky v objektu makra nabídky můžete použít k určení, jestli se má určitá nabídka nebo místní nabídka Zobrazit, ale jenom v nabídkách na nejvyšší úrovni. Výrazy podmínek se nedají použít k zobrazení nebo skrytí příkazů nebo podnabídek v nabídkách. Výraz podmínky můžete také použít ke skrytí nebo zobrazení vlastní místní nabídky nebo globální místní nabídky.

Volitelně může být makro nabídky, které vytvoříte v kroku 2, součástí objektu makra. Pokud máte třeba několik místních nabídek pro různé objekty nebo ovládací prvky, můžete vytvořit jediný objekt makra, který bude obsahovat všechna potřebná makra nabídky. Nezapomeňte pro každé submakro použít jedinečný název. V kroku 3 použijte následující zápis, který odkazuje na makro: MacroObjectName. subnázev_makra. Třeba mcrAddShortcutMenus. AddMenu2.

Začátek stránky

Vytvoření vlastních místních nabídek v aplikaci Access 2007

Okno s návrhem makra se v Accessu 2007 ve srovnání s novější verzí liší, takže v případě, že používáte Access 2007, rozbalíte následující části.

V tomto kroku vytvoříte skupinu maker, jejíž každé makro bude samostatný příkaz v místní nabídce.

Co je skupina maker?

Skupina maker je jeden objekt makra, který obsahuje nejméně dvě nezávislá makra. Jednotlivá makra jsou označena zadáním názvu pro každé makro ve sloupci názvy maker. Na následujícím obrázku je Macro3 skupina maker. NotFoundMsg a FoundMsg jsou jednotlivá makra ve skupině, každé makro sestávající ze dvou akcí makra.

Příklad skupiny maker

Poznámka: Ve výchozím nastavení je sloupec název makra skrytý. Pokud chcete zobrazit sloupec název makra , klikněte na kartě Návrh ve skupině Zobrazit či skrýt na tlačítko Názvy maker.

  1. Na kartě Vytvoření klikněte ve skupině Makra a kód na tlačítko Makro. Pokud není tento příkaz k dispozici, klikněte na šipku pod tlačítkem Modul nebo pod tlačítkem Modul třídy a potom klikněte na položku Makro.

  2. Na kartě Návrh klikněte ve skupině Zobrazit nebo skrýt na tlačítko Názvy maker a zobrazte tak sloupec název makra .

  3. Pro každý příkaz, který chcete použít ve vlastní místní nabídce:

    • Do sloupce název makra zadejte text, který se má zobrazit v místní nabídce (například tisk sestavy nebo uložení).

      1. Poznámka: Pokud chcete vytvořit přístupovou klávesu, abyste mohli vybrat příkaz pomocí klávesnice, zadejte do pole název příkazu znak ampersand (&) před písmeno, které chcete použít (například "&Save"). Tento dopis bude v nabídce podtržený.

    • Ve sloupci Akce vyberte první akci, kterou chcete provést po kliknutí na příkaz v místní nabídce.

    • Pokud existují další akce, které chcete provést, když vyberete tento příkaz, přidejte ho na další řádky. U každé následné akce nechte buňku název makra prázdnou.

      1. Poznámka: Pokud chcete vytvořit řádek mezi dvěma příkazy nabídky, zadejte do sloupce název makra mezi příslušné příkazy nabídky.

  4. Uložte a pojmenujte makro, třeba mcrShortcutMenuCommands.

Na následujícím obrázku je příklad skupiny maker pro vlastní nabídku nebo místní nabídku.

A menu macro group in Design view

Tento krok vypadá jako nadbytečných, ale pokud chcete vytvořit místní nabídku ze skupiny maker, kterou jste vytvořili v kroku 1, musíte vytvořit druhé makro, které obsahuje akci makra PřidatNabídku . Toto makro se někdy nazývá "makro nabídky".

  1. Na kartě Vytvoření klikněte ve skupině Makra a kód na tlačítko Makro. Pokud není tento příkaz k dispozici, klikněte na šipku pod tlačítkem Modul nebo pod tlačítkem Modul třídy a potom klikněte na položku Makro.

  2. Na prvním řádku makra vyberte PřidatNabídku v seznamu akcí .

  3. V části argumenty akcezadejte do pole název nabídky název nabídky (například příkazy pro sestavy). Tento argument není povinný, ale doporučuje se, když v kroku 3 plánujete přidat nabídku na kartu pásu karet (například kartu Doplňky ve formuláři nebo sestavě). Pokud je nabídka přidána jako místní nabídka v kroku 3, je argument název nabídky ignorován.

  4. Do pole název makra nabídky zadejte název makra, které jste vytvořili v kroku 1.

  5. Uložte a pojmenujte makro, třeba mcrAddShortcutMenu.

Na následujícím obrázku je příklad makra nabídky, které vytvoří nabídku, kterou jsme vytvořili v kroku 1.

A menu macro in Design view

Podle toho, kde se má nabídka Zobrazit, použijte některý z následujících postupů.

  • Přidání nabídky na kartu Doplňky ve formuláři nebo sestavě

    Tento postup použijte, pokud chcete, aby se nabídka zobrazila na kartě Doplňky pro určitý formulář nebo sestavu, jak je znázorněno na následujícím obrázku:

    Add-Ins tab containing a custom menu

    1. V navigačním podokně klikněte pravým tlačítkem myši na formulář nebo sestavu, kde se má nabídka Zobrazit, a potom klikněte na příkaz návrhové zobrazení.

    2. Na kartě Návrh ve skupině Zobrazit nebo skrýt klikněte na Seznam vlastností.

    3. Výběrem možnosti formulář nebo Sestava v horní části podokna úloh seznam vlastností vyberte celý objekt.

    4. Na kartě jiné v seznamu vlastností zadejte do pole vlastnosti místní nabídky název makra, které jste vytvořili v kroku 2 (v tomto příkladu "mcrAddShortcutMenu").

      Při příštím otevření formuláře nebo sestavy se na pásu karet zobrazí karta Doplňky . Kliknutím na kartu zobrazte nabídku.

      Další informace o způsobech přizpůsobení pásu karet, jako je přidání vlastních karet nebo skrytí výchozích karet, najdete v článku Vytvoření vlastního pásu karet v Accessu.

      Pás karet je součástí Fluent systému Microsoft Office.

  • Přidání nabídky jako místní nabídky pro formulář, sestavu nebo ovládací prvek

    Tento postup použijte, pokud chcete, aby se nabídka zobrazila, když kliknete pravým tlačítkem myši na konkrétní formulář, sestavu nebo ovládací prvek, jak je znázorněno na následujícím obrázku:

    A simple shortcut menu

    1. V navigačním podokně klikněte pravým tlačítkem myši na formulář nebo sestavu, kde se má místní nabídka zobrazovat, a potom klikněte na návrhové zobrazení.

    2. Na kartě Návrh ve skupině Zobrazit nebo skrýt klikněte na Seznam vlastností.

    3. Vyberte ovládací prvek nebo objekt, ke kterému chcete připojit místní nabídku.

      Poznámka: Pokud chcete vybrat celý objekt, vyberte v seznamu v horní části podokna úloh seznam vlastností možnost formulář nebo Sestava .

    4. Na kartě jiné v seznamu vlastností zadejte do pole vlastností řádek místní nabídky název makra, které jste vytvořili v kroku 2 (v tomto příkladu "mcrAddShortcutMenu").

  • Přidání nabídky jako globální místní nabídky

    Tento postup nahradí všechny výchozí místní nabídky v aktuální databázi. Vlastní místní nabídky, které jste připojili ke konkrétním formulářům, sestavám nebo ovládacím prvkům, nebudou ovlivněny.

    1. Klikněte na tlačítko Microsoft Office a potom klikněte na Možnosti aplikace Access.

    2. V dialogovém okně Možnosti aplikace Access klikněte na Aktuální databáze.

    3. V části Možnosti pásu karet a panelu nástrojůzadejte do pole místní řádek nabídek název makra, které jste vytvořili v kroku 2 (v tomto příkladu "mcrAddShortcutMenu").

  • Vlastní místní nabídky nahrazují výchozí místní nabídky pro objekty, ke kterým jsou připojené. Pokud chcete, aby se v těchto nabídkách používaly některé příkazy pro Access, použijte k vložení příkazů do skupin maker v nabídkách akce SpustitPříkaz .

  • Vlastní místní nabídka připojená k ovládacímu prvku nahrazuje všechny další vlastní místní nabídky, které jsou definované v databázi. Vlastní místní nabídka připojená k formuláři nebo sestavě nahrazuje vlastní globální místní nabídku.

  • Když zadáte makro nabídky pro formulář nebo sestavu nebo databázi, Access spustí toto makro nabídky při otevření formuláře, sestavy nebo databáze. Pokud provedete změny v makru nabídky nebo ve skupině maker, která definuje jeho příkazy v otevřeném formuláři, sestavě nebo databázi, musíte zavřít formulář, sestavu nebo databázi a znovu ji otevřít, aby se změny projevily.

  • Pokud chcete vytvořit Podnabídka, použijte krok 1 a vytvořte samostatnou skupinu maker, která bude obsahovat jenom příkazy podnabídky. Potom opakujte krok 1 a definujte příkazy nabídky vyšší úrovně. Příkaz přidejte jako položku ve skupině maker na vyšší úrovni pomocí akce makra PřidatNabídku . Následující obrázek znázorňuje skupinu maker pro nabídku, která obsahuje podnabídku, a zobrazí výslednou místní nabídku. Třetí řádek ve skupině makro vytvoří podnabídku exportovat do... (mcrSubMenu).

    A shortcut menu that contains a submenu

    Pomocí akcí PřidatNabídku ve skupinách maker jednotlivých úrovní nabídky můžete vytvořit více úrovní podnabídek. Pro každou akci PřidatNabídku zadejte hodnotu pro argument název nabídky , jinak se podnabídka v nabídce vyšší úrovně zobrazí jako prázdný řádek.

  • Podmínky pro makro jsou podporovány pouze v makru na nejvyšší úrovni. Jinak řečeno: v makru nabídky můžete použít podmínku pro určení, jestli se má určitá nabídka nebo místní nabídka Zobrazit, ale jenom v nabídkách na nejvyšší úrovni. Podmínky se nedají použít k zobrazení nebo skrytí příkazů nebo podnabídek v nabídkách. Podmínku můžete také použít ke skrytí nebo zobrazení vlastní místní nabídky nebo globální místní nabídky.

  • Volitelně může být makro nabídky, které vytvoříte v kroku 2, součástí skupiny maker. Pokud máte třeba několik místních nabídek pro různé objekty nebo ovládací prvky, můžete vytvořit jediný objekt makra, který bude obsahovat všechna potřebná makra nabídky. Ujistěte se, že je zobrazen sloupec název makra a pro každé makro zadejte jedinečný název. V kroku 3 použijte následující zápis, který odkazuje na makro: macrogroupname. názevmakra. Třeba mcrAddShortcutMenus. AddMenu2.

Začátek stránky

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×