Vytvoření výběrového dotazu

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Výběrový dotaz umožňuje získat jen ta data, která potřebjete pro zobrazení v datovém listu. Tabulka Produkt v horní části následujícího obrázku má víc sloupců, ale pomocí výběrového dotazu můžete získat přehledné zobrazení, které obsahuje jen ty sloupce, které potřebujete.

Zobrazení tabulky a výsledků dotazu vedle sebe.

Můžete taky přidat kritéria pro filtrování počtu vrácených řádků. Třeba najít jen produkty dražší než 1000 Kč.

Tip : Výběrový dotaz se hodí taky pro získání dat z několika souvisejících tabulek, pro seskupení dat nebo pro vypočítání součtů.

V tomto článku si ukážeme, jak vytvořit jednoduchý výběrový dotaz v počítačových databázích a taky v aplikaci pro Access.

Vytvoření výběrového dotazu v počítačové databázi

Například v počítačové databázi s tabulkou produkty, chcete-li zobrazit pouze názvy produktů a ceny pro každý produkt, můžete vytvořit vyberte pomocí Průvodce dotazem: na karta vytvořit, klikněte na Průvodce dotazem a umožňují Průvodce vás provede jednotlivými proces vytvoření a spuštění dotazu.

Pokud ale chcete připojit kritéria ke svému dotazu, použijte návrh dotazu:

  1. Klikněte na Vytvoření > Návrh dotazu.

  2. V dialogovém okně Zobrazit tabulku poklikejte na tabulku produkty > Zavřít.

  3. Přidání polí do návrhové mřížky, poklikejte Název produktu a pole Ceníková cena.

  4. Přidejte v Ceníková cena kritérium do řádku kritérií. Třeba >=1000 pro zobrazení seznamu produktů, které stojí 1000 Kč a víc.

Návrh dotazu s kritériem

  1. Výsledky dotazu zobrazíte kliknutím na Spustit na kartě Návrh.

Výsledky výběrového dotazu s přidanými kritérii

Vytvoření výběrového dotazu v aplikaci pro Access

Vytvoření stejného výběrového dotazu ve webové aplikaci pro Access je podobné. Chce to jen něco málo navíc, aby byly výsledky dotazu vidět v prohlížeči:

  1. Klikněte na Domů > Upřesnit > dotazu.

  2. V políčko Zobrazit tabulku poklikejte produktytabulky > Zavřít.

    Zobrazení návrhu dotazu se zvýrazněnou kartou dotazu

  3. Přidání polí do návrhové mřížky, v dialogovém okně produkty poklikejte Název produktu a Ceníková cena.

  4. Klikněte pravým tlačítkem myši na kartu dotazu > Uložit a dejte vašemu dotazu název.

  5. Pokud chcete zobrazit výsledky dotazu, klikněte pravým tlačítkem myši na kartu dotazu > Zobrazení Datový list.

Aby byly výsledky tohoto dotazu vidět v prohlížeči, musíte přidat zobrazení tohoto dotazu do zdrojové tabulky (tabulka Produkty):

  1. Vyberte tabulky produkty.

Doplnění zobrazení Datový list dotazu do zdrojové tabulky.

  1. Klikněte na ikonu se znaménkem plus, zadejte název zobrazení a vyberte Datový list z rozevíracího seznamu Typ zobrazení.

  2. V rozevíracím seznamu Zdroj záznamů zvolte dotaz, který chcete zobrazit a klikněte na Přidat nové zobrazení.

    Tip : Pokud jste v jednom dotazu použili víc tabulek, můžete toto zobrazení přidat do všech tabulek nebo do libovolné z nich.

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Sdílení Facebook Facebook Twitter Twitter E-mail E-mail

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×