Vytvoření, spuštění, úprava nebo odstranění makra

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Pokud chcete ušetřit čas na často prováděným úkolům, můžete uložit kroky těchto úkolů jako makra. Potom když budete chtít proveďte jednu z těchto zaznamenané úkoly, můžete aktivovat makro k provedení kroků.

Word

Ve Wordu 2016 pro Mac můžete vytvořit makra s klávesovou zkratku, spustit makro a odstranit makro, které už nepotřebujete.

  1. Klikněte na Zobrazení > Makra > Zaznamenat makro.

    Na kartě zobrazení klikněte na tlačítko makro a pak klikněte na záznam makra začít vytvářet makra.
  2. Zadejte název makra nebo přijměte výchozí nastavení, které Word obsahuje.

    Zadejte název makra název makra nebo přijmete obecný název aplikace Microsoft Word.
  3. Tento abyste makro mohli použít u všech nových dokumentů, které vytvoříte, ověřte vybraný Všechny dokumenty (normální) v seznamu Uložit makro do.

  4. Klikněte na klávesovou kombinaci kláves přiřadit makro.

    Word zobrazí dialogové okno Vlastní klávesnice.

  5. Zadejte do pole nového klávesová zkratka: stiskněte kombinaci kláves.

    Word zobrazí příkazu nebo akce makra již byly přiřazeny kombinaci kláves případné po stisknutí kombinace.

    Po stisknutí kombinace kláves Word zobrazí příkazu nebo akce aktuálně přiřazené k této kombinace kláves, pokud existuje.

  6. Pokud přiřazeny kombinace kláves, kterou jste si vybrali, odstraňte ji z pole stiskněte klávesovou zkratku nový a vyberte novou kombinaci kláves.

    Přejděte k dalším krokem po jste našli nepřiřazené kombinace kláves.

    Word identifikuje po stisknutí kombinace kláves, která není dosud nebyly přiřazeny k příkazu nebo akce makra.
  7. Klávesová zkratka použít u všech nových dokumentů, zda Normal.dotm, globální šabloně, je vybraná v seznamu změny uložit do.

    Vyberte Normal.dotm mohlo být makro dostupné pro použití u nových dokumentů, které jste vytvořili.
  8. Klikněte na tlačítko Přiřadit.

  9. Až budete chtít záznamu makra, klikněte na OK.

  10. Klikněte příkazy nebo stisknutím klávesy u každého kroku v úkolu.

    Word záznamů myší a stisknutím kláves, ale nezaznamenává text, který vyberete myší. Chcete-li vybrat text při záznamu makra, použijte funkci klávesnice.

  11. Pro ukončení záznamu klikněte na Zobrazení > Makra > Zastavit záznam.

    Klikněte na tlačítko Zastavit záznam v nabídce makra pozastavit záznam makra.

Spuštění makra, stiskněte klávesovou zkratku přiřazenou nebo spuštění makra ze seznamu makra.

  1. Klikněte na Zobrazení > Makra > Zobrazit makra.

    Klikněte na Zobrazit makra prohlížení a úpravy makra přidružený k aktuálnímu dokumentu.
  2. V seznamu název makra vyberte makro, které chcete spustit.

  3. Klikněte na Spustit.

    Po výběru makra název makra, klikněte na spustit ho spusťte.

  1. Klikněte na Zobrazení > Makra > Zobrazit makra.

    Klikněte na Zobrazit makra prohlížení a úpravy makra přidružený k aktuálnímu dokumentu.
  2. Ověřte, že umístění určeného makra v zahrnuje umístění makra, které chcete odstranit.

    Vyberte umístění makra, které si přejete zobrazit ze seznamu Prohledat seznam.

    Seznam bude obsahovat dokument, který se otevře v aktuálním okně, jakož i globální šablony a Word příkazy.

  3. Do pole název makra vyberte makro, které chcete odstranit a klikněte na znaménko mínus pod seznamem.

    Vyberte makro, které chcete odstranit a klikněte na znaménko mínus klikněte v seznamu.
  4. Když Word zobrazí výzvu k potvrzení odstranění makra, klikněte na Ano.

Excel

V Excelu 2016 pro Mac můžete vytvořit makra s klávesovou zkratku, spustit makro a odstranit makro, které už nepotřebujete.

Během zaznamenávání makra záznamy záznam makra všechny potřebné kroky potřebná k dokončení akce, které chcete makro provádět. Tento postup můžete zahrnout psát text nebo čísla, kliknutím na buňky nebo příkazy na pásu karet a v nabídkách, formátování, výběr buněk, řádků nebo sloupců a tažením myší vyberte buňky v tabulce.

Poznámka : Příkazy pro záznam, vytvoření nebo odstranění makra, jakož i další funkce, jsou rovněž k dispozici na kartě Vývojář na pásu karet. Další informace o používání karty Vývojář naleznete v tématu použití karta Vývojář k vytvoření nebo odstranění makra v Excelu 2016 pro Mac.

  1. Vyberte Nástroje > makra > Nový záznam.

    Vyberte nástroje, poté makra a záznam nového makra:

  2. Do pole Název makra zadejte název makra.

    Zadejte makra název, umístění a klávesovou zkratkou

  3. Chcete-li vytvořit klávesovou zkratku makra, zadejte do pole ALT + Cmd písmeno.

  4. V rozevíracím seznamu vyberte umístění pro makro.

    Uložení makra

    Postup

    V dokumentu, který vytváříte v makro

    This Workbook

    do všech otevřených dokumentů

    New Workbook

    tak, aby bylo k dispozici při každém použití Excelu

    Osobní sešit maker

  5. (Volitelné) Přidáte popis makra.

  6. Až budete připraveni k záznamu, klikněte na OK.

  7. Klikněte příkazy nebo stisknutím klávesy u každého kroku v úkolu.

  8. Nahrávání ukončíte vyberte Nástroje > makra > Zastavit záznam. (Tento krok se nezaznamenávají v makru.)

    Vyberte zastavit záznam

Spuštění makra, stiskněte klávesovou zkratku přiřazenou nebo spuštění makra z dialogového okna makra.

  1. Na kartě Zobrazení klikněte na Zobrazit makra.

  2. Klikněte na tlačítko makra v místní nabídku a vyberte možnost Tento sešit.

  3. Vyberte makro ze seznamu a klikněte na Spustit.

    V Excelu pro Mac makra dialogového okna

  1. Vyberte Nástroje > makra > makra.

    Vyberte makro a pak vyberte makra

  2. Vyberte makro, které chcete odstranit a stiskněte klávesu mínus.

    Vyberte název makra a potom vyberte znaménko minus

  3. Zobrazí se potvrzovací zpráva. Klikněte na Ano potvrďte odstranění.

    Potvrzení odstranění

Můžete taky odstranit makro na kartě Vývojář.

  1. Na kartě Vývojář klikněte na Makra.

  2. V seznamu klikněte na makro, které chcete odstranit, a pak klikněte na tlačítko pro odstranění.

    Vyberte makro a kliknutím na znaménko mínus, můžete ho odstranit

Word

Pokud chcete některý opakovaný úkol automatizovat, můžete ve Wordu rychle vytvořit makro. Můžete taky použít Visual Basic Editor a napsat vlastní skript (makro) v jazyce Microsoft Visual Basic for Applications, případně zkopírovat celé makro nebo jeho část do nového makra.

Během zaznamenávání makra se zaznamenávají všechny potřebné kroky potřebné k dokončení akce, které chcete makro provádět. Navigace zpět na kartě záznam není však součástí zaznamenané kroky.

  1. Na kartě Developer (Vývojář) klikněte v části Visual Basic na Record (Nahrát).

    Karta Vývojář ve Wordu, skupiny Visual Basic

    Pokud není karta Developer k dispozici

    1. Na pravé straně na pásu karet klikněte na Místní nabídka akce a pak klikněte na Ribbon Preferences.

    2. V části Customize (Přizpůsobit) zaškrtněte políčko Developer.

  2. Do pole Název makra zadejte název makra.

  3. V místní nabídce Store macro in (Uložit makro do) vyberte jednu z těchto možností:

    Pokud chcete makro uložit

    Klikněte na

    do dokumentu, ve kterém makro vytváříte

    [název dokumentu] (document) ([název dokumentu] (dokument))

    do všech otevřených dokumentů

    All Documents (Normal) (Všechny dokumenty (normální))

  4. Klikněte na tlačítko OK a proveďte akce, které chcete zaznamenat.

  5. Na kartě Developer klikněte v části Visual Basic na Stop (Zastavit).

Makro můžete vytvořit v integrovaném Visual Basic Editoru.

  1. Na kartě Developer klikněte v části Visual Basic na Editor.

    Karta Vývojář ve Wordu, skupiny Visual Basic

    Pokud není karta Developer k dispozici

    1. Na pravé straně na pásu karet klikněte na Místní nabídka akce a pak klikněte na Ribbon Preferences.

    2. V části Customize zaškrtněte políčko Developer.

  2. Pokud potřebujete vložit modul, klikněte ve Visual Basic Editoru na příkaz Module (Modul) v nabídce Insert (Vložit).

  3. V okně kódu modulu zadejte nebo vložte kód makra, který chcete použít.

  4. Po dokončení klikněte v nabídce Word na Close and Return to Microsoft Word (Zavřít a vrátit se do Microsoft Wordu).

  1. Na kartě Developer klikněte v části Visual Basic na Macros.

    Karta Vývojář ve Wordu, skupiny Visual Basic

    Pokud není karta Developer k dispozici

    1. Na pravé straně na pásu karet klikněte na Místní nabídka akce a pak klikněte na Ribbon Preferences.

    2. V části Customize zaškrtněte políčko Developer.

  2. V seznamu klikněte na makro, které chcete spustit, a pak klikněte na Run (Spustit).

K úpravě maker se používá Visual Basic Editor.

  1. Na kartě Developer klikněte v části Visual Basic na Macros.

    Karta Vývojář ve Wordu, skupiny Visual Basic

    Pokud není karta Developer k dispozici

    1. Na pravé straně na pásu karet klikněte na Místní nabídka akce a pak klikněte na Ribbon Preferences.

    2. V části Customize zaškrtněte políčko Developer.

  2. V seznamu klikněte na makro, které chcete upravit, a pak klikněte na Edit (Upravit).

    Spustí se Visual Basic Editor.

  3. Proveďte požadované změny.

  4. Po dokončení klikněte v nabídce Word na Close and Return to Microsoft Word.

  1. Na kartě Developer klikněte v části Visual Basic na Macros.

    Karta Vývojář ve Wordu, skupiny Visual Basic

    Pokud není karta Developer k dispozici

    1. Na pravé straně na pásu karet klikněte na Místní nabídka akce a pak klikněte na Ribbon Preferences.

    2. V části Customize zaškrtněte políčko Developer.

  2. V seznamu klikněte na makro, které chcete zkopírovat, a pak klikněte na Edit.

    Spustí se Visual Basic Editor.

  3. V okně s kódem v editoru Visual Basicu vyberte řádky makra, které chcete zkopírovat.

    Tip : Pokud chcete kopírovat celé makro, musí být součástí výběru řádky Sub a End Sub.

  4. V nabídce Edit (Úpravy) klikněte na příkaz Copy (Kopírovat).

  5. V poli Project (Projekt) v okně s kódem klikněte na modul, do kterého chcete kód umístit.

  6. V nabídce Edit (Úpravy) klikněte na příkaz Paste (Vložit).

  1. Na kartě Developer klikněte v části Visual Basic na Macros.

    Karta Vývojář ve Wordu, skupiny Visual Basic

    Pokud není karta Developer k dispozici

    1. Na pravé straně na pásu karet klikněte na Místní nabídka akce a pak klikněte na Ribbon Preferences.

    2. V části Customize zaškrtněte políčko Developer.

  2. V seznamu klikněte na makro, které chcete odstranit, a pak klikněte na Delete (Odstranit).

PowerPoint

Pokud chcete automatizovat opakované úkoly, můžete Visual Basic for Applications vytvoření Makro v aplikaci PowerPoint.

Makro můžete vytvořit v integrovaném Visual Basic Editoru.

  1. Na kartě Developer (Vývojář) klikněte v části Visual Basic na Editor.

    Karta Vývojář v PowerPointu na kartě Skupina Visual Basic

    Pokud není karta Developer k dispozici

    1. Na pravé straně na pásu karet klikněte na Místní nabídka akce a pak klikněte na Ribbon Preferences.

    2. V části Customize zaškrtněte políčko Developer.

  2. Pokud potřebujete vložit modul, klikněte ve Visual Basic Editoru na příkaz Module (Modul) v nabídce Insert (Vložit).

  3. V okně kódu modulu zadejte nebo vložte kód makra, který chcete použít.

  4. Po dokončení klikněte v nabídce PowerPoint na Close and Return to Microsoft PowerPoint (Zavřít a vrátit se do Microsoft PowerPointu).

  1. Na kartě Developer klikněte v části Visual Basic na Macros.

    Karta Vývojář v PowerPointu na kartě Skupina Visual Basic

    Pokud není karta Developer k dispozici

    1. Na pravé straně na pásu karet klikněte na Místní nabídka akce a pak klikněte na Ribbon Preferences.

    2. V části Customize zaškrtněte políčko Developer.

  2. V seznamu klikněte na makro, které chcete spustit, a pak klikněte na Run (Spustit).

K úpravě maker se používá Visual Basic Editor.

  1. Na kartě Developer klikněte v části Visual Basic na Macros.

    Karta Vývojář v PowerPointu na kartě Skupina Visual Basic

    Pokud není karta Developer k dispozici

    1. Na pravé straně na pásu karet klikněte na Místní nabídka akce a pak klikněte na Ribbon Preferences.

    2. V části Customize zaškrtněte políčko Developer.

  2. V seznamu klikněte na makro, které chcete upravit, a pak klikněte na Edit (Upravit).

    Spustí se Visual Basic Editor.

  3. Proveďte požadované změny.

  4. Po dokončení klikněte v nabídce PowerPoint na Close and Return to Microsoft PowerPoint (Zavřít a vrátit se do Microsoft PowerPointu).

  1. Na kartě Developer klikněte v části Visual Basic na Macros.

    Karta Vývojář v PowerPointu na kartě Skupina Visual Basic

    Pokud není karta Developer k dispozici

    1. Na pravé straně na pásu karet klikněte na Místní nabídka akce a pak klikněte na Ribbon Preferences.

    2. V části Customize zaškrtněte políčko Developer.

  2. V seznamu klikněte na makro, které chcete zkopírovat, a pak klikněte na Edit.

    Spustí se Visual Basic Editor.

  3. V okně s kódem v editoru Visual Basicu vyberte řádky makra, které chcete zkopírovat.

    Tip : Pokud chcete kopírovat celé makro, musí být součástí výběru řádky Sub a End Sub.

  4. V nabídce Edit (Úpravy) klikněte na příkaz Copy (Kopírovat).

  5. V poli Project (Projekt) v okně s kódem klikněte na modul, do kterého chcete kód umístit.

  6. V nabídce Edit (Úpravy) klikněte na příkaz Paste (Vložit).

  1. Na kartě Developer klikněte v části Visual Basic na Macros.

    Karta Vývojář v PowerPointu na kartě Skupina Visual Basic

    Pokud není karta Developer k dispozici

    1. Na pravé straně na pásu karet klikněte na Místní nabídka akce a pak klikněte na Ribbon Preferences.

    2. V části Customize zaškrtněte políčko Developer.

  2. V seznamu klikněte na makro, které chcete odstranit, a pak klikněte na Delete (Odstranit).

Excel

Pokud chcete některý opakovaný úkol automatizovat, můžete v Excelu rychle vytvořit makro. Můžete taky použít Visual Basic Editor a napsat vlastní skript (makro) v jazyce Microsoft Visual Basic for Applications, případně zkopírovat celé makro nebo jeho část do nového makra.

Zaznamenají se všechny kroky potřebné k provedení akcí, které má makro vykonávat. Navigace zpátky na kartu a zastavení nahrávání se však nenahraje.

  1. Na kartě Developer (Vývojář) klikněte v části Visual Basic na Record (Nahrát).

    Karta Vývojář v Excelu na kartě Skupina Visual Basic

    Pokud není karta Developer k dispozici

    1. Na pravé straně na pásu karet klikněte na Místní nabídka akce a pak klikněte na Ribbon Preferences.

    2. V části Customize (Přizpůsobit) zaškrtněte políčko Developer.

  2. Do pole Název makra zadejte název makra.

    Tip : Pokud chcete pro makro vytvořit klávesovou zkratku, zadejte nějaké písmeno do pole Option+Cmd+.

  3. V místní nabídce Store macro in (Uložit makro do) vyberte jednu z těchto možností:

    Pokud chcete makro uložit

    Klikněte na

    do dokumentu, ve kterém makro vytváříte

    This Workbook

    do všech otevřených dokumentů

    New Workbook

    tak, aby bylo k dispozici při každém použití Excelu

    Personal Macro Workbook

    Osobním sešitě maker je umístěn v uživatelé / uživatelskéjméno/knihovně/aplikace podporovat / v aplikaci Microsoft Excel.

  4. Klikněte na tlačítko OK a proveďte akce, které chcete zaznamenat.

  5. Na kartě Developer klikněte v části Visual Basic znovu na Record.

Makro můžete vytvořit v integrovaném Visual Basic Editoru.

  1. Na kartě Developer klikněte v části Visual Basic na Editor.

    Karta Vývojář v Excelu na kartě Skupina Visual Basic

    Pokud není karta Developer k dispozici

    1. Na pravé straně na pásu karet klikněte na Místní nabídka akce a pak klikněte na Ribbon Preferences.

    2. V části Customize zaškrtněte políčko Developer.

  2. Pokud potřebujete vložit modul, klikněte ve Visual Basic Editoru na příkaz Module (Modul) v nabídce Insert (Vložit).

  3. V okně kódu modulu zadejte nebo vložte kód makra, který chcete použít.

  4. Po dokončení klikněte v nabídce Excel na Close and Return to Microsoft Excel (Zavřít a vrátit se do Microsoft Excelu).

  1. Na kartě Developer klikněte v části Visual Basic na Macros.

    Karta Vývojář v Excelu na kartě Skupina Visual Basic

    Pokud není karta Developer k dispozici

    1. Na pravé straně na pásu karet klikněte na Místní nabídka akce a pak klikněte na Ribbon Preferences.

    2. V části Customize zaškrtněte políčko Developer.

  2. V seznamu klikněte na makro, které chcete spustit, a pak klikněte na Run (Spustit).

    Tip : Pokud chcete makro spustit pomocí klávesové zkratky, stiskněte klávesy OPTION+ COMMAND (PŘÍKAZ) +písmeno, které jste zadali při vytváření klávesové zkratky.

K úpravě maker se používá Visual Basic Editor.

  1. Na kartě Developer klikněte v části Visual Basic na Macros.

    Karta Vývojář v Excelu na kartě Skupina Visual Basic

    Pokud není karta Developer k dispozici

    1. Na pravé straně na pásu karet klikněte na Místní nabídka akce a pak klikněte na Ribbon Preferences.

    2. V části Customize zaškrtněte políčko Developer.

  2. V seznamu klikněte na makro, které chcete upravit, a pak klikněte na Edit (Upravit).

    Spustí se Visual Basic Editor.

  3. Proveďte požadované změny.

  4. Po dokončení klikněte v nabídce Excel na Close and Return to Microsoft Excel.

Po dokončení tohoto postupu se makro spustí pokaždé, když otevřete sešit, který ho obsahuje.

  1. Na kartě Developer klikněte v části Visual Basic na Record.

    Karta Vývojář v Excelu na kartě Skupina Visual Basic

    Pokud není karta Developer k dispozici

    1. Na pravé straně na pásu karet klikněte na Místní nabídka akce a pak klikněte na Ribbon Preferences.

    2. V části Customize zaškrtněte políčko Developer.

  2. Do pole Název makra zadejte Automatické_otevření.

  3. V místní nabídce Store macro in (Uložit makro do) vyberte jednu z těchto možností:

    Pokud chcete makro uložit

    Klikněte na

    do dokumentu, ve kterém makro vytváříte

    This Workbook

    do všech otevřených dokumentů

    New Workbook

    tak, aby bylo k dispozici při každém použití Excelu

    Personal Macro Workbook

  4. Klikněte na tlačítko OK a proveďte akce, které chcete zaznamenat.

  5. Na kartě Developer klikněte v části Visual Basic znovu na Record.

  6. V nabídce File (Soubor) klikněte na příkaz Save As (Uložit jako).

  7. V místní nabídce Format (Formát) klikněte na Excel Macro-Enabled Workbook (.xlsm) (Sešit Excelu s podporou maker (*.xlsm)) a potom klikněte na Save (Uložit).

  1. Na kartě Developer klikněte v části Visual Basic na Macros.

    Karta Vývojář v Excelu na kartě Skupina Visual Basic

    Pokud není karta Developer k dispozici

    1. Na pravé straně na pásu karet klikněte na Místní nabídka akce a pak klikněte na Ribbon Preferences.

    2. V části Customize zaškrtněte políčko Developer.

  2. V seznamu klikněte na makro, které chcete zkopírovat, a pak klikněte na Edit.

    Spustí se Visual Basic Editor.

  3. V okně s kódem v editoru Visual Basicu vyberte řádky makra, které chcete zkopírovat.

    Tip : Pokud chcete kopírovat celé makro, musí být součástí výběru řádky Sub a End Sub.

  4. V nabídce Edit (Úpravy) klikněte na příkaz Copy (Kopírovat).

  5. V poli Project (Projekt) v okně s kódem klikněte na modul, do kterého chcete kód umístit.

  6. V nabídce Edit (Úpravy) klikněte na příkaz Paste (Vložit).

  1. Na kartě Developer klikněte v části Visual Basic na Macros.

    Karta Vývojář v Excelu na kartě Skupina Visual Basic

    Pokud není karta Developer k dispozici

    1. Na pravé straně na pásu karet klikněte na Místní nabídka akce a pak klikněte na Ribbon Preferences.

    2. V části Customize zaškrtněte políčko Developer.

  2. V seznamu klikněte na makro, které chcete odstranit, a pak klikněte na Delete (Odstranit).

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×