Vytvoření přehledu (seskupení) dat na listu

Chcete-li seskupit a shrnout seznam dat, můžete vytvořit přehled až s osmi úrovněmi, pro každou skupinu jednu. Každá vnitřní úroveň představovaná vyšším číslem v Symboly přehledu zobrazuje Podrobná data pro předchozí vnější úroveň, kterou v symbolech přehledu představuje nižší číslo. Přehled je možné použít k rychlému zobrazení souhrnných řádků či sloupců nebo k zobrazení podrobností u jednotlivých skupin. Můžete vytvořit přehled řádků (jak je ukázáno v příkladu níže), přehled sloupců nebo přehled řádků i sloupců.

Seznam s přehledem
Přehled vytvořený z řádků obsahujících data o prodeji, která jsou seskupená podle geografických oblastí a měsíců. Zobrazuje se v něm několik souhrnných řádků a řádků podrobností.

1.  Pokud chcete zobrazit řádky určité úrovně, klikněte na příslušný symbol přehledu jedna, dvě, tři .

2.  Úroveň jedna obsahuje celkový prodej pro všechny řádky s podrobnostmi.

3.  Úroveň dvě obsahuje celkový prodej za jednotlivé měsíce v každé oblasti.

4.  Úroveň tři obsahuje řádky s podrobnostmi (v tomto případě řádky 11 až 13).

5.  Chcete-li rozbalit nebo sbalit data v přehledu, klikněte na znaménka symbolů přehledu plus a mínus .

Co chcete udělat?

Vytvořit přehled z řádků

Vytvořit přehled ze sloupců

Zobrazit nebo skrýt data přehledu

Přizpůsobit si přehled pomocí stylů

Kopírovat data přehledu

Skrýt nebo odebrat přehled

Vytvořit souhrnnou sestavu s grafem

Vytvoření přehledu z řádků

  1. Každý sloupec dat, ze kterých chcete vytvořit přehled, musí mít v prvním řádku popisek, musí obsahovat v jednotlivých sloupcích podobné údaje a v dané oblasti se nesmí vyskytovat žádné prázdné řádky ani sloupce.

  2. Zajistěte, aby řádky s podrobnostmi měly i souhrnný řádek – mezisoučet. Proveďte jednu z následujících akcí:

    Vložení souhrnných řádků pomocí příkazu Souhrn    

    • Příkaz Souhrn vloží funkci SUBTOTAL bezprostředně pod nebo nad každou skupinu řádků podrobností a automaticky vytvoří přehled. Další informace o používání funkce SUBTOTAL naleznete v tématu SUBTOTAL (funkce).

      Vložení vlastních souhrnných řádků    

    • Vložte vlastní souhrnné řádky se vzorci přímo pod nebo nad každou skupinu řádků podrobností. Například pod (nebo nad) řádky s údaji o prodeji v březnu a dubnu pomocí funkce SUMA získáte mezisoučet údajů o prodeji za tyto měsíce. V tabulce dále v tomto článku je uveden příklad tohoto postupu.

  3. Určete, jestli mají být souhrnné řádky umístěné pod nebo nad podrobnými. Na kartě Data klikněte ve skupině Přehled na ikonu pro otevření dialogového okna Přehled.
    Kliknutí na ikonu pro otevření dialogového okna ve skupině Přehled

  4. Pokud jsou souhrnné řádky nad podrobnými řádky, zrušte zaškrtnutí políčka Souhrnné řádky pod podrobné. Jinak políčko ponechte, jak je.

  5. Vytvořte přehled svých dat. Proveďte jednu z následujících akcí:

    Automatické vytvoření přehledu dat

    1. V případě potřeby vyberte buňku v oblasti buněk, pro které chcete vytvořit přehled.

    2. Na kartě Data klikněte ve skupině Přehled na šipku pod tlačítkem Seskupit a potom na tlačítko Automatický přehled.

      Kliknutí na šipku pod Seskupit a potom na Automatický přehled

    Ruční vytvoření přehledu dat

    Důležité informace: Při ručním seskupování úrovní přehledu je nejlepší mít zobrazená všechna data, abyste tak předešli nesprávnému seskupení řádků.

    1. Vytvořte přehled vnější skupiny.

      Jak vytvořit přehled vnější skupiny

      1. Vyberte všechny podřízené souhrnné řádky a s nimi související podrobné řádky.

        V níže uvedených datech například řádek 6 obsahuje mezisoučet pro řádky 2 až 5, řádek 10 mezisoučet pro řádky 7 až 9 a řádek 11 obsahuje celkový součet. Chcete-li seskupit všechna podrobná data pro řádek 11, vyberte řádky 2 až 10.

         

        A

        B

        C

        1

        Oblast

        Měsíc

        Prodej

        2

        Východ

        Březen

        9 647 Kč

        3

        Východ

        Březen

        4 101 Kč

        4

        Východ

        Březen

        7 115 Kč

        5

        Východ

        Březen

        2 957 Kč

        6

        Východ

        Souhrn za březen

        23 820 Kč

        7

        Východ

        Duben

        4 257 Kč

        8

        Východ

        Duben

        1 829 Kč

        9

        Východ

        Duben

        6 550 Kč

        10

        Východ

        Souhrn za duben

        12 636 Kč

        11

        Souhrn za východ

        36 456 Kč

        Důležité informace: Do výběru nezahrnujte souhrnný řádek (řádek 11).

      2. Na kartě Data ve skupině Přehled klikněte na Seskupit, klikněte na Řádky a potom klikněte na OK.

        Kliknutí na Řádky a potom na OK

        Na obrazovce se vedle skupiny zobrazí symboly přehledu.

    2. Můžete také vytvořit přehled vnitřní vnořené skupiny – podrobných řádků pro daný oddíl dat.

      Vytvoření přehledu vnitřní vnořené skupiny (skupiny podrobných řádků)

      1. Pro každou vnitřní vnořenou skupinu vyberte řádky podrobností sousedící s řádkem, který obsahuje souhrnný řádek.

        V níže uvedeném příkladu pro seskupení řádků 2 až 5, jejichž souhrnným řádkem je řádek, 6 vyberte řádky 2 až 5. Pro seskupení řádků 7 až 9, jejichž souhrnným řádkem je 10, vyberte řádky 7 až 9.

         

        A

        B

        C

        1

        Oblast

        Měsíc

        Prodej

        2

        Východ

        Březen

        9 647 Kč

        3

        Východ

        Březen

        4 101 Kč

        4

        Východ

        Březen

        7 115 Kč

        5

        Východ

        Březen

        2 957 Kč

        6

        Východ

        Souhrn za březen

        23 820 Kč

        7

        Východ

        Duben

        4 257 Kč

        8

        Východ

        Duben

        1 829 Kč

        9

        Východ

        Duben

        6 550 Kč

        10

        Východ

        Souhrn za duben

        12 636 Kč

        11

        Souhrn za východ

        36 456 Kč

        Důležité informace: Do výběru nezahrnujte souhrnný řádek.

      2. Na kartě Data klikněte ve skupině Přehled na tlačítko Seskupit.

        Kliknutí na Seskupit na kartě Data

        Na obrazovce se vedle skupiny zobrazí symboly přehledu.

      3. Pokračujte ve výběru a seskupování vnitřních řádků, dokud nevytvoříte všechny úrovně, které chcete v přehledu uvést.

      4. Pokud chcete řádky oddělit, vyberte je a potom na kartě Data klikněte ve skupině Přehled na Oddělit.

        Můžete také oddělit části přehledu, ale neodebrat ho přitom celý. Při klikání na jednotlivé značky Značka Plus nebo Značka mínus u skupiny podržte klávesu SHIFT a potom na kartě Data klikněte ve skupině Přehled na Oddělit.

        Důležité informace: Pokud přehled oddělíte, když jsou podrobná data skrytá, může řádek podrobností zůstat skrytý. Data můžete zobrazit přetažením ukazatele myši přes čísla viditelných řádků sousedících se skrytými řádky. Na kartě Domů klikněte ve skupině Buňky na Formát, přejděte na Skrýt a zobrazit a potom klikněte na Zobrazit skryté řádky.

Začátek stránky

Vytvoření přehledu ze sloupců

  1. Každý řádek dat, ze kterých chcete vytvořit přehled, musí mít v prvním sloupci popisek, musí obsahovat v jednotlivých sloupcích podobné údaje a v dané oblasti se nesmí vyskytovat žádné prázdné řádky ani sloupce.

  2. Vložte vlastní souhrnné sloupce se vzorci bezprostředně napravo nebo nalevo od každé skupiny sloupců podrobností. V tabulce uvedené v kroku 4 je znázorněn příklad.

    Poznámka:  Pokud chcete vytvořit přehled dat podle sloupců, je nutné mít souhrnné sloupce, které obsahují vzorce odkazující na buňky v jednotlivých sloupcích podrobností v dané skupině.

  3. Určete, zda je souhrnný sloupec umístěn napravo nebo nalevo od sloupce podrobností. Na kartě Data klikněte ve skupině Přehled na ikonu pro otevření dialogového okna Přehled.

    Jak určit umístění souhrnného sloupce

    1. Na kartě Data klikněte ve skupině Přehled na ikonu pro otevření dialogového okna pro nastavení přehledu.

      Kliknutí na ikonu pro otevření dialogového okna ve skupině Přehled

    2. Chcete-li zadat souhrnný sloupec nalevo od sloupce podrobností, zrušte zaškrtnutí políčka Souhrnné sloupce napravo od podrobných. Chcete-li zadat souhrnný sloupec napravo od sloupce podrobností, zaškrtněte políčko Souhrnné sloupce napravo od podrobných.

    3. Klikněte na tlačítko OK.

  4. Chcete-li vytvořit přehled dat, proveďte jednu z následujících akcí:

    Automatické vytvoření přehledu dat

    1. V případě potřeby vyberte buňku v oblasti.

    2. Na kartě Data klikněte ve skupině Přehled na šipku pod tlačítkem Seskupit a potom na tlačítko Automatický přehled.

    Ruční vytvoření přehledu dat

    Důležité informace: Při ručním seskupování úrovní přehledu je nejlepší mít zobrazená všechna data, abyste tak předešli nesprávnému seskupení sloupců.

    1. Vytvořte přehled vnější skupiny.

      Vytvoření přehledu vnější skupiny (všechny sloupce kromě celkového součtu)

      1. Vyberte všechny podřízené souhrnné sloupce a s nimi související podrobná data.

        V následujícím příkladu obsahuje sloupec E souhrny pro sloupce B až D, sloupec I souhrny pro sloupce F až H a sloupec J celkové souhrny. Chcete-li seskupit všechny podrobnosti do sloupce J, vyberte sloupce B až I.

         

        A

        B

        C

        D

        O

        G

        H

        I

        J

        1

        Oblast

        Leden

        Únor

        Březen

        I.

        Duben

        Květen

        Červen

        II.

        H1

        2

        Východ

        371

        504

        880

        1 755

        186

        653

        229

        1 068

        2 823

        3

        Západ

        192

        185

        143

        520

        773

        419

        365

        1 557

        2 077

        4

        Sever

        447

        469

        429

        1 345

        579

        180

        367

        1 126

        2 471

        5

        Jih

        281

        511

        410

        1 202

        124

        750

        2 000

        1 074

        2 276

        Důležité informace: Nezahrnujte do výběru sloupec J (celkové součty).

      2. Na kartě Data klikněte ve skupině Přehled na tlačítko Seskupit.

        Kliknutí na Seskupit na kartě Data

        Na obrazovce se vedle skupiny zobrazí symboly přehledu.

    2. Případně můžete vytvořit přehled vnitřní vnořené skupiny (jednotlivé skupiny podrobných sloupců).

      Vytvoření přehledu vnitřní vnořené skupiny (skupiny podrobných sloupců)

      1. Pro každou vnitřní vnořenou skupinu vyberte sloupce podrobností sousedící se sloupcem, který obsahuje souhrnný sloupec.

        V níže uvedeném příkladu pro seskupení sloupců B až D, jejichž souhrnným sloupcem je sloupec E, vyberte sloupce B až D. Pro seskupení sloupců F až H, jejichž souhrnným sloupcem je sloupec I, vyberte sloupce F až H.

         

        A

        B

        C

        D

        O

        G

        H

        I

        J

        1

        Oblast

        Leden

        Únor

        Březen

        I.

        Duben

        Květen

        Červen

        II.

        H1

        2

        Východ

        371

        504

        880

        1 755

        186

        653

        229

        1 068

        2 823

        3

        Západ

        192

        185

        143

        520

        773

        419

        365

        1 557

        2 077

        4

        Sever

        447

        469

        429

        1 345

        579

        180

        367

        1 126

        2 471

        5

        Jih

        281

        511

        410

        1 202

        124

        750

        2 000

        1 074

        2 276

        Důležité informace:  Do výběru nezahrnujte souhrnný sloupec pro tuto skupinu.

      2. Na kartě Data klikněte ve skupině Přehled na Seskupit.

        Kliknutí na Seskupit na kartě Data

        Na obrazovce se vedle skupiny zobrazí symboly přehledu.

  5. Pokračujte ve výběru a seskupování vnitřních sloupců, dokud nevytvoříte všechny úrovně, které chcete v přehledu uvést.

  6. Chcete-li sloupce oddělit, vyberte je a potom na kartě Data klikněte ve skupině Přehled na Oddělit.

Kliknutí na Oddělit na kartě Data

Můžete taky oddělit části přehledu, ale neodebrat ho přitom celý. Při klikání na jednotlivé značky Značka Plus nebo Značka mínus u skupiny podržte klávesu SHIFT a potom na kartě Data klikněte ve skupině Přehled na Oddělit.

Pokud přehled oddělíte ve chvíli, kdy jsou podrobná data skrytá, sloupce podrobností zůstanou skryté. Data můžete zobrazit přetažením ukazatele myši přes písmena viditelných sloupců sousedících se skrytými sloupci. Na kartě Domů klikněte ve skupině Buňky na Formát, přejděte na položku Skrýt a zobrazit a klikněte na Zobrazit skryté sloupce.

Začátek stránky

Zobrazení nebo skrytí dat přehledu

  1. Pokud se nezobrazují symboly přehledu jedna, dvě, tři , plus a mínus , klikněte na tlačítko Microsoft Office Obrázek tlačítka Office a potom klikněte na Možnosti aplikace Excel (Excel 2007) NEBO kartu Soubor (ostatní verze) a potom klikněte na Možnosti, klikněte na kategorii Upřesnit a potom v části Zobrazit možnosti pro tento list vyberte list a zaškrtněte políčko Zobrazit symboly přehledu v případě jeho použití.

  2. Klikněte na tlačítko OK.

  3. Proveďte jednu nebo více následujících akcí:

    Zobrazení nebo skrytí podrobných dat pro skupinu    

    • Když chcete podrobná data pro skupinu zobrazit, klikněte na tlačítko plus u skupiny.

    • Když chcete podrobná data pro skupinu skrýt, klikněte na tlačítko mínus u skupiny.

      Rozbalení nebo sbalení celého přehledu na určitou úroveň    

    • V symbolech přehledu jedna, dvě, tři klikněte na požadované číslo úrovně. Podrobnosti na nižších úrovních zůstanou skryty.

      Pokud má přehled například čtyři úrovně, můžete při zobrazování ostatních úrovní skrýt čtvrtou úroveň kliknutím na symbol tři .

      Zobrazení nebo skrytí všech podrobných dat přehledu    

    • Všechny podrobnosti zobrazíte kliknutím na nejnižší úroveň v symbolech přehledu jedna, dvě, tři . Pokud má přehled například tři úrovně, klikněte na symbol úrovně tři .

    • Pokud chcete všechny podrobnosti skrýt, klikněte na jedna .

Začátek stránky

Přizpůsobení přehledu pomocí stylů

Pro přehled vytvořený z řádků používá Microsoft Excel styly, jako třeba úroveň_řádku_1 a úroveň_řádku_2. Pro přehled vytvořený ze sloupců používá Excel styly, jako třeba úroveň_sloupce_1 a úroveň_sloupce_2. K odlišení souhrnných řádků nebo sloupců v datech se ve stylech používá tučný formát, kurzíva a další formáty textu. Změnou způsobu, jakým jsou jednotlivé styly definované, můžete u přehledu použít různé formáty textu a buněk a přizpůsobit si tak vzhled přehledu. Styl můžete u přehledu použít, když přehled vytváříte, ale i potom.

Udělejte jednu nebo víc z těchto věcí:

Automatické použití stylu u souhrnného řádku nebo sloupce    

  1. Na kartě Data klikněte ve skupině Přehled na ikonu pro otevření dialogového okna pro nastavení přehledu.

    Kliknutí na ikonu pro otevření dialogového okna ve skupině Přehled

  2. Zaškrtněte políčko Automaticky přiřadit styl.

Použití stylu u existujícího souhrnného řádku nebo sloupce    

  1. Vyberte buňky, u nichž chcete použít styly přehledu.

  2. Na kartě Data klikněte ve skupině Přehled na ikonu pro otevření dialogového okna pro nastavení přehledu.

    Kliknutí na ikonu pro otevření dialogového okna ve skupině Přehled

  3. Zaškrtněte políčko Automaticky přiřadit styl.

  4. Klikněte na tlačítko Použít styl.

Přehled dat se dá naformátovat taky použitím automatických formátů.

Začátek stránky

Kopírování dat přehledu

  1. Pokud se nezobrazují symboly přehledu jedna, dvě, tři , plus a mínus , klikněte na tlačítko Microsoft Office Obrázek tlačítka Office a potom klikněte na Možnosti aplikace Excel (Excel 2007) NEBO klikněte kartu Soubor (ostatní verze) a potom klikněte na Možnosti, klikněte na kategorii Upřesnit a potom v části Zobrazit možnosti pro tento list vyberte list a zaškrtněte políčko Zobrazit symboly přehledu v případě jeho použití.

  2. Pomocí symbolů přehledu jedna, dvě, tři , mínus a plus skryjte podrobná data, která nechcete kopírovat.

    Další informace najdete v části Zobrazení nebo skrytí dat přehledu.

  3. Vyberte oblast souhrnných řádků.

  4. Na kartě Domů ve skupině Úpravy klikněte na položku Najít a vybrat a poté klikněte na příkaz Přejít na.

    Kliknutí na Najít a vybrat a potom na Přejít na

  5. Klikněte na tlačítko Přejít na – jinak.

  6. Klikněte na přepínač Pouze viditelné buňky.

  7. Klikněte na tlačítko OK a zkopírujte data.

Začátek stránky

Skrytí nebo odebrání přehledu

Poznámka: Skrytím nebo odebráním přehledu nedojde k odstranění žádných dat.

Skrytí přehledu

  • (Excel 2007) Klikněte na tlačítko Microsoft Office Obrázek tlačítka Office a potom klikněte na Možnosti aplikace Excel NEBO klikněte kartu Soubor (ostatní verze) a potom klikněte na Možnosti, klikněte na kategorii Upřesnit a potom v části Zobrazit možnosti pro tento list vyberte list s přehledem, který chcete skrýt, a zrušte zaškrtnutí políčka Zobrazit symboly přehledu v případě jeho použití.

Odebrání přehledu

  1. Klikněte na požadovaný list.

  2. Na kartě Data klikněte ve skupině Přehled na tlačítko Oddělit a klikněte na příkaz Vymazat přehled.

    Kliknutí na Oddělit a potom na Vymazat přehled

    Důležité informace: Odstraníte-li přehled ve chvíli, kdy jsou podrobná data skrytá, mohou zůstat řádky nebo sloupce podrobností skryté. Data můžete zobrazit přetažením ukazatele myši přes čísla viditelných řádků nebo písmena viditelných sloupců sousedících se skrytými řádky a sloupci. Na kartě Domů klikněte ve skupině Buňky na položku Formát, přejděte na položku Skrýt a zobrazit a poté klikněte na příkaz Zobrazit skryté řádky nebo příkaz Zobrazit skryté sloupce.

Začátek stránky

Vytvoření souhrnné sestavy s grafem

Představte si, že chcete vytvořit souhrnnou sestavu dat, ve které se zobrazí pouze souhrny a jejich graf. Obecně můžete postupovat takto:

  1. Vytvoření souhrnné sestavy

    1. Vytvořte přehled dat.

      Další informace naleznete v částech Vytvoření přehledu z řádků nebo Vytvoření přehledu ze sloupců.

    2. Kliknutím na symboly přehledu jedna, dvě, tři , plus a mínus skryjete podrobnosti a zobrazíte pouze souhrny, jak je ukázáno v následujícím příkladu přehledu řádků:

      Seznam s přehledem zobrazující pouze řádky součtů

    3. Další informace najdete v části Zobrazení nebo skrytí dat přehledu.

  2. Zakreslení souhrnné sestavy do grafu

    1. Vyberte data, která chcete zakreslit do grafu.

      Například pro zakreslení pouze souhrnů prodejců Novák a Novotná, nikoli však celkových souhrnů, vyberte buňky A1 až C11, jak je ukázáno v následujícím příkladu.

    2. Vytvořte graf. Například: na kartě Vložit ve skupině Grafy klikněte na možnost Doporučené grafy nebo vyberte jiný typ grafu.

      Pokud například k vytvoření grafu použijete Průvodce grafem, bude výsledek podobný jako v následujícím příkladu.

      Graf vytvořený na základě souhrnných dat

      Když v seznamu dat s přehledem zobrazíte nebo skryjete podrobnosti, graf se taky aktualizuje tak, aby se v něm data zobrazila nebo skryla.

Začátek stránky

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×