Vytvoření nebo spuštění makra

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

V aplikaci Word můžete zautomatizovat častých úkolů: vytváření a spouštění maker. Makro je posloupnost příkazů a instrukcí společně jako jeden příkaz automaticky provádět úkolu.

Pokud chcete ušetřit čas na úkolech, které děláte často, svažte jednotlivé kroky do makra. Nejdřív makro zaznamenejte. Pak ho můžete spustit kliknutím na tlačítko na panelu nástrojů Rychlý přístup nebo stiskem kombinace kláves. Záleží na tom, jak si ho nastavíte.

  1. Klikněte na Zobrazení > Makra > Zaznamenat makro.

    Příkaz Zaznamenat makro

  2. Zadejte název makra.

    Pole Název makra

  3. Abyste tohle makro mohli použít u všech nových dokumentů, které vytvoříte, nezapomeňte v poli Uložit makro v vybrat možnost Všechny dokumenty (Normal.dotm).

    Pole pro výběr místa uložení makra

  4. Pokud chcete makro spouštět kliknutím na tlačítko, klikněte na Tlačítko.

    Kliknutím přiřadíte makro k tlačítku

  5. Klikněte na nové makro (jeho název vypadá podobně jako Normal.NewMacros.<váš název makra>) a klikněte na Přidat.

    Makro a tlačítko Přidat

  6. Klikněte na Změnit.

    Tlačítko Změnit v okně Přizpůsobení panelu nástrojů Rychlý přístup

  7. Zvolte obrázek tlačítka, zadejte požadovaný název a dvakrát klikněte na OK.

    Možnosti tlačítka v okně Tlačítko Změnit

  8. Teď je čas pro záznam kroků. Pro každý krok úkolu klikněte na příkaz nebo stiskněte tlačítko. Word zaznamená vaše kliknutí a stisknutí kláves.

    Poznámka : Při záznamu makra vybírejte text pomocí klávesnice. Výběr provedený pomocí myši makro nezaznamená.

  9. Pro ukončení záznamu klikněte na Zobrazení > Makra > Zastavit záznam.

    Příkaz Zastavit záznam

Tlačítko vašeho makra se zobrazí na panelu nástrojů Rychlý přístup.

Tlačítko makra na panelu nástrojů Rychlý přístup

Kliknutím na tlačítko makro spustíte.

  1. Klikněte na Zobrazení > Makra > Zaznamenat makro.

    Příkaz Zaznamenat makro

  2. Zadejte název makra.

    Pole Název makra

  3. Abyste tohle makro mohli použít u všech nových dokumentů, které vytvoříte, nezapomeňte v poli Uložit makro v vybrat možnost Všechny dokumenty (Normal.dotm).

    Pole pro výběr místa uložení makra

  4. Pokud chcete makro spouštět stiskem klávesové zkratky, klikněte na Klávesnici.

    Kliknutím přiřadíte makro ke klávesové zkratce

  5. Do pole Stiskněte klávesovou zkratku zadejte kombinaci kláves.

  6. Zkontrolujte, jestli tato kombinace už není přiřazená k něčemu jinému. Pokud ano, zkuste jinou kombinaci.

  7. Abyste toto makro mohli použít u všech nových dokumentů, které vytvoříte, nezapomeňte v poli Změny uložit do vybrat možnost Normal.dotm.

  8. Klikněte na Přiřadit.

  9. Teď je čas pro záznam kroků. Pro každý krok úkolu klikněte na příkaz nebo stiskněte tlačítko. Word zaznamená vaše kliknutí a stisknutí kláves.

    Poznámka : Při záznamu makra vybírejte text pomocí klávesnice. Výběr provedený pomocí myši makro nezaznamená.

  10. Pro ukončení záznamu klikněte na Zobrazení > Makra > Zastavit záznam.

    Příkaz Zastavit záznam

Makro spustíte stiskem klávesové zkratky.

Když chcete spustit makro, klikněte na tlačítko na panelu nástrojů Rychlý přístup a stiskněte klávesovou zkratku. Nebo můžete makro spustit ze seznamu Makra.

  1. Klikněte na Zobrazení > Makra > Zobrazit makra.

    Příkaz Zobrazit makra

  2. V seznamu Název makra klikněte na makro, které chcete spustit.

  3. Klikněte na Spustit.

Aby mohlo být makro z jednoho dokumentu dostupné ve všech nových dokumentech, přidejte ho do šablony Normal.dotm.

  1. Otevřete dokument obsahující makro.

  2. Klikněte na Zobrazení > Makra > Zobrazit makra.

    Příkaz Zobrazit makra

  3. Klikněte na Organizátor.

    Tlačítko Organizátor v okně Zobrazit makra

  4. Klikněte na makro, které chcete přidat do šablony Normal.dotm a pak na Kopírovat.

  1. Klikněte na Soubor > Možnosti > Přizpůsobit pás karet.

  2. V rozevíracím seznamu Zvolit příkazy z klikněte na položku Makra.

  3. Klikněte na požadované makro.

  4. V části Přizpůsobit pás karet klikněte na kartu a vlastní skupinu, do které chcete makro přidat.

Pokud nemáte vlastní skupinu, klikněte na tlačítko Nová skupina. Potom klikněte na Přejmenovat a zadejte název vlastní skupiny.

  1. Klikněte na Přidat.

  2. Kliknutím na Přejmenovat zvolíte pro makro symbol a zadáte požadovaný název.

  3. Dvakrát klikněte na OK.

  1. Na kartě Vývojář klikněte ve skupině Kód na tlačítko Makra.

  2. Do pole název makra zadejte název makra.

    Poznámka : Pokud zadáte název nového makra: stejný název jako předdefinovaný makra v aplikaci Word, nahradí nové akce makra vestavěné makro. Seznam vestavěných maker zobrazíte kliknutím na Příkazy Word v seznamu Prohledat.

  3. V seznamu Prohledat klikněte na šablonu nebo dokument, ve kterém chcete makro uložit.

    Zpřístupnění makra ve všech dokumentech, nezapomeňte klikněte na Normal.dotm.

  4. Klikněte na vytvořit otevřete editoru jazyka Visual Basic.

Po otevření editoru jazyka Visual Basic, je vhodné Další informace o práci s jazykem Visual Basic for Applications. Další informace najdete v nabídce Nápověda klikněte na Microsoft Visual Basic Help nebo stiskněte klávesu F1.

Můžete zaznamenávat do posloupnosti akcí nebo zadáním Visual Basic kódem aplikací v Visual Basic Editor můžete vytvořit makro od začátku.

Poznámka : Práce s makry v Office Word 2007, musíte nejdřív zobrazit kartu Vývojář.

  1. Klikněte na tlačítko Microsoft Office Obrázek tlačítka a pak klikněte na Možnosti aplikace Word.

  2. Klikněte na položku Oblíbené.

  3. V části Nejpoužívanější možnosti při práci s aplikací Word zaškrtněte políčko Zobrazit kartu Vývojář na pásu karet.

    Poznámka : Pás karet je součástí Fluent systému Microsoft Office.

  1. Na kartě Vývojář klikněte ve skupině Kód na Zaznamenat makro.

    Skupina Kód na kartě Vývojář
  2. Do pole název makra zadejte název makra.

    Poznámka : Pokud jste vytvořte nové makro stejný název jako předdefinovaný makra v Office Word 2007, nové akce makra nahradí vestavěné makro. Zobrazení seznamu předdefinované makra, na kartě Vývojář ve skupině kód na tlačítko makra. V seznamu Prohledat klikněte na položku Příkazy Word.

  3. V rozevíracím seznamu Uložit makro do klikněte na Šablona nebo dokument, ve kterém chcete makro uložit.

    Důležité : Zpřístupnění makra ve všech dokumentech, nezapomeňte klikněte na Normal.dotm.

  4. Do pole Popis napište krátký popis makra.

  5. Proveďte některou z následujících akcí:

    • Zahájit nahrávání    Před nahráváním makro bez jeho přiřazení k tlačítku na panelu nástrojů Rychlý přístup nebo zkratku s klávesou CTRL, klikněte na OK.

    • Tlačítko Vytvořit    Přiřadíte makro k tlačítku na panelu nástrojů Rychlý přístup, postupujte takto:

      1. Klikněte na tlačítko.

      2. V části Přizpůsobit panel nástrojů Rychlý přístup vyberte dokument (nebo všechny dokumenty) pro kterého chcete makro přidat na panel nástrojů Rychlý přístup.

        Důležité : Zpřístupnění makra ve všech dokumentech, nezapomeňte klikněte na Normal.dotm.

      3. Ve skupinovém rámečku dialogové okno Zvolit příkazy z klikněte na makro, které chcete zaznamenat a klikněte na tlačítko Přidat.

      4. Chcete-li na tlačítko přizpůsobit, klikněte na změnit.

      5. V části Symbol klikněte na symbol, který chcete použít pro tlačítko.

      6. Do pole Zobrazovaný název zadejte název makra, který chcete zobrazit.

      7. Klikněte na OK dvakrát se začne zaznamenávat makro.

        Zobrazí se symbol, který vyberete v panelu nástrojů Rychlý přístup. Název, který zadáte se zobrazí po nastavení ukazatele myši na symbol.

    • Přiřazení klávesové zkratky    Přiřadíte makro ke klávesové zkratce, postupujte takto:

      1. Klikněte na klávesnici.

      2. V seznamu Příkazy klikněte na makro, které chcete zaznamenat.

      3. Do pole stiskněte klávesovou zkratku zadejte kláves, které chcete a potom klikněte na přiřadit.

      4. Klikněte na tlačítko Zavřít se začne zaznamenávat makro.

  6. Provedení akce, které chcete zahrnout do makra.

    Poznámka : Během zaznamenávání makra můžete myší na příkazy nebo možnosti, ale ne na vyberte text. Chcete-li vybrat text musí pomocí klávesnice. Další informace o výběru textu pomocí klávesnice najdete v článku Vyberte text.

  7. Pozastavit záznam akcí, klikněte ve skupině kód na Zastavit záznam.

Změna klávesové zkratky pro makra

  1. Klikněte na tlačítko Microsoft Office Obrázek tlačítka a pak klikněte na Možnosti aplikace Word.

  2. Klikněte na Přizpůsobit.

  3. Vedle klávesové zkratky klikněte na Upravit.

  4. V seznamu kategorie klikněte na tlačítko makra.

  5. V seznamu makra klikněte na makro, které chcete změnit.

  6. Do pole stiskněte klávesovou zkratku zadejte kombinaci kláves, která chcete vybrat.

  7. Zaškrtněte políčko Aktuální klávesy, abyste měli jistotu, že nejsou přiřazování, které už používáte pro provedení úkolu různé kombinace kláves.

  8. V seznamu změny uložit do klikněte na požadovanou možnost, která odpovídá, ve které chcete makro spouštět.

    Důležité : Zpřístupnění makra ve všech dokumentech, nezapomeňte klikněte na Normal.dotm.

  9. Klikněte na tlačítko Zavřít.

  1. Na kartě Vývojář klikněte ve skupině Kód na tlačítko Makra.

    Skupina Kód na kartě Vývojář

  2. V seznamu název makra klikněte na makro, který chcete spustit.

  3. Klikněte na příkaz Spustit.

  1. Na kartě Vývojář klikněte ve skupině Kód na tlačítko Makra.

    Skupina Kód na kartě Vývojář

  2. Do pole název makra zadejte název makra.

    Poznámka : Pokud jste vytvořte nové makro stejný název jako předdefinovaný makra v Office Word 2007, nové akce makra nahradí vestavěné makro. Seznam vestavěných maker zobrazíte kliknutím na Příkazy Word v seznamu Prohledat.

  3. V seznamu Prohledat klikněte na Šablona nebo dokument, ve kterém chcete makro uložit.

    Zpřístupnění makra ve všech dokumentech, nezapomeňte klikněte na Normal.dotm.

  4. Klikněte na vytvořit otevřete editoru jazyka Visual Basic.

Po otevření editoru jazyka Visual Basic, je vhodné Další informace o práci s jazykem Visual Basic for Applications. Další informace najdete v nabídce Nápověda klikněte na Microsoft Visual Basic Help nebo stiskněte klávesu F1.

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×