Vytvoření návrhu formuláře tak, aby se měnil podle stavu pracovního postupu

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Můžete vytvářet formuláře aplikace Microsoft Office InfoPath k zobrazení konkrétních dat, která odpovídá aktuální stav pracovního postupu. Provedete návrhem šablony formuláře použít pravidla, která zahájit akce v jeho formuláře založené na stav pracovního postupu. To můžete zjednodušit procesy, které uživatelé používají vyplňovat formuláře.

Tento článek popisuje, jak navrhnout šabloně formulář vyúčtování výdajů automaticky zobrazíte různá zobrazení šablony formuláře v závislosti na stav přidružené pracovního postupu schválení. Například před spuštěním pracovního postupu formuláře se zobrazí výdaje zobrazení, která obsahuje tabulku s opakováním kterého uživatelé mohou zadat náklady. V průběhu po stav pracovního postupu formuláři zobrazí souhrn výdajů zobrazení, které zobrazuje celkové náklady v každé kategorii. Dokončeno po stav pracovního postupu se zobrazí formulář zobrazení dokončeno, které obsahuje podrobnosti o na čase odhadovaná náhradu.

Pokud chcete formuláře nastavit tak, aby reagovaly na stav pracovního postupu, je třeba provést určité kroky na webu služby Microsoft Office SharePoint Server 2007 nebo Windows SharePoint Services 3.0, kde se formuláře nacházejí, a určité kroky v aplikaci InfoPath. Na webu služby SharePoint je nutné vytvořit pracovní postup a Typ obsahu webu a v aplikaci InfoPath musíte k šabloně formuláře přidat datové připojení, vytvořit pravidlo a šablonu formuláře publikovat.

Poznámka : Tento článek vychází ze vzorového scénáře, kdy je šablona formuláře publikována jako typ obsahu webu. Šablonu formuláře můžete také publikovat ve sdíleném síťovém umístění nebo můžete při jejím publikování na webu služby SharePoint vytvořit novou knihovnu dokumentů. Další informace o publikování šablon formulářů naleznete v části Viz také.

V tomto článku

Úvod k používání pracovních postupů s formuláři aplikace InfoPath

Aspekty kompatibility:

Než začnete

Krok 1: Přidání pracovního postupu Schválení do knihovny

Krok 2: Přidání datového připojení k šabloně formuláře

Krok 3: Přidání pravidla určujícího konkrétní zobrazení k šabloně formuláře

Krok 4: Publikování šablony formuláře jako typu obsahu webu

Krok 5: Přidání typu obsahu do knihovny dokumentů

Úvod k používání pracovních postupů s formuláři aplikace InfoPath

Pracovní postupy umožňují uživatelům snáze spolupracovat na dokumentech a zvládat projektové úlohy tím, že u dokumentů a položek implementují na webu služby Microsoft Office SharePoint Server 2007 nebo Windows SharePoint Services 3.0 specifické podnikové procesy. Prostřednictvím pracovních postupů lze v organizacích lépe dodržovat konzistentní podnikové procesy a zároveň zvýšit produktivitu a efektivitu lepší správou úloh a kroků tvořících konkrétní firemní procesy. Díky tomu se mohou uživatelé, kteří tyto úlohy provádějí, namísto samotného zvládání pracovního postupu soustředit na svou práci.

Formulář aplikace InfoPath k zobrazení konkrétních dat, která odpovídá aktuální stav pracovního postupu můžete povolit. Provedete návrhem šablony formuláře použít pravidla, která zahájit akce ve formuláři podle stavu pracovního postupu. To můžete zjednodušit procesy, které uživatelé používat k vyplňování formulářů. Můžete třeba povolit tak, aby zobrazení jen pro čtení když stav pracovního postupu je Dokončeno, tedy neměli změnit data ve formuláři.

Pokud chcete, aby pracovní postupy bylo možné použít v šablonách formulářů aplikace InfoPath, je nutné je přidat do seznamu, knihovny nebo typu obsahu služby SharePoint. Dostupnost pracovních postupů rovněž závisí na typu webu a na tom, zda byly vlastní pracovní postupy vytvořeny pomocí aplikace Microsoft Office SharePoint Designer 2007.

Tento článek na základě pracovního postupu Schválení ilustruje, jak lze pracovní postupy používat se šablonami formulářů aplikace InfoPath. Pracovní postup Schválení směruje formulář aplikace InfoPath, který je uložen v knihovně, skupině osob ke schválení. Ve výchozím nastavení je pracovnímu postupu Schválení přidružen typ obsahu Dokument a je automaticky k dispozici v knihovnách dokumentů nebo formulářů.

Jednotlivé pracovní postupy je definován různých stavy s popisných názvů, například Probíhá. Názvy stavů se liší podle typu pracovního postupu. Příklad pracovního postupu schválení, která je dostupná na serverech musí běžet Microsoft Office SharePoint Server 2007 – patří stav Probíhá, zrušeno a Dokončeno. Stavy třístavového pracovního postupu, která je dostupná v Windows SharePoint Services 3.0 – to možné definovat osoba, která přidá pracovního postupu do knihovny nebo seznamu, že jiných pracovních postupů pomocí standardní stavy například stav Probíhá uvedeno dříve. Popisný název je viditelná pro uživatele, sice stavy pracovního postupu jsou představovány programově číselné hodnoty. Návrh šablony formuláře a měnil podle stavu konkrétní pracovní postup, musíte znát číselná hodnota pro stav pracovního postupu, který chcete použít. Je to proto aplikace InfoPath pomocí číselnou hodnotu pracovní postup spustit akci, například přepínání zobrazení.

Jak bylo zmíněno výše, šablonu formuláře aplikace InfoPath můžete nastavit tak, aby zobrazovala specifická data odpovídající aktuálnímu stavu pracovního postupu. Ačkoli tento článek popisuje postup nastavení šablony formuláře vyúčtování výdajů tak, aby automaticky nabízela určité zobrazení v závislosti na stavu pracovního postupu, můžete pracovní postup upravit také přidáním dalších akcí. Namísto nastavení formulářů na používání určitých zobrazení je můžete například nastavit tak, aby v dialogovém okně zobrazovaly zprávu s pokyny. A namísto použití pracovního postupu Schválení můžete použít třístavový pracovní postup.

Poznámka : Povolíte-li jiné akce než popsané v tomto článku, může být nutné provést další kroky, aby bylo zajištěno, že šablona formuláře bude s používaným pracovním postupem správně fungovat.

Začátek stránky

Aspekty kompatibility:

Máte-li v úmyslu vytvořit Šablona formuláře kompatibilní s prohlížečem, nezapomeňte, že panel akcí dokumentu, který se při vyplňování formulářů zobrazuje v dokumentech sady Microsoft Office, včetně formulářů aplikace InfoPath, se nezobrazí v šablonách formulářů kompatibilních s prohlížečem, které uživatelé vyplňují v prohlížeči. Přesto ale můžete tyto formuláře s pracovními postupy používat. Ke změně stavu pracovního postupu u těchto formulářů mohou účastníci pracovního postupu použít nastavení knihovny dokumentů. Další informace o změně nastavení pracovního postupu pomocí webů služby SharePoint naleznete v části Viz také.

Začátek stránky

Než začnete

Před provedením postupů uvedených v tomto článku zkontrolujte následující:

  • Požádejte správce serverové farmy o potvrzení, že je pracovní postup Schválení nainstalován a povolen pro web služby SharePoint, který chcete použít.

  • Ujistěte se, zda máte pro web služby SharePoint přinejmenším Úroveň oprávnění Návrh. Toto oprávnění je nezbytné k publikování šablony formuláře a k vytvoření pracovního postupu.

  • Vytvořte šablonu formuláře s dvěma nebo více zobrazeními a přizpůsobte každé z nich tak, aby obsahovalo typ dat vhodný pro příslušný stav pracovního postupu. Například u zobrazení, které se má objevit při dokončení pracovního postupu, lze ovládací prvky v tomto zobrazení nastavit tak, aby byly jen pro čtení.

  • Vytvořte knihovnu dokumentů nebo formulářů a ověřte, zda je knihovna nastavena tak, aby povolovala více typů obsahu.

Začátek stránky

Krok 1: Přidání pracovního postupu Schválení do knihovny

Tento scénář vychází z pracovního postupu Schválení, ale podle potřeby můžete použít jiný typ pracovního postupu. Použijete-li jiný typ, příslušné možnosti se mohou od možností popsaných v tomto článku lišit.

  1. Otevřete knihovnu, do které chcete pracovní postup přidat.

  2. V nabídce Nastavení klepněte na nastavení pro typ knihovny, kterou otevíráte.

    V knihovně dokumentů klepněte například na příkaz Nastavení knihovny dokumentů.

  3. V části Oprávnění a správa klepněte na položku Nastavení pracovního postupu.

  4. Klepněte na položku Přidat pracovní postup.

  5. Na stránce Přidat pracovní postup klepněte v části Pracovní postup na položku Schválení.

  6. V oblasti Název zadejte jedinečný název pracovního postupu.

    1. V oblasti Seznam úkolů zadejte seznam úkolů, které chcete použít pro tento pracovní postup.

      Poznámky : 

      • Můžete použít výchozí seznam Úkoly nebo vytvořit nový. Pokud použijete výchozí seznam Úkoly, budou moci účastníci pracovního postupu snadno najít a zobrazit svoje úkoly pracovního postupu pomocí zobrazení Vlastní úkoly v seznamu Úkoly.

      • Pokud pracovní postup obsahuje citlivé nebo důvěrné informace, které chcete oddělit od obecného seznamu Úkoly, vytvořte nový seznam úkolů.

      • Nový seznam úkolů je vhodné vytvořit, pokud organizace používá velký počet pracovních postupů nebo pokud pracovní postupy obsahují mnoho úkolů. V tomto případě můžete vytvořit seznamy úkolů pro každý pracovní postup.

  7. V části Seznam historie zadejte seznam úkolů, který se má použít s tímto pracovním postupem. V seznamu historie se zobrazí všechny události, ke kterým dojde během každé instance pracovního postupu.

    Můžete použít výchozí seznam Historie nebo vytvořit nový. Pokud bude vaše organizace používat mnoho pracovních postupů, můžete vytvořit samostatný seznam historie pro každý z nich.

  8. Chcete-li povolit ruční spuštění pracovního postupu, zaškrtněte políčko Umožnit ruční spuštění tohoto pracovního postupu ověřeným uživatelem s oprávněním Upravit položky v části Možnosti spuštění.

  9. Má-li spuštění pracovního postupu vyžadovat další oprávnění, zaškrtněte políčko Ke spuštění pracovního postupu vyžadovat oprávnění Spravovat seznamy.

  10. Zadejte případné další požadované možnosti, včetně toho, kdy chcete pracovní postup spustit, a potom klepněte na tlačítko Další.

  11. Na stránce Přizpůsobit pracovní postup zadejte požadované možnosti, včetně způsobu směrování úkolů, výchozích počátečních hodnot a způsobu dokončení pracovního postupu, a potom klepněte na tlačítko OK.

    Vyberte možnosti v kterýchkoli z následujících oblastí. Nemusíte zadat možnosti v každé oblasti:

    Úkoly pracovního postupu

    Akce

    Akce

    Přiřazení úkolů všem účastníkům najednou (paralelní pracovní postup)

    Zaškrtněte políčko Všem účastníkům zároveň (paralelně).

    Přiřazení úkolů vždy jen jednomu účastníkovi, který musí úkol dokončit, aby další účastník mohl pokračovat dalším úkolem (sériový pracovní postup).

    Zaškrtněte políčko Vždy jen jednomu účastníkovi (sériově).

    Povolení, aby účastníci pracovního postupu mohli přiřazovat úkoly jiným uživatelům.

    Zaškrtněte políčko Znovu přiřadit úkol jiné osobě.

    Povolení, aby účastníci pracovního postupu mohli požadovat změnu dokumentu nebo položky. Změna musí být před dokončením úkolu schválena.

    Zaškrtněte políčko Zadat požadavek na změnu před dokončením úkolu.

    Výchozí hodnoty spuštění pracovního postupu

    Akce

    Akce

    Určení výchozího seznamu účastníků pro všechny instance tohoto pracovního postupu

    Zadejte jména účastníků, které chcete zahrnout do pracovního postupu při spuštění, nebo klepněte na tlačítko Schvalovatelé a potom vyberte uživatele nebo skupiny z adresářové služby.

    Poznámky : 

    • Jména oddělte středníky.

    • Pokud tento pracovní postup nastavíte jako sériový, přidejte jména jeho účastníků v pořadí, ve kterém mají být úkoly přiřazovány.

    Přiřazení jednotlivých úkolů skupinám namísto jejich přiřazení každému členovi skupiny

    Zaškrtněte políčko Každé zadané skupině přiřaďte jeden úkol. (Nerozbalujte skupiny.).

    Povolení, aby uživatelé spouštějící pracovní postup mohli změnit nebo přidat účastníky.

    Zaškrtněte políčko Povolit změny seznamu účastníků při zahájení tohoto pracovního postupu.

    Zadání výchozí zprávy zobrazované s každým úkolem

    Do textového pole zadejte zprávu nebo pokyny.

    Zadání termínu splnění pro paralelní pracovní postupy

    Zadejte datum v oblasti Termín splnění úkolů (paralelní).

    Určení, kolik času mají účastníci sériového pracovního postupu k dokončení úkolů.

    V části Na dokončení úkolu poskytněte každému uživateli následující dobu (sériový) zadejte hodnotu a potom vyberte možnost Dny nebo Týdny, která bude označovat časovou jednotku.

    Zadání seznamu uživatelů, kteří při spuštění pracovního postupu mají obdržet upozornění (nebudou jim však přiřazovány úkoly).

    V části Upozornit další uživatele zadejte jména osob, které mají být upozorněny, nebo klepněte na tlačítko Kopie a vyberte uživatele nebo skupiny z adresářové služby.

    Poznámka : Jména oddělte středníky.

    Dokončení pracovního postupu

    Akce

    Akce

    Zadat, že paralelní pracovní postup je dokončen, pokud určitý počet účastníků dokončí své úkoly

    Zaškrtněte políčko Následující počet úkolů je dokončen a zadejte hodnotu.

    Určení, že pracovní postup bude dokončen při odmítnutí dokumentu nebo položky.

    Zaškrtněte políčko Dokument je odmítnut.

    Zadat, že pracovní postup je dokončen, pokud jsou dokument nebo položka změněny

    Zaškrtněte políčko Dokument je změněn.

    Akce po dokončení pracovního postupu

    Akce

    Akce

    Aktualizovat stav schválení dokumentu nebo položky po dokončení pracovního postupu

    Zaškrtněte políčko Aktualizovat stav schválení (pomocí tohoto pracovního postupu lze řídit schválení obsahu).

    Poznámky : 

    • Používáte-li k řízení schvalování obsahu pro knihovnu pracovní postup Schválení a pokud jste na stránce Přidat pracovní postup zaškrtli políčko Spustit tento pracovní postup ke schválení publikování hlavní verze položky, bude toto políčko ve výchozím nastavení zaškrtnuto.

    • Pokud jste na stránce Přidat pracovní postup nezaškrtli políčko Spustit tento pracovní postup ke schválení publikování hlavní verze položky, protože nechcete, aby se jednalo o výchozí pracovní postup pro schvalování obsahu v knihovně, můžete zaškrtnutím tohoto políčka nastavit tento pracovní postup jako sekundární pracovní postup pro schvalování obsahu, který mohou konkrétní uživatelé spustit ručně.

Začátek stránky

Krok 2: Přidání datového připojení k šabloně formuláře

Následující postup popisuje přidání sekundárního datového připojení, které zjišťuje stav pracovního postupu přidaného v kroku 1. Toto sekundární datové připojení poskytuje data, na základě kterých se podle pravidel ve formuláři přepínají zobrazení v závislosti na stavu pracovního postupu.

  1. V aplikaci InfoPath klepněte v nabídce Nástroje na příkaz Datová připojení.

  2. V dialogovém okně Datová připojení klikněte na tlačítko Přidat.

  3. V Průvodci datovým připojením klikněte na možnost Vytvořit nové připojení k, pokračujte kliknutím na příkaz Přijímat data a na tlačítko Další.

  4. Na další stránce průvodce klikněte na položku Knihovna nebo seznam SharePoint a na tlačítko Další.

  5. Na další stránce průvodce zadejte adresu URL webu služby SharePoint.

  6. V seznamu Vyberte seznam nebo knihovnu klepněte na název knihovny dokumentů, do které jste v kroku 1 přidali pracovní postup Schválení, a klepněte na tlačítko Další.

  7. Na další stránce průvodce zaškrtněte v seznamu Vyberte pole políčko vedle názvu pole, které se shoduje s názvem pracovního postupu.

    Název pole se s názvem pracovního postupu nemusí shodovat přesně. Pokud název pole začíná zvláštním znakem (tedy jiným znakem než podtržítkem nebo písmenem), název pracovního postupu bude v seznamu upraven.

  8. Zaškrtněte políčko Zahrnout data pouze pro aktivní formulář a klepněte na tlačítko Další.

  9. Zrušte zaškrtnutí políčka Uložit kopii dat do šablony formuláře a potom klepněte na tlačítko Další.

  10. Na další stránce průvodce zadejte do pole Zadejte název tohoto datového připojení popisný název pro toto sekundární datové připojení. Právě tento název se zobrazí v seznamu Zdroj dat v podokně úloh Zdroj dat.

  11. Jestliže chcete dotaz spustit automaticky při každém otevření formuláře uživatelem, zaškrtněte políčko Automaticky načíst data při otevření formuláře.

  12. Na poslední stránce průvodce klepněte na tlačítko Dokončit.

  13. V dialogovém okně Datová připojení klepněte na tlačítko Zavřít.

Začátek stránky

Krok 3: Přidání pravidla určujícího konkrétní zobrazení k šabloně formuláře

Při navrhnout šablonu formuláře se automaticky zobrazí dialogové okno, nastavte hodnotu pole, dotaz nebo odeslání dat formuláře do datového připojení, přepnutí zobrazení, nebo otevření nebo zavření formuláře v odpovědi na některé události a podmínky pomocí pravidel. Události můžete zahrnout změnu v konkrétním poli nebo skupinu Zdroj dat, klikněte na tlačítko, vložení Opakující se oddíl nebo řádku v Opakující se tabulka nebo otevření nebo odeslání formuláře. Podmínky mohou obsahovat výpočty, výrazy XPath a role uživatelů. Podmínky mohou také obsahovat zda hodnotu z pole odkazuje na prázdnou buňku, je v určitém rozsahu, se rovná hodnotě jiné pole začíná nebo obsahuje určité znaky.

V tomto případě vytvoříte pravidlo pro přepínání zobrazení na základě stavu pracovního postupu.

  1. V nabídce Nástroje klepněte na příkaz Možnosti formuláře.

  2. V seznamu Kategorie klepněte na možnost Otevřít a uložit.

  3. V části Chování při otevření klepněte na tlačítko Pravidla.

  4. V dialogovém okně Pravidla pro otevírání formulářů klepněte na tlačítko Přidat.

  5. Do pole Název zadejte název pravidla.

    Zadejte například Přepínání zobrazení.

  6. Chcete-li určit podmínku, kdy se má pravidlo spustit, klepněte na tlačítko Nastavit podmínku.

  7. Ve skupinovém rámečku Použít pravidlo, pokud je podmínka splněna klepněte v prvním poli na možnost Vybrat pole nebo skupinu.

  8. V seznamu Zdroj dat klepněte na název sekundárního zdroje dat, který jste přidali v kroku 2, a klepněte na tlačítko OK.

  9. Klepněte na název pole, které odpovídá stavu pracovního postupu.

    Je možné, že budete muset v okně rozbalovat složky, dokud se požadované pole neobjeví.

  10. V dialogovém okně Podmínka klepněte ve druhém seznamu na položku Je rovno.

  11. V třetím seznamu klepněte na položku Zadejte číslo a potom zadejte hodnotu, která odpovídá stavu pracovního postupu.

    Například pro zobrazení, které se zobrazí při dokončení pracovního postupu, zadejte hodnotu 5.

    Číselné hodnoty stavů pracovního postupu Schválení

    Stav

    Číselná hodnota

    Probíhá

    2

    Dokončeno

    5

    Zrušeno

    15

    Schváleno

    16

    Zamítnuto

    17

    Poznámky : 

    • Číselné hodnoty stavů v jiných pracovních postupech se mohou lišit.

    • Hodnota stavu pracovního postupu v aplikaci InfoPath je jen pro čtení. To znamená, že nelze navrhnout šablonu formuláře, ve kterém by uživatel mohl ručně měnit stav pracovního postupu zadáním hodnoty do ovládacího prvku přímo ve formuláři.

  12. Klepněte na tlačítko OK.

  13. V dialogovém okně Pravidlo klepněte na tlačítko Přidat akci.

  14. V části Akce klepněte na možnost Přepnout zobrazení.

  15. V části Zobrazení klepněte na název zobrazení, které chcete zobrazit, jakmile stav pracovního postupu bude odpovídat stavu v dané podmínce, a potom klepněte na tlačítko OK.

    Pokud jste například zadali v kroku 11 hodnotu 2, klepněte na název zobrazení, které se má objevit, když bude pracovní postup ve stavu Probíhá.

  16. V dialogovém okně Pravidlo klepněte na tlačítko OK.

  17. Opakováním kroků 4 až 16 vytvoříte další pravidla pro přepnutí příslušných zobrazení v jednotlivých fázích pracovního postupu.

Začátek stránky

Krok 4: Publikování šablony formuláře jako typu obsahu webu

Šablonu formuláře můžete publikovat buď do knihovny dokumentů, nebo jako typ obsahu webu, který lze použít ve více knihovnách dokumentů v rámci kolekce webů. Vzhledem k tomu, že jste již vytvořili knihovnu dokumentů a přiřadili k ní pracovní postup, je nutné šablonu formuláře publikovat jako typ obsahu. Později můžete typ obsahu webu odpovídající dané šabloně formuláře přidružit k vytvořené knihovně.

Kromě publikování jako typu obsahu webu můžete šablonu formuláře publikovat také ve sdíleném síťovém umístění nebo můžete při jejím publikování na webu služby SharePoint vytvořit novou knihovnu dokumentů. Další informace o publikování šablon formulářů naleznete v části Viz také.

  1. V nabídce Soubor klepněte na příkaz Uložit.

  2. V dialogovém okně Uložit jako přejděte do umístění, kam chcete uložit šablonu formuláře, a klepněte na tlačítko Uložit.

  3. Podokno úloh Kontrola návrhu zobrazíte klepnutím na příkaz Kontrola návrhu v nabídce Nástroje.

  4. Pokud jsou v podokně úloh Kontrola návrhu uvedeny chyby, opravte je a potom klepnutím na tlačítko Aktualizovat zjistěte, zda stále přetrvávají.

  5. V nabídce Soubor klikněte na příkaz Publikovat.

  6. V průvodci publikováním klepněte na možnost Na server SharePoint s nebo bez služby InfoPath Forms Services a klepněte na tlačítko Další.

  7. Na další stránce průvodce zadejte do pole Zadejte umístění služby SharePoint nebo InfoPath Forms Services umístění webu služby SharePoint, na který chcete šablonu formuláře publikovat, a klepněte na tlačítko Další.

  8. Chcete-li uživatelům umožnit vyplnění tohoto formuláře pomocí webového prohlížeče, zaškrtněte na další stránce průvodce políčko Povolit vyplnění tohoto formuláře pomocí prohlížeče.

  9. Klepněte na položku Typ obsahu webu (upřesnit) a poté na tlačítko Další.

  10. Na další stránce průvodce klepněte na tlačítko Vytvořit nový typ obsahu.

  11. V seznamu Založit typ obsahu na klepněte na položku Formulář a poté na tlačítko Další.

  12. Na další stránce průvodce zadejte název a popis nového typu obsahu a poté klepněte na tlačítko Další.

  13. Na další stránce průvodce zadejte do pole Zadejte umístění a název souboru šablony formuláře umístění webu služby SharePoint a potom klepněte na tlačítko Procházet.

  14. V dialogovém okně Procházet přejděte k umístění na serveru, do kterého chcete publikovat šablonu formuláře jako typ obsahu webu, do pole Název souboru zadejte název šablony formuláře a klepněte na tlačítko Uložit.

  15. Klepněte na tlačítko Další.

  16. V šabloně formuláře vyberte pole, která chcete zobrazit jako sloupce ve výchozím zobrazení knihovny dokumentů.

    Postup

    1. Klepněte na tlačítko Přidat.

    2. Vyberte pole, které chcete v knihovně dokumentů přidat jako sloupec, a potom proveďte jednu z následujících akcí:

      • Zadejte název sloupce do pole Název sloupce.

      • Vyberte sloupec webu v seznamu Skupina sloupců webu, vyberte název v seznamu Název sloupce a potom klepněte na tlačítko OK.

        Jestliže jste k zobrazení dat v knihovně dokumentů zvolili opakující se pole, můžete klepnutím na hodnotu v seznamu Funkce definovat, jakým způsobem chcete pole v knihovně dokumentů zobrazit. Je možné zvolit zobrazení první hodnoty v poli, poslední hodnoty v poli nebo počtu všech výskytů pole či zda mají být všechny hodnoty sloučeny.

    3. Klikněte na OK.

  17. Klepněte na tlačítko Další.

  18. Na další straně průvodce ověřte, zda jsou uvedené informace správné a klepněte na tlačítko Publikovat.

  19. Klepněte na tlačítko Zavřít a poté ověřte, zda je šablona formuláře na webu služby SharePoint zobrazena jako typ obsahu.

    Postup

    1. Ve webovém prohlížeči otevřete web služby SharePoint.

    2. V nabídce Akce webu v pravém horním rohu webu klepněte na možnost Nastavení webu.

    3. V dialogovém okně Nastavení webu klepněte v oblasti Galerie na položku Typy obsahu webu.

      Šablona formuláře by měla být uvedena v seznamu Typy obsahu aplikace InfoPath v oblasti Galerie typů obsahu webu.

Začátek stránky

Krok 5: Přidání typu obsahu do knihovny dokumentů

Typy obsahu umožňuje organizacím uspořádat a spravovat efektivnější zpracování obsahu v kolekci webů. Definování typů obsahu pro určité typy dokumentů, organizace můžete zajistit jednotlivé skupiny obsahu efektivněji spravovat. Můžete nastavit do seznamu nebo knihovny obsahující položky z více typů položek nebo dokumentů přidáním typy obsahu seznamu nebo knihovny.

Poznámka : Chcete-li do seznamu nebo knihovny přidat typy obsahu, potřebujete pro tento seznam nebo knihovnu přinejmenším oprávnění na úrovni Návrh.

Než začnete, přesvědčte se, zda je knihovna nastavena tak, aby povolovala více typů obsahu.

Povolení více typů obsahu

  1. V nabídce Nastavení klepněte na příkaz Nastavení knihovny dokumentů.

  2. V oblasti Obecné nastavení klepněte na položku Upřesnit nastavení.

  3. V části Typy obsahu vyberte položku Ano, čímž povolíte více typů obsahu, a klepněte na tlačítko OK.

  1. Pokud seznam nebo knihovna nejsou dosud otevřené, klepněte na jejich název na panelu Snadné spuštění.

    Poznámka : Pokud se název seznamu nebo knihovny neobjeví, klepněte na tlačítko Zobrazit veškerý obsah webu a potom na název požadovaného seznamu nebo knihovny.

  2. V nabídce Nastavení klepněte na příkaz Nastavení knihovny dokumentů.

  3. V části Typy obsahu klepněte na položku Přidat ze stávajících typů obsahu webu.

  4. V seznamu Vybrat typy obsahu webu v části Vybrat typy obsahu vyberte skupinu typů obsahu webu, ze které chcete vybírat.

  5. V seznamu Dostupné typy obsahu webu klepněte na požadovaný typ obsahu a potom klepnutím na tlačítko Přidat přesuňte vybraný typ do seznamu Typy obsahu k přidání.

  6. Chcete-li přidat další typy obsahu, opakujte kroky 4 a 5 a potom klepněte na tlačítko OK.

Pokud nyní uživatel vytvoří nový formulář v této knihovně, bude zobrazení formuláře odpovídat stavu pracovního postupu.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×