Vytvoření kontingenční tabulky se externímu zdroji dat

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Možnost analyzovat všechna data vám může pomoct přijímat lepší obchodní rozhodnutí. Někdy je ale těžké zjistit, kde začít, hlavně pokud máte hodně dat uložených mimo Excel, například v databázi Microsoft Accessu nebo Microsoft SQL Serveru, nebo v souboru krychle OLAP (Online Analytical Processing). V takovém případě se připojíte k externímu zdroji dat a pak vytvoříte kontingenční tabulku, pomocí které můžete data shrnout, analyzovat, prozkoumat a prezentovat.

Tady se dozvíte, jak vytvoříte kontingenční tabulku pomocí připojení externích dat:

  1. Klikněte na jakoukoliv buňku v listu.

  2. Klikněte na Vložení > Kontingenční tabulka.

    Tlačítko Kontingenční tabulka na kartě Vložit

  3. V dialogovém okně Vytvořit kontingenční tabulku klikněte v části Zvolte data, která chcete analyzovat na Použít externí zdroj dat.

    Dialogové okno Vytvořit kontingenční tabulku s volbou vybraného externího zdroje dat

  4. Klikněte na Zvolit připojení.

  5. Na kartě Připojení nechejte v poli Zobrazit vybraná Všechna připojení nebo vyberte kategorii připojení obsahující zdroj dat, ke kterému se chcete připojit.

Pokud chcete znovu připojit nebo sdílet existující připojení, použijte připojení ze seznamu Připojení v tomto sešitě.

  1. V seznamu připojení vyberte připojení a pak klikněte na Otevřít.

  2. V části Zvolte umístění sestavy kontingenční tabulky vyberte umístění.

    • Pokud chcete kontingenční tabulku umístit na nový list počínaje buňkou A1, klikněte na Nový list.

    • Pokud chcete vložit kontingenční tabulku do aktivního listu, vyberte Existující list a pak do pole Místo zadejte buňku, kde má kontingenční tabulka začínat.

  3. Klikněte na OK.

    Excel přidá prázdnou kontingenční tabulku a zobrazí seznam polí, takže je možné Zobrazit pole, která se má a znovu je uspořádat do vlastního rozložení.

    Seznam polí zobrazující pole externích dat

  4. V oddílu seznamu polí zaškrtněte políčko vedle názvu pole pro vložení tohoto pole do výchozí oblasti oddílu oblastí Seznamu polí.

    Obvykle se jiná než číselná pole přidávají do oddílu Řádky, číselná pole do oddílu Hodnoty a pole data a času do oddílu Sloupce. Pole můžete podle potřeby přesunout do jiného oddílu.

    Tip :  Můžete také kliknout pravým tlačítkem na název pole a pak vybrat Přidat k filtru sestavy, Přidat k popiskům sloupců, Přidat k popiskům řádků nebo Přidat k hodnotám pro přidání pole do této oblasti v oddílu oblastí, nebo přetáhnout pole z oddílu polí do oblasti v oddílu oblastí.

    Pomocí Seznamu polí dál uspořádat data kontingenční tabulky tak, že pravým tlačítkem na pole v oddílu oblastí a pak vyberete požadovanou oblast, kterou chcete případně pole přetáhnete mezi oblastmi v oddílu oblastí.

Připojení k novému externímu zdroji dat

Pokud chcete vytvořit nové externí datové připojení k SQL Serveru a importovat data do Excelu jako kontingenční tabulku, udělejte toto:

  1. Klikněte na Data > Z jiných zdrojů.

Tlačítko Z jiných zdrojů na kartě Data

  1. Klikněte na požadované připojení.

    • Kliknutím na Ze serveru SQL Server vytvoříte připojení k tabulce SQL Serveru.

    • Kliknutím na Ze Služby pro analýzu vytvoříte připojení ke krychli služby SQL Server Analysis.

  2. V části Průvodce datovým připojením dokončete kroky pro vytvoření připojení.

    • Na stránce 1 zadejte databázový server a určete, jak se k němu chcete připojit.

    • Na stránce 2 zadejte databázi, tabulku nebo dotaz obsahující požadovaná data.

    • Na stránce 3 zadejte soubor připojení, který chcete vytvořit.

Pokud chcete vytvořit nové připojení k accessové databázi a importovat data do Excelu jako kontingenční tabulku, udělejte tohle:

  1. Klikněte na Data > Z aplikace Access.

Tlačítko Z aplikace Access na kartě Data

  1. V dialogovém okně Vybrat zdroj dat najděte databázi, ke které se chcete připojit, a klikněte na Otevřít.

  2. V dialogovém okně Vybrat tabulku vyberte požadovanou tabulku a klikněte na OK.

Pokud existuje více tabulek, zaškrtněte políčko Povolit výběr více tabulek, abyste mohli zaškrtnout políčka u tabulek, které chcete, a pak klikněte na OK.

  1. V dialogovém okně Importovat data vyberte, jak chcete zobrazit data v sešitu a kam je chcete vložit, a pak klikněte na OK.

Tabulky se automaticky přidají do datového modelua Accessová databáze se přidá do připojení sešitu.

Další informace o kontingenčních tabulkách

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×