Vytvoření histogramu

Vytvoření histogramu

Histogram je sloupcový graf, ve kterém se zobrazují data četnosti.

Poznámka: V tomto tématu jsou jenom rozhovory o vytváření histogramu. Informace o grafech Paretova (uspořádaného histogramu) najdete v tématu Vytvoření Paretova grafu.

  1. Vyberte data.

    (Typickým příkladem dat histogramu)

    Data použitá k vytvoření ukázky histogramu nahoře
  2. Klikněte na Vložení > Vložit statistický graf > Histogram.

    Příkaz Histogram po stisknutí tlačítka Vložit statistický graf

    Histogram můžete vytvořit také na kartě všechny grafy v části Doporučené grafy.

Tipy: 

  • Pomocí karet Návrh a Formát upravte vzhled grafu.

  • Pokud tyto karty nevidíte, kliknutím kamkoliv do histogramu přidejte Nástroje grafu na pás karet.

Karty Návrh a Formát pro Nástroje grafu

  1. Klikněte pravým tlačítkem myši na vodorovnou osu grafu, klikněte na Formát osya potom na Možnosti osy.

    Příkaz Formátovat osu v místní nabídce
  2. Pomocí informací v této tabulce rozhodněte, jaké možnosti chcete v podokně úloh Formát osy nastavit.

    Možnost

    Popis

    Podle kategorie:

    Tuto možnost vyberte, pokud jsou kategorie (vodorovná osa) místo číselných. Histogram seskupí stejné kategorie a na ose hodnot vynese součet hodnot.

    Tip: Pokud chcete spočítat výskyty textových řetězců, přidejte sloupec a vyplňte ho hodnotou 1, pak vykreslete histogram a nastavte intervaly na Podle kategorie.

    Automaticky:

    Toto je výchozí nastavení histogramů. Šířka přihrádky se vypočítá pomocí standardního referenčního pravidla Scott.

    Šířka intervalu:

    Zadejte kladné desetinné číslo pro počet datových bodů v každém rozsahu.

    Počet intervalů:

    Zadejte počet intervalů histogramu (včetně intervalů přetečení a podtečení).

    Interval přetečení:

    Zaškrtnutím tohoto políčka vytvoříte přihrádku pro všechny hodnoty nad hodnotou v poli vpravo. Pokud chcete hodnotu změnit, zadejte do pole jiné desetinné číslo.

    Interval podtečení:

    Zaškrtněte toto políčko, pokud chcete vytvořit přihrádku pro všechny hodnoty pod nebo za hodnotu v poli vpravo. Pokud chcete hodnotu změnit, zadejte do pole jiné desetinné číslo.

    Podokno úloh Formát osy

Tip: Pokud si chcete přečíst další informace o grafu histogramu a o tom, jak vám pomůže vizualizovat statistická data, podívejte se na tento příspěvek na blog v obrazci, Paretova týmu a krabicovém grafu . Můžete se taky dozvědět víc o dalších nových typech grafů popsaných v tomto příspěvku na blogu.

Automatická možnost (Scott – normální referenční pravidlo)   

Možnost vzorce pro automatický výpočet

Scottovo normální referenční pravidlo se snaží minimalizovat odchylku histogramu v porovnání se sadou dat s předpokládaným normálním rozdělením.

Možnost přihrádka přetečení   

Vzorec pro možnost Přetečení přihrádky

Možnost přihrádka podtečení   

Vzorec pro možnost Podtečení přihrádky
  1. Ujistěte se, že jste načetli analytické aplikace. Další informace najdete v článku zavedení doplňku Analytické aplikace v Excelu.

  2. V listu zadejte do jednoho sloupce vstupní data. První buňka může obsahovat popisek.

    Použijte kvantitativní číselná data, například množství položek nebo skóre dosažená v testech. Nástroj Histogram nepracuje s kvalitativními číselnými daty, například s identifikačními čísly zadanými jako text.

  3. Do dalšího sloupce zadejte čísla tříd seřazená vzestupně. První buňka může obsahovat popisek.

    Doporučujeme použít vlastní čísla tříd, protože mohou být užitečnější pro vaši analýzu. Pokud nezadáte čísla tříd, nástroj Histogram vytvoří rovnoměrně rozdělené intervaly tříd použitím minimální a maximální hodnoty ve vstupní oblasti jako počátečního a koncového bodu.

  4. Klikněte na Data > Analýza dat.

    Skupina Analýza – tlačítko Analýza dat

  5. Klikněte na Histogram > OK.

    Dialogové okno Analýza dat

  6. Ve skupinovém rámečku Vstup udělejte tohle:

    1. Do pole Vstupní oblast zadejte odkaz na oblast buněk, která obsahuje vstupní čísla.

    2. Do pole Hranice tříd zadejte odkaz na oblast buněk, která obsahuje čísla tříd.

      Pokud jste v listu použili popisky sloupců, můžete je zahrnout do odkazů na buňky.

      Tip: Místo abyste zadávali odkazy ručně, můžete kliknutím na tlačítko Obrázek tlačítka dočasně zmenšit dialogové okno a vybrat oblasti v listu. Dalším kliknutím na toto tlačítko se dialogové okno zase rozbalí.

  7. Pokud jste do odkazů na buňky zahrnuli popisky sloupců, zaškrtněte políčko Popisky.

  8. Ve skupinovém rámečku Možnosti výstupu zvolte umístění výstupu.

    Histogram můžete umístit na stejný list, na nový list v aktuálním sešitu nebo na list v novém sešitu.

  9. Zaškrtněte některé z těchhle políček:

    Pareto (tříděný histogram): Data se zobrazí v sestupném pořadí frekvencí.

    Kumulativní procentuální podíl:     Zobrazí se kumulativní procentuální podíly a do grafu histogramu se přidá čára pro kumulativní procentuální podíl.

    Vytvořit graf:     Zobrazí se vložený graf histogramu.

  10. Klikněte na OK.

    Pokud chcete histogram přizpůsobit, můžete změnit textové popisky a Kliknutím kamkoli do grafu histogramu použít tlačítka prvky grafu, styly grafua tlačítko filtru grafu na pravé straně grafu.

  1. Vyberte data.

    (Typickým příkladem dat histogramu)

    Data použitá k vytvoření ukázky histogramu nahoře
  2. Klikněte na Vložení > Graf.

    Tlačítko Graf ve skupině Ilustrace na kartě Vložit ve Wordu
  3. V dialogovém okně Vložit graf klikněte v části všechny grafyna histogram a potom klikněte na OK.

Tipy: 

  • Pomocí karet Návrh a Formát na pásu karet můžete přizpůsobit vzhled grafu.

  • Pokud tyto karty nevidíte, kliknutím kamkoliv do histogramu přidejte Nástroje grafu na pás karet.

Karty Návrh a Formát pro Nástroje grafu

  1. Klikněte pravým tlačítkem myši na vodorovnou osu grafu, klikněte na Formát osya potom na Možnosti osy.

    Příkaz Formátovat osu v místní nabídce
  2. Pomocí informací v této tabulce rozhodněte, jaké možnosti chcete v podokně úloh Formát osy nastavit.

    Možnost

    Popis

    Podle kategorie:

    Tuto možnost vyberte, pokud jsou kategorie (vodorovná osa) místo číselných. Histogram seskupí stejné kategorie a na ose hodnot vynese součet hodnot.

    Tip: Pokud chcete spočítat výskyty textových řetězců, přidejte sloupec a vyplňte ho hodnotou 1, pak vykreslete histogram a nastavte intervaly na Podle kategorie.

    Automaticky:

    Toto je výchozí nastavení histogramů.

    Šířka intervalu:

    Zadejte kladné desetinné číslo pro počet datových bodů v každém rozsahu.

    Počet intervalů:

    Zadejte počet intervalů histogramu (včetně intervalů přetečení a podtečení).

    Interval přetečení:

    Zaškrtnutím tohoto políčka vytvoříte přihrádku pro všechny hodnoty nad hodnotou v poli vpravo. Pokud chcete hodnotu změnit, zadejte do pole jiné desetinné číslo.

    Interval podtečení:

    Zaškrtněte toto políčko, pokud chcete vytvořit přihrádku pro všechny hodnoty pod nebo za hodnotu v poli vpravo. Pokud chcete hodnotu změnit, zadejte do pole jiné desetinné číslo.

    Podokno úloh Formát osy

Tip: Pokud si chcete přečíst další informace o grafu histogramu a o tom, jak vám pomůže vizualizovat statistická data, podívejte se na tento příspěvek na blog v obrazci, Paretova týmu a krabicovém grafu . Můžete se taky dozvědět víc o dalších nových typech grafů popsaných v tomto příspěvku na blogu.

Pomocí těchto kroků vytvořte histogram v Excelu pro Mac:

  1. Vyberte data.

    (Typickým příkladem dat histogramu)

    Data použitá k vytvoření ukázky histogramu nahoře
  2. Na pásu karet klikněte na kartu vložení a potom na Ikona statistického grafu (Statistická ikona) a v části histogramvyberte histogram.

Tipy: 

  • Pomocí karet Návrh grafu a Formát upravte vzhled grafu.

  • Pokud karty návrh a Formátgrafu nevidíte, přidejte je na pás karet Kliknutím kamkoli do histogramu.

Pokud chcete vytvořit histogram v Excelu 2011 pro Mac, budete muset stáhnout doplněk od jiného výrobce. Další podrobnosti najdete v tématu o analytickém doplňku v excelu 2011 pro Mac .

V Excel Online můžete zobrazit histogram (sloupcový graf, který zobrazuje data kmitočtu), ale nemůžete ho vytvořit, protože vyžaduje analytické doplňky, Excel doplněk, který není Excel Online podporovaný.

Pokud máte desktopovou aplikaci Excel, můžete pomocí tlačítka Upravit v aplikaci Excel otevřít Excel na ploše a vytvořit histogram.

Tlačítko pro úpravy v Excelu

  1. Klepnutím vyberte data.

    Data použitá k vytvoření ukázky histogramu nahoře
  2. Pokud jste na telefonu, zobrazte pás karet klepnutím na ikonu pro úpravy Ikona Upravit . a klepněte na Domů.

  3. Klepněte na vložit > grafy > histogramu.

    V případě potřeby můžete prvky grafu přizpůsobit.

    Poznámka: Tato funkce je dostupná jenom v případě, že máte předplatné Office 365. Pokud předplatné Office 365 máte, zkontrolujte si, jestli máte nejnovější verzi Office.

    Vyzkoušejte Office 365 nebo nejnovější verzi Excelu

  1. Klepnutím vyberte data.

    Data použitá k vytvoření ukázky histogramu nahoře
  2. Pokud jste na telefonu, klepněte na ikonu pro úpravy Ikona Upravit pro zobrazení pásu karet a potom klepněte na Domů.

  3. Klepněte na vložit > grafy > histogramu.

Pokud chcete vytvořit histogram v Excel, zadejte dva typy dat – data, která chcete analyzovat, a čísla přihrádek, která představují intervaly, podle kterých chcete měřit frekvenci. Data musíte uspořádat do dvou sloupců na listu. Tyto sloupce musí obsahovat následující údaje:

  • Vstupní data    Toto jsou data, která chcete analyzovat pomocí nástroje Histogram.

  • Čísla přihrádek    Tato čísla představují intervaly, které má nástroj histogram použít k měření vstupních dat v analýze dat.

Při použití nástroje Histogram Excel spočítá počet datových bodů v každé datové přihrádce. Datový bod je obsažený v určité přihrádce, pokud je číslo větší než nejnižší mez a je rovna nebo menší než největší mez datové přihrádky. Pokud vynecháte oblast, Excel vytvoří sadu rovnoměrně distribuovaných přihrádek mezi minimální a maximální hodnotou vstupních dat.

Výstup analýzy histogramu se zobrazí na novém listu (nebo v novém sešitu) a zobrazuje tabulku histogramu a sloupcový graf, který odráží data v tabulce histogram.

Potřebujete další pomoc?

Kdykoli se můžete zeptat některého odborníka v technické komunitě Excelu, získat podporu v komunitě pro odpovědi, případně navrhnout novou funkci nebo vylepšení na fóru Excel User Voice.

Poznámka:  Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát vědět, jestli vám informace pomohly? Pokud chcete, můžete se podívat na anglickou verzi článku.

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×