Vytvoření externího odkazu (propojení) na oblast buněk v jiném sešitu

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Odkazovat na obsah buněk v jiném sešitu lze vytvořením externího odkazu. Externí odkaz (propojení) je odkaz na buňku nebo na oblast buněk v listu jiného sešitu aplikace Excel nebo odkaz na zadaný název jiného sešitu. Odkazovat lze na konkrétní oblast buněk, definovaný název oblasti buněk nebo lze definovat název pro externí odkaz.

Co chcete udělat?

Zobrazit další informace o externích odkazech

Vytvoření externího odkazu mezi buňkami v různých sešitech

Vytvoření externího odkazu na název definovaný v jiném sešitu

Definovat název obsahující externí odkaz na buňky v jiném sešitu

Další informace o externích odkazech

Ačkoli jsou externí odkazy podobné odkazům na buňky, existují mezi těmito druhy odkazů podstatné rozdíly. Externí odkazy se používají při práci s velkým množstvím dat nebo se složitými vzorci uloženými v několika sešitech. Tyto odkazy se tvoří jiným způsobem a mají jiný vzhled v buňkách a v Řádek vzorců.

Vhodná použití externích odkazů

Externí odkazy jsou užitečné především tehdy, není-li praktické uchovávat velké modely v listech společně ve stejném sešitu.

  • Sloučení dat z několika sešitů    Můžete propojit sešity několika uživatelů nebo oddělení a příslušná data začlenit do souhrnného sešitu. Tímto způsobem, když se při změně zdrojových sešitech nemají ručně změnit souhrnné sešitu.

  • Vytvoření různých zobrazení dat:     Můžete zadat všechna data do jednoho nebo více zdrojových sešitů a potom vytvořit sešit sestav, který bude obsahovat externí odkazy pouze na příslušná data.

  • Zjednodušení rozsáhlých, složitých modelů:     Pokud rozložíte složitý model do řady vzájemně závislých sešitů, můžete s modelem pracovat, aniž by bylo nutné otevírat všechny příslušné listy. Menší sešity se snadněji mění, nevyžadují tolik paměti, rychleji se otevírají, ukládají a vypočítávají.

Způsoby vytváření externích odkazů

Pokud k vytvoření externího odkazu použijete odkaz na buňky, můžete dané informace použít ve vzorcích. Přepínáním různých typů odkazů na buňky můžete při přesunutí externího odkazu také kontrolovat, které buňky jsou propojeny. Pokud například použijete relativní odkaz, pak po přesunutí externího odkazu buňka nebo buňky, ke kterým propojení směřuje, zohlední novou polohu odkazu v listu.

Při vytváření externího odkazu z jednoho sešitu do jiného sešitu byste měli použít název odkazující na buňky, se kterými vytváříte propojení. Externí odkaz můžete vytvořit pomocí již existujícího názvu nebo si můžete název definovat při vytváření externího odkazu. Pomocí názvu si snáze zapamatujete obsah buněk, ke kterým propojení směřuje. Externí odkazy, které používají definované názvy se při přesunutí nezmění, protože název odkazuje na konkrétní buňku nebo oblast buněk. Pokud chcete, aby se externí odkaz využívající definovaný název při přesunutí změnil, můžete změnit název použitý v externím odkazu nebo buňky, na které název odkazuje.

Vzhled externího odkazu na jiný sešit

Vzorce obsahující externí odkazy na jiné sešity jsou v závislosti na tom, zda je zdrojový sešit (poskytující data do vzorce) otevřený v aplikaci Excel nebo zavřený, zobrazovány dvěma způsoby.

Pokud je zdroj otevřený v aplikaci Excel, obsahuje externí odkaz název sešitu v hranatých závorkách ([ ]). Za ním následuje název listu, vykřičník (!) a buňky, na kterých vzorec závisí. Následující vzorec například sečte buňky z oblasti C10:C25 sešitu s názvem Rozpočet.xlsx.

Externí odkaz

=SUMA([Rozpočet.xlsx]Roční!C10:C25)

Není-li zdroj otevřený v aplikaci Excel, obsahuje externí odkaz celou cestu.

Externí odkaz

=SUMA('C:\Sestavy\[Rozpočet.xlsx]Roční'!C10:C25)

Poznámka : Jestliže název jiného listu nebo sešitu obsahuje jiné než abecední znaky, je nutné název (cestu) uzavřít do jednoduchých uvozovek (').

Ve vzorcích obsahujících propojení na definovaný Název v jiném sešitu je použit název sešitu, za kterým následuje vykřičník (!) a příslušný název. Následující vzorec například sečte buňky z oblasti s názvem Prodej v sešitu s názvem Rozpočet.xlsx.

Externí odkaz

=SUMA(Rozpočet.xlsx!Prodej)

Začátek stránky

Vytvoření externího odkazu mezi buňkami v různých sešitech

  1. Otevřete sešit, který bude obsahovat externí odkaz (cílový sešit) a sešit obsahující data, na která chcete vytvořit propojení (zdrojový sešit).

  2. Ve zdrojovém sešitě klikněte na Uložit Obrázek tlačítka na panelu Nástrojů Rychlý přístup.
    Klávesová zkratka:    stiskněte kombinaci kláves CTRL + S.

  3. Vyberte buňky, ve kterých chcete vytvořit externí odkaz.

  4. Zadejte znak = (rovná se). Pokud chcete provést výpočty s hodnotou externího odkazu nebo ji chcete použít ve funkci, zadejte Operátor nebo funkci, která má externímu odkazu předcházet.

  5. Přejděte do zdrojového sešitu a potom klepněte na list obsahující buňky, na které chcete vytvořit propojení.

  6. Vyberte buňku nebo buňky obsahující data, na která chcete vytvořit propojení.

  7. Vraťte se do cílového sešitu a všimněte si, že aplikace Excel přidala odkaz na zdrojový sešit a na buňky, které jste vybraly v předchozím kroku.

  8. V cílovém listu můžete také upravovat nebo měnit vzorec.

  9. Stiskněte kombinaci kláves CTRL+SHIFT+ENTER.

Začátek stránky

Vytvoření externího odkazu na název definovaný v jiném sešitu

  1. Otevřete sešit, který bude obsahovat externí odkaz (cílový sešit) a sešit obsahující data, na která chcete vytvořit propojení (zdrojový sešit).

  2. Ve zdrojovém sešitě klikněte na Uložit Obrázek tlačítka na panelu Nástrojů Rychlý přístup.
    Klávesová zkratka:    stiskněte kombinaci kláves CTRL + S.

  3. Vyberte buňky, ve kterých chcete vytvořit externí odkaz.

  4. Zadejte znak = (rovná se). Pokud chcete provést výpočty s hodnotou externího odkazu nebo ji chcete použít ve funkci, zadejte operátor nebo funkci, která má externímu odkazu předcházet.

  5. Na kartě Zobrazení ve skupině Okno klepněte na příkaz Přepnout okna, klepněte na zdrojový sešit a potom klepněte na list obsahující buňky, na které chcete vytvořit propojení.

    Skupina Okno na kartě Zobrazení

  6. Stiskněte klávesu F3 a vyberte název, na který chcete vytvořit propojení.

Začátek stránky

Zadání názvu, který obsahuje externí odkaz na buňky v jiném sešitu

  1. Otevřete cílový sešit i zdrojový sešit.

  2. V cílovém sešitě klepněte na kartě Vzorce ve skupině Definované názvy na položku Definovat název.

    Vzhled pásu karet aplikace Excel

  3. V dialogovém okně Nový název zadejte do pole Název název oblasti.

  4. Odstraňte obsah pole Odkaz na a ponechejte v něm kurzor.

    Pokud název obsahuje vzorec, zadejte jej a umístěte ukazatel na místo, kde se má nacházet externí odkaz. Zadejte například vzorec =SUMA() a umístěte ukazatel do závorek.

  5. Na kartě Zobrazení ve skupině Okno klepněte na příkaz Přepnout okna, klepněte na zdrojový sešit a potom klepněte na list obsahující buňky, na které chcete vytvořit propojení.

    Skupina Okno na kartě Zobrazení

  6. Vyberte buňku nebo oblast buněk, na které chcete vytvořit propojení.

  7. V dialogovém okně Nový název klepněte na tlačítko OK.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Sdílení Facebook Facebook Twitter Twitter E-mail E-mail

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×