Vytvoření datového modelu v Excelu

Vytvoření datového modelu v Excelu

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Datový Model je nový přístup pro integrace dat z více tabulek, efektivní vytváření zdroje relačních dat do Excelového sešitu. V aplikaci Excel datové modely se používají transparentně, poskytnutí tabulková data použité v sestavách kontingenční tabulky, kontingenční grafy a Power View. Před začte podrobnosti, můžete chtít trochu a podívejte se na video nebo trvat našeho Průvodce výukové na načíst a transformovat a doplňku Power Pivot.

Poznámka : Tento článek popisuje datových modelech v Excelu 2013. Však stejné modelování dat a doplňku Power Pivot funkcích v Excelu 2013 použít do Excelu 2016. Je efektivně málo rozdíl mezi těchto verzích Excelu.

Většinou o přítomnosti datového modelu ani nebudete vědět. V Excelu je datový model vizualizovaný jako kolekce tabulek v seznamu polí. Pokud s modelem chcete přímo pracovat, budete muset použít doplněk Microsoft Office Power Pivot v Microsoft Excelu 2013.

Při importování relačních dat se model vytvoří automaticky, když vyberete víc tabulek:

  1. Pokud chcete v Excelu importovat data z databáze Accessu nebo jiné relační databáze, ve které je víc souvisejících tabulek, použijte příkaz Data > Načíst externí data.

  2. Excel vás vyzve k výběru tabulky. Zaškrtněte políčko Povolit výběr více tabulek.

    Dialog Vybrat tabulku

  3. Vyberte dvě nebo více tabulek, klikněte na Další a Dokončit.

  4. V dialogu Import Dat vyberte požadovanou možnost vizualizace dat, například kontingenční tabulku v novém listu, a vytvořte sestavu.

Teď máte datový model se všemi naimportovanými tabulkami. Protože jste zvolili možnost Sestava kontingenční tabulky, model se zobrazuje v seznamu polí, který použijete pro vytvoření sestavy kontingenční tabulky.

Seznam polí kontingenční tabulky

Co můžete s tímto modelem dělat? Můžete ho použít k vytvoření kontingenčních tabulek, kontingenčních grafů a sestav nástroje Power View ve stejném sešitu. Můžete ho upravit přidáním nebo odebráním tabulek a pokud používáte doplněk Power Pivot, můžete model rozšířit přidáním počítaných sloupců, počítaných polí, hierarchií a klíčových ukazatelů výkonu (KPI).

Při vytváření datového modelu je důležitá možnost vizualizace. Vizualizace dat získáte díky těmto možnostem: Sestava kontingenční tabulky, Kontingenční graf nebo Sestava nástroje Power View. Tyto možnosti umožňují pracovat se všemi tabulkami společně. Pokud jste místo toho vybrali možnost Tabulka, každá importovaná tabulka bude umístěna do samostatného listu. V daném uspořádání jde tabulky používat jednotlivě. Společné použití tabulek vyžaduje kontingenční tabulku, kontingenční graf nebo sestavu nástroje Power View.

Poznámky : 

  • Modely se vytvářejí implicitně při současném importu dvou nebo víc tabulek do Excelu.

  • Modely se vytvářejí explicitně při použití doplňku Power Pivot mohli importovat data. V doplňku model představuje ve s kartami rozložení, kde jednotlivých kartách obsahuje tabulková data. V tématu získání dat pomocí doplňku Power Pivotse dozvíte základní informace o importu dat pomocí databáze SQL serveru.

  • Model může obsahovat jednu tabulku. Pokud chcete vytvořit model jen s jednou tabulkou, vyberte tabulku a v doplňku Power Pivot klikněte na Přidat do datového modelu. Tento postup využijete, pokud chcete použít funkce doplňku Power Pivot, například filtrované datové sady, počítané sloupce, počítaná pole, klíčové ukazatele výkonu a hierarchie.

  • Relace tabulek jde vytvářet automaticky, pokud jste importovali související tabulky, které mají relace primárních a cizích klíčů. Excel obvykle dokáže použít informace o importovaných relacích jako základ pro relace tabulek v datovém modelu.

  • Tipy ke zmenšení velikosti datového modelu najdete v tématu Vytvoření efektivně využívajícího paměť datového modelu pomocí Excelu 2013 a doplňku Power Pivot.

  • Další informace najdete v tématu kurz: Analýza dat kontingenční tabulky pomocí datového modelu v Excelu 2013.

Tip : Sešit obsahuje data, ale můžete poznám, jestli obsahuje datový Model? Stav modelu můžete rychle zjistit tak, že otevřením okna Power Pivot. Pokud data se zobrazí na kartách, existuje model. Další informace o zjistit, jaká data zdroje se používají v datovém modelu sešitu.

Použití datového modelu v jiné kontingenční tabulce, kontingenčním grafu a sestavě nástroje Power View

Sešit Excelu může obsahovat jen jeden datový model, ale tento model jde opakovaně použít v celém sešitu.

  1. V Excelu postupně klikněte na Vložit > Kontingenční tabulka.

  2. V okně Vytvořit kontingenční tabulku klikněte na Použít externí zdroj dat a potom klikněte na Vybrat připojení.

  3. V možnosti Stávající připojení klikněte na Tabulky.

  4. V nabídce Datový model sešitu je jako výchozí vybraná možnost Tabulky v datovém modelu sešitu. Klikněte na Otevřít a potom na OK. Zobrazí se seznam Pole kontingenční tabulky, který zobrazuje všechny tabulky v modelu.

Přidání stávajících nesouvisejících dat do datového modelu

Předpokládejme, že jste importovali nebo zkopírovali velké množství dat, která chcete použít v modelu, ale při importu jste nezaškrtli políčko Přidat data do datového modelu. Vložení nových dat do modelu je snadnější, než si myslíte.

  1. Začněte s daty, která chcete přidat do modelu. Můžete použít libovolný rozsah dat, ale doporučujeme použít pojmenovaný rozsah.

  2. Označte buňky, které chcete přidat, nebo – pokud jsou data v tabulce nebo pojmenovaném rozsahu – umístěte kurzor do buňky.

  3. K přidání dat použijte jeden z těchto postupů:

  4. Klikněte na Power Pivot > Přidat do datového modelu.

  5. Klikněte na Vložit > Kontingenční tabulka a potom v dialogu Vytvořit kontingenční tabulku zaškrtněte políčko Přidat data do datového modelu.

Oblasti nebo tabulce je nyní přidán do modelu jako propojené tabulky. Další informace o práci s propojenými tabulkami v modelu, najdete v článku Přidání dat o používání Excel propojené tabulky v doplňku Power Pivot.

Upřesnění a rozšíření datového modelu v doplňku Power Pivot

Datové modely v Excelu umocňují a obohacují práci se sestavami, zejména když obsahují kontingenční tabulky nebo jiné formáty sestav, které slouží ke zkoumání a analýze dat. I přes svůj význam zůstávají datové modely záměrně v pozadí, takže se můžete soustředit na to, co s nimi chcete dělat.

Předpokládejme ale, že chcete pracovat přímo s modelem. Za předpokladu, že je seznam polí založený na modelu, můžete třeba chtít odebrat tabulky nebo pole, protože nejsou v seznamu užitečné. Chcete třeba zobrazit všechna podkladová data, která model poskytuje, nebo přidat klíčové ukazatele výkonu, hierarchie a obchodní logiku. Ze všech těchto i mnoha dalších důvodů budete upravovat přímo datový model.

Upravit nebo spravovat datový Model, můžete doplněk Power Pivot. Doplněk je součástí Office Professional Plus verzi Excelu 2013, ale není povolený ve výchozím nastavení. Další informace o Spusťte Power Pivot in Microsoft Excel doplňku.

Rozdíly mezi tabulkou doplňku Power Pivot a tabulkou v listu

V Power Pivot nemůžete přidat řádku do tabulky zadáním přímo na nový řádek, jako je možné v Excelovém listu. Ale může přidat řádků pomocí příkazů Vložit a aktualizace dat.

Data v listu Excelu jsou často proměnlivá a nepravidelná: jeden řádek může obsahovat číselná data a další řádek může obsahovat grafiku nebo textový řetězec. Tabulka v doplňku Power Pivot je na rozdíl od toho podobnější relační databázi, kde každý řádek má stejný počet sloupců a většina sloupců obsahuje data.

Použití datového modelu v nástroji Power View

Datový model slouží jako základ pro sestavu nástroje Power View. Použitím doplňku Power Pivot můžete optimalizovat model a zlepšit vytváření sestav nástroje Power View. Optimalizace zahrnuje: Zadání výchozího seznamu polí, výběr reprezentativních polí nebo obrázků, které umožní jedinečnou identifikaci řádků, nebo zadání způsobu, jakým jsou v aplikaci pro vytváření sestav zpracovány řádky s opakujícími se hodnotami (například zaměstnanci nebo zákazníci se stejným jménem).

  1. Datový model vytvořte naimportováním několika souvisejících tabulek.

  2. Kliknutím na Power Pivot > Spravovat otevřete okno Power Pivot.

  3. Vyberte tabulku a použijte optimalizaci:

    1. Klikněte na Upřesnit > sada výchozích polí. Vyberte pole, která by se měly automaticky v sestavě Power View po kliknutí na nadřazené tabulce. Další informace najdete v článku Konfigurace sady výchozích polí pro sestavy nástroje Power View .

    2. Klikněte na Upřesnit > chování tabulky. Optimalizace pro sestavy rozložení, které data seskupit. Seskupení podléhá výchozí chování, které někdy vyrobeno neočekávané výsledky, například sloučení řádky, které by měl být uveden samostatně. Další informace najdete v článku Konfigurace vlastností chování tabulky u sestav Power View .

    3. Klikněte na Upřesnit > Kategorie dat. Některé vizualizace sestav závisí na typu dat. Pokud máte například tabulku založenou na čase či kalendářním datu, můžete přiřadit kategorii Datum, která pomáhá nástroji Power View při vizualizacích založených na časech.

  4. Opakujte postup pro další tabulky.

  5. V aplikaci Excel, klikněte na Vložit > Power View zahajte novou zprávu. V tématu Power View: zkoumání, vizualizace a prezentace dat Další informace.

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×