Vytvoření řešení pro sledování majetku pomocí aplikací InfoPath a Excel

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Microsoft Office InfoPath umožňuje vytvářet šablony formulářů pro zadávání a shromažďování dat. Microsoft Office Excel 2007 umožňuje uživatelům provádět výpočty, vytvářet grafy a analyzovat data. Pomocí těchto dvou aplikací a jazyka XML můžete snadno a bez programování navrhnout jednoduché, ale účinné firemní řešení pro sledování firemního majetku.

základní informace o řešení ke sledování majetku

V tomto článku

Úvod k tvorbě řešení pro sledování majetku

Krok 1: Přizpůsobení šablony formuláře Přehled majetku

Krok 2: Namapování souboru schématu a přizpůsobení rozložení tabulky v Excelu

Krok 3: Vytvoření souhrnné sestavy kontingenční tabulky a kontingenčního grafu

Krok 4: Shromáždění informací o majetku od uživatelů

Krok 5: Import formulářů do Excelu

Závěrečné úvahy: Možnost použití seznamu SharePointu nebo databáze Accessu

Úvod k tvorbě řešení pro sledování majetku

Mezi aplikacemi InfoPath a Excel můžete přenášet data ve formátu XML. Aplikace InfoPath sice nabízí jednoduché a nekomplikované odeslání dat formuláře do aplikace Excel příkazem Exportovat, můžete ale zvolit i jiný přístup, který vám poskytne výrazně větší flexibilitu. Když v aplikaci Excel explicitně namapujete soubor schématu XML aplikace InfoPath (XSD) a poté do Excelu importujete soubory formuláře aplikace InfoPath (XML), můžete si přizpůsobit rozložení dat a lépe využít funkce Excelu k efektivní správě a analýze dat.

V tomto článku na příkladu formuláře Přehled majetku ilustrujeme, jak můžete využít kombinaci technologií InfoPath, XML a Excel. Představte si, že vaše organizace každoročně provádí inventuru majetku v kancelářích jednotlivých zaměstnanců. Poté se spustí sestava v Excelu, jejíž výsledky pomohou při rozhodování, jaký rozpočet na vybavení zaměstnancům přidělit v následujícím roce. Diagram níže přehledně ukazuje, jak můžete shromáždit, sledovat a vykázat údaje o majetku ve vašem oddělení.

a

1. Je vytvořena šablona formuláře Přehled majetku.

2. Soubor schématu je namapován k tabulce aplikace Excel a rozložení tabulky se vhodně přizpůsobí.

3. Je vytvořena prázdná souhrnná sestava kontingenční tabulky a kontingenčního grafu.

4. Pomocí formuláře Přehled majetku se shromáždí data od uživatelů.

5. Všechna data z formuláře se exportují do tabulky v Excelu a sestavy kontingenční tabulky a kontingenčního grafu se aktualizují.

Toto řešení zahrnuje následující uživatelské role a produkty:

Ikona úplné podpory = Povinné Ikona nepodporování = Není vyžadováno

Požadavky na software

Role

Office InfoPath 2007

Office Outlook 2007

Office Excel 2007

Tvůrce návrhu řešení

Ikona úplné podpory

Ikona úplné podpory

Ikona úplné podpory

Pracovník s rozhodovacími pravomocemi

Ikona úplné podpory

Ikona úplné podpory

Ikona úplné podpory

Zaměstnanci

Ikona úplné podpory

Ikona úplné podpory

Ikona nepodporování

Začátek stránky

Krok 1: Přizpůsobení šablony formuláře Přehled majetku

Šablona formuláře Přehled majetku, která je součástí aplikace InfoPath, umožňuje shromažďovat informace o jednotlivých položkách majetku v kanceláři zaměstnance. Zaznamenává oddělení, kam zaměstnanec náleží, kategorie majetku a podrobnosti o každé položce majetku. V tomto řešení odešle tvůrce formuláře šablonu na e-mailový účet pracovníka s rozhodovací pravomocí pomocí aplikace Office Outlook 2007.

Šablona sledování majetku

Úkol 1: Otevření a přizpůsobení šablony formuláře Přehled majetku

Vzhledem k tomu, že šablonu formuláře obsahující ovládací prvek pole s formátovaným textem a odkazy na obrázky nelze publikovat pro seznam příjemců e-mailu, je třeba v ukázkové šabloně formuláře Přehled majetku udělat drobnou změnu.

  1. V nabídce Soubor klikněte na příkaz Navrhnout šablonu formuláře.

  2. V dialogovém okně Navrhnout šablonu formuláře klikněte v části Otevřít šablonu formuláře na odkaz Přizpůsobit ukázkový formulář.

  3. V dialogovém okně Začínáme klikněte na Ukázka – Přehled a potom v části Úkoly formulářů klikněte na Navrhnout tento formulář.

  4. Klikněte pravým tlačítkem na ovládací prvek assetNotes, přejděte na vlastnosti pole s formátovaným textem, klikněte na kartu Zobrazení a potom v části Dostupné formátování zrušte zaškrtnutí políčka Propojené obrázky.

Úkol 2: Určení možností odeslání

Dalším úkolem je definovat možnosti odeslání, aby zaměstnanci mohli odeslat na e-mailový účet pracovníka s rozhodovací pravomocí jednoznačně pojmenovaný soubor formuláře (XML).

  1. V nabídce Nástroje klikněte na Možnosti odeslání.

  2. V dialogovém okně Možnosti odeslání zaškrtněte políčko Povolit uživatelům odeslat tento formulář.

  3. Klepněte na položku Odeslat data formuláře do jednoho umístění a poté v seznamu vyberte možnost E-mail.

  4. Klepněte na tlačítko Přidat.

    Zobrazí se Průvodce datovým připojením.

  5. Do pole Komu zadejte alias pracovníka s rozhodovacími pravomocemi, který bude přijímat všechny odeslané formuláře.

  6. Nastavte jedinečný předmět každého e-mailu: v poli Předmět

    • klikněte na tlačítko Vložit vzorec Obrázek tlačítka .

    • Zadejte následující vzorec:

concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)

  • Klikněte na příkaz Ověřit vzorec a poté dvakrát na tlačítko OK.

  • Do pole Úvod zadejte požadovanou zprávu, případně přidejte důležité pokyny k tomuto řešení.

  • Klepněte na tlačítko Další.

  • Na další stránce průvodce klikněte na možnost Odeslat data formuláře jako přílohu a zaškrtněte políčko Připojit šablonu formuláře, aby uživatelé mohli formulář otevřít.

    Zajistíte tak, aby zaměstnanci měli k dispozici soubor šablony formuláře (XSN) v případě, že budou mít potíže otevřít jej ze síťového umístění.

  • Nastavte jedinečný název každého souboru formuláře (XML): v poli Název přílohy

    1. klikněte na tlačítko Vložit vzorec Obrázek tlačítka .

    2. Zadejte stejný vzorec jako v řádku Předmět:

concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)

  1. Klikněte na příkaz Ověřit vzorec a poté dvakrát na tlačítko OK.

  • Klepněte na tlačítko Další.

  • Na další stránce průvodce zadejte do pole Zadejte název tohoto datového připojení popisný název tohoto datového připojení pro odesílání.

  • Ověřte správnost informací v oddílu Shrnutí a klikněte na tlačítko Dokončit.

  • Uložte formulář do veřejné síťové složky přístupné jak pracovníkovi s rozhodovacími pravomocemi, tak všem zaměstnancům.

Začátek stránky

Krok 2: Namapování souboru schématu a přizpůsobení rozložení tabulky v Excelu

Nastavení připojení mezi aplikacemi InfoPath a Excel vyžaduje provést tři úkoly: extrahovat soubor schématu pro šablonu formuláře Přehled majetku, namapovat tento soubor schématu do aplikace Excel a přizpůsobit výchozí rozložení tabulky v Excelu, ve které se shromáždí všechny importované soubory s daty formulářů XML.

Úkol 1: Extrahování souboru schématu z aplikace InfoPath

  1. V aplikaci InfoPath otevřete soubor šablony formuláře Přehled majetku.

  2. V nabídce Nástroje klikněte na příkaz Navrhnout tento formulář.

  3. V nabídce Soubor klikněte na příkaz Uložit jako zdrojové soubory.

  4. V dialogovém okně Vyhledat složku zaškrtněte složku, kam chcete soubor schématu uložit, nebo vytvořte novou složku.

Poznamenejte si umístění složky, kde jsou uloženy všechny zdrojové soubory, a název souboru schématu, v tomto případě myschema.xsd, který obsahuje definici schématu dat XML ve formuláři.

Úkol 2: Namapování souboru schématu aplikace InfoPath do Excelu

  1. Vytvořte nový excelový soubor a uložte jej do umístění, kam má přístup pracovník s rozhodovacími pravomocemi.

  2. Pokud v Excelu nevidíte kartu Vývojář, zobrazte ji následujícím způsobem:

    1. Klikněte na Tlačítko Microsoft Office Obrázek tlačítka Office a potom na tlačítko Možnosti aplikace Excel.

    2. Ve skupině Nejpoužívanější možnosti při práci s aplikací Excel zaškrtněte v kategorii Oblíbené políčko Zobrazit na pásu kartu Vývojář a poté klepněte na tlačítko OK.

      Poznámka : Pás karet je součástí rozhraní Fluent systému Microsoft Office.

  3. Na kartě Vývojář klepněte ve skupině XML na položku Zdroj.

    Skupina XML na pásu karet

    Zobrazí se podokno úloh Zdroj XML.

  4. Klikněte na Mapování XML a poté v dialogovém okně Mapování XML klikněte na Přidat.

  5. V počítači s Windows Vista    

    1. V adresním řádku klikněte na jednotku nebo složku obsahující soubor myschema.xsd, který jste vytvořili v kroku 2 části Úkol 1: Extrahování souboru schématu z aplikace InfoPath.

      V počítači s Microsoft Windows XP    

    2. V seznamu Oblast hledání klikněte na jednotku nebo složku obsahující soubor myschema.xsd, který jste vytvořili v kroku 2 části Úkol 1: Extrahování souboru schématu z aplikace InfoPath.

  6. Klepněte na příslušný soubor a potom na tlačítko Otevřít.

  7. Jakmile se zobrazí dialogové okno Více kořenů, klikněte na kořenový uzel assetTracking, který je definován v souboru myschema.xsd, a potvrďte kliknutím na tlačítko OK.

    Mapování XML se zobrazí v podokně úloh Zdroj XML.

  8. Přetáhněte element uzlu ns1:asset, což je opakující se element XML, do umístění na listu, kde se má zobrazit excelová tabulka.

    mapování souboru schématu inopath do aplikace excel

Úkol 3: Přizpůsobení rozložení tabulky aplikace Excel

Excelová tabulka ve výchozím nastavení jako názvy elementů XML používá záhlaví sloupců tabulky. Tato záhlaví však můžete změnit tak, že upravíte jejich buňky.

  1. Chcete-li upravit výchozí záhlaví sloupců, ponechte tabulku aplikace Excel vybranou, vyhledejte řetězec předpony ns1:asset a odstraňte jej. Například záhlaví ns1:assetID tedy změníte na ID.

    přizpůsobení záhlaví tabulky aplikace excel

  2. Šířku sloupců upravíte tak, že kliknete na tlačítko Vybrat vše a poté dvakrát kliknete na ohraničení kteréhokoli záhlaví sloupce.

Začátek stránky

Krok 3: Vytvoření souhrnné sestavy kontingenční tabulky a kontingenčního grafu

Pracovníci s rozhodovací pravomocí využívají sestavy kontingenčních tabulek a grafů při analýze, zkoumání a vizualizaci souhrnných dat. Pokud sestavy kontingenční tabulky a grafu, které chcete v tomto scénáři použít, nastavíte předem, bude si analytik později moci jednoduše spustit sestavu se zjištěnými daty.

  1. Vyberte buňku v tabulce aplikace Excel.

  2. Na kartě Vložit klikněte ve skupině Tabulky na položku Kontingenční tabulka a poté klikněte na položku Kontingenční tabulka.

    Vzhled pásu karet aplikace Excel

    V Excelu se zobrazí dialogové okno Vytvořit kontingenční tabulku.

  3. Chcete-li sestavu kontingenční tabulky umístit na nový list počínaje buňkou A1, klikněte na přepínač Nový list a potom na tlačítko OK.

    Aplikace Excel vloží do zadaného místa prázdnou kontingenční tabulku a zobrazí seznam polí kontingenční tabulky, takže můžete přidat pole, vytvořit rozložení a dále kontingenční tabulku přizpůsobit.

  4. Chcete-li vytvořit sestavu dat napříč tabulkami, přetáhněte pole ID do oblasti Hodnoty, pole Oddělení do oblasti Popisky sloupců, pole Kategorie do oblasti Popisky řádek a pole Přiřazeno do oblasti Filtr sestavy.

  5. Klikněte na kontingenční tabulku.

  6. Na kartě Vložit ve skupině Grafy klikněte na typ grafu Pruhový.

    Vzhled pásu karet aplikace Excel

  7. Ve skupinovém rámečku Dvojrozměrný pruhový klikněte na možnost Skupinový pruhový.

  8. Upravte velikost a umístění sestavy kontingenčního grafu podle svých představ.

prázdné sestav kontingenčních tabulek a grafů

Začátek stránky

Krok 4: Shromáždění informací o majetku od uživatelů

Když je teď šablona formuláře připravena na zadání dat, je třeba formulář publikovat a odeslat jednotlivým zaměstnancům. Když zaměstnanci vyplněný formulář vracejí, odesílají jej jako datový soubor XML jako přílohu e-mailové zprávy určené pracovníkovi s rozhodovací pravomocí. Tento pracovník pak může všechny zprávy přesunout do složky, kterou v Outlooku vyhradí aplikaci InfoPath . V tomto případě se doporučuje určit uživatelům termín dokončení formuláře, aby pracovník s rozhodovacími pravomocemi mohl po vypršení termínu spustit sestavu na základě všech vyplněných formulářů.

zadávání dat do formuláře sledování majetku

  1. V aplikaci InfoPath otevřete šablonu formuláře (soubor XSN), kterou jste si uložili v kroku 1: Návrh ukázkové šablony formuláře Přehled majetku

  2. V nabídce Nástroje klikněte na příkaz Navrhnout tento formulář.

  3. V nabídce Soubor klikněte na příkaz Publikovat.

  4. V průvodci publikováním klepněte na možnost Na seznam příjemců e-mailu a klepněte na tlačítko Další.

  5. Na další stránce průvodce zadejte do pole Název šablony formuláře název šablony formuláře a klepněte na tlačítko Další. Název šablony formuláře se zobrazí v předmětu e-mailové zprávy, která je zaslána příjemcům ze seznamu.

  6. Můžete také na další stránce průvodce vytvořit sloupce, které se zobrazí ve složkách aplikace Outlook a usnadní uspořádání e-mailových zpráv.

  7. Klepněte na tlačítko Další.

  8. Klepněte na tlačítko Publikovat.

  9. Po ukončení průvodce publikováním se otevře e-mailová zpráva obsahující formulář.

  10. Napište text, zadejte jména zaměstnanců nebo použijte distribuční seznam a zprávu odešlete.

Pracovník s rozhodovacími pravomocemi může všechny odeslané formuláře XML v aplikaci Outlook uspořádat dvěma způsoby:

  • Pokud se při prvním otevření zprávy zobrazí okno zprávy Složky formulářů aplikace InfoPath, klikněte na Vytvořit složku formulářů.

  • Nastavte v Outlooku pravidlo, které bude všechny související formuláře aplikace InfoPath přesouvat do této složky.

    Další informace naleznete v tématu Správa zpráv pomocí pravidel.

Začátek stránky

Krok 5: Import formulářů do Excelu

Vzhledem k tomu, že jste v krocích 2 a 3 již vytvořili sešit aplikace Excel, pracovník s rozhodovací pravomocí může data formuláře jednoduše exportovat a prohlížet. Stačí, když soubory XML exportuje z Outlooku a importuje je do excelového sešitu a poté data obnoví.

Úkol 1: Export formulářů z Outlooku do složky ve Windows

  1. V Outlooku vyberte složku, která obsahuje všechny formuláře získané od zaměstnanců, a stisknutím kombinace kláves CTRL + A v ní vyberte všechny e-mailové zprávy s formuláři.

  2. Klikněte na výběr pravým tlačítkem, přejděte na příkaz Akce aplikace InfoPath a potom klikněte na Exportovat formuláře.

  3. V dialogovém okně Exportovat formuláře vyberte požadovanou složku a klikněte na tlačítko OK.

Úkol 2: Import formulářů do Excelu

  1. V sešitě aplikace Excel, který jste vytvořili v kroku 2: Namapování souboru schématu a přizpůsobení rozložení tabulky v Excelu, vyberte v excelové tabulce některou z namapovaných buněk.

  2. Na kartě Vývojář klikněte ve skupině XML na položku Import.

    Skupina XML na pásu karet

    Zobrazí se dialogové okno Importovat XML.

  3. V počítači s Windows Vista    

  4. Proveďte jednu z následujících akcí:

    • Pokud jsou soubory uspořádány pod sebou, podržte klávesu SHIFT a klikněte na první a poslední soubor v seznamu.

    • Pokud spolu soubory nesousedí, podržte klávesu CTRL a klikněte v seznamu na každý soubor, který chcete importovat.

  5. Klepněte na tlačítko Importovat.

    Tabulka importovaná data aplikace Excel

Ve výchozím nastavení Excel přepíše případné stávající údaje v mapovaných buňkách, což je v tomto podnikovém řešení žádoucí konečný výsledek. Pracovník s rozhodovacími pravomocemi by ovšem mohl také chtít importovat data několikrát a sledovat vývoj inventury ještě před vypršením konečného termínu.

Poznámka : V aplikaci Excel proto můžete data rovněž připojit, což je v některých situacích vhodnější. Slouží k tomu volba Připojit nová data k existujícím tabulkám XML (na kartě Vývojář ve skupině XML klikněte na Vlastnosti mapování).

Další informace najdete v tématech nápovědy aplikace Excel Import dat XML a Připojení nebo přepsání namapovaných dat XML.

Úkol 3: Obnovení sestav kontingenční tabulky a kontingenčního grafu

  • Klikněte na některou buňku v sestavě kontingenční tabulky.

  • Na kartě Možnosti klikněte ve skupině Data na šipku vedle tlačítka Aktualizovat vše a potom klikněte na příkaz Aktualizovat.

    Pás karet v aplikaci Outlook

konečnou sestavu kontingenční tabulky a kontingenčního grafu

Excelový sešit teď obsahuje všechna data a souhrnné sestavy, které potřebujete jako podklady k rozdělení rozpočtu na vybavení na další rok. V sešitě samozřejmě provádět další analýzy podle svých potřeb a využívat při tom řazení, filtrování nebo podmíněné formátování dat.

Začátek stránky

Závěrečné úvahy: Možnost použití seznamu SharePointu nebo databáze Accessu

Jako alternativu můžete zvážit, že k přenosu dat mezi aplikacemi InfoPath a Excel použijete místo formulářů XML databázi aplikace Access nebo seznam SharePointu.

Použití seznamu SharePointu

V aplikaci InfoPath se dá seznam služby SharePoint jednoduše použít jako zdroj dat jen pro čtení. Máte na výběr dva přístupy:

  • Ze seznamu SharePointu exportujte data do Excelu, čímž se v Excelu automaticky vytvoří datové připojení.

  • V Excelu datové připojení k seznamu SharePointu explicitně vytvořte.

Po vytvoření datového připojení můžete aktualizovat data v Excelu a načíst tak aktuální data.

Seznam SharePointu můžete použít k přidání a aktualizaci dat, formulář aplikace InfoPath pak zajistí zobrazení položky ze seznamu (například složité nebo dlouhé položky je nejlepší zobrazit svisle). V Excelu pak můžete data analyzovat podrobněji.

kombinující aplikace infopath, sharepointového seznamu a aplikace excel

1. Zobrazte jednu položku, kterou jednoduše zkontrolujete v aplikaci InfoPath.

2. Přidejte data do seznamu SharePointu a aktualizujte je.

3. Aktualizujte data a vytvořte aktuální sestavu v Excelu.

Další informace najdete v tématech Přidání datového připojení k seznamu nebo knihovně dokumentů služby SharePoint a Import dat ze seznamu služby SharePoint.

Použití databáze aplikace Access

Z aplikace InfoPath můžete vytvořit připojení pro čtení i zápis k databázi aplikace Access. Z aplikace Excel můžete naopak explicitně vytvořit datové připojení k databázi aplikace Access. Jeho obnovením pak načtete aktuální data. Můžete dokonce definovat připojení tak, aby se automaticky aktualizovalo při otevření sešitu nebo v pravidelných intervalech, třeba každých pět minut.

Databázi aplikace Access můžete použít jako zprostředkovatele mezi aplikacemi InfoPath a Excel. Když odešlete formulář aplikace InfoPath do Accessu, databáze v Accessu se aktualizuje. Když poté obnovíte datové připojení v Excelu, načtete z Accessu aktualizovaná data. Ve výsledku tedy nepřímo předáváte data z aplikace InfoPath do sešitu v Excelu.

kombinování aplikace infopath, zpřístupňovat a aplikace excel

1. Zobrazení formuláře a jeho odeslání do databáze Accessu

2. Uložení dat v databázi Accessu

3. Aktualizace data a vytvoření aktuální sestavy v Excelu.

Další informace najdete v tématu Návrh šablony formuláře, který je založen na databázi aplikace Microsoft Access.

Tip : Věděli jste, že formulář aplikace InfoPath můžete vytvořit přímo z aplikace Access 2007? Pokud vaši uživatelé mají v počítači nainstalovány aplikace Outlook 2007 a InfoPath 2007, můžete od nich shromáždit data přímo z aplikace Access 2007 pomocí průvodce Shromažďovat data prostřednictvím e-mailových zpráv. Další informace naleznete v tématu nápovědy Accessu 2007 Shromažďování dat prostřednictvím e-mailových zpráv.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×