Vyhodnocení vnořeného vzorce po jednotlivých krocích

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Vysvětlení, jak vnořené Vzorec počítá konečný výsledek je někdy složité protože mívají několik průběžných výpočtů logických testů. Pomocí dialogu Vyhodnocení vzorce různé části vnořeného vzorce vyhodnocené v pořadí, ve kterém vzorec počítá uvidíte. Například vzorec =když(průměr(F2:F5) > 50,SUM(G2:G5),0) je snadněji pochopitelný, když uvidíte následující intermediate výsledky:

Kroky zobrazené v dialogovém okně

Popis

=KDYŽ(PRŮMĚR(F2:F5)>50;SUMA(G2:G5);0)

Nejdřív se zobrazí vnořený vzorec. Funkce PRŮMĚR a SUMA jsou vnořené ve funkci KDYŽ.

=KDYŽ(40>50;SUMA(G2:G5);0)

F2: F5 oblast buněk s hodnotami 55, 35, 45 a 25 a výsledek funkce průměr(F2:F5) je vlastně 40.

=KDYŽ(Nepravda;SUMA(G2:G5);0)

40 není větší než 50, takže je výrazů v prvním argumentu funkce KDYŽ (argumentu podmínka) NEPRAVDA.

0

Funkce KDYŽ vrátí hodnotu argumentu třetího (argument ne). Funkce SUM není vyhodnocena, protože je druhým argumentem funkce KDYŽ (argument PRAVDA) a je vrácena jenom při splnění výraz.

  1. Vyberte buňky, které chcete vyhodnotit. Buňky můžete upravovat jenom jednotlivě.

  2. Na kartě Vzorce klikněte ve skupině Závislosti vzorců na tlačítko Vyhodnocení vzorce.

    The Formula Auditing group on the Formulas tab

  3. Kliknutím na Vyhodnotit prozkoumejte hodnotu podtrženého odkazu. Výsledek vyhodnocení se zobrazí kurzívou.

    Pokud podtržená část vzorce tvoří odkaz na jiný vzorec, kliknutím na Vstoupit zobrazte další vzorec v okně Vyhodnocení. Kliknutím na Vystoupit se vraťte k předchozí buňce a vzorci.

    Poznámka : Tlačítko Vstoupit není pro odkaz dostupné při druhém zobrazení odkazu ve vzorci, a to ani když vzorec odkazuje na buňku v samostatném sešitu.

  4. Pokračujte, dokud nevyhodnotíte všechny části vzorce.

  5. Pokud chcete znovu zobrazit vyhodnocení, klikněte na Restartovat.

    Pokud chcete vyhodnocení ukončit, klikněte na Zavřít.

    Poznámky : 

    • Nejsou některé části vzorce, které používáte IF a ZVOLTE funkce Vyhodnocená a #není_k_dispozici se zobrazí v poli vyhodnocení.

    • Pokud je odkaz prázdný, zobrazí se v poli Vyhodnocení nulová hodnota (0).

    • Budou přepočítány následující funkce každé změně sešitu a mohou způsobit Vyhodnocení vzorce do jiné položek zobrazených v buňce výsledky: RAND, OBLASTÍ, INDEX, ODSAZENÍ, BUŇKY, NEPŘÍMÝ.ODKAZ, ŘÁDKY; SLOUPCE; NYNÍ, DNES, RANDBETWEEN.

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×