Vyhodnocení vnořeného vzorce po jednotlivých krocích

Někdy není lehké pochopit, jak vnořený Vzorec došel ke konečnému výsledku, protože provádí řadu průběžných výpočtů a logických testů. Dialogové okno Vyhodnocení vzorce ale umožňuje zobrazit různé části vnořeného vzorce, které se za účelem výpočtu vzorce vyhodnocují. Například vzorec = když (průměr (F2: F5) >50, suma (G2: G5), 0) je snazší pochopit, když uvidíte následující mezilehlé výsledky:

Kroky zobrazené v dialogovém okně

Popis

=KDYŽ(PRŮMĚR(F2:F5)>50;SUMA(G2:G5);0)

Nejdřív se zobrazí vnořený vzorec. Funkce PRŮMĚR a SUMA jsou vnořené ve funkci KDYŽ.

=KDYŽ(40>50;SUMA(G2:G5);0)

Oblast buněk F2:F5 obsahuje hodnoty 55, 35, 45 a 25. Výsledek funkce PRŮMĚR(F2:F5) je tím pádem 40.

=KDYŽ(Nepravda;SUMA(G2:G5);0)

40 není větší než 50, a proto je výraz v prvním argumentu funkce když (argument podmínka) NEPRAVDA.

0

Funkce KDYŽ vrátí hodnotu třetího argumentu (argumentu Ne). Funkce SUMA není vyhodnocená, protože je druhým argumentem funkce když (argument Ano) a je vrácená jenom v případě, že je výraz pravdivý.

  1. Vyberte buňky, které chcete vyhodnotit. Buňky můžete upravovat jenom jednotlivě.

  2. Na kartě Vzorce klikněte ve skupině Závislosti vzorců na tlačítko Vyhodnocení vzorce.

    Skupina Závislosti vzorců na kartě Vzorce

  3. Kliknutím na Vyhodnotit prozkoumejte hodnotu podtrženého odkazu. Výsledek vyhodnocení se zobrazí kurzívou.

    Pokud podtržená část vzorce tvoří odkaz na jiný vzorec, kliknutím na Vstoupit zobrazte další vzorec v okně Vyhodnocení. Kliknutím na Vystoupit se vraťte k předchozí buňce a vzorci.

    Poznámka: Tlačítko Vstoupit není pro odkaz dostupné při druhém zobrazení odkazu ve vzorci, a to ani když vzorec odkazuje na buňku v samostatném sešitu.

  4. Pokračujte, dokud nevyhodnotíte všechny části vzorce.

  5. Pokud chcete znovu zobrazit vyhodnocení, klikněte na Restartovat.

    Pokud chcete vyhodnocení ukončit, klikněte na Zavřít.

    Poznámky: 

    • Některé části vzorců, které používají funkce když a CHOOSE, se nevyhodnotí a v poli vyhodnocení se zobrazí #N/a.

    • Pokud je odkaz prázdný, zobrazí se v poli Vyhodnocení nulová hodnota (0).

    • Vzorce s cyklickými odkazy se nemusí vyhodnocovat očekávaným způsobem. Pokud potřebujete cyklický odkaz, můžete Povolit iterační výpočet.

    • Následující funkce se přepočítávají při každém změně listu a může to způsobit, že nástroj vyhodnocení vzorce poskytne výsledky odlišné od toho, co se zobrazuje v buňce: NÁHČÍSLO, posun, buňka, nepřímé, dnes, RANDBETWEEN, info a SUMIF (v některých scénáře).

Poznámka:  Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát vědět, jestli vám informace pomohly? Pokud chcete, můžete se podívat na anglickou verzi článku.

Viz taky

Jak se vyhnout nefunkčním vzorcům

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×