Vyhledávání hodnot pomocí funkce SVYHLEDAT, INDEX nebo POZVYHLEDAT

Důležité informace:  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Když chcete ve velkém seznamu najít nějakou hodnotu, můžete použít vyhledávací funkci. Hodně se používá funkce SVYHLEDAT, ale dobře vám může posloužit taky funkce VVYHLEDAT a společné použití funkcí INDEX a POZVYHLEDAT.

Tady je syntaxe funkce SVYHLEDAT a přehled argumentů, které používá:

=SVYHLEDAT(<hledaná hodnota>;<prohledávaná oblast>;<sloupec>;<přibližná shoda>)

Příklad: =SVYHLEDAT(21500;C2:E7;3;NEPRAVDA)

  • První z argumentů – to jsou údaje, bez kterých funkce nebude pracovat – je hodnota, kterou chcete vyhledat. Může to být odkaz na buňku, třeba B2, nebo určitá hodnota, třeba „Svoboda“ nebo 21500.

  • Druhý argument je oblast buněk, ve které by se podle vás měla hledaná hodnota nacházet.

    Důležité informace: U funkce SVYHLEDAT je potřeba, aby byl sloupec obsahující hledanou hodnotu nebo odkaz na buňku v této oblasti úplně vlevo.

  • Třetí argument je sloupec v prohledávané oblasti buněk obsahující hodnotu, kterou chcete zobrazit.

Čtvrtý argument je sice volitelný, zadejte většina lidí FALSE (nebo 0). Proč? Protože to přinutí funkci vyhledala přesnou shodu na vyhledávání. Můžete zadat žádný argument nebo hodnotu PRAVDA, ale pokud nenašlo přesné shody, vrátí funkce nejbližšípřibližnou shodu– a obvykle většina lidí nechcete, aby se přibližnou shodu.

Pokud chcete zobrazit, jak přibližnou shodu může být vážný problém, Předpokládejme, že hledáte ceny pro část s ID 2345768, ale přepněte dvěma čísly a chybně ve vzorci takto: =VLOOKUP(2345678,A1:E7,5). vzorec vrátí cenu nepovedlo části, protože funkce SVYHLEDAT najít na nejbližší číslo menší než nebo rovno zadanému číslu (2345678). Může skončily fakturace zákazníka nesprávně kvůli této chybě.

Pokud jako argument přibližná shoda zadáte NEPRAVDA nebo 0 a nenajde se přesná shoda, vrátí vzorec místo špatné hodnoty chybovou hodnotu #NENÍ_K_DISPOZICI a to je mnohem lepší. #NENÍ_K_DISPOZICI v takovém případě neznamená, že jste vzorec zadali špatně (s výjimkou chybně zadaného čísla). Znamená to, že se číslo 2345678 nenašlo, protože jste chtěli 2345768.

Teď si na příkladu ukážeme, co tato funkce dělá. Když do buňky B2 (první argument) napíšete nějakou hodnotu, prohledá funkce SVYHLEDAT oblast buněk C2:E7 (druhý argument) a vrátí hodnotu ze třetího sloupce v této oblasti, sloupce E (třetí argument), pro nejbližší přibližnou shodu.

Typické použití funkce SVYHLEDAT

V tomto příkladu je čtvrtý argument nechaný prázdný, takže funkce vrátí přibližnou shodu.

Použití funkce VVYHLEDAT

Až budete umět pracovat s funkcí SVYHLEDAT, bude pro vás používání funkce VVYHLEDAT už hračka. Zadávají se stejné argumenty, ale funkce VVYHLEDAT hledá hodnoty v řádcích místo ve sloupcích.

Společné použití funkcí INDEX a POZVYHLEDAT

Když nechcete být omezení na prohledávání jenom levého sloupce, můžete použít kombinaci funkcí INDEX a POZVYHLEDAT. Vzorec, ve kterém se používají tyto funkce společně, je sice o něco složitější než vzorec s funkcí SVYHLEDAT, ale zato může být výkonnější. Jsou i lidé, kteří kombinaci funkcí INDEX a POZVYHLEDAT používají mnohem raději než funkci SVYHLEDAT.

V tomto příkladu vidíme krátký seznam, ve kterém není hledaná hodnota (Chicago) v levém sloupci. Takže nemůžeme použít funkci SVYHLEDAT. Použijeme místo ní funkci POZVYHLEDAT a budeme v oblasti B1:B11 hledat Chicago. To se nachází na řádku 4. Funkce INDEX pak použije tuto hodnotu jako argument pro vyhledávání a ve čtvrtém sloupci (sloupec D) zjistí, kolik má Chicago obyvatel. Použitý vzorec je vidět v buňce A14.

Vyhledání hodnoty pomocí funkcí INDEX a POZVYHLEDAT

Další informace o vyhledávacích funkcí

Začátek stránky

Poznámka: Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×