Office
Přihlásit se

Vyhledávání hodnot pomocí funkce SVYHLEDAT, INDEX nebo POZVYHLEDAT

Poznámka:  Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady .

Předpokládejme, že máte seznamu čísel kanceláří umístění a musíte znát which employees are jsou v jednotlivých office. Tabulky je obrovské, tak, aby si myslíte, že je náročné úkolu. Je skutečně docela snadno pomocí funkce vyhledávání.

Funkce SVYHLEDAT a VVYHLEDAT společně s funkcí INDEX a POZVYHLEDAT,jsou některé nejužitečnějších funkcí v Excelu.

Poznámka: Funkce Průvodce vyhledáváním je už není dostupná v aplikaci Excel.

Tady je příklad toho, jak používat funkci SVYHLEDAT.

=SVYHLEDAT(B2;C2:E7;3;PRAVDA)

V tomto příkladu B2 první argumentje – tedy prvek data, která funkce pro práci. Funkce SVYHLEDAT tento první argument je hodnota, která chcete vyhledat. Tento argument může být odkaz na buňku nebo pevnou hodnotu "Miklus" ATP 21 000. Druhý argument je oblast buněk, C2-:E7, ve kterém chcete hledat hodnotu, kterou chcete najít. Třetí argument je sloupec oblasti buněk obsahující hodnotu, která byste se obrátit.

Čtvrtý argument je nepovinný krok. Zadejte TRUE nebo FALSE. Pokud PRAVDA připojí nebo odejdou argument prázdná, funkce vrátí přibližnou shodu hodnoty zadané v prvním argumentu. Pokud zadáte hodnotu NEPRAVDA, funkce se shodují s hodnotou poskytnout tak, že první argument. Jinými slovy, prázdné je čtvrtý argument – nebo že zadáte hodnotu TRUE – umožňuje větší flexibilitu.

Tento příklad ukazuje, jak funkce funguje. Když zadáte hodnotu v buňce B2 (první argument), funkce SVYHLEDAT vyhledá buňky v oblasti C2:E7 (2 argument) a vrátí nejbližší přibližnou shodu od třetího sloupce v oblasti sloupce E (3 argument).

Typické použití funkce SVYHLEDAT

Čtvrtý argument není prázdný, takže funkce vrátí přibližnou shodu. Pokud ne, je třeba zadat jeden z hodnoty ve sloupcích C a D získání výsledku vůbec.

Pokud je pro vás pohodlnější s funkcí SVYHLEDAT, je taky funkce VVYHLEDAT je rovnoměrně z vnější snadno se použije. Zadání stejných argumentů, ale hledá v řádcích namísto sloupců. "

Vyzkoušejte si to

Pokud budete chtít vyzkoušet vyhledávacích funkcí, než si je vyzkoušíte na vlastních datech, tady je pár ukázek. Někteří uživatelé aplikace Excel jako při použití funkce SVYHLEDAT a VVYHLEDAT; ostatní raději, INDEX a POZVYHLEDAT společném používání. Zkuste obou metod a sledujte, které z nich nejvíce líbí.

Příklad funkce SVYHLEDAT v praxi

Zkopírujte následující data do prázdné tabulky.

TIP:    Před vložením dat do Excelu nastavte šířku sloupců A až C na 250 pixelů a klikněte na Zalamovat Text (kartaDomů, skupina Zarovnání ).

Hustota

Viskozita

Teplota

0,457

3,55

500

0,525

3,25

400

0,606

2,93

300

0,675

2,75

250

0,746

2,57

200

0,835

2,38

150

0,946

2,17

100

1,09

1,95

50

1,29

1,71

0

Vzorec

Popis

Výsledek

=SVYHLEDAT(1;A2:C10;2)

Hledá hodnotu 1 ve sloupci A při použití přibližné shody, najde ve sloupci A nejvyšší hodnotu menší než nebo rovnou 1, což je 0,946, a potom vrátí hodnotu ze sloupce B na stejném řádku.

2,17

=SVYHLEDAT(1;A2:C10;3;PRAVDA)

Hledá hodnotu 1 ve sloupci A při použití přibližné shody, najde ve sloupci A nejvyšší hodnotu menší než nebo rovnou 1, což je 0,946, a potom vrátí hodnotu ze sloupce C na stejném řádku.

100

=SVYHLEDAT(0,7;A2:C10;3;NEPRAVDA)

Hledá hodnotu 0,7 ve sloupci A při použití přesné shody. Vzhledem k tomu, že sloupec A takovou hodnotu neobsahuje, je vrácena chyba.

#NENÍ_K_DISPOZICI

=SVYHLEDAT(0,1;A2:C10;2;PRAVDA)

Hledá hodnotu 0,1 ve sloupci A při použití přibližné shody. Protože hodnota 0,1 je menší než nejmenší hodnota ve sloupci A, vrátí se chyba.

#NENÍ_K_DISPOZICI

=SVYHLEDAT(2;A2:C10;2;PRAVDA)

Hledá hodnotu 2 ve sloupci A při použití přibližné shody, najde ve sloupci A nejvyšší hodnotu menší než nebo rovnou 2, což je 1,29, a potom vrátí hodnotu ze sloupce B na stejném řádku.

1,71

Příklad funkce VVYHLEDAT

Zkopírujte všechny buňky v této tabulce a vložte je do buňky A1 v prázdném excelovém sešitě.

TIP:    Před vložením dat do Excelu nastavte šířku sloupců A až C na 250 pixelů a klikněte na Zalamovat Text (kartaDomů, skupina Zarovnání ).

Auta

Bagry

Buldozery

4

4

9

5

7

10

6

8

11

Vzorec

Popis

Výsledek

=VVYHLEDAT("Auta";A1:C4;2;PRAVDA)

Vyhledá "Auta" v řádku 1 a vrátí hodnotu z řádku 2, která je ve stejném sloupci (sloupec A).

4

=VVYHLEDAT("Bagry";A1:C4;3;NEPRAVDA)

Vyhledá "Bagry" v řádku 1 a vrátí hodnotu z řádku 3, která je ve stejném sloupci (sloupec B).

7

=VVYHLEDAT("B";A1:C4;3;PRAVDA)

Vyhledá "B" v řádku 1 a vrátí hodnotu z řádku 3, která je ve stejném sloupci. Protože se nenašla přesná shoda, použila se největší hodnota na řádku 1, která je menší než "B": "Auta", ve sloupci A.

5

=VVYHLEDAT("Buldozery";A1:C4;4)

Vyhledá "Buldozery" v řádku 1 a vrátí hodnotu z řádku 4, která je ve stejném sloupci (sloupec C).

11

=VVYHLEDAT(3; {1,2,3;"a","b","c";"d","e","f"}; 2; PRAVDA)

Vyhledá číslo 3 v třířádkové maticové konstantě a vrátí hodnotu z řádku 2 ve stejném sloupci (v tomto případě třetím). V této maticové konstantě jsou tři řádky hodnot oddělené od sebe středníkem (;). Protože se “c” našlo v řádku 2 a ve stejném sloupci jako 3, vrátí hodnotu “c”.

c

INDEX a POZVYHLEDAT příklady

Tento poslední příklad využívá funkcí INDEX a POZVYHLEDAT společně se vrátíte nejbližší číslo faktury a odpovídající datem pro každou z pěti měst. Vzhledem k tomu datu je vrácena jako číslo, používáme funkci hodnota.na.text k formátování jako datum. Výsledek funkce POZVYHLEDAT funkce INDEX skutečně používá jako argument. Kombinaci funkcí INDEX a POZVYHLEDAT slouží dvakrát po jednotlivých vzorec – nejdřív se chcete vrátit číslo faktury a potom datu.

Zkopírujte všechny buňky v této tabulce a vložte je do buňky A1 v prázdném excelovém sešitě.

TIP:    Před vložením dat do Excelu nastavte šířku sloupců A až D na 250 pixelů a klikněte na Zalamovat Text (kartaDomů, skupina Zarovnání ).

Faktura

Město

Datum faktury

Nejnovější faktura podle města, s datem

3115

Plzeň

07.04.12

="Plzeň = "&INDEX($A$2:$C$33,POZVYHLEDAT("Plzeň",$B$2:$B$33,0),1)& ", Datum faktury: " & TEXT(INDEX($A$2:$C$33,POZVYHLEDAT("Plzeň",$B$2:$B$33,0),3),"m/d/rr")

3137

Plzeň

09.04.12

="Hodonín = "&INDEX($A$2:$C$33,POZVYHLEDAT("Hodonín",$B$2:$B$33,0),1)& ", Datum faktury: " & TEXT(INDEX($A$2:$C$33,POZVYHLEDAT("Hodonín",$B$2:$B$33,0),3),"m/d/rr")

3154

Plzeň

11.04.12

="Domažlice = "&INDEX($A$2:$C$33,POZVYHLEDAT("Domažlice",$B$2:$B$33,0),1)& ", Datum faktury: " & TEXT(INDEX($A$2:$C$33,POZVYHLEDAT("Domažlice",$B$2:$B$33,0),3),"m/d/rr")

3191

Plzeň

21.04.12

="Nový Bydžov = "&INDEX($A$2:$C$33,POZVYHLEDAT("Nový Bydžov",$B$2:$B$33,0),1)& ", Datum faktury: " & TEXT(INDEX($A$2:$C$33,POZVYHLEDAT("Nový Bydžov",$B$2:$B$33,0),3),"m/d/rr")

3293

Plzeň

25.04.12

="Tábor = "&INDEX($A$2:$C$33,POZVYHLEDAT("Tábor",$B$2:$B$33,0),1)& ", Datum faktury: " & TEXT(INDEX($A$2:$C$33,POZVYHLEDAT("Tábor",$B$2:$B$33,0),3),"m/d/rr")

3331

Plzeň

27.04.12

3350

Plzeň

28.04.12

3390

Plzeň

01.05.12

3441

Plzeň

02.05.12

3517

Plzeň

08.05.12

3124

Hodonín

09.04.12

3155

Hodonín

11.04.12

3177

Hodonín

19.04.12

3357

Hodonín

28.04.12

3492

Hodonín

06.05.12

3316

Domažlice

25.04.12

3346

Domažlice

28.04.12

3372

Domažlice

01.05.12

3414

Domažlice

01.05.12

3451

Domažlice

02.05.12

3467

Domažlice

02.05.12

3474

Domažlice

04.05.12

3490

Domažlice

05.05.12

3503

Domažlice

08.05.12

3151

Nový Bydžov

09.04.12

3438

Nový Bydžov

02.05.12

. 3471

Nový Bydžov

04.05.12

3160

Tábor

18.04.12

3328

Tábor

26.04.12

3368

Tábor

29.04.12

3420

Tábor

01.05.12

3501

Tábor

06.05.12

Další informace o vyhledávacích funkcí

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×