Vyhledávání hodnot pomocí funkce SVYHLEDAT, INDEX nebo POZVYHLEDAT

Důležité informace:  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Dejme tomu, že máte seznam čísel kanceláří a chcete zjistit, který zaměstnanec sedí v které kanceláři. Jenomže váš excelový sešit je obrovský, jak se v tom člověk má vyznat? Právě od toho tu jsou funkce vyhledávání. Nejužitečnější jsou funkce SVYHLEDAT a VVYHLEDAT, hned po nich pak funkce INDEX a POZVYHLEDAT.

Poznámka:  Dřív v Excelu býval Průvodce vyhledáváním, teď už ale k dispozici není.

Rychle si připomeneme, jak používat funkci SVYHLEDAT.

=SVYHLEDAT(B2;C2:E7;3;PRAVDA)

První z řady argumentů – to jsou údaje, bez kterých funkce nebude pracovat – je hodnota, kterou chcete vyhledat. Může jít o odkaz na buňku nebo i pevnou hodnotu jako třeba Novák nebo 21 000. Druhý argument je oblast buněk, ve které chcete tuhle hodnotu hledat. V našem příkladu vyhledáváme v oblasti C2-E7. A třetí argument je sloupec v této oblasti buněk, který obsahuje hodnotu, kterou chcete zobrazit.

Čtvrtý argument je nepovinný a může to být buď Pravda, nebo Nepravda. Pokud zadáte hodnotu PRAVDA nebo necháte čtvrtý argument prázdný, funkce bude vyhledávat i přibližné shody s hodnotou zadanou v prvním argumentu. Pokud zadáte NEPRAVDA, funkce najde jen hodnoty, které prvnímu argumentu odpovídají přesně. Jinými slovy, když necháte poslední argument prázdný nebo do něj napíšete PRAVDA, vyhledávání bude trochu volnější.

Teď si na příkladu ukážeme, jak funkce funguje. Když do buňky B2 (zadané v prvním argumentu) napíšete nějakou hodnotu, funkce SVYHLEDAT prohledá oblast buněk C2-E7 (zadanou v druhém argumentu) a vrátí buňku ze třetího sloupce v této oblasti, sloupce E (zadaného ve třetím argumentu), ve které se nachází hodnota nejvíc se přibližující hledané hodnotě.

Typické použití funkce SVYHLEDAT

Čtvrtý argument je prázdný, takže funkce bude vracet i přibližné shody. Kdybychom chtěli čtvrtý argument vyplnit, bylo by nutné zadat některou z hodnot ve sloupci C nebo D, jinak by vyhledávání nic nenašlo.

Až se seznámíte s funkcí SVYHLEDAT, používání funkce VVYHLEDAT už pro vás bude hračka. Budete zadávat stejné argumenty, ale hodnoty se budou hledat v řádcích místo ve sloupcích.

Vyzkoušejte si to

Pokud si chcete s vyhledávacími funkcemi napřed pohrát, než si je vyzkoušíte na vlastních datech, tady jsou některá ukázková data. Někteří uživatelé rádi používají funkce SVYHLEDAT a VVYHLEDAT, jiní dávají přednost společnému použití funkcí INDEX a POZVYHLEDAT. Ozkoušejte si je všechny a vyberte si ty, které vám vyhovují.

Funkce SVYHLEDAT v praxi

Zkopírujte všechny buňky v této tabulce a vložte je do buňky A1 v prázdném excelovém sešitě.

Tip:    Před vložením dat do Excelu nastavte šířku sloupců A až C na 250 pixelů a klikněte na Zalamovat text (karta Domů, skupina Zarovnání).

Hustota

Viskozita

Teplota

0,457

3,55

500

0,525

3,25

400

0,606

2,93

300

0,675

2,75

250

0,746

2,57

200

0,835

2,38

150

0,946

2,17

100

1,09

1,95

50

1,29

1,71

0

Vzorec

Popis

Výsledek

'=SVYHLEDAT(1,A2:C10,2)

Hledá hodnotu 1 ve sloupci A při použití přibližné shody, najde ve sloupci A nejvyšší hodnotu menší než nebo rovnou 1, což je 0,946, a potom vrátí hodnotu ze sloupce B na stejném řádku.

=SVYHLEDAT(1;A2:C10;2)

"=VLOOKUP(1,A2:C10,3,TRUE)

Hledá hodnotu 1 ve sloupci A při použití přibližné shody, najde ve sloupci A nejvyšší hodnotu menší než nebo rovnou 1, což je 0,946, a potom vrátí hodnotu ze sloupce C na stejném řádku.

=SVYHLEDAT(1;A2:C10;3;PRAVDA)

'=SVYHLEDAT(0,7,A2:C10,3,NEPRAVDA)

Hledá hodnotu 0,7 ve sloupci A při použití přesné shody. Vzhledem k tomu, že sloupec A takovou hodnotu neobsahuje, je vrácena chyba.

=SVYHLEDAT(0,7;A2:C10;3;NEPRAVDA)

"=SVYHLEDAT(0,1,A2:C10,2,PRAVDA)

Hledá hodnotu 0,1 ve sloupci A při použití přibližné shody. Protože hodnota 0,1 je menší než nejmenší hodnota ve sloupci A, vrátí se chyba.

=SVYHLEDAT(0,1;A2:C10;2;PRAVDA)

"=SVYHLEDAT(2,A2:C10,2,PRAVDA)

Hledá hodnotu 2 ve sloupci A při použití přibližné shody, najde ve sloupci A nejvyšší hodnotu menší než nebo rovnou 2, což je 1,29, a potom vrátí hodnotu ze sloupce B na stejném řádku.

=SVYHLEDAT(2;A2:C10;2;PRAVDA)

Funkce VVYHLEDAT v praxi

Zkopírujte všechny buňky v této tabulce a vložte je do buňky A1 v prázdném excelovém sešitě.

Tip:    Před vložením dat do Excelu nastavte šířku sloupců A až C na 250 pixelů a klikněte na Zalamovat text (karta Domů, skupina Zarovnání).

Auta

Bagry

Buldozery

4

4

9

5

7

10

6

8

11

Vzorec

Popis

Výsledek

'=VVYHLEDAT("Auta", A1:C4, 2, PRAVDA)

Vyhledá "Auta" v řádku 1 a vrátí hodnotu z řádku 2, která je ve stejném sloupci (sloupec A).

=VVYHLEDAT("Auta";A1:C4;2;PRAVDA)

'=VVYHLEDAT("Bagry", A1:C4, 3, NEPRAVDA)

Vyhledá "Bagry" v řádku 1 a vrátí hodnotu z řádku 3, která je ve stejném sloupci (sloupec B).

=VVYHLEDAT("Bagry";A1:C4;3;NEPRAVDA)

'=VVYHLEDAT("B", A1:C4, 3, PRAVDA)

Vyhledá "B" v řádku 1 a vrátí hodnotu z řádku 3, která je ve stejném sloupci. Protože se nenašla přesná shoda, použila se největší hodnota na řádku 1, která je menší než "B": "Auta" ve sloupci A.

=VVYHLEDAT("B";A1:C4;3;PRAVDA)

'=VVYHLEDAT("Buldozery", A1:C4, 4)

Vyhledá "Buldozery" v řádku 1 a vrátí hodnotu z řádku 4, která je ve stejném sloupci (sloupec C).

=VVYHLEDAT("Buldozery";A1:C4;4)

'=VVYHLEDAT(3, {1,2,3;"a","b","c";"d","e","f"}, 2, PRAVDA)

Vyhledá číslo 3 v třířádkové maticové konstantě a vrátí hodnotu z řádku 2 ve stejném sloupci (v tomto případě třetím). V této maticové konstantě jsou tři řádky hodnot oddělené od sebe středníkem (;). Protože se “c” našlo na řádku 2 a ve stejném sloupci jako 3, vrátí hodnotu “c”.

=VVYHLEDAT(3;{1;2;3|"a";"b";"c"|"d";"e";"f"};2;PRAVDA)

Funkce INDEX a POZVYHLEDAT v praxi

V tomto příkladu se společně používají funkce INDEX a POZVYHLEDAT k vrácení posledního čísla faktury a jeho odpovídajícího data pro pět měst. Protože se datum vrací jako číslo, použijeme funkci TEXT k naformátování jako data. Funkce INDEX ve skutečnosti používá jako argument výsledek funkce POZVYHLEDAT. Kombinace funkcí INDEX a POZVYHLEDAT se v jednotlivých verzích používá dvakrát – za prvé k vrácení čísla faktury a za druhé k vrácení data.

Zkopírujte všechny buňky v této tabulce a vložte je do buňky A1 v prázdném excelovém sešitě.

Tip:    Před vložením dat do Excelu nastavte šířku sloupců A až D na 250 pixelů a klikněte na Zalamovat text (karta Domů, skupina Zarovnání).

Faktura

Město

Datum faktury

Nejnovější faktura podle města, s datem

3115

Plzeň

07.04.12

="Plzeň = "&INDEX($A$2:$C$33,POZVYHLEDAT("Plzeň",$B$2:$B$33,0),1)& ", Datum faktury: " & TEXT(INDEX($A$2:$C$33,POZVYHLEDAT("Plzeň",$B$2:$B$33,0),3),"m/d/rr")

3137

Plzeň

09.04.12

="Hodonín = "&INDEX($A$2:$C$33,POZVYHLEDAT("Hodonín",$B$2:$B$33,0),1)& ", Datum faktury: " & TEXT(INDEX($A$2:$C$33,POZVYHLEDAT("Hodonín",$B$2:$B$33,0),3),"m/d/rr")

3154

Plzeň

11.04.12

="Domažlice = "&INDEX($A$2:$C$33,POZVYHLEDAT("Domažlice",$B$2:$B$33,0),1)& ", Datum faktury: " & TEXT(INDEX($A$2:$C$33,POZVYHLEDAT("Domažlice",$B$2:$B$33,0),3),"m/d/rr")

3191

Plzeň

21.04.12

="Nový Bydžov = "&INDEX($A$2:$C$33,POZVYHLEDAT("Nový Bydžov",$B$2:$B$33,0),1)& ", Datum faktury: " & TEXT(INDEX($A$2:$C$33,POZVYHLEDAT("Nový Bydžov",$B$2:$B$33,0),3),"m/d/rr")

3293

Plzeň

25.04.12

="Tábor = "&INDEX($A$2:$C$33,POZVYHLEDAT("Tábor",$B$2:$B$33,0),1)& ", Datum faktury: " & TEXT(INDEX($A$2:$C$33,POZVYHLEDAT("Tábor",$B$2:$B$33,0),3),"m/d/rr")

3331

Plzeň

27.04.12

3350

Plzeň

28.04.12

3390

Plzeň

01.05.12

3441

Plzeň

02.05.12

3517

Plzeň

08.05.12

3124

Hodonín

09.04.12

3155

Hodonín

11.04.12

3177

Hodonín

19.04.12

3357

Hodonín

28.04.12

3492

Hodonín

06.05.12

3316

Domažlice

25.04.12

3346

Domažlice

28.04.12

3372

Domažlice

01.05.12

3414

Domažlice

01.05.12

3451

Domažlice

02.05.12

3467

Domažlice

02.05.12

3474

Domažlice

04.05.12

3490

Domažlice

05.05.12

3503

Domažlice

08.05.12

3151

Nový Bydžov

09.04.12

3438

Nový Bydžov

02.05.12

. 3471

Nový Bydžov

04.05.12

3160

Tábor

18.04.12

3328

Tábor

26.04.12

3368

Tábor

29.04.12

3420

Tábor

01.05.12

3501

Tábor

06.05.12

Další informace o vyhledávacích funkcí

Začátek stránky

Poznámka: Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×