Vnoření funkce do jiné funkce

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Při vytváření vzorce pomocí funkce můžete do sebe vnořit funkce uvnitř jiné funkce. Po výběru, že používáte výsledky vnořených funkcí jako arguments– datovými údaji první funkce je potřeba spustit správně. Poznáte vždy, když je funkce vnořená vzhledem k tomu, že je v závorkách.

Tady je příklad. Funkce KDYŽ využívá jako argumenty vnořené funkce PRŮMĚR a SUMA.

=KDYŽ(PRŮMĚR(F2:F5)>50;SUMA(G2:G5);0)

Tento vzorec můžete číst zleva doprava. KDYŽ je průměrná hodnota buněk F2 až F5 větší než 50, pak je spočítán součet hodnot (SUMA) v buňkách G2 až G5. Jinak vzorec vrátí hodnotu 0.

Můžete do sebe vnořit 64 úrovní funkcí a zadáváte je jako všechny ostatní funkce:

  1. Klikněte na buňku, která bude obsahovat vzorec.

  2. Zadejte vzorec do řádku vzorců a stiskněte Enter.

Tady je další příklad. Vnořuje funkci KDYŽ do jiné funkce KDYŽ k výpočtu odpočtů na základě výše příjmu.

=KDYŽ(A5<31500;A5*15%;KDYŽ(A5<72500;A5*25%;A5*28%))

Tento příklad taky můžete číst zleva doprava. KDYŽ je hodnota v buňce A5 menší než 31 500, pak se vynásobí 15 %. Ale KDYŽ ne, provede se kontrola, jestli je hodnota menší než 72 500. KDYŽ ano, vynásobí se 25 %, jinak se vynásobí 28 %.

Při zápisu úrovně příjmu můžete (ale nemusíte) jako oddělovač tisíců použít mezeru. Excel ji v řádku vzorců automaticky odstraní a číslo naformátuje podle buňky.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×