Vložení zobrazení dat jako formuláře

Důležité informace:  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Formuláře jsou velice podstatnou součástí každé aplikace služby Microsoft SharePoint Web, ve které je potřeba sbírat data od uživatelů. Zobrazení dat jsou založena na technologii formulářů ASP.NET, což umožňuje jejich vložení jako zobrazení dat s atributem jen pro čtení nebo jako formuláře, pomocí nichž mohou uživatelé zadávat data do zdroje dat v okně webového prohlížeče. Ve službě Microsoft Office SharePoint Designer 2007 lze rychle vložit zobrazení dat jako formulář, čímž se uživatelům umožní provádět změny v následujících typech zdrojů dat: seznamy a knihovny, připojení databáze a místní soubory XML. Poznámka: Zobrazení dat vložené jako formulář lze použít pouze s uvedenými typy zdrojů dat.

Tento článek obsahuje informace o vkládání zobrazení dat jako formuláře. Dále zde naleznete informace o vytvoření zkušebního souboru XML, který lze použít jako zdroj dat pro potřeby příkladu.

Důležité informace: Tento článek obsahuje informace o vytvoření zobrazení dat ve webu SharePoint umístěném na serveru se službou Windows SharePoint Services 3.0. Tato funkce není dostupná, nachází-li se web na serveru bez služby Windows SharePoint Services 3.0.

V tomto článku

Než začnete

Proč vložení zobrazení dat jako formuláře?

Vytvoření souboru XML jako zdroje ukázkových dat

Vložení zobrazení dat jako formuláře

Úprava dat pomocí prohlížeče

Navrhované další kroky

Než začnete

V aplikaci Office SharePoint Designer 2007 jsou k dispozici dvě funkce umožňující uživatelům úpravu dat ve zobrazení dat v okně webového prohlížeče.

  • Vložení zobrazení dat jako formuláře.     Po vytvoření zobrazení dat jej lze vložit jako formulář s jednou nebo s více položkami. Tento formulář bude permanentně v režimu úprav a bude obsahovat buď jeden nebo několik záznamů. Uživatelé budou moci upravovat data a zadávat nové položky pomocí prohlížeče, nebudou však moci vložené položky odstraňovat. Jestliže může nastat potřeba úpravy několika položek najednou, je vhodné použít formulář s více položkami.

  • Přidat odkazy na existující zobrazení dat     Můžete přidat odkazy na existující zobrazení dat tak, aby uživatelé mohli upravovat, odstranění a vkládání záznamů ve zdroji dat. Klikněte na odkaz upravit záznamu vloženého v režimu úprav. Přidání odkazů do zobrazení dat vloženého jako formulář s nahradit odkazy tlačítka formuláře. Kromě toho-li přidat odkazy do zobrazení dat vloženého jako formulář s zobrazení dat se už zobrazovat poli formuláře ve výchozím nastavení; Zobrazí jenom data v zobrazení. Další informace naleznete v článku Změna, odstranit a vkládání záznamů ve zobrazení dat.

Po vložení zobrazení dat jako formuláře lze filtrovat, seřadit a seskupovat data, používat podmíněné formátování nebo vytvářet sloupce se vzorci. Po provedení a uložení změn uživateli budou veškeré filtry, seřazení, podmíněná formátování a sloupce se vzorci, které se k dané položce vztahují, automaticky upraveny podle aktualizovaných dat. K tlačítkům Uložit nebo Storno lze přidat integrované akce formuláře, které se ve formuláři ve výchozím nastavení zobrazí. Odkaz na další informace o integrovaných akcích formuláře naleznete v oddílu Viz také.

Začátek stránky

Proč vkládat zobrazení dat jako formulář?

Zobrazení dat je přizpůsobitelné zobrazení zdroje dat. Zobrazení dat lze vložit do stránky ASPX jako zobrazení nebo jako formulář. Je-li zobrazení dat vloženo jako zobrazení, je možné formátovat uspořádání vložených dat, ale nelze formátovat samotná data.

Jestliže však bude stejné zobrazení vloženo jako formulář, bude možné upravovat data v okně webového prohlížeče a veškeré změny se uloží do původního zdroje dat. Pomocí aplikace Office SharePoint Designer 2007 lze rychle vytvořit jeden ze tří typů formulářů ze stávajícího zdroje dat:

  • Formulář s jednou položkou zobrazuje ve formuláři jedinou položku, každé pole je na zvláštním řádku a název pole je nadpisem daného řádku. V tomto typu formuláře lze najednou upravovat data jediné položky. V tomto formuláři jsou umístěny odkazy, pomocí kterých lze zobrazit předchozí a další položku.

    Zobrazení dat vložené jako formulář s jednou položkou

  • Formulář s více položkami zobrazuje ve formuláři více položek, každé pole je ve zvláštním sloupci a název pole je nadpisem daného sloupce. V tomto typu formuláře lze upravit data více položek a uložení změn provést najednou.

    Zobrazení dat vložené jako formulář s více položkami

  • Formulář nové položky zobrazuje prázdná pole pro jedinou položku, každé pole je na zvláštním řádku a název pole je nadpisem daného řádku. V tomto typu formuláře lze do zdroje dat přidat data pro jednu novou položku. Z důvodu možnosti uložení dat najednou je vhodné do formuláře nové položky zahrnout všechna požadovaná pole.

    Formulář nové položky zobrazení dat vloženého jako formulář

Zobrazení dat vložená jako formulář lze vytvořit pro seznamy a knihovny služby SharePoint, pro připojení databáze nebo pro místní dokumenty XML. Po vložení zobrazení dat získá aplikace Office SharePoint Designer 2007 data ze zdroje dat ve formě XML zobrazí je pomocí technologie XSLT (Extensible Stylesheet Language Transformations). Formulář lze upravit, stejně jako kterékoli zobrazení dat, pomocí aplikace Office SharePoint Designer 2007.

Po vložení zobrazení dat na stránku můžete také pomocí nástrojů WYSIWYG v aplikaci Office SharePoint Designer 2007 přidávat nebo odebírat sloupce nebo měnit barvy či formátování písma. Při formátování zobrazení dat pomocí nástrojů WYSIWYG dostupných v aplikaci Office SharePoint Designer 2007 je do dokumentu HTML vložen kód XSL (Extensible Stylesheet Language). Přestože lze kód XSL upravovat přímo v zobrazení kódu, můžete pomocí nástrojů formátování v aplikaci Office SharePoint Designer 2007 použít kód XSL snadno a rychle i bez znalostí jazyka XSL.

Začátek stránky

Vytvoření souboru XML jako ukázkového zdroje dat

Společnost Northwind Traders zabývající se distribucí lahůdek sleduje své skladové zásoby v souboru XML. Když jsou zásoby nízké, zavolá člen týmu dodavatele daného produktu a zadá objednávku. Navrhuje se, aby bylo do zdroje dat vloženo zobrazení dat jako formulář, pomocí něhož by mohl člen týmu zadávající objednávku ihned aktualizovat množství objednaného zboží. Pomocí tohoto systému bude mít společnost Northwind Traders vždy nejnovější informace o stavu svých skladů.

V následujících postupech je nutné používat soubor XML jako zdroj dat. Pokud na serveru SharePoint nemáte soubor XML, je nejdříve nutné vytvořit seznam produktů společnosti Northwind Traders. Po vytvoření seznamu můžete vložit zobrazení dat jako formulář a aktualizovat tak data v seznamu.

Vytvoření souboru Products.xml

  1. V nabídce Soubor klepněte na příkaz Otevřít web.

  2. V dialogovém okně Otevřít web vyhledejte a vyberte web SharePoint a klepněte na tlačítko Otevřít.

  3. Pokud se zobrazí dialogové okno Připojit k s dotazem na uživatelské jméno a heslo, zadejte je a klepněte na tlačítko OK.

  4. V nabídce Soubor klepněte na příkaz Nový.

  5. V dialogovém okně Nový na kartě Stránka klepněte v podokně vlevo na položku Obecné a poté poklepejte na položku Textový soubor v podokně vpravo od levého podokna.

    Na webu se otevře nový textový soubor.

  6. Zkopírujte následující řádky kódu do schránky (vyberte je a stiskněte klávesovou zkratku CTRL+C).

    <?xml version="1.0" encoding="utf-8"?>
    <ProductsRoot>
    <Products>
    <ProductID>1</ProductID>
    <ProductName>Chai</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>1</CategoryID>
    <QuantityPerUnit>10 boxes x 20 bags</QuantityPerUnit>
    <UnitPrice>18</UnitPrice>
    <UnitsInStock>39</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>10</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>2</ProductID>
    <ProductName>Chang</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>1</CategoryID>
    <QuantityPerUnit>24 - 12 oz bottles</QuantityPerUnit>
    <UnitPrice>19</UnitPrice>
    <UnitsInStock>17</UnitsInStock>
    <UnitsOnOrder>40</UnitsOnOrder>
    <ReorderLevel>25</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>3</ProductID>
    <ProductName>Aniseed Syrup</ProductName>
    <SupplierID>1</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>12 - 550 ml bottles</QuantityPerUnit>
    <UnitPrice>10</UnitPrice>
    <UnitsInStock>13</UnitsInStock>
    <UnitsOnOrder>70</UnitsOnOrder>
    <ReorderLevel>25</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>4</ProductID>
    <ProductName>Chef Anton's Cajun Seasoning</ProductName>
    <SupplierID>2</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>48 - 6 oz jars</QuantityPerUnit>
    <UnitPrice>22</UnitPrice>
    <UnitsInStock>53</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>0</ReorderLevel>
    <Discontinued>0</Discontinued>
    </Products>
    <Products>
    <ProductID>5</ProductID>
    <ProductName>Chef Anton's Gumbo Mix</ProductName>
    <SupplierID>2</SupplierID>
    <CategoryID>2</CategoryID>
    <QuantityPerUnit>36 boxes</QuantityPerUnit>
    <UnitPrice>21.35</UnitPrice>
    <UnitsInStock>0</UnitsInStock>
    <UnitsOnOrder>0</UnitsOnOrder>
    <ReorderLevel>0</ReorderLevel>
    <Discontinued>1</Discontinued>
    </Products>
    </ProductsRoot>
  7. V aplikaci Office SharePoint Designer 2007 umístěte kurzor do horní části stránky a potom stisknutím kombinace kláves CTRL+V vložte právě zkopírovaný kód na stránku.

  8. V nabídce Soubor klikněte na příkaz Uložit jako.

  9. V dialogovém Uložit jako v poli název souboru zadejte products.xml.

  10. Ze seznamu Typ souboru vyberte položku XML a pak klepněte na tlačítko Uložit.

Začátek stránky

Vložení zobrazení dat jako formuláře

Při vložení zobrazení dat jako formuláře pomocí podokna úloh Podrobnosti zdroje dat nejdříve vložíte zobrazení dat do stránky. Potom vyberete zdroj dat v podokně úloh Knihovna zdrojů dat umožňujícím spravovat dostupné zdroje dat pro server SharePoint. Jakmile vyberete zdroj dat, otevře se podokno úloh Podrobnosti zdroje dat. V podokně úloh Podrobnosti zdroje dat zvolíte pole, která chcete zobrazit, a potom je vložíte do zobrazení dat.

Datové formuláře jsou založeny na technologii ASP.NET 2.0. Chcete-li vytvořit zobrazení dat, je potřeba začít se stránkou ASP.NET (soubor ASPX). V tomto příkladě vytvořte novou stránku ASP.NET a potom vložte zobrazení dat jako formulář pomocí podokna úloh Podrobnosti zdroje dat

  1. V nabídce Soubor klepněte na příkaz Nový.

  2. V dialogovém okně Nový na kartě Stránka klepněte na položku Obecné a poté poklepejte na položku ASPX.

    Otevře se nová stránka se značkou FORM.

    Značka form technologie ASP.NET

  3. V nabídce Zobrazení dat klepněte na příkaz Vložit zobrazení dat.

    Na stránce je nyní zobrazeno prázdné zobrazení dat a otevře se podokno úloh Knihovna zdrojů dat.

    Prázdné zobrazení dat

    Jakmile je vloženo zobrazení dat, je vše připraveno k přidání dat.

  4. V podokně úloh Knihovna zdrojů dat vyhledejte zdroj dat, klepněte na něj a potom klepněte na možnost Zobrazit data.

    V uvedeném příkladu klepněte v části Soubory XML na možnost products.xml a potom klepněte na možnost Zobrazit data. Pokud je záhlaví Soubory XML sbaleno, rozbalte ho klepnutím na znaménko plus (+).

  5. V podokně úloh Podrobnosti zdroje dat klepněte na pole, která chcete vložit do zobrazení dat.

    Tip: Chcete-li vybrat více polí, podržte při klepání na jednotlivá pole klávesu CTRL.

    V uvedeném příkladě klepněte ve složce KořenováSložkaProduktů v části Produkty na možnost NázevProduktu. Stiskněte a podržte klávesu CTRL a klepněte na možnosti JednotkyNaSkladě, ObjednánoJednotek a MinimálníÚroveň.

    Pole vybraná v podokně úloh Podrobnosti zdroje dat

  6. Klepněte na možnost Vložit vybraná pole jako a klepnutím na možnost Formulář s více položkami vložte vybraná data do zobrazení dat jako formuláře.

    Poznámka: Formulář s jednou položkou zobrazuje ve formuláři jedinou položku. Formulář s více položkami zobrazuje několik položek, každé pole je ve zvláštním sloupci a název pole je nadpisem daného sloupce.

    Pole vybraná v podokně úloh Podrobnosti zdroje dat se nyní zobrazí ve formuláři.

    Poznámka: Vzhledem k tomu, že se v tomto přikladu používá soubor XML, lze provést změny ve všech polích zobrazení dat. V závislosti na typu zdroje dat se však může stát, že některá pole nebude možné upravovat. Jestliže je například zdroj dat seznam služby SharePoint a ve formuláři chcete zobrazit systémová pole jako jsou Vytvořil nebo Změnil, nebude tato pole možné upravit.

    Vybraná data zobrazená jako formulář

    Po vložení zobrazení dat jako formuláře můžete pomocí nástrojů WYSIWYG (například panel nástrojů Formátování) upravovat písmo, zarovnávat text nebo měnit barvy. Při použití nového formátování pro datový bod v zobrazení dat použije aplikace Office SharePoint Designer 2007 formátování pro všechna data na stejné úrovni v souboru XML úpravou šablony stylů XSLT připojené ke stránce. Pokud jste například v předchozí ukázce vybrali možnost Chai a potom klepnuli na možnost Tučné na panelu nástrojů Formátování, použije aplikace Office SharePoint Designer 2007 stejné formátování pro veškerý obsah, který se zobrazí v poli NázevProduktu.

    Na všechna data v jedné úrovni je použito stejné formátování

  7. V nabídce Soubor klepněte na příkaz Uložit jako. V dialogovém okně Uložit jako do pole Název souboru zadejte požadovaný název souboru Uložit.

Začátek stránky

Změna dat pomocí prohlížeče

Po uložení stránky obsahující formulář lze zobrazit náhled formuláře v prohlížeči a provést v něm změny dat.

Typy polí a vstupní data

V tomto příkladu se jako zdroj dat používá soubor XML. Vzhledem k tomu, že soubor XML je soubor ve formátu prostého textu, nelze přesně určit typ hodnot, které by měla jednotlivá pole obsahovat. Příklad: Neexistuje omezení zabraňující zadání textu do pole, ve kterém mají být uvedena čísla, například pole ObjednánoJednotek.

Jestliže je však zdroj dat zdrojem dat SQL, například databáze SQL nebo knihovna nebo seznam služby SharePoint, mohou být typy polí zadány přímo ve zdroji dat. V takovém případě, jestliže do formuláře zadáte do číselného pole text a klepnete na tlačítko Uložit, se v okně prohlížeče zobrazí chybová zpráva vysvětlující, že kontrola zdroje dat nemohla provést aktualizaci. To znamená, že jste do formuláře zadali hodnoty, které zdroj dat nemůže přijmout. Jestliže se tato zpráva zobrazí, klepněte v prohlížeči na tlačítko Zpět a ve formuláři klepněte na tlačítko Storno a zrušte změny nebo zadejte do polí formuláře hodnoty, které zdroj dat přijme.

Z tohoto důvodu je při navrhování formuláře v aplikaci Office SharePoint Designer 2007 vhodné zahrnout do nadpisů sloupců i upozornění na eventuelní požadovaný typ vstupních dat.

Použití formuláře v prohlížeči

  1. V aplikaci Office SharePoint Designer 2007 v nabídce Soubor vyberte položku Náhled v prohlížeči a poté vyberte požadovaný typ prohlížeče a velikost okna.

    Klávesová zkratka: klikněte na stránku, kterou chcete zobrazit náhled v seznamu složek a stiskněte F12.

    V prohlížeči se zobrazí stránka s formulářem.

    Formulář s více položkami zobrazený v prohlížeči

  2. Můžete upravit kterákoli data zobrazená v polích formuláře v zobrazení dat. Rovněž lze změnit informace v několika polích několika položek najednou. Po provedení změn ve formuláři klepněte na příkaz Uložit pro uložení změn do zdroje dat nebo na příkaz Storno pro zrušení změn.

    V našem příkladu ve sloupci NázevProduktu v poli, který obsahuje slova Štursová, umístěte kurzor na konec slova Štursová; stiskněte klávesu MEZERNÍK a potom zadejte Čaj soustředit. Ve sloupci objednaných jednotek v Štursová záznamu typu 40. Ve sloupci objednaných jednotek v Chef Anton Cajun Seasoning záznamu zadejte 35a klikněte na Uložit. Formulář s aktualizovanými položkami zobrazený v prohlížeči.

    Zobrazí se datový formulář s aktualizovanými položkami

Začátek stránky

Doporučené další kroky

Zobrazení dat jsou velmi výkonná a zcela přizpůsobitelná zobrazení dynamických dat. Nyní již víte, jak vložit zobrazení dat jako formulář, mohly by se vám proto hodit následující informace:

  • Filtrování dat v zobrazení dat    Filtrování dat v zobrazení dat můžete jednoduše tak, aby data zobrazená přesně data, která chcete zobrazit. Další informace najdete v tématu filtrování dat v zobrazení dat.

  • Řazení a seskupení dat v zobrazení dat    Můžete rychle řadit nebo seskupovat data v zobrazení dat. Například můžete snadno seřadit seznam podle abecedy. Další informace najdete v tématu řazení a seskupení dat v zobrazení dat.

  • Použití podmíněného formátování pro zobrazení dat    Můžete použít konkrétní formátování, do zobrazení dat Pokud data v zobrazení dat splňují určité podmínky. Další informace najdete v tématu použití podmíněného formátování pro zobrazení dat.

  • Vytvoření sloupce vzorce v zobrazení dat    Můžete vytvořit počítaný sloupec, který se zobrazí výsledek výpočtu dat v zobrazení dat. Můžete například vynásobit jednotkovou cenu počtem jednotek na skladě a zobrazit celkové hodnoty položky do samostatného sloupce. Další informace najdete v tématu Vytvoření sloupce vzorce v zobrazení dat.

  • Úprava sloupců v zobrazení dat    Můžete rychle a snadno přidat, odebrat nebo změnit uspořádání sloupců v zobrazení dat. Další informace najdete v tématu Úprava sloupců v zobrazení dat.

  • Zobrazení ukázkových dat v zobrazení dat    Ukázková data můžete snadno zobrazit v zobrazení dat.

Začátek stránky

Poznámka: Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×