Vložení objektu v aplikaci Excel

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Object Linking and Embedding (OLE) umožňuje zahrnout obsah z jiných aplikací, jako je Word nebo Excel.

OLE je podporovaná v mnoha různých aplikací a OLE se používají k vytvoření obsah, který je vytvořený v jedné aplikaci k dispozici v jiné aplikaci. Například můžete vložit dokument Word v sešitu aplikace Office Excel. Jaké typy obsahu, který můžete vložit zobrazíte kliknutím na objekt ve skupině Text na kartě Vložit. V rozevíracím seznamu Typ objektu se zobrazí pouze programy, které jsou na počítači nainstalovaný, které podporují objekty OLE.

Pokud kopírujete informací mezi Excelu nebo libovolný program podporující OLE, třeba Word, můžete zkopírovat informace jako Propojený objekt nebo Vložený objekt. Hlavní rozdíly mezi propojené a vložené objekty jsou místo, kam se ukládají data a aktualizace objekt po jeho umístění v Cílový soubor. Vložené objekty jsou uložené v sešitu, který se vloží do a se neaktualizují. Propojené objekty zůstat v samostatných souborech a mohou být aktualizovány.

Propojené a vložené objekty v dokumentu

Propojené a vložené objekty v dokumentu Office pro Windows

1. vložený objekt neobsahuje žádné připojení ve zdrojovém souboru.

2. zdrojový soubor propojen na propojený objekt.

3. na zdrojový soubor aktualizuje propojený objekt.

Kdy použít propojené objekty

Pokud chcete informace ve vaší Cílový soubor mají být aktualizovány při změně dat v Zdrojový soubor, použijte propojené objekty.

U propojeného objektu zůstávají původní informace uloženy ve zdrojovém souboru. V cílovém souboru jsou zobrazeny symboly propojených informací a jsou zde uloženy pouze informace o umístění původních dat (a jejich velikost v případě, že je objektem graf aplikace Excel). Aby bylo možné zachovat propojení s původními daty, musí zůstat zdrojový soubor k dispozici v počítači nebo v síti.

Propojené informace lze automaticky aktualizovat při změně původní data ve zdrojovém souboru. Například pokud vybrat odstavec v dokumentu aplikace Word a vložte zkopírovaný odstavce jako propojený objekt v Excelovém sešitu, informace lze aktualizovat v aplikaci Excel se při změně informací v dokumentu aplikace Word.

Kdy použít vložené objekty

Pokud nechcete zkopírovaná data aktualizovat po změně ve zdrojovém souboru, použijte vložený objekt. Verze zdroje je vložený úplně v sešitu. Pokud zkopírujete informace jako vložený objekt, cílový soubor vyžaduje další místo na disku než pokud vytváříte odkaz informace.

Při otevření souboru v jiném počítači, si můžete zobrazit na vložený objekt bez nutnosti přístup k původní data. Protože vložený objekt neobsahuje žádná propojení na zdrojový soubor, na objekt neaktualizují při změně původní data. Pokud chcete změnit vložený objekt, poklikejte na objekt, který chcete otevřít a upravit ho ve zdrojovém programu. Zdrojový program (nebo jiné aplikace může tento objekt upravit) musí nainstalovaný v počítači.

Změna zobrazení objekt OLE

Propojený objekt nebo Vložený objekt můžete zobrazit v sešitu úplně stejně jako v Zdrojový program nebo jako ikona. Pokud sešit budou prohlížet online a nechcete tisknout sešitu, můžete zobrazit objekt jako ikona. To minimalizuje zobrazení prostor, který zabírá objektu. Uživatelům, kteří mají k zobrazení informací můžete poklikejte na ikonu.

Vložení objektu v listu

  1. Klikněte do buňky tabulky místo, kam chcete vložit objekt.

  2. Na kartě Vložení ve skupině Text klikněte na objekt Ikona objektu na pásu karet .
    Vložit objekt

  3. V dialogu objekt klikněte na kartu Vytvořit ze souboru.

  4. Klikněte na tlačítko Procházet a vyberte soubor, který chcete vložit.

  5. Pokud chcete vložit ikona do tabulky místo zobrazit obsah souboru, zaškrtněte políčko Zobrazit jako ikonu . Pokud nevyberete všechny zaškrtávací políčka, Excel zobrazí první stránku ze souboru. V obou případech celý soubor otevře dvojím kliknutím. Klikněte na OK.

    Poznámka : Po přidání ikonu nebo soubor, se můžete přetáhnout kdekoli na listu. Taky můžete nastavit velikost na ikonu nebo soubor pomocí úchytů pro změnu velikosti. Najít úchyty, klikněte na soubor nebo ikonu jednorázové.

Vložení odkazu do souboru

Můžete jednoduše přidat odkaz na objekt namísto plně vložení. Můžete to udělat, pokud sešit a na objekt, které chcete přidat jsou uložené na webu služby SharePoint, do sdílené síťové složky nebo podobné umístění a umístění souborů zůstane. To je užitečné, pokud propojený objekt obsahuje změny, protože odkaz, otevře se vždy aktuální dokument.

Poznámka : Pokud přesunete propojeného souboru do jiného umístění, odkaz přestal fungovat.

  1. Klikněte do buňky tabulky místo, kam chcete vložit objekt.

  2. Na kartě Vložení ve skupině Text klikněte na objekt Ikona objektu na pásu karet .
    Vložit objekt

  3. Klikněte na kartu Vytvořit ze souboru .

  4. Klikněte na tlačítko Procházet a vyberte soubor, který chcete vytvořit propojení.

  5. Zaškrtněte políčko připojit k souboru a klikněte na OK.

Vytvoření nového objektu z v Excelu

Můžete vytvořit úplně nový objekt podle jiného programu, aniž byste opustili svůj sešit. Pokud chcete přidat podrobnější vysvětlení do grafu nebo tabulce, můžete například vytvořit vložený dokument, například soubor Word nebo PowerPoint v Excel. Můžete nastavit objekt zobrazený přímo v listu nebo přidání ikony, které se otevře soubor.

Tento vložený objekt je wordový dokument.
  1. Klikněte do buňky tabulky místo, kam chcete vložit objekt.

  2. Na kartě Vložení ve skupině Text klikněte na objekt Ikona objektu na pásu karet .
    Vložit objekt

  3. Na kartě Vytvořit nový vyberte typ objektu, který chcete vložit ze seznamu prezentovat. Pokud chcete vložit ikona do tabulky místo samotného objektu, zaškrtněte políčko Zobrazit jako ikonu.

  4. Klikněte na OK. V závislosti na typu soubor, který vkládáte otevře se nové okno programu nebo aplikace Excel se zobrazí okno úprav.

  5. Vytvořte nový objekt, který chcete vložit.

    Až budete hotovi, pokud Excel otevřete nové okno aplikace ve které jste vytvořili objekt, můžete pracovat přímo v ní.

    Vložený wordový dokument můžete upravit přímo v Excelu.

    Po dokončení práce v okně, můžete udělat další úkoly bez uložení vložený objekt. Pokud ukončíte sešit nových objektů automaticky uloží.

    Poznámka : Po přidání objektu můžete přetáhnout a pusťte kdekoli na listu Excel. Můžete také změnit velikost objektu pomocí úchytů pro změnu velikosti. Najít úchyty, klepněte na objekt jednorázové.

Vložení objektu v listu

  1. Klikněte do buňky tabulky místo, kam chcete vložit objekt.

  2. Na kartě Vložit klepněte ve skupinovém rámečku Text na položku Objekt.

    Možnost Objekt je na kartě Vložení.
  3. Klepněte na kartu Vytvořit ze souboru.

    Karta Vytvořit ze souboru v dialogovém okně Objekt
  4. Klikněte na tlačítko Procházet a vyberte soubor, který chcete vložit.

  5. Pokud chcete vložit ikona do tabulky místo zobrazit obsah souboru, zaškrtněte políčko Zobrazit jako ikonu . Pokud nevyberete všechny zaškrtávací políčka, Excel zobrazí první stránku ze souboru. V obou případech celý soubor otevře dvojím kliknutím. Klikněte na OK.

    Poznámka : Po přidání ikonu nebo soubor, se můžete přetáhnout kdekoli na listu. Taky můžete nastavit velikost na ikonu nebo soubor pomocí úchytů pro změnu velikosti. Najít úchyty, klikněte na soubor nebo ikonu jednorázové.

Vložení odkazu do souboru

Můžete jednoduše přidat odkaz na objekt namísto plně vložení. Můžete to udělat, pokud sešit a na objekt, které chcete přidat jsou uložené na webu služby SharePoint, do sdílené síťové složky nebo podobné umístění a umístění souborů zůstane. To je užitečné, pokud propojený objekt obsahuje změny, protože odkaz, otevře se vždy aktuální dokument.

Poznámka : Pokud přesunete propojeného souboru do jiného umístění, odkaz přestal fungovat.

  1. Klikněte do buňky tabulky místo, kam chcete vložit objekt.

  2. Na kartě Vložit klepněte ve skupinovém rámečku Text na položku Objekt.

    Možnost Objekt je na kartě Vložení.
  3. Klikněte na kartu Vytvořit ze souboru .

  4. Klikněte na tlačítko Procházet a vyberte soubor, který chcete vytvořit propojení.

  5. Zaškrtněte políčko připojit k souboru a klikněte na OK.

    Na kartě Vytvořit ze souboru zaškrtněte políčko Propojit se souborem.

Vytvoření nového objektu z v Excelu

Můžete vytvořit úplně nový objekt podle jiného programu, aniž byste opustili svůj sešit. Pokud chcete přidat podrobnější vysvětlení do grafu nebo tabulce, můžete například vytvořit vložený dokument, například soubor Word nebo PowerPoint v Excel. Můžete nastavit objekt zobrazený přímo v listu nebo přidání ikony, které se otevře soubor.

Tento vložený objekt je wordový dokument.
  1. Klikněte do buňky tabulky místo, kam chcete vložit objekt.

  2. Na kartě Vložit klepněte ve skupinovém rámečku Text na položku Objekt.

    Možnost Objekt je na kartě Vložení.
  3. Na kartě Vytvořit nový vyberte typ objektu, který chcete vložit ze seznamu prezentovat. Pokud chcete vložit ikona do tabulky místo samotného objektu, zaškrtněte políčko Zobrazit jako ikonu.

    Karta Vytvořit nový v dialogovém okně Objekt
  4. Klikněte na OK. V závislosti na typu soubor, který vkládáte otevře se nové okno programu nebo aplikace Excel se zobrazí okno úprav.

  5. Vytvořte nový objekt, který chcete vložit.

    Až budete hotovi, pokud Excel otevřete nové okno aplikace ve které jste vytvořili objekt, můžete pracovat přímo v ní.

    Vložený wordový dokument můžete upravit přímo v Excelu.

    Po dokončení práce v okně, můžete udělat další úkoly bez uložení vložený objekt. Pokud ukončíte sešit nových objektů automaticky uloží.

    Poznámka : Po přidání objektu můžete přetáhnout a pusťte kdekoli na listu Excel. Můžete také změnit velikost objektu pomocí úchytů pro změnu velikosti. Najít úchyty, klepněte na objekt jednorázové.

Propojení nebo vložení obsahu z jiné aplikace pomocí OLE

Můžete propojení nebo vložení část nebo celý obsah z jiného programu.

Vytvoření odkazu na obsah z jiného programu

  1. Klikněte do listu, kam chcete umístit Propojený objekt.

  2. Na kartě Vložit klepněte ve skupinovém rámečku Text na položku Objekt.

    Vzhled pásu karet aplikace Excel

  3. Klepněte na kartu Vytvořit ze souboru.

  4. Do pole Název souboru zadejte název souboru nebo soubor vyberte ze seznamu klepnutím na tlačítko Procházet.

  5. Zaškrtněte políčko Vytvořit propojení.

  6. Proveďte jeden z následujících kroků:

    • Chcete-li zobrazit obsah, zrušte zaškrtnutí políčka Zobrazit jako ikonu.

    • Zobrazit ikonu, zaškrtněte políčko Zobrazit jako ikona. V případě potřeby můžete změnit výchozí obrázek nebo popisek, klepněte na Ikonu změnit a potom klikněte na ikonu, kterou chcete ze seznamu ikona nebo do pole Titulek zadejte popisek.

    Poznámka : Pomocí příkazu objekt nelze vkládat symboly a určitých typů souborů. Pokud chcete vložit obrázek nebo soubor, na kartě Vložení ve skupině Ilustrace, klikněte na Obrázek.

Vkládání obsahu z jiného programu

  1. Klikněte do listu, kam chcete umístit Vložený objekt.

  2. Na kartě Vložit klepněte ve skupinovém rámečku Text na položku Objekt.

    Vzhled pásu karet aplikace Excel

  3. Pokud dokument už neexistuje, klikněte na Vytvořit novou kartu. V rozevíracím seznamu Typ objektu klikněte na typ objektu, který chcete vytvořit.

    Jestliže dokument již existuje, klepněte na kartu Vytvořit ze souboru. Do pole Název souboru zadejte název souboru nebo soubor vyberte ze seznamu klepnutím na tlačítko Procházet.

  4. Zrušte zaškrtnutí políčka Vytvořit propojení.

  5. Proveďte jeden z následujících kroků:

    • Chcete-li zobrazit obsah, zrušte zaškrtnutí políčka Zobrazit jako ikonu.

    • Zobrazit ikonu, zaškrtněte políčko Zobrazit jako ikona. Chcete-li změnit výchozí obrázek nebo popisek, klepněte na Ikonu změnit a klikněte na ikonu, kterou chcete ze seznamu ikona nebo do pole Titulek zadejte popisek.

Propojení nebo vložení Částečný obsah z jiného programu

  1. V aplikacích Excel vyberte informace, které chcete zkopírovat jako propojený nebo Vložený objekt.

  2. Na kartě Domů klepněte ve skupině Schránka na položku Kopírovat.

    Vzhled pásu karet aplikace Excel

  3. Přepněte na list, který chcete umístit a klikněte na místo, kam chcete tyto informace zobrazit.

  4. Na kartě Domů klikněte ve skupině Schránka na šipku pod možností Vložit a potom na Vložit jinak.

  5. Proveďte jeden z následujících kroků:

    • Informace vložíte jako propojený objekt klepnutím na tlačítko Vložit propojení.

    • Chcete-li vložit jako vložený objekt, klikněte na Vložit. V dialogovém okně jako klikněte na položku slovem "objekt" v názvu. Například pokud jste zkopírovali informace z dokumentu aplikace Word, klikněte na možnost Dokument aplikace Microsoft Word.

Změna zobrazení objekt OLE

  1. Klikněte pravým tlačítkem myši na ikonu nebo objekt, přejděte na Typ objektuobjekt (například Objekt dokument ) a potom klikněte na Převést.

  2. Proveďte jeden z následujících kroků:

    • Chcete-li zobrazit obsah, zrušte zaškrtnutí políčka Zobrazit jako ikonu.

    • Zobrazit ikonu, zaškrtněte políčko Zobrazit jako ikona. Pokud chcete můžete změnit výchozí obrázek nebo popisek. Aby je dostala, klepněte na Ikonu změnit a klikněte na ikonu, kterou chcete ze seznamu ikona nebo do pole Titulek zadejte popisek.

Ovládací prvek aktualizace propojené objekty

Můžete nastavit propojení do jiných programů mají být aktualizovány následujícími způsoby: automaticky při otevření Cílový soubor; ručně, kdy chcete zobrazit předchozí data před aktualizací dat z Zdrojový soubor; nebo když konkrétně požádat o aktualizaci, bez ohledu na to zda automatické nebo ruční aktualizaci je zapnutá.

Nastavení ruční aktualizace propojení s jinou aplikací

  1. Na kartě Data klepněte ve skupině Spravovat připojení na položku Upravit odkazy.

    Vzhled pásu karet aplikace Excel

    Poznámka : Příkaz Upravit odkazy není k dispozici, pokud soubor neobsahuje odkazy na další soubory.

  2. V seznamu zdroj klikněte na propojený objekt, který chcete aktualizovat. A ve sloupci Aktualizovat znamená, že je automatické propojení a Maktualizace sloupec znamená, že je odkaz nastavena na Ruční aktualizaci.

    Tip : Chcete-li vybrat více propojených objektů, podržte stisknutou klávesu CTRL a klikněte na požadované objekty. Chcete-li vybrat všechna propojení, stiskněte kombinaci kláves CTRL + A.

  3. Chcete-li, aby aktualizace propojeného objektu proběhla pouze po klepnutí na tlačítko Aktualizovat hodnoty, klepněte na přepínač Ručně.

Nastavení automatické aktualizace propojení s jinou aplikací

  1. Na kartě Data klepněte ve skupině Spravovat připojení na položku Upravit odkazy.

    Vzhled pásu karet aplikace Excel

    Poznámka : Příkaz Upravit odkazy není k dispozici, pokud soubor neobsahuje odkazy na další soubory.

  2. V seznamu zdroj klikněte na propojený objekt, který chcete aktualizovat. Písmeno A ve sloupci Aktualizovat znamená, že odkaz se automaticky aktualizuje a M ve sloupci Aktualizovat znamená, že odkaz musíte aktualizovat ručně.

    Tip : Chcete-li vybrat více propojených objektů, podržte stisknutou klávesu CTRL a klikněte na požadované objekty. Chcete-li vybrat všechna propojení, stiskněte kombinaci kláves CTRL + A.

  3. Klepněte na tlačítko OK.

Problém: nelze aktualizovat automatické propojení na listu

Možnost automaticky můžete přepsat tak, že možnost Aktualizovat odkazy na jiné dokumenty aplikace Excel.

Zajistit, že automatické odkazů na objekty OLE automaticky aktualizován:

  1. Klikněte na Tlačítko Microsoft Office Obrázek tlačítka , klikněte na Možnosti aplikace Excel a pak klikněte na kategorii Upřesnit.

  2. V části při výpočtech v tomto sešitu Ujistěte se, že je zaškrtnuto políčko Aktualizovat odkazy na další soubory.

Okamžitá aktualizace propojení s jinou aplikací

  1. Na kartě Data klepněte ve skupině Spravovat připojení na položku Upravit odkazy.

    Vzhled pásu karet aplikace Excel

    Poznámka : Pokud soubor neobsahuje propojené informace, není příkaz Upravit propojení k dispozici.

  2. Ve sloupci Zdroj klepněte na propojený objekt, který chcete aktualizovat.

    Tip : Chcete-li vybrat více propojených objektů, podržte stisknutou klávesu CTRL a klikněte na požadované objekty. Chcete-li vybrat všechna propojení, stiskněte kombinaci kláves CTRL + A.

  3. Klepněte na tlačítko Aktualizovat hodnoty.

Upravit obsah z aplikace sady OLE

Při práci v aplikaci Excel, můžete změnit obsah propojené nebo vložené z jiného programu.

Úpravy propojeného objektu ve zdrojovém programu

  1. Na kartě Data klepněte ve skupině Spravovat připojení na položku Upravit odkazy.

    Vzhled pásu karet aplikace Excel

    Poznámka : Pokud soubor neobsahuje propojené informace, není příkaz Upravit propojení k dispozici.

  2. V seznamu zdrojového souboru klikněte na zdroj pro Propojený objekt a potom klikněte na Otevřít zdroj.

  3. Proveďte požadované změny, které chcete propojený objekt.

  4. Ukončete Zdrojový program se vraťte do cílového souboru.

Úprava vloženého objektu ve zdrojovém programu

  1. Poklikejte na Vložený objekt a otevřete ho.

  2. Proveďte požadované změny, které chcete objekt.

  3. Pokud upravujete objekt na místě v otevřené aplikaci, klikněte kamkoli mimo objekt se vrátíte do Cílový soubor.

    Pokud upravíte vložený objekt ve zdrojovém programu v samostatném okně, ukončete aplikaci zdroje se vraťte do cílového souboru.

Poznámka : Poklikáním některé vložené objekty, například videa a zvukové klipy, spustí místo spuštění programu. Upravit jednu z těchto vložených objektů, klikněte pravým tlačítkem myši na ikonu nebo objekt, přejděte na Typ objektuobjekt (například Objekt multimediální klip ) a potom klikněte na Upravit.

Úprava vloženého objektu v aplikaci než zdrojový program

  1. Vyberte Vložený objekt, kterou chcete upravit.

  2. Klikněte pravým tlačítkem myši na ikonu nebo objekt, přejděte na Typ objektuobjekt (například Objekt dokument ) a potom klikněte na Převést.

  3. Proveďte jeden z následujících kroků:

    • Pokud chcete převést na vložený objekt typ, který určíte v seznamu, klikněte na převést na.

    • Pokud chcete otevřít vložený objekt jako typ, který určíte v seznamu beze změny typu vloženého objektu, klikněte na Aktivovat.

Vyberte objekt OLE pomocí klávesnice

  1. Stisknutím kombinace kláves CTRL+G zobrazte dialogové okno Přejít na.

  2. Klikněte na zvláštní a vyberte objekty.

  3. Stisknutím klávesy TAB, dokud není vybrán požadovaný objekt.

  4. Stiskněte kombinaci kláves SHIFT+F10.

  5. Přejděte na nebo Objekt grafu a potom klikněte na Upravit.

Problém: Při poklepání propojeného nebo vloženého objektu, "nelze upravit" zobrazí se zpráva

Tato zpráva se zobrazí, když Zdrojový soubor nebo Zdrojový program nelze otevřít.

Ujistěte se, že zdrojový program je k dispozici     Pokud zdrojový program není nainstalován ve vašem počítači, převeďte objekt na formát souboru programu, který jste nainstalovali.

Zkontrolujte, zda že paměť je adekvátní množství     Ujistěte se, že máte dost paměti ke spuštění aplikace zdroje. Zavřete ostatní programy a uvolnit tak pamětí, v případě potřeby.

Zavřete všechna dialogová okna     Pokud je zdrojový program, ujistěte se, že nemá všechna otevřená dialogová. Přepněte do zdrojový program a zavřete všechna otevřená dialogová.

Zavřením zdrojového souboru     Pokud zdrojový soubor je propojený objekt, ujistěte se, že jiný uživatel nemá ji otevřete.

Zkontrolujte, zda se nezměnil název zdrojového souboru     -Li zdrojový soubor, který chcete upravit na propojený objekt, ujistěte se, že má stejný název jako když jste vytvořili propojení a zda nebyla přesunut. Vyberte propojený objekt a potom klikněte na příkaz Upravit odkazy na kartě Data klikněte ve skupině připojení zobrazit název zdrojového souboru. Pokud zdrojový soubor byl přejmenovat nebo přesunout, vyhledejte zdrojový soubor a obnovte na odkaz pomocí na tlačítko Změnit zdroj v dialogovém okně Upravit odkazy.

Potřebujete další pomoc?

Kdykoli se můžete zeptat některého odborníka v technické komunitě Excelu, získat podporu v komunitě pro odpovědi, případně navrhnout novou funkci nebo vylepšení na fóru Excel User Voice.

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×