Výběr dat pomocí dotazu

Chcete-li vybrat konkrétní data z jednoho nebo více zdrojů, můžete použít výběrový dotaz. Výběrový dotaz umožňuje načíst pouze data, která chcete, a také usnadňuje kombinování dat z několika zdrojů. Jako zdroj dat pro výběrový dotaz můžete použít tabulky nebo jiné výběrové dotazy. Toto téma obsahuje přehled výběrových dotazů a nabízí postup vytvoření výběrového dotazu pomocí Průvodce dotazem nebo Návrhové zobrazení.

Pokud chcete použít ukázkovou databázi Northwind, abyste se dozvěděli víc o fungování dotazů, najdete víc informací v článku Úvod k dotazům.

V tomto článku

Základní informace

Vytvoření výběrového dotazu pomocí Průvodce dotazem

Vytvoření dotazu pomocí návrhového zobrazení

Základní informace

Při práci s daty používáte jen zřídka všechna data z tabulky. Například, když chcete použít data z tabulky Kontakty, obvykle se chcete podívat na jeden konkrétní záznam nebo možná jen na telefonní číslo. Někdy chcete zkombinovat data z více než jedné tabulky, například informace o zákazníkovi s informacemi o objednávce. Chcete-li vybrat data, která chcete použít, použijte výběrový dotaz.

Výběrový dotaz je databázový objekt, který zobrazuje informace v Zobrazení Datový list. Dotaz data neukládá, zobrazuje data uložená v tabulkách. Dotaz může zobrazit data z jedné nebo více tabulek, z jiných dotazů nebo z kombinace obojího.

Výhody používání dotazů

Dotaz umožňuje:

  • Zobrazení dat pouze z polí, která chcete vidět. Po otevření tabulky se zobrazí všechna pole. Dotaz představuje praktický způsob uložení výběru polí.

    Poznámka : Dotaz pouze odkazuje na data, neukládá je. Když ukládáte dotaz, neukládáte kopii dat.

  • Kombinování dat z několika zdrojů. Tabulky obvykle zobrazují pouze data, která ukládají. Dotaz vám umožňuje vybrat pole z různých zdrojů a také vám umožňuje určit, jak by se měly informace kombinovat.

  • Použití výrazů jako polí. Jako pole můžete například použít funkci Datum nebo funkci Formát s polem a řídit tak způsob formátování dat pole ve výsledcích dotazu.

  • Zobrazování záznamů, které splňují určená kritéria. Po otevření tabulky se zobrazí všechny záznamy. Dotaz představuje praktický způsob uložení výběru záznamů.

Základní postup pro vytvoření výběrového dotazu

Výběrový dotaz můžete vytvořit pomocí Průvodce dotazem nebo v návrhovém zobrazení. Některé prvky pro návrh nejsou v průvodci k dispozici, můžete je ale přidat později v návrhovém zobrazení. Přestože se tyto dvě metody od sebe trochu liší, základní kroky jsou v podstatě stejné:

  1. Vyberte tabulky nebo dotazy, které chcete použít jako zdroj dat.

  2. Ze zdrojů dat určete pole, která chcete zahrnout.

  3. Volitelně můžete určit kritéria, která omezí záznamy vrácené dotazem.

Po spuštění vytvořeného výběrového dotazu se zobrazí výsledky. Chcete-li výběrový dotaz spustit, otevřete jej ve zobrazení Datový list. Pokud dotaz uložíte, můžete jej v případě potřeby kdykoli znovu použít, například jako zdroj dat pro formulář, sestavu nebo jiný dotaz.

Začátek stránky

Vytvoření výběrového dotazu pomocí Průvodce dotazem

Pomocí Průvodce dotazem můžete výběrový dotaz vytvořit automaticky. Při použití průvodce budete mít menší kontrolu nad podrobnostmi návrhu dotazu. Obvykle ale dotaz vytvoříte rychleji, než kdybyste průvodce nepoužili. Kromě toho může průvodce zachytit některé jednoduché chyby návrhu a vyzve vás k provedení jiné akce.

Při použití průvodce nejsou některé prvky pro návrh k dispozici. Nicméně až s průvodcem skončíte, můžete dotaz upravit v návrhovém zobrazení.

Než začnete

Pokud použijete pole ze zdrojů dat, které mezi sebou nemají relaci, Průvodce dotazem se vás dotáže, jestli nechcete relace vytvořit. Průvodce vám otevře okno Relace. Pokud ale některé relace upravíte, budete muset průvodce restartovat. Proto před spuštěním průvodce zvažte vytvoření relací mezi tabulkami, které pro dotaz potřebujete.

Další informace o vytváření relací mezi tabulkami naleznete v článku Příručka k relacím mezi tabulkami.

Použití Průvodce dotazem

  1. Na kartě Vložení klepněte ve skupině Jiné na položku Průvodce dotazem.

  2. V dialogovém okně Nový dotaz klepněte na položku Průvodce jednoduchým dotazem a poté klepněte na tlačítko OK.

  3. Dále přidejte pole. Můžete přidat až 255 polí z až 32 tabulek nebo dotazů.

    1. Pro každé pole proveďte tyto dva kroky:

    2. V části Tabulky či dotazy klepněte na tabulku nebo dotaz, který obsahuje pole.

    3. V části Pole k dispozici poklepejte na pole, které chcete přidat do seznamu Vybraná pole.

    4. Až přidáte všechna požadovaná pole, klepněte na Další.

  4. Pokud jste nepřidali žádná číselná pole (pole, která obsahují číselná data), přejděte ke kroku 9. Pokud jste nějaká číselná pole přidali, průvodce se zeptá, jestli má dotaz vrátit podrobnosti nebo souhrnná data.

    1. Proveďte jednu z následujících akcí:

    2. Pokud chcete zobrazit jednotlivé záznamy, klepněte na Podrobnosti a poté klepněte na Další. Přejděte ke kroku 9.

    3. Pokud chcete zobrazit souhrnná číselná data, například průměry, klepněte na Souhrn a potom klepněte na Možnosti souhrnu.

  5. V dialogovém okně Možnosti souhrnu určete pole, která chcete shrnout, a způsob, jakým chcete, aby se data shrnula. Jsou uvedena pouze číselná pole.

    1. Pro každé číselné pole vyberte jednu z následujících funkcí:

    2. Sum:    Dotaz vrátí součet všech hodnot v poli.

    3. Avg:    Dotaz vrátí průměr hodnot v poli.

    4. Min:    Dotaz vrátí nejmenší hodnotu v poli.

    5. Max:    Dotaz vrátí největší hodnotu v poli.

  6. Pokud chcete do výsledků dotazu zahrnout počet záznamů ze zdroje dat, zaškrtněte příslušné políčko Spočítat záznamy ve zdroji dat.

  7. Klepnutím na tlačítko OK zavřete dialogové okno Možnosti souhrnu.

  8. Pokud jste do dotazu nepřidali pole typu datum a čas, přejděte ke kroku 9. Pokud jste do dotazu přidali pole typu datum a čas, Průvodce dotazem se zeptá, jak byste chtěli hodnoty kalendářních dat seskupit. Předpokládejme například, že jste do dotazu přidali číselné pole (Cena) a pole typu datum a čas (Čas_transakce) a poté jste v dialogovém okně Možnosti souhrnu určili, že chcete zobrazit průměrnou hodnotu číselného pole Cena. Vzhledem k tomu, že jste přidali pole typu datum a čas, můžete nechat vypočítat souhrnné hodnoty pro každou hodnotu data a času: pro každý den, pro každý měsíc, za každé čtvrtletí nebo pro každý rok.

    1. Poznámka : V návrhovém zobrazení můžete pomocí výrazu seskupovat dle libovolného časového období, průvodce ale nabízí pouze tyto volby.

    2. Vyberte časové období, které chcete k seskupení datových a časových hodnot použít, a poté klepněte na tlačítko Další.

  9. Dotaz pojmenujte, určete, zda jej chcete otevřít nebo upravit, a potom klepněte na tlačítko Dokončit.

    Pokud se rozhodnete dotaz otevřít, zobrazí se vybraná data ve zobrazení Datový list. Pokud se rozhodnete dotaz upravit, otevře se v návrhovém zobrazení.

Začátek stránky

Vytvoření dotazu pomocí návrhového zobrazení

Chcete-li výběrový dotaz vytvořit ručně, můžete použít návrhové zobrazení. Při použití návrhového zobrazení budete mít větší kontrolu nad podrobnostmi o návrhu dotazu, snadněji ale uděláte chybu v návrhu a může to trvat déle, než kdybyste použili průvodce.

Vytvoření dotazu

Krok 1: Přidání zdrojů dat

Krok 2: Spojení souvisejících zdrojů dat

Krok 3: Přidání výstupních polí

Krok 4: Určení kritéria

Krok 5: Shrnutí dat

Krok 1: Přidání zdrojů dat

Při použití návrhového zobrazení budete zdroje dat a pole přidávat v samostatných krocích, protože pro přidávání zdrojů dat používáte dialogové okno Zobrazit tabulku. Nicméně, pokud chcete, můžete další zdroje dat přidat později.

  1. Ve skupině Jiné na kartě Vytvořit klepněte na tlačítko Návrh dotazu.

  2. V dialogovém okně Zobrazit tabulku na kartě Obojí poklepejte na každý zdroj dat, který chcete použít.

  3. Zavřete dialogové okno Zobrazit tabulku.

Automatická spojení

Pokud přidáváte zdroje dat s definovanými relacemi, přidají se tyto relace do dotazu automaticky jako spojení. Spojení určují, jak by se měla kombinovat data ze souvisejících zdrojů. Aplikace Access rovněž vytvoří automaticky spojení mezi dvěma tabulkami, pokud mají pole s kompatibilními datovými typy a jedno z nich je Primární klíč.

Možná budete chtít spojení vytvořená aplikací Access upravit. Aplikace Access určí, jaký typ spojení se má podle relace, kterou spojení představuje, vytvořit. Pokud aplikace Access vytvoří spojení a neexistuje žádná definovaná relace, vytvoří Vnitřní spojení.

Pokud aplikace Access po přidání zdroje dat vytvoří automaticky správná spojení, můžete přejít na Krok 3: Přidání výstupních polí.

Použití stejného zdroje dat vícekrát

V některých případech chcete spojit dvě kopie stejné tabulky nebo dotazu, což se označuje jako Vlastní spojení, kdy se sloučí záznamy ze stejné tabulky, pokud ve spojených polích existují shodné hodnoty. Máte například tabulku Zaměstnanci s polem Nadřízený, které u záznamu každého zaměstnance zobrazuje identifikátor manažera místo jeho jména. K zobrazení jména manažera u záznamu jednotlivých zaměstnanců můžete místo toho použít spojení sama na sebe.

Když přidáte zdroj dat podruhé, aplikace Access připojí k názvu druhé instance _1. Pokud byste například přidali dvakrát tabulku Zaměstnanci, druhá instance by se jmenovala Zaměstnanci_1.

Začátek oddílu

Krok 2: Spojení souvisejících zdrojů dat

Pokud zdroje dat, které přidáváte do dotazu, již mají relace, aplikace Access pro každou z nich vytvoří vnitřní spojení. Pokud je zajištěna Referenční integrita, je nad čarou spojení u Relace 1:N zobrazena číslice 1 označující tabulku na straně 1 a symbol nekonečna () označující tabulku na straně N.

Pokud do dotazu přidáte dotazy a nevytvoříte mezi nimi relace, aplikace Access mezi nimi, nebo mezi dotazy a tabulkami, které nejsou v relaci, spojení automaticky nevytvoří. Pokud aplikace Access po přidání zdrojů dat spojení nevytvoří, musíte je obvykle přidat sami. Zdroje dat, které nejsou spojené s žádným dalším zdrojem dat, mohou způsobovat potíže s výsledky dotazu.

Možná taky budete chtít změnit typ spojení z vnitřního spojení na Vnější spojení, aby dotaz obsahoval více záznamů.

Přidání spojení

  • Chcete-li přidat spojení, přetáhněte pole z jednoho zdroje dat na odpovídající pole ve druhém zdroji dat.

    Aplikace Access mezi těmito dvěma poli zobrazí čáru, která ukazuje, že bylo vytvořeno spojení.

    Čára spojení v zobrazení Návrh dotazu
    Čára spojení (v červeném kroužku).

Změna spojení

  1. Poklepejte na spojení, které chcete změnit.

    Zobrazí se dialogové okno Vlastnosti spojení.

    Dialogové okno Vlastnosti spojení
    Dialogové okno Vlastnosti spojení. Povšimněte si, že se názvy tabulek v dialogovém okně mění podle toho, jak se mění množina zahrnutých tabulek.
  2. V dialogovém okně Vlastnosti spojení si projděte tři možnosti.

  3. Klepněte na možnost, kterou chcete použít, a potom klepněte na tlačítko OK.

Jakmile jsou spojení připravena, přidejte výstupní pole – pole obsahující data, která chcete vidět ve výsledcích dotazu.

Začátek oddílu

Krok 3: Přidání výstupních polí

Pole z libovolného zdroje dat, který jste přidali v kroku 1, přidáte snadno.

  • Chcete-li přidat pole, přetáhněte jej ze zdroje dat v horním podokně okna návrhu dotazu dolů na řádek Pole v návrhové mřížce v dolním podokně okna návrhu dotazu.

    Když pole přidáte tímto způsobem, aplikace Access automaticky vyplní řádek Tabulka v návrhové mřížce tak, aby obsahoval zdroje dat pole.

Použití výrazu ve výstupním poli

Chcete-li utvořit výstup dotazu provedením výpočtů nebo použitím funkce, můžete jako výstupní pole použít Výraz. Výraz, stejně jako funkce, jako například Format nebo InStr, může použít data z libovolného zdroje dat dotazu a může také obsahovat konstanty a aritmetické operátory.

  1. V prázdném sloupci návrhové mřížky dotazu klepněte pravým tlačítkem myši na řádek Pole a potom klepněte na příkaz Lupa v místní nabídce.

  2. V dialogovém okně Lupa zadejte nebo vložte výraz. Před výraz zadejte název, který chcete použít pro výstup výrazu, následovaný dvojtečkou. Pokud byste chtěli výraz označit například jako Poslední aktualizace, měli byste výraz začít textem: Poslední aktualizace:.

    Poznámka : Pomocí výrazů můžete provádět spoustu úkonů. Podrobné vysvětlení výrazů je nad rámec tohoto článku. Další informace o vytváření výrazů naleznete v článku Vytvoření výrazu.

Začátek oddílu

Krok 4: Určení kritéria

Tento krok je volitelný.

K omezení záznamů, které váš dotaz vrátí, můžete použít kritérium. Záznamy se omezí na základě toho, jestli hodnoty daného pole odpovídají určenému kritériu.

Určení kritéria pro výstupní pole

  1. V návrhové mřížce dotazu v řádku Kritéria zadejte pole, podle jehož hodnot chcete omezovat, a zadejte výraz, který musí hodnoty pole splňovat, aby mohly být zahnuty do výsledků. Chcete-li například omezit dotaz tak, aby byly vráceny záznamy, ve kterých má pole Město hodnotu Las Vegas, v řádku Kritéria zadejte do daného pole Las Vegas.

    Některé příklady kritérií dotazů naleznete v článku Příklady kritérií dotazů.

  2. Veškerá alternativní kritéria můžete určit v řádku Nebo pod řádkem Kritéria.

    Pokud určíte alternativní kritéria, stačí, aby hodnoty polí splňovaly některá z uvedených kritérií a budou ve výsledku dotazu zahrnuty.

Kritéria pro více polí

Kritéria můžete použít u více polí. Když to tak uděláte, musí být všechna kritéria v daném řádku Kritéria a Nebo splněna, aby mohl být záznam zahrnut.

Určení kritéria pomocí pole, které nebude na výstupu.

Do návrhu dotazu můžete přidat pole, jehož data nechcete zahrnout do výstupu dotazu. Toto můžete chtít provést v případě, kdy chcete hodnoty pole použít k omezení výsledků dotazu a nechcete je přitom vidět.

  1. Přidejte pole do návrhové mřížky.

  2. Zrušte zaškrtnutí políčka pro dané pole v řádku Zobrazit.

  3. Určete kritérium stejně, jako byste to udělali pro výstupní pole

Začátek oddílu

Krok 5: Shrnutí dat

Tento krok je volitelný.

Možná budete chtít data shrnout, obzvlášť pokud se bude jednat o číselná data. Budete chtít například zobrazit průměrnou cenu nebo souhrn prodeje.

K vytvoření souhrnu dat v dotazu můžete použít řádek Souhrn. Ve výchozím nastavení není v návrhovém zobrazení řádek Souhrn zobrazen.

  1. Při otevřeném dotazu v návrhovém zobrazení klepněte na kartě Návrh ve skupině Zobrazit či skrýt na možnost Souhrn.

    V návrhové mřížce aplikace Access se zobrazí řádek Souhrn.

  2. Pro každé pole, která chcete sumarizovat, zvolte funkci ze seznamu v řádku Souhrn. Dostupnost funkcí závisí na datovém typu pole.

Začátek oddílu

Začátek stránky

Sdílení Facebook Facebook Twitter Twitter E-mail E-mail

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×