Uspořádání položek v seznamu

To, jakým způsobem uspořádáte seznamy, závisí na potřebách skupiny a na tom, jakému způsobu uložení a vyhledávání informací dáváte přednost.

V tomto článku:

Způsoby uspořádání seznamů

Přidání sloupce do seznamu

Vytvoření zobrazení

Výběr jiného zobrazení

Přidání složky do seznamu

Způsoby uspořádání seznamů

Zde jsou uvedeny některé způsoby uspořádání seznamů a položek seznamů:

  • Přidání sloupců.    Aby vaše skupina dokázala určit nejdůležitější položky, můžete do seznamu přidat sloupce. Můžete také přidat další sloupce, pokud chcete shromažďovat další informace pro každou položku seznamu, například název oddělení nebo jméno zaměstnance.

    Pokud máte v seznamu více položek, můžete zvážit indexování určitých sloupců ke zdokonalení výkonu při prohlížení více položek nebo při přepínání zobrazení. Touto funkcí nelze změnit způsob uspořádání položek, může však společnostem umožnit snadněji ukládat velký počet položek v seznamu. Indexování však může znamenat větší nároky na místo v databázi. Další informace získáte od správce.

  • Vytvoření zobrazení.    Pokud uživatelé ve skupině potřebují často zobrazovat data různými způsoby, můžete použít zobrazení. V zobrazeních se k řazení, seskupování, filtrování a zobrazování dat používají sloupce. Můžete také vybrat, kolik položek se v každém zobrazení najednou zobrazí. Uživatelé mohou například procházet seznam v sadách po 25 nebo 100 položkách seznamu na stránku, a to v závislosti na předvolbách a rychlosti připojení.

    Zobrazení nabízí flexibilitu k ukládání velkého počtu položek v seznamu, ale k zobrazení pouze dílčích sad, které v danou dobu chcete zobrazit, například pouze položky, které byly publikovány tento rok, nebo pouze aktuální události v kalendáři. Můžete vytvořit osobní zobrazení, která budete mít k dispozici pouze vy, a pokud máte oprávnění k úpravě seznamu, můžete vytvořit veřejná zobrazení, která jsou k dispozici pro všechny uživatele.

  • Vytvoření složek.    Složky můžete přidávat do většiny typů seznamů, pokud vlastník seznamu povolil vytvoření složek. To je užitečné zejména v případě, že lze položky seznamu konkrétním způsobem rozdělit, například podle projektu nebo podle skupiny. Složky umožňují uživatelům snadněji procházet a spravovat položky seznamu. Windows SharePoint Services 3.0 nabízí stromové zobrazení, které uživatelům umožňuje navigaci na webech a ve složkách podobným způsobem, jakým pracují se složkami na pevném disku. Například každé oddělení může mít svou vlastní složku.

    Konzistentní používání seznamů na různých webech:    Pokud vaše skupina pracuje s více typy seznamů, můžete dosáhnout jejich konzistentnosti pomocí Typ obsahu, sloupců webu a šablon seznamů. Tyto funkce umožňují efektivním způsobem opakovaně používat nastavení a strukturu seznamů. Můžete například vytvořit typ obsahu pro problémy služeb zákazníkům - v tomto typu obsahu budou definovány určité sloupce (například kontakt na zákazníka) a obchodní procesy. Dalším příkladem může být vytvoření sloupce webu pro názvy oddělení - tento sloupec webu bude obsahovat rozevírací seznam oddělení. Takový sloupec je možné použít opakovaně ve více seznamech a zajistit tak, aby se názvy zobrazily ve všech seznamech stejným způsobem.

    Odkazy na další informace o typech obsahu, sloupcích webu a šablonách seznamů naleznete v části Viz také.

Přestože můžete používat funkce seznamu různými způsoby, závisí to, jakým způsobem je budete používat, na velikosti a počtu položek seznamu, a potřebách společnosti.

Uložení více souborů v jednom seznamu

Může být nutné, aby jeden rozsáhlý seznam sloužil k různým účelům. Máte například velký počet technických problémů, které budete sledovat ve společnosti, a tyto problémy se mohou týkat více projektů a skupin.

Jediný seznam použijte v tomto případě:

  • Skupina potřebuje zobrazit souhrnné informace o položkách seznamu nebo zobrazovat různé pohledy na stejnou sadu položek. Vedoucí například chce zobrazit průběh zpracování všech technických problémů pro danou společnost nebo všechny problémy zaznamenané ve stejném období.

  • Uživatelé chtějí procházet nebo vyhledávat problémy ve stejném umístění na webu.

  • Chcete pro položky seznamu použít stejné nastavení, například sledování Správa verzí souborů nebo vyžadování schválení.

  • Skupiny pracující se seznamem sdílejí podobné vlastnosti, například stejné úrovně oprávnění. Pro konkrétní položky seznamu lze nastavit jedinečná oprávnění, pokud se však úrovně oprávnění významně liší, bude pravděpodobně vhodnější používat více seznamů.

  • Chcete analyzovat informace o seznamu nebo přijmout sloučené aktualizace seznamu. Můžete nastavit, aby vám bylo zasláno upozornění v případě, že dojde ke změně položek seznamu, nebo si můžete prohlížet změny seznamu pomocí technologie RSS. Kanály RSS umožňují členům pracovní skupiny zobrazit sloučený seznam informací, které se změnily.

Vytvoření více seznamů

Více seznamů je vhodnější používat v případě výrazných rozdílů mezi položkami, které chcete spravovat, nebo mezi skupinami uživatelů, kteří s nimi budou pracovat.

Více seznamů použijte v tomto případě:

  • Neočekáváte, že uživatelé budou najednou potřebovat souhrny položek.

  • Skupiny uživatelů, kteří s informacemi pracují, se liší a mají různé úrovně oprávnění.

  • Je třeba používat různá nastavení pro více sad položek, například správa verzí nebo schvalování.

  • Není potřeba analyzovat položky společně nebo přijímat sloučené aktualizace seznamů.

Začátek stránky

Přidání sloupce do seznamu

Informace v seznamech jsou uloženy ve sloupcích, například Titul, Příjmení nebo Společnost. Pokud potřebujete uložit další informace o položkách seznamu, můžete přidat další sloupce, které vám pomohou setřídit, seskupit a vytvořit více zobrazení seznamu. Seznam můžete například seřadit podle termínu splnění nebo seskupit položky podle názvu oddělení.

U typu sloupce, který vytváříte, je k dispozici několik možností, k nimž patří jeden řádek textu, rozevírací seznam možností, číslo vypočtené z jiných sloupců nebo jméno a obrázek osoby na webu.

Poznámka : Následující postup začíná na stránce seznamu, do kterého chcete přidat sloupec. Pokud seznam není ještě otevřen, klepněte na jeho název na panelu Snadné spuštění. Pokud se název seznamu nezobrazí, klepněte na možnost Zobrazit veškerý obsah webu a potom klepněte na název seznamu.

  1. V nabídce Nastavení Settings menu klikněte na příkaz Vytvořit sloupec.

  2. V oblasti Název a typ zadejte do pole Název sloupce požadovaný název.

  3. V seznamu Typ informací v tomto sloupci vyberte typ informací, které chcete zobrazit ve sloupci.

  4. V oblasti Další nastavení sloupce zadejte do pole Popis popis, který uživatelům usnadní porozumění účelu sloupce a druhu dat, která by měl obsahovat. Tento popis je nepovinný.

  5. V závislosti na vybraném typu sloupce se v oblasti Další nastavení sloupce mohou zobrazit další možnosti. Vyberte požadované další nastavení.

  6. Chcete-li sloupec přidat do výchozího zobrazení, které uživatelé vašeho webu automaticky uvidí při prvním otevření seznamu nebo knihovny, klikněte na možnost Přidat do výchozího zobrazení.

  7. Klikněte na tlačítko OK.

Začátek stránky

Vytvoření zobrazení

Pomocí zobrazení lze zobrazovat položky seznamu, které jsou pro vás nejdůležitější nebo které nejlépe vyhovují konkrétnímu účelu. Můžete například vytvořit zobrazení položek, které byly vytvořeny v poslední době, položky týkající se konkrétního oddělení nebo položky, které byly vytvořeny stejnou osobou.

Různá zobrazení seznamu úkolů

Při zobrazení většiny seznamů nebo knihovny můžete dočasně setřídit nebo vyfiltrovat položky tak, že přejdete na název sloupce a klepnete na šipku vedle názvu sloupce. To je užitečné v případě, že chcete občas položky seznamu zobrazit určitým způsobem, je však nutné kroky zopakovat při příštím zobrazení seznamu.

Seřazení položek v seznamu nebo knihovně

Pokud myslíte, že budete chtít seznam zobrazit určitým způsobem často, můžete vytvořit zobrazení. Toto zobrazení můžete použít vždy, když budete pracovat se seznamem. Vytvořené zobrazení je přidáno do nabídky Zobrazit Nabídka Zobrazení seznamu.

Seznamy mohou mít osobní a veřejná zobrazení. Kterýkoli uživatel si může vytvořit osobní zobrazení, pomocí kterého si bude zobrazovat seznamy určitým způsobem nebo filtrovat pouze položky seznamu, které chce zobrazit. Pokud máte oprávnění k návrhu webu, můžete vytvořit veřejné zobrazení, které bude moci použít každý uživatel prohlížející si seznam. Kterékoli veřejné zobrazení lze také nastavit jako výchozí zobrazení, aby se uživatelům seznam automaticky zobrazil v tomto zobrazení.

Při návrhu webu můžete také vytvořit propojení na další stránky zobrazení nebo návrhu pomocí Webová část využívajících jiná zobrazení. Tým může například chtít propojit zobrazení seznamu obsahující pouze dokumenty, které byly vytvořeny jejich členy týmu.

Pokud členové skupiny zobrazí seznam mobilního zařízení, můžete vytvořit mobilní zobrazení s limity, například počet položek zobrazených v zobrazení, optimální pro šířku pásma a omezení zařízení. Další informace o vytváření zobrazení naleznete v části Viz také.

  1. Pokud seznam není dosud otevřený, klikněte na jeho název na panelu Snadné spuštění.

    Pokud se název vašeho seznamu nezobrazuje, klikněte na tlačítko Zobrazit veškerý obsah webu a potom na název daného seznamu.

  2. V nabídce Nastavení Settings menu klikněte na příkaz Vytvořit zobrazení.

  3. V části Zvolte formát zobrazení klepněte na typ zobrazení, který chcete vytvořit. V řadě situací budete chtít vytvořit Standardní zobrazení, pro konkrétní situace (například pokud budete chtít vytvořit kalendář nebo zobrazení Ganttova diagramu) však můžete zvolit i jiná zobrazení.

  4. Do pole Název zobrazení zadejte název zobrazení, například Seřazeno podle příjmení.

  5. Pokud chcete, aby bylo toto zobrazení nastaveno jako výchozí, zaškrtněte políčko Nastavit jako výchozí zobrazení.Toto zobrazení můžete nastavit jako výchozí pouze tehdy, pokud je to veřejné zobrazení a vy máte oprávnění ke změnám návrhu seznamu.

  6. V oblasti Cílová skupina v části Cílová skupina zobrazení vyberte, zda chcete vytvořit osobní zobrazení, které můžete použít pouze vy, nebo veřejné zobrazení přístupné ostatním uživatelům.

  7. V oblasti Sloupce můžete zobrazit nebo skrýt sloupce zaškrtnutím příslušných políček. Vedle názvu sloupce zadejte číslo určující pořadí sloupce v zobrazení.

  8. V části Seřadit zvolte, zda a jak se mají položky seznamu seřadit. K seřazení můžete použít dva sloupce, například nejdříve podle příjmení autora a potom podle jeho křestního jména.

  9. V části Filtr zvolte, zda a jak chcete položky seznamu filtrovat. Filtrované zobrazení vám ukazuje menší výběr seznamu, například pouze položky, které byly vytvořeny konkrétním oddělením, nebo se stavem Schváleno.

  10. V oblasti Seskupit podle lze seskupit položky stejné hodnoty do vlastního oddílu, například do rozbalitelného oddílu dokumentů podle určitého autora.

  11. V oblasti Souhrny můžete počítat počet položek ve sloupcích, například celkový počet problémů. Někdy lze zjišťovat další informace, například průměry.

  12. V oblasti Styl vyberte požadovaný styl zobrazení, například stínovaný seznam, v němž je každý druhý řádek stínován.

  13. Pokud seznam obsahuje složky, můžete vytvořit zobrazení, které složky neobsahuje (tomu se někdy říká nestrukturované zobrazení). Chcete-li zobrazit všechny položky seznamu na stejné úrovni, klepněte na možnost Zobrazit všechny položky bez složek.

  14. Podle potřeby můžete omezit, kolik položek lze v seznamu zobrazit nebo kolik položek lze zobrazit na stejné stránce. Toto nastavení je užitečné zejména v případě, že vytváříte zobrazení pro mobilní zařízení. V části Omezení počtu položek vyberte požadované možnosti.

  15. Pokud budete chtít seznam zobrazit v mobilním zařízení, vyberte požadované možnosti v části Mobilní.

  16. Klikněte na tlačítko OK.

Začátek stránky

Výběr jiného zobrazení

Některé seznamy mohou mít více než jedno zobrazení a podle potřeby můžete vytvořit další zobrazení. Pokud jsou k dispozici jiná zobrazení, můžete přepínat zobrazení pomocí nabídky Zobrazit.

  1. Pokud seznam není dosud otevřený, klikněte na jeho název na panelu Snadné spuštění.

    Pokud se název vašeho seznamu nezobrazuje, klikněte na tlačítko Zobrazit veškerý obsah webu a potom na název daného seznamu.

  2. V nabídce Zobrazení Nabídka Zobrazení klikněte na požadované zobrazení.

    Tip : Chcete-li v existujícím zobrazení provést změny, klepněte na nabídku Zobrazit a potom klepněte na možnost Upravit toto zobrazení.

Začátek stránky

Přidání složky do seznamu

Pokud je v seznamu více typů položek, můžete seznam uspořádat přidáním složek.

  1. Pokud seznam není dosud otevřený, klikněte na jeho název na panelu Snadné spuštění.

    Pokud se název vašeho seznamu nezobrazuje, klikněte na tlačítko Zobrazit veškerý obsah webu a potom na název daného seznamu.

  2. V nabídce Nový Nabídka Nový klepněte na příkaz Nová složka.

    Příkaz Nová složka není k dispozici v případě, že osoba, která vytvořila seznam, zadala, aby v seznamu nebylo možné vytvářet složky.

  3. Zadejte název složky a klepněte na tlačítko OK.

Tip : Pokud máte více seznamů se složkami nebo uživatelé ve vaší skupině chtějí procházet obsah seznamu stejným způsobem jako obsah na pevném disku, může vaše skupina povolit používání stromového zobrazení. Pomocí stromového zobrazení můžete rozbalovat, sbalovat a snadno procházet složky.

Začátek stránky

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×