Určení počtu výskytů hodnoty v Excelu

Důležité informace:  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Předpokládejme, že chcete zjistit, kolikrát se určitý text nebo číselná hodnota vyskytuje v oblasti buněk. Třeba:

  • Pokud oblast dat, například A2:D20, obsahuje číselné hodnoty 5, 6, 7 a 6, vyskytuje se číslo 6 dvakrát.

  • Pokud sloupec obsahuje příjmení Novák, Veselý, Veselý a Veselý, opakuje se příjmení Veselý třikrát.

Existuje několik způsobů, jak určit počet výskytů hodnoty.

Co chcete udělat?

Určit počet výskytů jedné hodnoty pomocí funkce

Určit počet výskytů podle více kritérií pomocí funkce COUNTIFS

Určit počet výskytů podle kritéria pomocí funkcí POČET a KDYŽ

Určit počet výskytů více textových nebo číselných hodnot pomocí funkcí SUMA a KDYŽ

Určit počet výskytů více hodnot pomocí sestavy kontingenční tabulky

Určení počtu výskytů jedné hodnoty pomocí funkce

Tento úkol provedete pomocí funkce COUNTIF.

Příklad

Zkopírujte vzorová data v následující tabulce a vložte je do buňky A1 nového excelového sešitu. Aby vzorce zobrazily výsledky, vyberte je, stiskněte F2 a potom stiskněte Enter. Pokud potřebujete, můžete přizpůsobit šířky sloupců a zobrazit si všechna data.

Prodejce

Faktura

Stoklasa

15 000

Nováček

9 000

Macek

8 000

Macek

20 000

Nováček

5 000

Lazecký

22 500

Vzorec

Popis

Výsledek

=COUNTIF(A2:A7;"Stoklasa")

Počet faktur od Stoklasy (3)

=COUNTIF(A2:A7;"Stoklasa")

'=COUNTIF(A2:A7;A4)

Počet faktur od Macka (2)

=COUNTIF(A2:A7;A4)

'=COUNTIF(B2:B7;"< 20000")

Počet faktur s hodnotou nižší než 20 000 (4)

=COUNTIF(B2:B7;"< 20000")

'=COUNTIF(B2:B7;">="&B5)

Počet faktur s hodnotou vyšší nebo rovnou 20 000 (2)

=COUNTIF(B2:B7;">="&B5)

Další informace o použití této funkce najdete v tématu Funkce COUNTIF.

Začátek stránky

Určení počtu podle více kritérií pomocí funkce COUNTIFS

Funkce COUNTIFS byla poprvé uvedená v Excelu 2007 a podobá se funkci COUNTIF až na jeden zásadní rozdíl: funkce COUNTIFS umožňuje použít kritéria u buněk ve víc oblastech a spočítá, kolikrát jsou splněná všechna kritéria. S funkcí COUNTIFS se dá použít až 127 dvojic oblast/kritérium. Syntaxe této funkce vypadá takto:

COUNTIFS(oblast_kritérií1, kritérium1, [oblast_kritérií2, kritérium2],…)

Příklad

ID zaměstnance

Číslo kraje

Oddělení

20552

2

Prodej

21268

2

Finance

23949

1

Správce

24522

4

Správce

28010

3

Informační technologie

29546

4

Prodej

31634

3

Informační technologie

32131

1

Informační technologie

35106

4

Finance

40499

1

Lidské zdroje

42051

1

Prodej

43068

2

Lidské zdroje

45382

2

Finance

47971

1

Informační technologie

Kolik zaměstnanců je v kraji č. 2 a v oddělení Finance?

'=COUNTIFS(B2:B15;"2";C2:C15;"Finance")

=COUNTIFS(B2:B15;"2";C2:C15;"Finance")

První oblastí kritérií jsou čísla krajů, druhou oblastí kritérií jsou názvy oddělení. Kritérium použité pro první oblast kritérií je 2 a kritérium pro druhou oblast kritérií je Finance. Funkce COUNTIFS zkontroluje, jestli jsou splněné obě podmínky.

Další informace o určení počtu výskytů splnění více kritérií ve více oblastech pomocí této funkce najdete v tématu Funkce COUNTIFS.

Začátek stránky

Určení počtu výskytů podle kritéria pomocí funkcí POČET a KDYŽ

Předpokládejme, že potřebujete určit, kolik prodejců prodalo konkrétní výrobek v určité oblasti, nebo chcete vědět, kolik měl konkrétní prodejce obchodů přesahujících určitou hodnotu. K tomu můžete použít funkce KDYŽ a POČET. Nejdřív pomocí funkce KDYŽ otestujte podmínku, a pokud funkce KDYŽ vrátí výsledek Pravda, pak pomocí funkce POČET spočítejte buňky.

Příklady

Oblast

Prodejce

Typ

Prodej

Jih

Nováček

Nápoje

3571

Západ

Chvojková

Mléčné výrobky

3338

Východ

Macek

Nápoje

5122

Sever

Macek

Mléčné výrobky

6239

Jih

Lazecký

Plodiny

8677

Jih

Chvojková

Maso

450

Jih

Chvojková

Maso

7673

Východ

Macek

Plodiny

664

Sever

Chvojková

Plodiny

1 500

Jih

Lazecký

Maso

6596

Vzorec

Popis

Výsledek

=POČET(KDYŽ((A2:A11="Jih")*(C2:C11="Maso");D2:D11))

Počet prodejů masa v oblasti Jih (3)

=POČET(KDYŽ((A2:A11="Jih")*(C2:C11="Maso");D2:D11))

=POČET(KDYŽ((B2:B11="Macek")*(D2:D11>=1000);D2:D11))

Počet Mackových prodejů s objemem vyšším než 1 000 Kč (2)

=POČET(KDYŽ((B2:B11="Macek")*(D2:D11>=1000);D2:D11))

Poznámka: 

  • Vzorce v tomto příkladu se musí zadat jako maticové vzorce. Pokud jste tento sešit otevřeli v desktopové aplikaci Excel a chcete vzorec změnit nebo vytvořit podobný vzorec, stiskněte F2 a pak Ctrl+Shift+Enter, aby vzorec vrátil očekávané výsledky.

  • Aby vzorce fungovaly, musí být druhým argumentem funkce KDYŽ číslo.

Funkce POČET počítá buňky, které obsahují čísla, a čísla v seznamu argumentů. Funkce KDYŽ vrátí jednu hodnotu, pokud je zadaná podmínka vyhodnocena jako Pravda, a jinou hodnotu, pokud je zadaná podmínka vyhodnocena jako Nepravda.

Další informace o těchto funkcích najdete v tématech Funkce POČET a Funkce KDYŽ.

Začátek stránky

Určení počtu výskytů více textových nebo číselných hodnot pomocí funkcí SUMA a KDYŽ

V následujících příkladech jsou společně použité funkce KDYŽ a SUMA. Funkce KDYŽ nejdřív otestuje hodnoty v některých buňkách, a pokud se vrátí výsledek Pravda, funkce SUMA u těchto hodnot, které úspěšně prošly testem, spočítá součet.

Příklady

Prodejce

Faktura

Stoklasa

15000

Stoklasa

9000

Macek

8000

Macek

20000

Stoklasa

5000

Lazecký

22500

Vzorec

Popis

Výsledek

=SUMA(KDYŽ((A2:A7="Novák")+(A2:A7="Veselý");1;0))

Počet faktur prodejce Stoklasy nebo Veselého

=SUMA(KDYŽ((A2:A7="Novák")+(A2:A7="Veselý");1;0))

=SUMA(KDYŽ((B2:B7<9000)+(B2:B7>19000);1;0))

Počet faktur s hodnotou nižší než 9 000 Kč nebo vyšší než 19 000 Kč

=SUMA(KDYŽ((B2:B7<9000)+(B2:B7>19000);1;0))

=SUMA(KDYŽ(A2:A7="Novák";KDYŽ(B2:B7<9000;1;0)))

Počet faktur prodejce Stoklasy s hodnotou nižší než 9 000 (1)

=SUMA(KDYŽ(A2:A7="Novák";KDYŽ(B2:B7<9000;1;0)))

Poznámka: Vzorce v tomto příkladu se musí zadat jako maticové vzorce. Pokud jste tento sešit otevřeli v desktopové aplikaci Excel a chcete vzorec změnit nebo vytvořit podobný vzorec, stiskněte F2 a pak Ctrl+Shift+Enter, aby vzorec vrátil očekávané výsledky.

Začátek stránky

Určení počtu výskytů více hodnot pomocí sestavy kontingenční tabulky

K zobrazení součtů a zjištění počtu výskytů jedinečných hodnot můžete použít sestavu kontingenční tabulky. Kontingenční tabulka nabízí způsob, jak rychle a interaktivně shrnout velké objemy dat. Můžete v ní rozbalovat a sbalovat různé úrovně dat, abyste se dokázali lépe zaměřit na výsledky a přejít od souhrnných dat z oblastí, které vás zajímají, k podrobnostem. Navíc můžete přesouvat řádky do sloupců nebo sloupce do řádků a prohlížet si tak různé souhrny zdrojových dat.

Příklad zdrojových dat a výsledné sestavy kontingenční tabulky

1   Zdrojová data, v tomto případě z listu

2   Zdrojové hodnoty pro souhrn sloupců Golf za Čtv3 v sestavě kontingenční tabulky

3   Celá sestava kontingenční tabulky

4   Souhrn zdrojových hodnot v buňkách C2 a C8 ze zdrojových dat

Vytvoření sestavy kontingenční tabulky

  1. Vyberte sloupec obsahující data.
    Ujistěte se, zda má záhlaví.

  2. Na kartě Vložení klikněte ve skupině Tabulky na Kontingenční tabulka.
    Zobrazí se dialogové okno Vytvořit kontingenční tabulku.

  3. Klikněte na přepínač Vybrat tabulku či oblast.

  4. Kliknutím na přepínač Nový list vložte sestavu kontingenční tabulky do nového listu do buňky A1.

  5. Klikněte na tlačítko OK. Do zadaného umístění bude přidána prázdná sestava kontingenční tabulky a zobrazí se seznam polí kontingenční tabulky.

  6. Přetáhněte název pole z oblasti polí v horní části seznamu polí kontingenční tabulky do pole Popisky řádků v oblasti rozložení v dolní části seznamu polí kontingenční tabulky.

  7. Přetáhněte stejný název pole z oblasti polí v horní části seznamu polí kontingenční tabulky do pole Hodnoty v oblasti rozložení v dolní části seznamu polí kontingenční tabulky.

Poznámka: Pokud data obsahují čísla, bude v sestavě kontingenční tabulky vypočtený součet položek, nikoli jejich počet. Jestliže chcete součtovou funkci SUMA změnit na součtovou funkci POČET, vyberte buňku v tomto sloupci a poté na kartě Analyzovat ve skupině Aktivní pole klikněte na příkaz Nastavení pole, pak na kartu Souhrny, klikněte na položku Počet a potom klikněte na tlačítko OK.

Začátek stránky

Poznámka: Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×