Testování kombinace podmínek pomocí funkcí A a NEBO

Pokud potřebujete najít data, která splňují víc než jednu podmínku, třeba počet prodaných kusů od dubna do ledna nebo kusy, které prodala Petra, můžete použít současně funkce A a NEBO. Tady je příklad:

Použití funkcí A a NEBO v jednom vzorci

V tomto vzorci je funkce A vnořená do funkce NEBO tak, aby hledala počet prodaných kusů od 1.dubna 2011 do 1. ledna 2012, nebo jakékoli kusy prodané Petrou. Vidíte, že vrací hodnotu Pravda pro kusy, které prodala Petra a taky pro kusy, které prodal Pavel a Karel v období zadaném ve vzorci.

Tady je vzorec v podobě, ve které ho můžete zkopírovat a vložit. Pokud si s ním chcete pohrát v ukázkovém sešitu, přejděte na konec článku.

=NEBO(A(C2>DATUM(2011;4;30);C2<DATUM(2012;1;1));B2="Petra")

Teď se na vzorec podíváme podrobněji. Funkce NEBO vyžaduje sadu argumentů (data), které může testovat a zjišťovat, jestli je výsledek pravda nebo nepravda. V tomto vzorci je prvním argumentem funkce A a funkce DATUM, která je v ní vnořená. Druhým je "Petra". Vzorec se dá číst takto: Otestuj, jestli byly nějaké prodeje po 30.dubnu 2011 a před 1.lednem 2012, nebo něco prodala Petra.

Funkce A taky vrátí Pravda nebo Nepravda. Většinou se funkce A používá k rozšíření jiné funkce, třeba NEBO a KDYŽ. V tomto příkladu by funkce NEBO správná data bez funkce A nenašla.

Použití funkcí A a NEBO s funkcí KDYŽ

Funkce A a NEBO se taky dají použít společně s funkcí KDYŽ.

Funkce A a NEBO vnořené ve funkci KDYŽ

V tomto příkladu si pracovníci zaslouží prémie, až prodají zboží nejméně za 125 000 USD, s výjimkou jižní oblasti, kde je trh menší. V takovém případě mají nárok na prémie po dosažení prodeje v hodnotě 100 000 USD.

=KDYŽ(NEBO(C4>=125000;A(B4="Jih";C4>=100000))=PRAVDA;C4*0,12;"Bez prémií")

Podívejme se podrobněji. Funkce KDYŽ vyžaduje ke správné práci trojí data (argumenty). První je logický test, druhý je hodnota, která se má zobrazit, pokud má test hodnotu Pravda, a třetí je hodnota, která se má zobrazit, když je výsledkem testu Nepravda. V tomto příkladu funkce NEBO a všechno, co je v ní vnořené, představuje logický test. Dalo by se to číst takto: Najdi hodnoty větší nebo rovné 125 000, pokud hodnota ve sloupci C není „Jih“; v takovém případě hledej hodnotu větší než 100 000 a pokaždé, když budou splněné obě podmínky, vynásob hodnotu koeficientem 0,12, což je částka provize. Jinak zobraz „Bez prémií“.

Začátek stránky

Vyzkoušejte si to

Pokud si chcete s příklady v tomto článku napřed pohrát a teprve pak si je vyzkoušet na vlastních datech, poskytne vám tento vložený sešit aplikace Excel Online pár ukázkových dat.

EWA

Tenhle sešit se dá otevřít taky v Excelu. Stačí, když v pravém dolním rohu souborů kliknete na ikonu Excelu Ikona Excelu v Excel Web Appu , uložíte soubor na vhodné místo v počítači a otevřete ho.

Začátek stránky

Sdílení Facebook Facebook Twitter Twitter E-mail E-mail

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×