Spuštění makra

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Makro lze spustit několika způsoby. Vždy je lze spustit pomocí příkazu nabídky. V závislosti na přiřazeném způsobu spuštění lze makro spustit také stisknutím Klávesová zkratka s klávesou CTRL nebo klepnutím na tlačítko panelu nástrojů, oblast na objektu, grafiku nebo ovládací prvek. Makro lze také spustit automaticky při otevření sešitu.

Poznámka : Pokud je úroveň zabezpečení maker v aplikaci Microsoft Office Excel nastavena na hodnotu Zakázat všechna makra bez oznámení, budou spouštěna pouze digitálně podepsaná makra nebo makra uložená v důvěryhodném umístění, například ve složce pro spuštění aplikace Excel. Pokud makro, které chcete spustit, není digitálně podepsáno nebo uloženo v důvěryhodném umístění, lze dočasně nastavit úroveň zabezpečení, která umožňuje spouštění všech maker.

Další informace o tom, jak změnit nastavení zabezpečení maker najdete v tématu Změna nastavení zabezpečení maker v aplikaci Excel.

Co chcete udělat?

Spuštění makra

Spuštění makra stisknutím klávesové zkratky s klávesou CTRL

Spuštění makra kliknutím na tlačítko na panelu nástrojů Rychlý přístup

Spuštění makra kliknutím na oblast grafického objektu

Spusťte makro automaticky při otevření sešitu

Spuštění makra

  1. Pokud není k dispozici karta Vývojář, zobrazte ji následujícím způsobem:

    1. Klikněte na tlačítko Microsoft Office Obrázek tlačítka Office a potom klikněte na tlačítko Možnosti aplikace Excel.

    2. Ve skupině Nejpoužívanější možnosti při práci s aplikací Excel zaškrtněte v kategorii Oblíbené políčko Zobrazit na pásu kartu Vývojář a poté klikněte na tlačítko OK.

  2. Chcete-li dočasně nastavit úroveň zabezpečení tak, aby byla povolena všechna makra, postupujte následujícím způsobem:

    1. Na kartě Vývojář ve skupině kód na tlačítko Zabezpečení maker.
      Skupina Kód na kartě Vývojář

    2. V kategorii Nastavení maker klikněte v části Nastavení maker na přepínač Povolit všechna makra (nedoporučuje se, mohlo by umožnit spuštění potenciálně nebezpečného kódu) a potom klikněte na tlačítko OK.

    3. Poznámka : Chcete-li zabránit spuštění potenciálně nebezpečného kódu, doporučujeme vrátit se k některému z nastavení, která zakazují všechna makra po dokončení práce s makry. nebo Další informace o tom, jak změnit nastavení, najdete v článku Změna nastavení zabezpečení maker v aplikaci Excel.

  3. Otevřete sešit obsahující makro.

  4. Na kartě Vývojář klepněte ve skupině Kód na tlačítko Makra.

  5. V poli se seznamem Název makra klepněte na makro, které chcete upravit.

  6. Proveďte některou z následujících akcí:

    1. Chcete-li spustit makro v sešitu aplikace Excel, klepněte na tlačítko Spustit.

      Makro lze spustit také stisknutím kombinace kláves CTRL+F8. Spuštěné makro lze přerušit stisknutím klávesy ESC.

    2. Pokud chcete makro spustit z modulu Microsoft Visual Basic, klepněte na Upravit a v nabídce Spustit příkaz Run Sub/UserForm Obrázek tlačítka nebo stiskněte klávesu F5.

Začátek stránky

Spuštění makra stisknutím klávesové zkratky s klávesou CTRL

  1. Pokud není k dispozici karta Vývojář, zobrazte ji následujícím způsobem:

    1. Klikněte na tlačítko Microsoft Office Obrázek tlačítka Office a potom klikněte na tlačítko Možnosti aplikace Excel.

    2. V kategorii Oblíbené v části Nejpoužívanější možnosti při práci s aplikací Excel zaškrtněte políčko Zobrazit kartu Vývojář na pásu karet a klikněte na OK.

  2. Na kartě Vývojář klepněte ve skupině Kód na tlačítko Makra.

    Skupina Kód na kartě Vývojář

  3. V seznamu Název makra klikněte na makro, ke kterému chcete přiřadit klávesovou zkratku s klávesou CTRL.

  4. Klepněte na tlačítko Možnosti.

  5. Zadejte do pole Klávesová zkratka libovolné malé či velké písmeno, které chcete použít.
    Poznámku    klávesová zkratka přednost před všemi stejnými výchozími Excel klávesovými zkratkami je otevřený sešit obsahující makro. Seznam CTRL kombinace klávesových zkratek, které již byly přiřazeny v Excelu najdete v tématu klávesové zkratky a funkční klávesy aplikace Excel.

  6. Do pole Popis napište krátký popis makra.

  7. Klepněte na tlačítko OK a potom na tlačítko Storno.

Začátek stránky

Spuštění makra kliknutím na tlačítko na panelu nástrojů Rychlý přístup

.

  1. Klikněte na Tlačítko Microsoft Office Obrázek tlačítka Office a pak na Možnosti aplikace Excel.

  2. Klepněte na příkaz Přizpůsobit a poté v seznamu Zvolit příkazy z vyberte položku Makra.

  3. Klepněte v seznamu na makro, které jste vytvořili, a potom klepněte na tlačítko Přidat.

  4. Chcete-li změnit obrázek makra, vyberte makro v poli, kam bylo přidáno, a potom klepněte na tlačítko Změnit.

  5. V části Symbol klepněte na obrázek tlačítka, který chcete použít.

  6. Chcete-li změnit název makra, které se zobrazí po přesunutí ukazatele myši na tlačítko, zadejte do pole Zobrazovaný název název, který chcete použít.

  7. Klikněte na OK přidáte tlačítko makra na panel Nástrojů Rychlý přístup.
    Panel nástrojů pro rychlý přístup

  8. Klepněte na panelu nástrojů Rychlý přístup na tlačítko makra.

Začátek stránky

Spuštění makra klepnutím na oblast grafického objektu

  1. V listu vyberte stávající objekt grafiky, například obrázek, objekt klipart, tvar nebo obrázek SmartArt.

  2. Chcete-li na stávajícím objektu vytvořit aktivní bod, klepněte na kartě Vložit ve skupině Ilustrace na položku Tvary, vyberte požadovaný tvar a poté jej nakreslete na stávající objekt.

    Skupina Obrázky na kartě Vložení

  3. Klepněte pravým tlačítkem myši na vytvořený aktivní bod a poté v Místní nabídka klepněte na příkaz Přiřadit makro.

  4. Proveďte některou z následujících akcí:

    • Chcete-li ke grafickému objektu přiřadit stávající makro, dvakrát na ně klikněte, nebo zadejte jeho název do pole Název makra.

    • Záznam nového makra: Pokud chcete přiřadit na vybraný grafický objekt, klikněte na záznam. Po dokončení záznamu makra, klikněte na Zastavit záznam Obrázek tlačítka na kartě Vývojář ve skupině kód.

Klikněte na tlačítko Zastavit záznam Obrázek tlačítka v levé části stavového řádku.

  • Chcete-li upravit existující makro, klikněte na jeho název v seznamu Název makra a na tlačítko Upravit.

  • Klepněte na tlačítko OK.

  • V listu vyberte aktivní bod.

    Tím zobrazíte panel Kreslení a přidáte do něj kartu Formát.

    Skupina Styly obrazců na kartě Formát nástrojů kreslení

  • Na kartě Formát proveďte ve skupině Tvar následující akce:

    • Klepněte na šipku vedle položky Výplň tvaru a poté klepněte na možnost Bez výplně.

    • Klepněte na šipku vedle položky Obrys tvaru a poté klepněte na možnost Bez obrysu.

Začátek stránky

Automatické spuštění makra při otevření sešitu

Pokud zaznamenané makro uložíte pod názvem Auto_otevření, bude spuštěno při každém otevření sešitu, který je obsahuje. Automatického spuštění makra při otevření sešitu lze dosáhnout také vytvořením procedury jazyka Visual Basic for Applications (VBA) v události Open sešitu pomocí Visual Basic Editor. Událost Open je předdefinovaná událost sešitu, která při každém otevření sešitu spustí kód příslušného makra.

Vytvoření makra Auto_otevření

  1. Pokud není k dispozici karta Vývojář, zobrazte ji následujícím způsobem:

    1. Klikněte na tlačítko Microsoft Office Obrázek tlačítka Office a potom klikněte na tlačítko Možnosti aplikace Excel.

    2. V kategorii Oblíbené zaškrtněte v části Nejpoužívanější možnosti při práci s aplikací Excel políčko Zobrazit na pásu kartu Vývojář a klepněte na tlačítko OK.

  2. Chcete-li dočasně nastavit úroveň zabezpečení tak, aby byla povolena všechna makra, postupujte následujícím způsobem:

    1. Na kartě Vývojář ve skupině kód klikněte na Zabezpečení maker.

      Skupina Kód na kartě Vývojář

    2. V kategorii Nastavení maker klikněte v části Nastavení maker na přepínač Povolit všechna makra (nedoporučuje se, potenciálně nebezpečných by umožnit spuštění kódu) a klikněte na OK.

      Poznámka : Aby se zabránilo spuštění potenciálně nebezpečného kódu, doporučujeme vrátit se po dokončení práce s makry k nastavení se zakázanými makry.

  3. Chcete-li makro uložit s určitým sešitem, otevřete nejdříve daný sešit.

  4. Na kartě Vývojář klikněte ve skupině Kód na tlačítko Záznam makra.

  5. Do pole Název makra zadejte Automatické_otevření.

  6. V rozevíracím seznamu Uložit makro do vyberte sešit, do kterého chcete makro uložit.

    Tip : Pokud chcete makro je k dispozici při práci aplikace Excel, vyberte Osobní sešit maker. Po výběru Osobní sešit maker aplikace Excel vytvoří skryté osobním sešitě maker (Personal.xlsb), pokud dosud neexistuje a ukládá makro v tomto sešitu. Ve Windows Vista je tento sešit uložený ve složce name\AppData\Local\Microsoft\Excel\XLStart C:\Users\user. V systému Microsoft Windows XP tento sešit uložený ve složce Data\Microsoft\Excel\XLStart C:\Documents and Settings\uživatelské ukládají. Sešity do složky XLStart jsou při každém spuštění Excelu automaticky neotevírají. Pokud chcete makro v osobním sešitě maker automatické spuštění v jiném sešitu, je nutné také uložit daný sešit do složky XLStart tak, že jsou tyto sešity otevřené při spuštění Excelu.

  7. Klikněte na tlačítko OK a proveďte akce, které chcete zaznamenat.

  8. Na kartě Vývojář ve skupině kód na tlačítko Zastavit záznam Obrázek tlačítka .

    Klikněte na tlačítko Zastavit záznam Obrázek tlačítka v levé části stavového řádku.

    Poznámky : 

    • Pokud jste při ukládání makra v kroku 6 zvolili položku Tento sešit nebo Nový sešit, uložte nebo přesuňte sešit do jedné ze složek XLStart.

    • Pro záznam makra Auto_otevření platí následující omezení:

      • Pokud ukládáte makro Auto_otevření do sešitu, který již obsahuje událost Open s procedurou jazyka VBA, procedura pro událost Open přepíše všechny akce v makru Auto_otevření.

      • Při programovém otevření sešitu pomocí metody Open je makro Auto_otevření ignorováno.

      • Makro Auto_otevření je spuštěno před otevřením jakéhokoli jiného sešitu. Při záznamu akcí, které mají být provedeny ve výchozím sešitu Sešit1 nebo v sešitu načteném ze složky XLStart, proto při restartování aplikace Excel nedojde ke spuštění makra Auto_Open, protože je makro spuštěno ještě před otevřením výchozích sešitů a sešitů otevřených při spuštění.

        Pokud narazíte na tato omezení, je nutné pro událost Open vytvořit místo makra Auto_otevření proceduru jazyka VBA. Příslušný postup je popsán v další části tohoto článku.

Vytvoření procedury jazyka VBA pro událost Open sešitu

V následujícím příkladu je událost Open použita ke spuštění makra při otevření sešitu.

  1. Pokud není k dispozici karta Vývojář, zobrazte ji následujícím způsobem:

    1. Klikněte na tlačítko Microsoft Office Obrázek tlačítka Office a potom klikněte na tlačítko Možnosti aplikace Excel.

    2. V kategorii Oblíbené zaškrtněte v části Nejpoužívanější možnosti při práci s aplikací Excel políčko Zobrazit na pásu kartu Vývojář a klepněte na tlačítko OK.

  2. Chcete-li dočasně nastavit úroveň zabezpečení tak, aby byla povolena všechna makra, postupujte následujícím způsobem:

    1. Na kartě Vývojář ve skupině kód na tlačítko Zabezpečení maker.
      Skupina Kód na kartě Vývojář

    2. V kategorii Nastavení maker klepněte v části Nastavení maker na přepínač Povolit všechna makra (nedoporučuje se, mohlo by umožnit spuštění potenciálně nebezpečného kódu) a potom klepněte na tlačítko OK.

      Poznámka : Aby se zabránilo spuštění potenciálně nebezpečného kódu, doporučujeme vrátit se po dokončení práce s makry k nastavení se zakázanými makry.

  3. Uložte a zavřete všechny otevřené sešity.

  4. Otevřete sešit, do kterého chcete přidat makro, nebo vytvořte nový sešit.

  5. Na kartě Vývojář klikněte ve skupině Kód na tlačítko Visual Basic.

  6. V okně Průzkumník projektu klikněte pravým tlačítkem myši na objekt ThisWorkbook a pak klikněte na Zobrazit kód.

    Tip : Pokud okno Prohlížeč projektu není zobrazen, v nabídce Zobrazit klikněte na položku Průzkumník projektu.

  7. V seznamu Object (Objekt) nad oknem kódu vyberte položku Workbook (Sešit).

    Tím dojde k automatickému vytvoření prázdné procedury pro událost Open, která bude vypadat například takto:

    1. Private Sub Workbook_Open()

    2. End Sub

  8. Přidejte do procedury následující řádky kódu:

    1. Private Sub Workbook_Open()

      1. Datum MsgBox

      2. Worksheets("Sheet1"). Range("a1"). Hodnota = datum

    2. End Sub

  9. Přejděte do aplikace Excel a sešit uložte jako sešit aplikace Excel s podporou maker (soubor XLSM).

  10. Zavřete a znovu otevřete sešit. Při novém otevření souboru je spuštěna procedura Workbook_Open, která zobrazí okno s aktuálním datem.

  11. Klikněte v okně na tlačítko OK.

    Všimněte si, že v důsledku spuštění procedury Workbook_Open je datum zobrazeno také v buňce A1 na listu List1.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Sdílení Facebook Facebook Twitter Twitter E-mail E-mail

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×