Správa oblastí externích dat a jejich vlastností

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Změnou vlastností oblasti externích dat můžete spravovat data, která byla do listu importována prostřednictvím připojení k externímu zdroji dat, jako je například databáze, webový dotaz nebo textový soubor.

Co chcete udělat?

Další informace o oblastí externích dat a vlastností

Vyhledání oblasti externích dat

Změna názvu oblasti externích dat

Změna podkladového dotazu pro oblast externích dat

Kopírování oblasti externích dat a zadaného dotazu

Určení způsobu přidání nových dat do oblasti externích dat

Určení formátování a rozložení dat

Kopírování vzorců při rozšíření oblasti externích dat

Zmrazení dat v oblasti externích dat

Přizpůsobení názvů polí v oblasti externích dat

Odstranění oblasti externích dat

Další informace o oblastech externích dat a jejich vlastnostech

Oblast externích dat (označovaná také jako tabulka dotazů) je definovaný název nebo název tabulky, který definuje umístění dat přenesených do listu. Při připojení k externím datům aplikace Excel automaticky vytvoří oblast externích dat. Jedinou výjimkou je sestava kontingenční tabulky, která je připojena ke zdroji dat. Sestava kontingenční tabulky nepoužívá oblast externích dat. V aplikaci Excel lze rozvrhnout a formátovat oblasti externích dat nebo můžete oblast externích dat použít ve výpočtech stejným způsobem jako jakákoli jiná data.

Vlastnosti oblasti externích dat

Oblast externích dat má další vlastnosti (nezaměňovat s vlastnostmi připojení), které lze použít ke správě dat, jako je například zachování formátování buněk a šířky sloupce. Tyto vlastnosti oblasti externích dat můžete změnit po kliknutí na tlačítko Vlastnosti ve skupině Připojení na kartě Data. Potom proveďte následujícím způsobem požadované změny:

  • Pro oblasti externích dat vytvořené v aplikaci Microsoft Query a v Průvodci datovým připojením použijte dialogové okno Vlastnosti externích dat.

  • Pro oblasti externích dat vytvořené z importovaného textového souboru nebo webového dotazu, který načte data HTML, použijte dialogové okno Vlastnosti oblasti externích dat.

  • Pro oblasti externích dat vytvořené z webového dotazu, který načte data XML, použijte dialogové okno Vlastnosti mapování XML.

Použití šablon s oblastmi externích dat

Pokud chcete sdílet souhrn nebo sestavu, která je založená na externích datech, možnost poskytnout jiným uživatelům sešit, ve kterém oblasti externích dat nebo vytvoření šablony sestavy. Šablona sestavy umožňuje uložit souhrn nebo sestavu bez uložení externích dat, aby tento soubor je menší. Při otevření šablony sestavy je načíst externí data.

Začátek stránky

Vyhledání oblasti externích dat

  1. Vyberte list, ve kterém chcete hledat Oblast externích dat.

  2. Na Řádek vzorců klikněte na šipku vedle Pole Název a potom klikněte na název oblasti externích dat, které chcete.

Začátek stránky

Změna názvu oblasti externích dat

  1. Na kartě Vzorce klikněte ve skupině Definované názvy na Správce názvů.

    Vzhled pásu karet aplikace Excel

  2. V dialogovém okně Správce názvů klikněte na název oblasti externích dat a potom klikněte na tlačítko Upravit. Můžete také dvakrát kliknout na název.

  3. V dialogovém okně Upravit název zadejte do pole Název nový název odkazu.

Poznámka : Tlačítkem Zavřít se dialogové okno Správce názvů pouze zavře. Již provedené změny není třeba potvrzovat kliknutím na tlačítko Zavřít.

Začátek stránky

Změna podkladového dotazu pro oblast externích dat

Podkladový dotaz lze změnit pro oblast externích dat vytvořenou v aplikaci Microsoft Query, z importovaného textového souboru, z webového dotazu nebo pomocí Průvodce datovým připojením.

Změna podkladového dotazu pro oblast externích dat vytvořenou v aplikaci Microsoft Query

  1. Klikněte na buňku v oblasti externích dat, pro kterou chcete změnit podkladový dotaz.

  2. Na kartě Data klikněte ve skupině Připojení na tlačítko Vlastnosti.

    Vzhled pásu karet aplikace Excel

  3. V dialogovém okně Vlastnosti externích dat klikněte na Vlastnosti připojení vlastnosti .

  4. V dialogovém okně Vlastnosti připojení klepněte na kartu Definice a na tlačítko Upravit dotaz.

Další informace o vytváření nebo úpravách dotazů a v aplikaci Microsoft Query naleznete v nápovědě k této aplikaci.

Změna podkladového dotazu pro oblast externích dat vytvořenou z importovaného textového souboru

  1. Klikněte na buňku v oblasti externích dat, pro kterou chcete změnit podkladový dotaz.

  2. Na kartě Data klikněte ve skupině připojení na připojení.

    Vzhled pásu karet aplikace Excel

  3. V dialogovém okně Připojení sešitu klikněte na tlačítko Vlastnosti.

  4. V dialogovém okně Vlastnosti připojení klepněte na kartu Definice a na tlačítko Upravit dotaz.

  5. V dialogovém okně Importovat textový soubor klikněte na možnost Importovat.

  6. V Průvodci importem textu proveďte změny importovaného textového souboru a potom klepněte na tlačítko Dokončit.

    Další informace o importu textových souborů naleznete v tématu Import a export textových souborů.

Změna podkladového dotazu pro oblast externích dat vytvořenou z webového dotazu

  1. Klikněte na buňku v oblasti externích dat, pro kterou chcete změnit podkladový dotaz.

  2. Na kartě Data klikněte ve skupině Připojení na tlačítko Vlastnosti.

    Vzhled pásu karet aplikace Excel

  3. V dialogovém okně Připojení sešitu klikněte na tlačítko Vlastnosti.

  4. V dialogovém okně Vlastnosti připojení klepněte na kartu Definice a na tlačítko Upravit dotaz.

  5. V dialogovém okně Upravit webový dotaz proveďte změny webového dotazu a klikněte na tlačítko Dokončit.

Další informace o vytváření a úpravách webových dotazů naleznete v tématu Načtení externích dat z webové stránky.

Změna podkladového dotazu pro oblast externích dat vytvořenou z webového dotazu pomocí Průvodce datovým připojením

  1. Klikněte na buňku v oblasti externích dat, pro kterou chcete změnit podkladový dotaz.

  2. Na kartě Data klikněte ve skupině Připojení na tlačítko Vlastnosti.

    Vzhled pásu karet aplikace Excel

  3. V dialogovém okně Vlastnosti externích dat klikněte na Vlastnosti připojení vlastnosti .

  4. V dialogovém okně Vlastnosti připojení klikněte na kartu Definice.

  5. Proveďte jeden z následujících kroků:

    • V seznamu Typ příkazu klikněte na položku Tabulka a potom v poli Text příkazu změňte název příslušné tabulky, zobrazení nebo dotazu.

    • V seznamu Typ příkazu klikněte na položku SQL nebo Výchozí a potom v poli Text příkazu upravte příkaz SQL.

      Poznámka : V závislosti na tom, jak bylo připojení definováno, nemusí být pole Typ příkazu dostupné (zobrazuje se šedě).

Začátek stránky

Kopírování oblasti externích dat a zadaného dotazu

  1. Na řádku vzorců klikněte na šipku vedle Pole názvů a vyberte název oblasti externích dat, kterou chcete kopírovat.

    V případě tabulky aplikace Excel vyberte název oblasti a stisknutím klávesové zkratky CTRL+A vyberte záhlaví tabulky.

    Chcete-li zahrnout popisky sloupců nebo vzorce, které nejsou součástí oblasti externích dat, vyberte obsahující popisky sloupců nebo vzorce, které chcete zkopírovat. Klikněte v řádku vzorců na šipku vedle Pole názvů a klikněte na název oblasti externích dat, kterou chcete kopírovat.

  2. Na kartě Domů klikněte ve skupině Schránka na Kopírovat.

    Vzhled pásu karet aplikace Excel

  3. Přejděte do sešitu, do kterého chcete oblast externích dat vložit.

  4. Klikněte na levou horní buňku Oblast pro vložení.

    Abyste měli jistotu, že Externí data nenahrazuje existující data, ujistěte se, že list neobsahuje žádná data ve skupinovém rámečku nebo napravo od aktuální buňky, které můžete kliknout.

  5. Na kartě Domů klepněte ve skupině Schránka na položku Vložit.

Poznámka : Pokud zkopírujete pouze část oblasti externích dat, základní Dotaz nezkopíruje a zkopírovaná data se nedá aktualizovat.

Začátek stránky

Určení způsobu přidání nových dat do oblasti externích dat

Jestliže je při aktualizaci dat do aplikace Excel vrácena menší nebo větší sada dat, můžete určit, jakým způsobem má být zpracována.

  1. Na kartě Data klikněte ve skupině Připojení na tlačítko Vlastnosti.

    Vzhled pásu karet aplikace Excel

  2. V dialogovém okně Vlastnosti oblasti externích dat klikněte v části Při změně počtu řádků v oblasti dat po aktualizaci na jednu z následujících položek:

    • Vložit buňky pro nová data, odstranit nepoužité buňky

      Poznámky : 

      • Při přidání jednoho či více řádků do zdroje dat dojde k posunu buněk přímo pod oblastí externích dat směrem dolů, k posunu buněk vpravo od oblasti externích dat však nedojde.

      • Při odstranění jednoho či více řádků ze zdroje dat dojde k posunu buněk přímo pod oblastí externích dat směrem nahoru, k posunu buněk vpravo od oblasti externích dat však nedojde.

    • Vložit celé řádky pro nová data, vymazat nepoužité buňky

      Poznámky : 

      • Při přidání jednoho či více řádků do zdroje dat dojde k posunu buněk přímo pod oblastí externích dat a vpravo od ní směrem dolů.

      • Při odstranění jednoho či více řádků ze zdroje dat nedojde k posunu buněk přímo pod oblastí externích dat a vpravo od ní.

    • Přepsat stávající buňky novými daty, vymazat nepoužité buňky

      Poznámky : 

      • Při přidání jednoho či více řádků do zdroje dat dojde k přepsání buněk přímo pod oblastí externích dat, k posunu buněk vpravo od oblasti externích dat však nedojde.

      • Při odstranění jednoho či více řádků ze zdroje dat nedojde k posunu buněk přímo pod oblastí externích dat a vpravo od ní.

Začátek stránky

Určení formátování a rozložení dat

  1. Na kartě Data klikněte ve skupině Připojení na tlačítko Vlastnosti.

    Vzhled pásu karet aplikace Excel

  2. V části Formát a rozložení dat proveďte jednu nebo více z následujících akcí:

    • Pokud chcete, aby byly na prvním řádku uvedeny názvy polí, zaškrtněte políčko Zahrnout názvy polí.

      Poznámka : Toto zaškrtávací políčko je k dispozici pouze pro oblast externích dat převedenou z aplikace systému Microsoft Office 2003 nebo pro oblast externích dat vytvořenou programem.

    • Chcete-li přidat sloupec s čísly řádků, zaškrtněte políčko Zahrnout čísla řádků.

      Poznámka : Toto zaškrtávací políčko není k dispozici pro importovaný textový soubor, soubor XML nebo webový dotaz.

    • Chcete-li zachovat použitý formát buněk, zaškrtněte políčko Zachovat formát buněk.

      Poznámka : Pokud je pro webový dotaz vybrána v dialogovém okně Možnosti možnost Úplné formátování HTML, je zaškrtnutí tohoto políčka automaticky zrušeno. K dialogovému oknu Možnosti získáte přístup z dialogového okna Upravit dotaz.

    • Chcete-li zachovat nastavené šířky sloupců, zaškrtněte políčko Nastavit šířku sloupce.

    • Chcete-li zachovat použité řazení, filtrování a rozložení sloupců, zaškrtněte políčko Zachovat řazení, filtrování a rozložení sloupců.

      Poznámka : Toto zaškrtávací políčko není k dispozici pro webové dotazy.

    • Chcete-li zachovat filtrování sloupců, zaškrtněte políčko Zachovat filtrování sloupců.

      Poznámka : Toto zaškrtávací políčko je k dispozici pouze pro webové dotazy založené na datech XML.

Začátek stránky

Kopírování vzorců při rozšíření oblasti externích dat

Poznámka : Následující postup platí pouze pro oblast externích dat převedenou z aplikace systému Microsoft Office 2003 nebo pro oblast externích dat vytvořenou programem. Všechny oblasti externích dat vytvořené pomocí uživatelského rozhraní jsou vytvořeny jako tabulky aplikace Excel. Při přidání nových řádků a doplnění počítaných sloupců se tyto tabulky automaticky rozšíří.

  1. Do buňky sousedící s prvním řádkem v oblasti externích dat zadejte vzorec.

    Poznámka : V závislosti na tom, zda první řádek obsahuje záhlaví, může být první řádek dat prvním nebo druhým řádkem oblasti externích dat.

  2. Vyberte buňku a poklikejte na Úchyt ke kopírování vzorce do všech řádků v oblasti externích dat.

  3. Klepněte na buňku v oblasti externích dat.

  4. Na kartě Data klikněte ve skupině Připojení na tlačítko Vlastnosti.

    Vzhled pásu karet aplikace Excel

  5. V dialogovém okně Vlastnosti oblasti externích dat zaškrtněte políčko Vložit vzorce do sloupců sousedících s daty.

    Poznámka : Pokud externích dat zvětší při můžete Aktualizovat, aplikace Excel zkopíruje pouze vzorce, které jsou vedle sebe a nebo v rámci externích dat.

Začátek stránky

Zmrazení dat v oblasti externích dat

Po zmrazení oblasti externích dat zůstanou zachována data, nikoli však zadaný dotaz; zmrazenou oblast externích dat tedy nelze aktualizovat.

Zrušení propojení dat v tabulce aplikace Excel

  1. Klikněte na list obsahující tabulku aplikace Excel, ze které chcete odstranit datové připojení.

  2. V řádku vzorců klikněte na šipku vedle Pole názvů a potom klikněte na název oblasti externích dat, ze které chcete odebrat datové připojení. Tím bude oblast dat vybrána.

  3. Na kartě Nástroje klikněte ve skupině Data externí tabulky na položku Zrušit propojení. Oblast dat zůstane zachována pod stejným názvem, avšak připojení bude odstraněno.

Zrušení propojení dat v oblasti

Poznámka : Následující postup platí pouze pro oblast externích dat převedenou z aplikace systému Microsoft Office 2003 nebo pro oblast externích dat vytvořenou programem. Všechny oblasti externích dat vytvořené pomocí uživatelského rozhraní jsou vytvořeny jako tabulky aplikace Excel. Při přidání nových řádků a doplnění počítaných sloupců se tyto tabulky automaticky rozšíří.

  1. Na kartě Data klikněte ve skupině Připojení na tlačítko Vlastnosti.

    Vzhled pásu karet aplikace Excel

  2. Zrušte zaškrtnutí políčka Uložit definici dotazu ve skupinovém rámečku Definice dotazu.

Poznámka : Při uložení sešitu je podkladový dotaz odstraněn. Uložené soubory databázových dotazů (s příponou DQY nebo ODC) však odstraněny nejsou. Pokud jste dotaz uložili při jeho vytvoření v Průvodci dotazem nebo v aplikaci Microsoft Query, je soubor dotazu uložen v počítači a dotaz lze znovu použít k načtení externích dat. Další informace naleznete v nápovědě k aplikaci Microsoft Query.

Začátek stránky

Přizpůsobení názvů polí v oblasti externích dat

Poznámka : Následující postup platí pouze pro oblast externích dat vytvořenou pomocí Průvodce datovým připojením nebo aplikace Microsoft Query (a nikoli pro importovaný textový soubor nebo webový dotaz), oblast externích dat převedenou z aplikace systému Microsoft Office 2003 nebo oblast externích dat vytvořenou programem. Všechny oblasti externích dat vytvořené pomocí uživatelského rozhraní jsou vytvořeny jako tabulky aplikace Excel.

  1. Provedením jednoho z následujících postupů vložte nad oblast externích dat prázdný řádek:

    • Vyberte buňku, nad kterou chcete vložit nový řádek. Potom na kartě Domů klikněte ve skupině Buňky na šipku u položky Vložit a pak klikněte na položku Vložit řádky listu. Vzhledem k tomu, že jste vybrali jednu buňku, je nad aktuální řádek vložen jeden nový řádek.

    • Klikněte na volič řádků pro řádek, nad který chcete vložit nový řádek. Potom na kartě Domů klikněte ve skupině Buňky na položku Vložit. Vzhledem k tomu, že jste vybrali jeden celý řádek, je nad vybraný řádek vložen jeden nový řádek.

  2. Do buněk v prázdném řádku zadejte požadované popisky.

  3. Klepněte na buňku v oblasti externích dat.

  4. Na kartě Data klikněte ve skupině Připojení na tlačítko Vlastnosti.

    Vzhled pásu karet aplikace Excel

  5. V dialogovém okně Vlastnosti oblasti externích dat zrušte ve skupinovém rámečku Formát a rozložení dat zaškrtnutí políčka Včetně názvů polí a potom klepněte na tlačítko OK.

  6. Pokud chcete odebrat existující názvy polí a aktualizace externích dat, klikněte na buňku v oblasti externích dat a klikněte na Aktualizovat Data Obrázek tlačítka .

Poznámka : Všechny změny názvů sloupců v aplikaci Microsoft Query jsou při načítání dat z databáze v oblasti externích dat zachovány. Informace o změně názvů sloupců v dotazu získáte v nápovědě k aplikaci Microsoft Query.

Začátek stránky

Odstranění oblasti externích dat

  1. Klikněte na list obsahující oblast externích dat, kterou chcete odstranit.

  2. Na řádku vzorců klikněte na šipku vedle Pole názvů a potom klikněte na název oblasti externích dat, kterou chcete odstranit.

    Pokud je oblast externích dat tabulka aplikace Excel, stisknutím kombinace kláves CTRL+A vyberte celou tabulku.

  3. Chcete-li odstranit oblast externích dat, stiskněte klávesu DELETE.

  4. Chcete-li odstranit podkladový dotaz, klikněte po zobrazení dotazu aplikace Excel na tlačítko Ano.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×