Spojení dvou zobrazení dat

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

V aplikaci Microsoft Office SharePoint Designer 2007 máte pravděpodobně ve zvyku tvořit aplikace, které rozsáhle využívají zdroje dat a zobrazení dat. Připojením zobrazení dat, která byla vložena jako zobrazení nebo formuláře, můžete mezi nimi vytvořit propojení, aby se při provedení akce se zobrazením dat změnil obsah jiného zobrazení dat. Propojení zobrazení dat je rychlým, ale účinným způsobem přidání interaktivity do vašeho webu nebo aplikace.

Poznámka : Zobrazení dat jsou druh webové části, takže koncepce a postupy v tomto článku platí stejně tak pro jakékoli dvě webové části, které lze propojit.

V tomto článku je uveden postup vytvoření dvou zobrazení dat a postup jejich propojení pomocí Průvodce připojením webových částí.

Další informace o zobrazení dat najdete v tématu Vytvoření zobrazení dat.

V tomto článku

Proč připojení webové části?

Vytvoření prvního zobrazení dat pomocí Products.xml

Vytvoření souboru XML jako zdroje ukázkových dat

Vytvoření zobrazení dat pomocí Suppliers.xml

Připojení webové části

Test připojení webové části

Odebrání připojení webové části

Proč propojovat webové části?

Propojením dvou webových částí můžete mezi nimi předávat data a synchronizovat jejich chování. Můžete například propojit webovou část Zobrazení seznamu, která zobrazuje seznam zaměstnanců, s webovou částí Obrázek. Po propojení obou webových částí se při každém klepnutí na jméno zaměstnance ve webové části Zobrazení seznamu zobrazí obrázek vybraného zaměstnance ve webové části Obrázek.

Jednoduché propojení webových částí můžete vytvořit prostřednictvím prohlížeče. Můžete například propojit jednu webovou část s druhou webovou částí, která je uložena na téže stránce webové části. Funkci propojení můžete však rozšířit pomocí aplikace Office SharePoint Designer 2007. Můžete například použít webovou část Formulář pro filtrování dat v jiné webové části nebo vytvořit propojení mezi webovými částmi dvou samostatných stránek webových částí v tomtéž webu nejvyšší úrovně. Obě akce vyžadují aplikaci Office SharePoint Designer 2007 a nelze je provést v prohlížeči.

Začátek stránky

Vytvoření prvního zobrazení dat pomocí souboru Products.xml

Firma Northwind Traders zabývající se distribucí lahůdek sleduje své skladové zásoby v souboru XML s názvem Products.xml a zobrazuje data z tohoto souboru v zobrazení dat. Toto zobrazení dat bylo vloženo jako formulář, aby mohl tým aktualizovat skladové zásoby prostřednictvím prohlížeče ukládáním změn do souboru Products.xml. Při ubývání skladových zásob vyvolá člen týmu dodavatele daného produktu, zadá objednávku a poté aktualizuje skladové zásoby pomocí zobrazení dat. Při každém zadání objednávky však musí člen týmu také vyhledat kontaktní údaje dodavatele.

Navrhněte vložení druhého zobrazení dat s kontaktními údaji dodavatele a poté propojení obou webových částí. Takto se členu týmu při zadávání objednávky zobrazí pro každý produkt skladové zásoby i kontaktní údaje dodavatele, a to klepnutím na jeden hypertextový odkaz.

Následující postup vyžaduje použití dvou souborů XML jako zdroje dat a vytváření zobrazení dat ze všech zdrojů dat. V našem příkladu, vytvořte první zobrazení dat z Products.xml provedením kroků v článku Vložení zobrazení dat jako formuláře. Vraťte se na tento článek vytvoření druhého zobrazení dat z Suppliers.xml.

Začátek stránky

Vytvoření souboru XML jako ukázkového zdroje dat

Firma Northwind Traders ukládá kontaktní údaje svých dodavatelů do souboru XML s názvem Suppliers.xml.

Vytvoření souboru Suppliers.xml

  1. V nabídce Soubor klepněte na příkaz Otevřít web.

  2. V dialogovém okně Otevřít web vyhledejte a vyberte web a klepněte na tlačítko Otevřít.

  3. Pokud se zobrazí dialogové okno Připojit k s dotazem na uživatelské jméno a heslo, zadejte je a klepněte na tlačítko OK.

  4. V nabídce Soubor klepněte na příkaz Nový.

  5. V dialogovém okně Nový poklepejte na položku Textový soubor.

    Na webu se otevře nový textový soubor.

  6. Zkopírujte následující řádky kódu do schránky (vyberte je a stiskněte klávesovou zkratku CTRL+C).

    <?xml version="1.0" encoding="utf-8"?>
    <SuppliersRoot>
    <Suppliers>
    <SupplierID>1</SupplierID>
    <CompanyName>Exotic Liquids</CompanyName>
    <ContactName>Charlotte Cooper</ContactName>
    <ContactTitle>Purchasing Manager</ContactTitle>
    <Address>49 Gilbert St.</Address>
    <City>London</City>
    <PostalCode>EC1 4SD</PostalCode>
    <Country>UK</Country>
    <Phone>(171) 555-2222</Phone>
    </Suppliers>
    <Suppliers>
    <SupplierID>2</SupplierID>
    <CompanyName>New Orleans Cajun Delights</CompanyName>
    <ContactName>Shelley Burke</ContactName>
    <ContactTitle>Order Administrator</ContactTitle>
    <Address>P.O. Box 78934</Address>
    <City>New Orleans</City>
    <Region>LA</Region>
    <PostalCode>70117</PostalCode>
    <Country>USA</Country>
    <Phone>(100) 555-4822</Phone>
    <HomePage>#CAJUN.HTM#</HomePage>
    </Suppliers>
    </SuppliersRoot>
  7. V aplikaci Office SharePoint Designer 2007 umístěte ukazatel myši do horní části stránky a potom stisknutím kombinace kláves CTRL+V vložte právě zkopírovaný kód na stránku.

  8. V nabídce Soubor klikněte na příkaz Uložit jako.

  9. V dialogovém Uložit jako v poli název souboru zadejte suppliers.xml.

  10. Ze seznamu Typ souboru vyberte položku XML a pak klepněte na tlačítko Uložit.

Začátek stránky

Vytvoření zobrazení dat pomocí souboru Suppliers.xml

  1. Otevřete stránku obsahující první zobrazení dat, které jste vytvořili v článku Vložení zobrazení dat jako formuláře.

    Ačkoli není nezbytné, aby obě zobrazení dat byla umístěna na téže stránce, v tomto případě chcete, aby tým viděl při klepnutí na produkt také kontaktní údaje dodavatele.

    Vybraná data zobrazená jako formulář

  2. Vyberte první zobrazení dat a poté dvojím stisknutím ŠIPKY VPRAVO umístěte kurzor pod zobrazení dat.

  3. V nabídce Zobrazení dat klepněte na příkaz Vložit zobrazení dat.

    Pod prvním zobrazení dat je nyní zobrazeno prázdné zobrazení dat a otevře se podokno úloh Knihovna zdrojů dat.

    Prázdné zobrazení dat

  4. V podokně úloh Knihovna zdrojů dat vyhledejte zdroj dat, klepněte na něj a potom klepněte na možnost Zobrazit data.

    V uvedeném příkladu v části Soubory XML klepněte na možnost Suppliers.xml a poté klepněte na možnost Zobrazit data. Pokud je záhlaví Soubory XML sbaleno, rozbalte ho klepnutím na znaménko (+).

  5. V podokně úloh Podrobnosti zdroje dat klepněte na pole, která chcete vložit do zobrazení dat.

    Tip : Chcete-li vybrat více polí, podržte při klepání na jednotlivá pole klávesu CTRL.

    U tohoto příkladu klepněte ve složce KořenováSložkaDodavatelů v položce Dodavatelé na položku NázevSpolečnosti. Stiskněte a podržte klávesu CTRL a klepněte na položku JménoKontaktu, Země a Telefon.

  6. Klepněte na možnost Vložit vybraná pole jako a klepnutím na možnost Zobrazení jedné položky vložte vybraná data do zobrazení dat.

    Zvolte zobrazení pouze jedné položky v zobrazení dat, protože chcete zobrazit najednou kontakt pouze pro jednoho dodavatele.

    Vybraná pole v podokně Podrobnosti zdroje dat se nyní zobrazí druhém zobrazení dat pod prvním zobrazením dat.

    Zobrazení dat dodavatele se zobrazí pod zobrazením dat produktu
    Pod Products.xml zobrazení dat se zobrazí zobrazení dat Suppliers.xml (červeně.).

Začátek stránky

Propojení webových částí

Soubory Suppliers.xml a Products.xml spolu souvisí prostřednictvím společného pole SupplierID. Pomocí Průvodce připojením webových částí propojte webové části propojením polí SupplierID v souboru Products.xml s polem SupplierID v souboru Suppliers.xml.

Poté co jste vytvořili dvě zobrazení dat, přidáte vedle každého produktu v zobrazení dat Products.xml text, který bude hypertextově odkazovat na zobrazení dat souboru Suppliers.xml. Klepnete-li na hypertextový odkaz pro produkt v prvním zobrazení dat, zobrazí se v druhém zobrazení dat kontaktní údaje dodavatele produktu.

Zobrazení dat souboru Products.xml je zdrojová webová část a zobrazení dat souboru Suppliers.xml je cílová webová část. Protože pracujete se zobrazením dat vloženým jako formulář, musíte vytvořit hypertextový odkaz mimo pole formuláře. Poté, co zadáte text, vyberte jej a pomocí Průvodce připojením webových částí vytvořte hypertextový odkaz v souboru Products.xml, který odkazuje na zobrazení dat souboru Suppliers.xml.

  1. V zobrazení dat vytvoření z Products.xml umístěte kurzor na místo vpravo od textového pole, které obsahuje název produktu, stiskněte klávesu MEZERNÍK a zadejte pořadí. Protože zobrazení dat pomocí transformací XSLT formátování, text "směru" je přidán do pole každý produkt v seznamu.

    Ve sloupci NázevProduktu se pro každý produkt v seznamu zobrazí objednávky

  2. V zobrazení dat vyberte text „objednávka“, klepněte pravým tlačítkem myši a v místní nabídce klepněte na položku Připojení webové části.

    Otevřete Průvodce připojením webových částí.

  3. V seznamu Zvolte akci u zdrojové webové části, která se má použít pro toto připojení, klepněte na položku Odeslat řádek dat do a poté klepněte na tlačítko Další.

    Stránka v Průvodci připojením webových částí

  4. V části Vyberte stránku s webovou částí pro připojení, klepněte na položku Připojit k webové části na této stránce a poté klepněte na tlačítko Další.

    Stránka v Průvodci připojením webových částí

  5. V seznamu Cílová webová část klepněte na položku suppliers.xml.

  6. Protože chcete filtrovat data v souboru Suppliers.xml s cílem nalézt odpovídající pole SupplierID daného produktu v prvním zobrazení dat, klepněte v seznamu Cílová akce na položku Načíst hodnoty filtru z a poté klepněte na tlačítko Další.

    Stránka v Průvodci připojením webových částí

  7. Ve sloupci Vstupní hodnoty pro Suppliers.xml vyhledejte položku SupplierID. V seznamu nalevo od položky SupplierID ve sloupci Sloupce v Products.xml klepněte na buňku, poté na šipku a poté klepněte v seznamu na položku SupplierID. Klepněte na tlačítko Další.

    Stránka v Průvodci připojením webových částí

  8. V seznamu Vytvořit hypertextový odkaz na klepněte na možnost [ Aktuální výběr] a poté klepněte na tlačítko Další.

    Stránka v Průvodci připojením webových částí

  9. Klikněte na Dokončit.

  10. V nabídce Soubor klepněte na příkaz Uložit. Můžete také stisknout klávesy CTRL+S.

Text „objednávka“ je nyní hypertextový odkaz a připojení webové části je konfigurováno.

Začátek stránky

Testování propojení webových částí

Poté, co bylo připojení webové části nakonfigurováno, můžete připojení testovat zobrazením náhledu stránky v prohlížeči.

  • Náhled zobrazíte v prohlížeči klepnutím na příkaz Náhled na panelu nástrojů Společné nebo stisknutím klávesy F12.

Obě webové části se zobrazí na stránce v prohlížeči. Chcete-li zobrazit dodavatele určitého produktu, klepněte v zobrazení dat na odkaz objednávka vedle požadovaného produktu ve sloupci NázevProduktu. V druhém zobrazení dat níže se zobrazí kontaktní údaje dodavatele.

Dvě propojená zobrazení dat na stránce

Poznámka : Firma Exotic Liquids je dodavatelem produktů Chai, Chang a anýzového sirupu. Firma New Orleans Cajun Delights je dodavatelem produktů Chef Anton’s Cajun Seasoning a Chef Anton’s Gumbo Mix.

Začátek stránky

Odebrání propojení webových částí

Propojení webových částí můžete také odebrat, aby mezi oběma webovými částmi již neexistovala vazba. Po propojení obě webové části obsahují seznam propojení, takže můžete pracovat se zdrojovou nebo cílovou webovou částí. Odebráním propojení ze zdrojové webové části dojde také k jeho odebrání z cílové webové části.

  1. Klepněte pravým tlačítkem myši na jedno ze zobrazení dat a v místní nabídce vyberte položku Připojení webové části.

  2. V dialogovém okně Připojení webových částí klepněte na propojení, které chcete odebrat, a poté klepněte na příkaz Odebrat.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×