Sečtení sloupce nebo řádku čísel v tabulce

Sloupec nebo řádek čísel v tabulce můžete sečíst tak, že použijete příkaz Vzorec.

  1. V tabulce klikněte na buňku, ve které chcete mít výsledek.

  2. Klikněte na kartu Nástroje tabulky – Rozložení a pak na Vzorec.

Tlačítko Vzorec na kontextové kartě Nástroje tabulky

  1. Podle údajů v závorkách zkontrolujte, jestli Word zahrnul do součtu všechny požadované buňky.

Vzorec SUM v poli Vzorec

=SUM(ABOVE) sečte čísla ve sloupci nad aktuální buňkou.

=SUM(LEFT) sečte čísla v řádku nalevo od aktuální buňky.

=SUM(BELOW) sečte čísla ve sloupci pod aktuální buňkou.

=SUM(RIGHT) sečte čísla v řádku napravo od aktuální buňky.

Pokud změníte čísla, která sčítáte, vyberte součet a stiskněte F9. Zobrazíte tak nové výsledky.

V tabulce můžete použít taky víc vzorců. Můžete například sečíst řádky do posledního sloupce napravo a do dolní buňky tohoto sloupce potom vložit celkový součet všech výsledků.

Další vzorce pro tabulky

Word obsahuje i další funkce pro tabulky – třeba AVERAGE a PRODUCT.

  1. V tabulce klikněte na buňku, ve které chcete mít výsledek.

  2. Klikněte na kartu Nástroje tabulky – Rozložení a pak na Vzorec.

Tlačítko Vzorec na kontextové kartě Nástroje tabulky

  1. V poli Vzorec vymažte vzorec SUM, ale zachovejte znaménko rovná se (=). Pak klikněte na Vložit funkci a vyberte požadovanou funkci.

Dialog Vzorec s nabídkou funkcí

  1. Do závorky zadejte, se kterými buňkami tabulky má vzorec pracovat:

Pokud chcete pracovat s čísly ve sloupci nad aktuální buňkou, zadejte ABOVE a klikněte na OK.

Pokud chcete pracovat s čísly v řádku nalevo od aktuální buňky, zadejte LEFT a klikněte na OK.

Pokud chcete pracovat s čísly ve sloupci pod aktuální buňkou, zadejte BELOW a klikněte na OK.

Pokud chcete pracovat s čísly v řádku napravo od aktuální buňky, zadejte RIGHT a klikněte na OK.

Když třeba chcete spočítat průměr čísel v řádku nalevo od dané buňky, klikněte na AVERAGE a zadejte LEFT:

=AVERAGE(LEFT)

Pro vynásobení dvou čísel klikněte na PRODUCT a zadejte umístění buněk tabulky:

=PRODUCT(ABOVE)

Tip: Pokud chcete do vzorce zadat specifičtější oblast buněk, můžete odkazovat na konkrétní buňky. Představte si, že každý sloupec tabulky je označený písmenem a každý řádek tabulky číslem jako na listu v Microsoft Excelu. Kdybyste například chtěli vynásobit čísla ve druhém a třetím sloupci druhého řádku, zadejte =PRODUCT(B2:C2).

Sloupec nebo řádek čísel můžete sečíst tak, že použijete příkaz Vzorec.

  1. V tabulce klikněte na buňku, ve které chcete mít výsledek.

  2. Na kartě rozložení vedle karty návrh tabulky vyberte vzorec.

    On the Layout tab, select Formula

  3. Podle údajů v závorkách zkontrolujte, jestli Word zahrnul do součtu všechny požadované buňky.

    The Formula box, showing the formula used to sum a column

    =SUM(ABOVE) sečte čísla ve sloupci nad aktuální buňkou.

    =SUM(LEFT) sečte čísla v řádku nalevo od aktuální buňky.

    =SUM(BELOW) sečte čísla ve sloupci pod aktuální buňkou.

    =SUM(RIGHT) sečte čísla v řádku napravo od aktuální buňky.

Tipy: 

  • Pokud změníte čísla, která sčítáte, vyberte součet a stiskněte fn+F9. Zobrazíte tak nové výsledky.

  • V tabulce můžete použít víc vzorců. Můžete třeba sečíst řádky do posledního sloupce napravo a do dolní buňky tohoto sloupce potom vložit celkový součet všech výsledků.

Další vzorce pro tabulky

Word obsahuje i další funkce pro tabulky – třeba AVERAGE a PRODUCT.

  1. V tabulce klikněte na buňku, ve které chcete mít výsledek.

  2. Na kartě Rozložení (vedle karty Návrh tabulky) klikněte na Vzorec.

    On the Layout tab, select Formula

  3. V poli Vzorec vymažte vzorec SUM, ale zachovejte znaménko rovná se (=). Pak klikněte na Vložit funkci a vyberte požadovanou funkci.

    V dialogovém okně Vzorec vyberte funkci v poli Vložit funkci

  4. Do závorky zadejte, se kterými buňkami tabulky má vzorec pracovat:

    Pokud chcete pracovat s čísly ve sloupci nad aktuální buňkou, zadejte ABOVE.

    Pokud chcete pracovat s čísly v řádku nalevo od aktuální buňky, zadejte LEFT.

    Pokud chcete pracovat s čísly ve sloupci pod aktuální buňkou, zadejte BELOW.

    Pokud chcete pracovat s čísly v řádku napravo od aktuální buňky, zadejte RIGHT.

    Když třeba chcete spočítat průměr čísel v řádku nalevo od dané buňky, klikněte na AVERAGE a zadejte LEFT:

    =AVERAGE(LEFT)

    Pro vynásobení dvou čísel klikněte na PRODUCT a zadejte umístění buněk tabulky:

    =PRODUCT(ABOVE)

Tip: Pokud chcete do vzorce zadat specifičtější oblast buněk, můžete odkazovat na konkrétní buňky. Představte si, že každý sloupec tabulky je označený písmenem a každý řádek tabulky číslem jako na listu v Microsoft Excelu. Kdybyste například chtěli vynásobit čísla ve druhém a třetím sloupci druhého řádku, zadejte =PRODUCT(B2:C2).

Pokud jste obeznámeni s desktopovou verzí Wordu, můžete pomocí vzorců provádět výpočty, jako je souhrn sloupců nebo řádků čísel v tabulce. Word pro web zachová vzorce, které už v dokumentu máte, ale zatím nenabízí možnost je přidat.

Pokud máte desktopovou verzi Wordu, otevřete dokument pomocí příkazu otevřít v aplikaci Word a vložte vzorec.

Obrázek příkazu Otevřít ve Wordu ve Wordu Online

Až to budete mít a dokument uložíte, uloží se, když ho otevřete v Word pro web.

Poznámka:  Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát vědět, jestli vám informace pomohly? Pokud chcete, můžete se podívat na anglickou verzi článku.

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×