Sčítání a odčítání časových hodnot

Sčítání a odčítání časových hodnot

Řekněme, že potřebujete přidat dvě různé časové hodnoty a získat souhrn. Nebo je třeba odečíst jednu časovou hodnotu, a získat tak celkový čas strávený prací na projektu.

Jak uvidíte v níže uvedených částech, Excel usnadňuje sčítání a odčítání.

Sčítání časových hodnot

Předpokládejme, že chcete vědět, kolik hodin a minut bude trvat provedení dvou úkolů. Odhadujete, že první úkol bude trvat 6 hodin a 45 minut a druhý úkol bude trvat 9 hodin a 30 minut.

Tady je jeden způsob, jak nastavit tento stav v listu.

  1. Do buňky B2 zadejte 6:45a dobuňky B3 zadejte 9:30.

  2. Do buňky B4 zadejte = B2 + B3 a stiskněte ENTER.

    Sečtená doba dvou úkolů

    Výsledek je 16:15 – 16 hodin a 15 minut – pro dokončení těchto dvou úkolů.

    Tip: Časy můžete sečíst taky díky funkci AutoSum, která slouží ke sčítání čísel. Vyberte buňku B4 a potom na kartě Domů zvolte AutoSum. Vzorec bude vypadat takto: = SUMA(B2:B3). Stisknutím klávesy ENTER získáte stejný výsledek, 16 hodin a 15 minut.

Dobře, tohle bylo jednoduché, ale když součet přesáhne 24 hodin, je potřeba podniknout další krok. Musíte pro výsledek vzorce použít speciální formát.

Pokud chcete přidat víc než 24 hodin:

  1. Do buňky B2 zadejte 12:45 a do buňky B3 zadejte 15:30.

  2. Do buňky B4 zadejte =B2+B3 a stiskněte Enter.

    Sečtením časových hodnot, jejichž součet přesahuje 24 hodin, vznikne nečekaný výsledek 4:15.

    Výsledek je 4:15, což není to, co byste očekávali. Je to proto, že čas pro úkol 2 je ve 24hodinovém čase. 15:30 je totéž jako 3:30.

  3. Abyste správně zobrazili časovou hodnotu delší než 24 hodin, postupujte takto: Vyberte buňku B4.

  4. Na kartě Domů ve skupině Buňky zvolte Formát a potom zvolte Formát buněk.

    Karta Domů, tlačítko Formát a příkaz Formát buněk

  5. V dialogovém okně Formát buněk zvolte Vlastnív seznamu Kategorie.

  6. V poli typ v horní části seznamu formátů zadejte [h]: mm; @ a pak zvolte OK.

    Všimněte si dvojtečky za [h] a středníkem po mm.

Výsledek je 28 hodin a 15 minut. Až budete tenhle formát příště potřebovat, bude se bude v seznamu Typ zobrazovat.

Odčítání časových hodnot

Tady je další příklad: řekněme, že vy i vaši přátelé znáte čas začátku a konce v dobrovolných projektech a chcete zjistit, kolik času jste strávili celkem.

Pokud chcete zjistit, jaký je rozdíl mezi dvěma časy, postupujte takto:

  1. Do buňky B2 zadejte čas zahájení a pro dop./odp. použijte "a" pro ODP. Pak stiskněte klávesu Enter.

  2. Do buňky C2 zadejte čas ukončení, včetně "a" nebo "p", a pak stiskněte ENTER.

  3. Zadejte další počáteční a koncové časy pro svoje přátele Jirku a Lenku.

  4. V buňce D2 odečtěte koncový čas od času zahájení zadáním vzorce = C2-B2a stiskněte ENTER.

    Jedna časová hodnota odečtená od druhé kvůli získání uplynulé doby

  5. V dialogovém okně Formát buněk klikněte v seznamu Druh na možnost Vlastní.

  6. V seznamu Typ klikněte na h:mm (pro hodiny a minuty) a klikněte na OK.

    Teď vidíme, že Richard pracoval 3 hodiny a 45 minut.

    Uplynulé doby uvedené ve sloupci D

  7. Abyste získali výsledky pro Jirku a Lenku, zkopírujte vzorec tak, že vyberete buňku D2 a přetáhnete ji do buňky D4.

    Formátování buňky D2 se zkopíruje spolu se vzorcem.

Pokud chcete odečíst čas delší než 24 hodin, postupujte takto:

Je nutné vytvořit vzorec, který odečte rozdíl mezi dvěma krátími součty více než 24 hodin.

Postupujte podle následujících pokynů:

  1. Ve výše uvedeném příkladu vyberte buňku B1 a přetáhněte ji do buňky B2, abyste vybrali obě buňky a použili formát u obou buněk současně.

  2. V dialogovém okně Formát buněk klikněte v seznamu Druh na možnost Vlastní.

  3. Do pole Typ v horní části seznamu formátů zadejte m/d/yyyy h:mm AM/PM.

    Povšimněte si prázdné mezery na konci yyyyu a na konci mm.

    Tenhle nový formát bude dostupný v seznamu Typ, kdykoliv ho budete potřebovat.

  4. Do buňky B1 zadejte počáteční datum ve tvaru den.měsíc.rok a včetně času s příponou „d“ nebo „o“ označující dopoledne nebo odpoledne.

    Uplynulá doba delší než 24 hodin

  5. Podobně zadejte koncové datum do buňky B2.

  6. Do buňky B3 zadejte vzorec =(B2-B1)*24.

Výsledek je 31,5 hodin.

Poznámka: V Excelu online můžete sčítat a odečítat víc než 24 hodin, ale nemůžete použít vlastní formát čísla.

Sčítání časových hodnot

Dejme tomu, že chcete vědět, kolik hodin a minut bude trvat dokončení dvou úkolů. Odhadujete, že první úkol bude trvat 6 hodin a 45 minut a druhý úkol bude trvat 9 hodin a 30 minut.

  1. Do buňky B2 zadejte 6:45 a do buňky B3 zadejte 9:30.

  2. Do buňky B4 zadejte =B2+B3 a pak stiskněte Enter.

Sečtená doba dvou úkolů

Provedení těchto dvou úkolů bude trvat 16 hodin a 15 minut.

Tip: Časy můžete sečíst taky pomocí tlačítka Automatické shrnutí. Klikněte do buňky B4. Potom klikněte na Domů > Automatické shrnutí. Vzorec bude vypadat takto: =SUMA(B2:B3). Stiskněte Enter a dostanete výsledek (16 hodin a 15 minut).

Odčítání časů

Řekněme, že se svými přáteli znáte čas zahájení a čas ukončení dobrovolnického projektu a chcete vědět, kolik času jste na něm strávili. Jinak se to dá říct taky tak, že chcete zjistit uplynulý čas neboli rozdíl mezi dvěma časy.

  1. Do buňky B2 zadejte čas zahájení, zadejte mezeru a pak zadejte "a" pro dop./odp. nebo "p" pro ODP. Do buňky C2 zadejte koncový čas a písmeno d nebo o podle potřeby a stiskněte Enter. Zadejte další počáteční časy pro své přátele Jirku a Lenku.

  2. V buňce D2 odečtěte od koncového času počáteční čas zadáním vzorce: =C2-B2 a stiskněte Enter.

Jedna časová hodnota odečtená od druhé kvůli získání uplynulé doby

Teď vidíme, že Richard pracoval 3 hodiny a 45 minut.

  1. Abyste získali výsledky pro Jirku a Lenku, zkopírujte vzorec kliknutím do buňky D2 a přetažením úchytu do buňky D4. Formátování buňky D2 se zkopíruje spolu se vzorcem.

Uplynulé doby uvedené ve sloupci D

Poznámka:  Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát vědět, jestli vám informace pomohly? Pokud chcete, můžete se podívat na anglickou verzi článku.

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders