Ruční zadávání dat do buněk listu

Důležité   Tento článek je strojově přeložených naleznete v tématu omezení. Anglická verze tohoto článku zde prosím najdete pro váš odkaz.

Chcete-li data do aplikace Excel zadávat ručně, máte několik možností. Data můžete zadávat do jedné buňky, do více buněk najednou nebo do více než jednoho List najednou. Zadávaná data mohou být čísla, text, kalendářní data nebo časy. Data lze formátovat různými způsoby. K dispozici je rovněž několik nastavení, které lze přizpůsobit tak, aby zadávání dat bylo snazší.

Toto téma nevysvětluje, jak k zadávání dat do listu používat datový formulář. Další informace o používání datových formulářů naleznete v části Přidání, úprava, vyhledání a odstranění řádků pomocí datového formuláře.

Důležité   Pokud do listu nejde zadávat data nebo pokud je nelze upravovat, může být tento list vámi nebo někým jiným uzamčen proti nechtěným změnám. V zamknutém listu lze zobrazovat data výběrem buněk, ale do zamknutých buněk nelze zadávat žádné informace. Ve většině případů byste zámek listu neměli odstraňovat bez souhlasu osoby, která jej vytvořila. Potřebujete-li list odemknout, klikněte na položku Odemknout list ve skupině Změny na kartě Revize. Pokud bylo při uzamčení listu nastaveno heslo, je nutné jej pro odemčení listu zadat.

Co chcete udělat?

Zadat text nebo číslo do buňky

Zadání čísla s pevným počtem desetinných míst

Zadání data nebo času do buňky

Zadání stejných dat do několika buněk současně

Zadání stejných dat do několika listů současně

Úprava nastavení listu a formátování buněk

Změna směru pro klávesu Enter

Změna šířky sloupce

Zalomení textu v buňce

Změna formátu čísla

Naformátovat číslo jako text

Zadání textu nebo čísla do buňky

  1. Na listu klikněte na buňku.

  2. Zadejte požadovaná čísla nebo text a stiskněte klávesu Enter nebo Tab.

    Tip   Pokud chcete v buňce zadat data na nový řádek, vložíte konec řádku stisknutím kombinace kláves Alt+Enter.

Začátek stránky

Zadání čísla s pevným počtem desetinných míst

  1. Na kartě Soubor klikněte na položku Možnosti.

  2. V kategorii Upřesnit zaškrtněte v části Možnosti úprav políčko Automaticky vložit desetinnou čárku.

  3. Do pole Počet zadejte kladné číslo pro počet číslic vpravo od desetinné čárky nebo záporné číslo pro počet číslic vlevo od desetinné čárky.

    Pokud například do pole Počet zadáte číslo 3 a do buňky zadáte číslo 2834, zobrazí se hodnota 2,834. Jestliže do pole Počet zadáte číslo -3 a do buňky zadáte číslo 283, zobrazí se hodnota 283000.

  4. Na listu klikněte na buňku a potom zadejte požadované číslo.

    Data zadaná do buněk před zaškrtnutím políčka Pevný počet desetinných míst nebudou ovlivněna.

    Tip   Možnost Pevný počet desetinných míst můžete dočasně potlačit tak, že při zadávání čísla napíšete desetinnou čárku.

Začátek stránky

Zadání data nebo času do buňky

  1. Na listu klikněte na buňku.

  2. Zadejte kalendářní datum nebo čas následujícím způsobem:

    • Části kalendářního data můžete oddělit tečkami nebo pomlčkami. Můžete například zadat 5.9.2002 nebo 5-Zář-2002.

    • Čas ve 12hodinovém cyklu zadáte tak, že napíšete čas, vložíte mezeru a přidáte d nebo o, například 9:00 o. Pokud tak neučiníte, bude čas v aplikaci Excel vložen ve 24hodinovém cyklu.

      Tip   Aktuální čas zadáte stisknutím kláves Ctrl+Shift+; (středník).

Poznámka   

  • Pokud chcete zadat datum nebo čas, které bude při novém otevření listu stále aktuální, můžete použít funkce DNES a NYNÍ.

  • Pokud do buňky zadáváte datum nebo čas, zobrazí se ve výchozím formátu data nebo času pro váš počítač nebo ve formátu, který byl na buňku použit před zadáním data nebo času. Výchozí formát data nebo času závisí na nastavení kalendářního data a času v dialogovém okně Místní nastavení (Ovládací panely, Hodiny, Jazyk a oblast). Pokud byla tato nastavení ve vašem počítači změněna, data a časy ve vašich sešitech, které nebyly naformátovány pomocí příkazu Formát buněk, jsou zobrazeny podle těchto nastavení.

  • Chcete-li použít výchozí formát data nebo času, klikněte na buňku obsahující datum nebo čas a potom stiskněte kombinaci kláves Ctrl+Shift+# nebo Ctrl+Shift+@.

Začátek stránky

Zadání stejných dat do několika buněk současně

  1. Vyberte buňky, do kterých chcete zadat stejná data. Buňky spolu nemusejí sousedit.

    Postup pro výběr buněk

    Požadovaný výběr

    Akce

    Jedna buňka

    Klikněte na buňku nebo pomocí kláves se šipkami na buňku přejděte.

    Oblast buněk

    Klikněte na první buňku v oblasti a poté přetažením ukazatele myši přejděte na poslední buňku, případně podržte klávesu SHIFT a pomocí kláves se šipkami výběr rozšiřte.

    Můžete také vybrat první buňku oblasti, stisknout klávesu F8 a pomocí kláves se šipkami rozšířit výběr. Chcete-li rozšiřování výběru ukončit, znovu stiskněte klávesu F8.

    Rozsáhlá oblast buněk

    Klikněte na první buňku v oblasti, podržte klávesu SHIFT a klikněte na poslední buňku oblasti. Poslední buňku můžete zobrazit posunutím zobrazení.

    Všechny buňky na listu

    Klikněte na tlačítko Vybrat vše.

    Tlačítko Vybrat vše

    Chcete-li vybrat celý list, můžete také stisknout kombinaci kláves CTRL+A.

    Pokud list obsahuje data, bude při stisknutí kombinace kláves CTRL+A vybrána aktuální oblast. Při dalším stisknutí kombinace kláves CTRL+A bude vybrán celý list.

    Nesousedící buňky nebo oblasti buněk

    Vyberte první buňku nebo oblast buněk. Potom podržte klávesu CTRL a vyberte ostatní buňky nebo oblasti.

    Můžete také vybrat první buňku nebo oblast buněk a stisknutím kombinace kláves SHIFT+F8 přidat k výběru další nesousedící buňku nebo oblast buněk. Chcete-li přidávání buněk nebo oblastí buněk k výběru ukončit, znovu stiskněte kombinaci kláves SHIFT+F8.

    Poznámka   Výběr nesousedících buněk nebo oblastí buněk nelze zrušit bez zrušení celého výběru.

    Celý řádek nebo sloupec

    Klikněte na záhlaví řádku nebo sloupce.

    List se záhlavím řádku a záhlavím sloupce

    1. Záhlaví řádku

    2. Záhlaví sloupce

    Buňky v řádku nebo sloupci lze také vybrat výběrem první buňky a stisknutím kombinace kláves CTRL+SHIFT+ŠIPKA (ŠIPKA VPRAVO nebo ŠIPKA VLEVO, ŠIPKA NAHORU nebo ŠIPKA DOLŮ pro sloupce).

    Pokud řádek či sloupec obsahuje data, bude pomocí kombinace kláves CTRL+SHIFT+ŠIPKA vybrán řádek či sloupec až po poslední použitou buňku. Opětovným stisknutím kombinace kláves CTRL+SHIFT+ŠIPKA vyberete celý řádek či sloupec.

    Sousedící řádky nebo sloupce

    Přetáhněte ukazatel myši přes záhlaví řádků nebo sloupců. Případně vyberte první řádek či sloupec, podržte klávesu SHIFT a vyberte poslední řádek či sloupec.

    Nesousedící řádky nebo sloupce

    Klikněte na záhlaví prvního řádku nebo sloupce ve výběru. Poté podržte klávesu CTRL a klikněte na záhlaví dalších řádků nebo sloupců, které chcete do výběru přidat.

    První nebo poslední buňka v řádku nebo sloupci

    Vyberte buňku v řádku nebo sloupci a potom stiskněte kombinaci kláves Ctrl+Šipka (Šipka vlevo nebo Šipka vpravo pro řádky, Šipka nahoru nebo Šipka dolů pro sloupce).

    První nebo poslední buňka na listu nebo v tabulce aplikace Microsoft Office Excel

    Stisknutím kombinace kláves CTRL+HOME vyberte první buňku na listu nebo v seznamu aplikace Excel.

    Stisknutím kombinace kláves CTRL+END vyberte poslední buňku na listu nebo v seznamu aplikace Excel obsahujícím data nebo formátování.

    Buňky k poslední použité buňce na listu (pravý dolní roh)

    Vyberte první buňku a potom stisknutím kombinace kláves Ctrl+Shift+End rozšiřte výběr na poslední použitou buňku na listu (pravý dolní roh).

    Buňky k začátku listu

    Vyberte první buňku a stisknutím kombinace kláves Ctrl+Shift+Home rozšiřte výběr na buňky k začátku listu.

    Více nebo méně buněk, než obsahuje aktivní výběr

    Podržte klávesu SHIFT a klikněte na poslední buňku, kterou chcete zahrnout do nového výběru. Novým výběrem teď bude obdélníková oblast mezi Aktivní buňka a buňkou, na kterou jste klikli.

    Tip   Chcete-li výběr buněk zrušit, klikněte na libovolnou buňku na listu.

  2. Do aktivní buňky zadejte data a stiskněte kombinaci kláves Ctrl+Enter.

    Tip   Stejná data do několika buněk můžete také zadat pomocí Úchyt Úchyt a automaticky tak vyplnit buňky listu daty.

    Další informace naleznete v článku Automatické vyplnění dat v buňkách listu.

Začátek stránky

Zadání stejných dat do několika listů současně

Tím, že více listů současně aktivní, můžete zadat nová data nebo změnit stávající data na jednom z listů a změny budou použity na stejné buňky ve všech vybraných listech.

  1. Klikněte na ouško prvního listu obsahujícího data, která chcete upravit. Potom stiskněte klávesu Ctrl a klikněte na ouška listů, ve kterých chcete data synchronizovat.

    Tlačítka pro pohyb mezi listy

    Poznámka   Pokud není ouško požadovaného listu viditelné, klikněte na tlačítka pro pohyb mezi listy tak, aby se zobrazilo. Potom na něj klikněte. Pokud se vám ouška požadovaných listů stále nedaří nalézt, zkuste maximalizovat okno dokumentu.

  2. Na aktivním listu vyberte buňku nebo Oblast, ve kterém chcete upravit existující nebo zadat nová data.

    Postup pro výběr buněk

    Požadovaný výběr

    Akce

    Jedna buňka

    Klikněte na buňku nebo pomocí kláves se šipkami na buňku přejděte.

    Oblast buněk

    Klikněte na první buňku v oblasti a poté přetažením ukazatele myši přejděte na poslední buňku, případně podržte klávesu SHIFT a pomocí kláves se šipkami výběr rozšiřte.

    Můžete také vybrat první buňku oblasti, stisknout klávesu F8 a pomocí kláves se šipkami rozšířit výběr. Chcete-li rozšiřování výběru ukončit, znovu stiskněte klávesu F8.

    Rozsáhlá oblast buněk

    Klikněte na první buňku v oblasti, podržte klávesu SHIFT a klikněte na poslední buňku oblasti. Poslední buňku můžete zobrazit posunutím zobrazení.

    Všechny buňky na listu

    Klikněte na tlačítko Vybrat vše.

    Tlačítko Vybrat vše

    Chcete-li vybrat celý list, můžete také stisknout kombinaci kláves CTRL+A.

    Pokud list obsahuje data, bude při stisknutí kombinace kláves CTRL+A vybrána aktuální oblast. Při dalším stisknutí kombinace kláves CTRL+A bude vybrán celý list.

    Nesousedící buňky nebo oblasti buněk

    Vyberte první buňku nebo oblast buněk. Potom podržte klávesu CTRL a vyberte ostatní buňky nebo oblasti.

    Můžete také vybrat první buňku nebo oblast buněk a stisknutím kombinace kláves SHIFT+F8 přidat k výběru další nesousedící buňku nebo oblast buněk. Chcete-li přidávání buněk nebo oblastí buněk k výběru ukončit, znovu stiskněte kombinaci kláves SHIFT+F8.

    Poznámka   Výběr nesousedících buněk nebo oblastí buněk nelze zrušit bez zrušení celého výběru.

    Celý řádek nebo sloupec

    Klikněte na záhlaví řádku nebo sloupce.

    List se záhlavím řádku a záhlavím sloupce

    1. Záhlaví řádku

    2. Záhlaví sloupce

    Buňky v řádku nebo sloupci lze také vybrat výběrem první buňky a stisknutím kombinace kláves CTRL+SHIFT+ŠIPKA (ŠIPKA VPRAVO nebo ŠIPKA VLEVO, ŠIPKA NAHORU nebo ŠIPKA DOLŮ pro sloupce).

    Pokud řádek či sloupec obsahuje data, bude pomocí kombinace kláves CTRL+SHIFT+ŠIPKA vybrán řádek či sloupec až po poslední použitou buňku. Opětovným stisknutím kombinace kláves CTRL+SHIFT+ŠIPKA vyberete celý řádek či sloupec.

    Sousedící řádky nebo sloupce

    Přetáhněte ukazatel myši přes záhlaví řádků nebo sloupců. Případně vyberte první řádek či sloupec, podržte klávesu SHIFT a vyberte poslední řádek či sloupec.

    Nesousedící řádky nebo sloupce

    Klikněte na záhlaví prvního řádku nebo sloupce ve výběru. Poté podržte klávesu CTRL a klikněte na záhlaví dalších řádků nebo sloupců, které chcete do výběru přidat.

    První nebo poslední buňka v řádku nebo sloupci

    Vyberte buňku v řádku nebo sloupci a potom stiskněte kombinaci kláves Ctrl+Šipka (Šipka vlevo nebo Šipka vpravo pro řádky, Šipka nahoru nebo Šipka dolů pro sloupce).

    První nebo poslední buňka na listu nebo v tabulce aplikace Microsoft Office Excel

    Stisknutím kombinace kláves CTRL+HOME vyberte první buňku na listu nebo v seznamu aplikace Excel.

    Stisknutím kombinace kláves CTRL+END vyberte poslední buňku na listu nebo v seznamu aplikace Excel obsahujícím data nebo formátování.

    Buňky k poslední použité buňce na listu (pravý dolní roh)

    Vyberte první buňku a potom stisknutím kombinace kláves Ctrl+Shift+End rozšiřte výběr na poslední použitou buňku na listu (pravý dolní roh).

    Buňky k začátku listu

    Vyberte první buňku a stisknutím kombinace kláves Ctrl+Shift+Home rozšiřte výběr na buňky k začátku listu.

    Více nebo méně buněk, než obsahuje aktivní výběr

    Podržte klávesu SHIFT a klikněte na poslední buňku, kterou chcete zahrnout do nového výběru. Novým výběrem teď bude obdélníková oblast mezi Aktivní buňka a buňkou, na kterou jste klikli.

    Tip   Chcete-li výběr buněk zrušit, klikněte na libovolnou buňku na listu.

  3. V aktivní buňce zadejte nová data nebo upravte data stávající a poté stiskem klávesy Enter nebo Tab přesuňte výběr na další buňku.

    Změny budou provedeny ve všech vámi vybraných listech.

  4. Opakujte předchozí krok, dokud nedokončíte zadávání nebo úpravy dat.

Poznámka   

  • Výběr více listů lze zrušit kliknutím na kterýkoli nevybraný list. Pokud není zobrazen žádný nevybraný list, klikněte pravým tlačítkem myši na ouško nějakého vybraného listu a pak klikněte na příkaz Oddělit listy.

  • Při zadávání nebo úpravách dat se změny projeví ve všech vybraných listech a mohou nechtěně nahradit data, která jste neměli v úmyslu měnit. Aby k tomu nedocházelo, můžete si všechny listy zobrazit současně a identifikovat potenciální konflikty dat.

    1. Na kartě Zobrazení ve skupině Okno klikněte na příkaz Nové okno.

    2. Přepněte do nového okna a klikněte na list, který chcete zobrazit.

    3. Opakujte kroky 1 a 2 u každého listu, který chcete zobrazit.

    4. Na kartě Zobrazení, ve skupině Okno, klikněte na příkaz Uspořádat vše a poté klikněte na požadovanou možnost.

    5. Chcete-li zobrazit listy pouze v aktivním sešitu, zaškrtněte v dialogovém okně Uspořádat okna políčko Okna aktivního sešitu.

Začátek stránky

Úprava nastavení listu a formátování buněk

V aplikaci Excel je několik nastavení, které lze změnit a usnadnit tak ruční zadávání dat. Některé změny ovlivní všechny sešity, některé ovlivní celý list a některé ovlivní pouze určené buňky.

Změna směru pro klávesu Enter

Pokud stisknete klávesu Tab pro zadání dat do několika buněk v řádku a potom na konci daného řádku stisknete klávesu Enter, posune se ve výchozím nastavení výběr na začátek dalšího řádku.

Ve výchozím nastavení posunete stisknutím klávesy Enter výběr o jednu buňku dolů a stisknutím klávesy Tab o jednu buňku doprava. Směr posunu u klávesy Tab nelze změnit, ale je možné zadat jiný směr u klávesy Enter. Změna tohoto nastavení ovlivní celý list, veškeré další otevřené listy, veškeré další otevřené sešity a všechny nové sešity.

  1. Na kartě Soubor klikněte na položku Možnosti.

  2. V kategorii Upřesnit zaškrtněte v části Možnosti úprav políčko Po stisknutí klávesy Enter přesunout výběr a pak v rozevíracím seznamu Směr klikněte na požadovaný směr.

Změna šířky sloupce

Buňky v některých případech může zobrazit #. Tato situace může nastat, jestliže buňka obsahuje číslo nebo datum a jeho sloupec nelze zobrazit všechny znaky, které vyžaduje jeho formátu. Předpokládejme například, že buňka v datovém formátu "dd/mm/rrrr" obsahuje 31/12/2015. Sloupec je však pouze dostatečně široký k zobrazení šest znaků. Buňka se zobrazí #. Chcete-li zobrazit celý obsah buňky s jeho aktuální formát, nutné zvětšit šířku sloupce.

  1. Klikněte na buňku, pro kterou chcete změnit šířku sloupce.

  2. Na kartě Domů klikněte ve skupině Buňky na tlačítko Formát.

    Skupina Buňky na kartě Domů

  3. V oddílu Velikost buněk proveďte jednu z následujících akcí:

    • Chcete-li přizpůsobit šířku buňky jejímu obsahu, klikněte na příkaz Přizpůsobit šířku sloupců.

    • Chcete-li zadat větší šířku sloupce, klikněte na příkaz Šířka sloupců a potom zadejte požadovanou šířku do pole Šířka sloupce.

Poznámka   Jako alternativu ke zvětšení šířky sloupce můžete změnit formát sloupce nebo dokonce i samostatné buňky. Můžete například změnit formát data tak, že se datum zobrazuje pouze jako den a měsíc (formát „dd.mm.“), například 31.12., nebo se číslo může zobrazovat ve vědeckém (exponenciálním) formátu, například jako 4E+08.

Zalomení textu v buňce

Nastavením možnosti pro zalomení textu můžete text v buňce zobrazit na více řádcích. Zalomení textu v buňce nemá vliv na jiné buňky.

  1. Klikněte na buňku, ve které chcete zalomit text.

  2. Na kartě Domů klikněte ve skupině Zarovnání na položku Zalamovat text.

Skupina Zarovnání na kartě Domů

Poznámka   Pokud se text nachází dlouhé slovo, nedojde k zalomení znaků (slovo se rozdělí); Místo toho můžete rozšířit sloupec nebo zmenšit velikost písma, chcete-li zobrazit celý text. Pokud po zalomení textu, není zobrazen celý text, bude pravděpodobně nutné upravit výšku řádku. Na kartě Domů ve skupině buňky klepněte na tlačítko Formát a v oddílu Velikost buňky klepněte na příkaz Přizpůsobit řádku.

Tip    Další informace o zalamování textu naleznete v článku Zalomení textu v buňce.

Změna formátu čísla

V aplikaci Excel je formát buňky nezávislý na datech, která sou v ní uložena. Tento rozdíl zobrazení může mít významný vliv, pokud se jedná o číselná data. Pokud je například zadávané číslo zaokrouhlené, je obvykle zobrazeno pouze zobrazené číslo. Výpočty s tímto číslem používají skutečnou hodnotu čísla uloženou v buňce, nikoliv zobrazené formátované číslo. Výpočty se tedy mohou zobrazovat nepřesně z důvodu zaokrouhlení v jedné nebo více buňkách.

Po zadání čísel do buňky můžete změnit formát, ve kterém jsou zobrazena.

  1. Klikněte na buňku s čísly, která chcete naformátovat.

  2. Na kartě Domů klikněte ve skupině Číslo na šipku vedle pole Formát čísla a potom klikněte na požadovaný formát.

    Pole Formát čísla na kartě Domů

    Tip   Pokud chcete vybrat číselný formát v seznamu dostupných formátů, klikněte na Další číselné formáty a potom v seznamu Druh klikněte na požadovaný formát.

Naformátování čísla jako textu

Čísla, která v aplikaci Excel nemají sloužit k výpočtům (například telefonní čísla), můžete naformátovat jako text tak, že před zadáním čísel naformátujete prázdné buňky pomocí možnosti Text.

  1. Vyberte prázdnou buňku.

  2. Na kartě Domů klikněte ve skupině Číslo na šipku vedle pole Formát čísla a potom klikněte na položku Text.

    Pole Formát čísla na kartě Domů

  3. Do naformátované buňky zadejte požadovaná čísla.

    Poznámka    Čísla zadaná do buněk před použitím formátu Text je třeba znovu zadat do naformátovaných buněk. Čísla můžete znovu zadat jako text tak, že postupně vyberete každou buňku, stisknete klávesu F2 a potom klávesu Enter.

Začátek stránky

Poznámka   Právní omezení strojového překladu: Tento článek byl přeložen počítačovým systémem bez lidského zásahu. Společnost Microsoft nabízí tyto strojový překlad pomoci cizí řeči uživatelům využívat obsah o produktech, službách a technologiích. Vzhledem k tomu, že článek byl strojově přeložených, mohou obsahovat chyby syntaktické slovní zásobu a gramatiku.

Použít na: Excel 2016 Preview, Excel 2013



Byly tyto informace užitečné?

Ano Ne

Jak ji můžeme vylepšit?

255 zbývajících znaků

Pokud si chcete chránit soukromí, nedávejte do zpětné vazby kontaktní informace. Ohodnoťte aplikaci zásady ochrany osobních údajů.

Děkujeme vám za zpětnou vazbu.

Zdroje technické podpory

Změnit jazyk