Rezervace souboru v knihovně aplikace SharePoint a vrácení souboru se změnami

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Rezervací souboru z knihovny na webu služby Microsoft Windows SharePoint Services zajistíte, že v průběhu vašich úprav nemůže soubor upravit žádný jiný uživatel. V průběhu rezervace můžete soubor upravit, zavřít, znovu otevřít a dokonce s ním pracovat na místním disku. Ostatní uživatelé nemohou soubor upravit nebo dokonce vidět vaše změny, dokud soubor nevrátíte zpět.

V tomto článku:

Základní informace

Rezervovat soubor z knihovny Sharepointu

Rezervaci souboru do knihovny služby SharePoint

Změna umístění kterém pracovat na souborech rezervované

Přehled

Pokud před tím, než začnete se soubory pracovat, provedete jejich rezervaci, předejdete konfliktům a nedorozuměním v případech, kdy na stejné sadě souborů pracuje několik uživatelů. Pokud soubor rezervujete pro sebe, můžete jej měnit pouze vy. Na webu SharePoint můžete rezervovat jakýkoli soubor, ke kterému máte oprávnění. Soubory lze rezervovat přímo z následujících aplikací sady Microsoft Office 2007: Word, Excel, PowerPoint a Visio.

Při vracení souboru můžete zadat poznámky, které popisují změny provedené v souboru. To umožňuje uživatelům pochopit, co se v souboru mezi jednotlivými verzemi změnilo. Tyto informace jsou zejména užitečné v případě, že se souborem pracuje několik uživatelů nebo soubor pravděpodobně projde několika revizemi. Pokud jsou ve vaší knihovně sledovány verze souborů, vaše poznámky budou uloženy do historie verzí souboru. Poznámky jsou užitečné pro uživatele, kteří potřebují prohlédnout nebo obnovit předchozí verzi souboru.

Vaše společnost může vyžadovat, abyste soubor před úpravami rezervovali. Je-li rezervace povinná, musíte před vytvořením souboru v knihovně nebo jeho uložením do knihovny provést operaci vrácení zpět.

V průběhu rezervace souboru nejsou změny, které provádíte, viditelné pro ostatní uživatele. Změny budou k dispozici až po vrácení souboru. Jsou však případy, kdy chcete soubor vrátit, aby ostatní uživatelé viděli vaše změny, ale chcete si ponechat soubor rezervovaný a pokračovat v práci. Když soubor vrátíte zpět, můžete se rozhodnout pokračovat v práci na souboru. Výjimkou je případ, kdy vaše knihovna sleduje hlavní a dílčí verze a vy vrátíte hlavní verzi. Hlavní verze většinou obsahuje výrazné změny od předchozí verze, zatímco vedlejší verze se od sebe liší pouze nepatrně. Hlavní verze například může obsahovat velké množství nového obsahu, zatímco dílčí verze obsahuje pouze opravy v pravopisu.

Pokud soubor na webu Windows SharePoint Services 3.0 rezervujete použitím aplikace sady Office, soubor je ve výchozím nastavení uložený na místním pevném disku do složky konceptů, která se nachází ve složce Dokumenty. Toto umístění můžete přesměrovat na jinou složku na pevném disku nebo na síti, případně můžete určit, aby byly rezervované soubory, na kterých pracujete, ukládány na webový server. Podle požadavků vaší organizace může správce určit vlastní umístění nebo úpravy výchozího umístění zcela zakázat.

Po rezervaci souboru z webu služby Microsoft Windows SharePoint Services 2.0 je soubor po celou dobu vaší práce uložený na serveru, nicméně změny budou ostatním uživatelům k dispozici až po vrácení souboru zpět. Ve většině případů se po rezervaci souboru z webu Windows SharePoint Services 3.0 zobrazí zpráva s informacemi, kam je soubor po rezervaci uložený. Tato zpráva se nezobrazí, pokud rezervujete soubor z webu služby Windows SharePoint Services 2.0.

Když je soubor rezervovaný, podokno úloh Správa dokumentů v aplikaci Office obsahuje příkaz pro vrácení souboru zpět.

Pokud sledujete hlavní i dílčí verze souborů, zobrazí se dotaz, zda vracíte zpět hlavní nebo vedlejší verzi souboru.

Začátek stránky

Rezervace souboru z knihovny aplikace SharePoint

Následující postup slouží k rezervaci souboru, který je již otevřený v některé aplikaci sady Office. Soubor můžete také rezervovat z knihovny na webu SharePoint.

V aplikacích sady Office 2007 postupujte takto:

Aplikace Word, Excel a PowerPoint

  1. Klikněte na Tlačítko Microsoft Office Obrázek tlačítka , klepněte na Server a potom klikněte na Rezervovat.

    Dokumenty Word se často ve výchozím nastavení otvírají v zobrazení přes celou obrazovku. Je-li to váš případ, může být zapotřebí před provedením tohoto kroku klepnout na tlačítko Náhled a přepnout do zobrazení náhledu.

  2. Pokud se zobrazí zpráva s informacemi, kde je soubor při rezervaci uložený, klepněte na tlačítko OK.

    Ve většině případů se tato zpráva zobrazí v okamžiku, kdy provádíte rezervaci souboru z webu Windows SharePoint Services 3.0.

    Tip : V dialogovém okně se zprávou, která popisuje cílové místo uložení rezervovaného souboru, můžete upravit možnosti pro práci s rezervovanými soubory.

Aplikace Visio

  1. V nabídce Soubor klepněte na příkaz Rezervovat.

  2. Pokud se zobrazí zpráva s informacemi, kde je soubor při rezervaci uložený, klepněte na tlačítko OK.

    Ve většině případů se tato zpráva zobrazí v okamžiku, kdy provádíte rezervaci souboru z webu Windows SharePoint Services 3.0.

    Tip : V dialogovém okně se zprávou, která popisuje cílové místo uložení rezervovaného souboru, můžete upravit možnosti pro práci s rezervovanými soubory.

Začátek stránky

Vrácení souboru se změnami do knihovny aplikace SharePoint

Následující postup slouží k vrácení souboru, který je již otevřený v některé aplikaci sady Office. Soubor můžete také vrátit z knihovny na webu SharePoint.

V aplikacích sady Office 2007 postupujte takto:

Aplikace Word, Excel a PowerPoint

  1. Klikněte na Tlačítko Microsoft Office Obrázek tlačítka , klepněte na Server a potom klikněte na Vrátit se změnami.

    Dokumenty Word se často ve výchozím nastavení otvírají v zobrazení přes celou obrazovku. Je-li to váš případ, může být zapotřebí před provedením tohoto kroku klepnout na tlačítko Náhled a přepnout do zobrazení náhledu.

  2. Pokud se zobrazí dotaz, zda chcete vrátit hlavní nebo dílčí verzi souboru, klepněte na přepínač Dílčí verze, pokud jste provedli dílčí změny, a na přepínač Hlavní verze, pokud dokument obsahuje zásadní úpravy.

  3. Do pole Komentář k verzi zadejte poznámky, které chcete uvést k provedeným změnám.

    Tyto poznámky se stanou součástí historie verzí souboru v knihovně aplikace SharePoint a budou užitečné pro všechny uživatele, kteří budou potřebovat zobrazit údaje o předchozích verzích.

  4. Pokud chcete po vrácení na souboru dále pracovat, zaškrtněte políčko Chcete po vrácení změn uložených v dokumentu ponechat dokument rezervovaný? (je-li k dispozici).

    Políčko je dostupné v případě, že v knihovně není zapnuto sledování verzí, že všechny verze jsou sledovány stejným způsobem nebo když vracíte dílčí verzi. Políčko není k dispozici, pokud vracíte hlavní verzi nebo soubor publikujete.

Aplikace Visio

  1. V nabídce Soubor klepněte na příkaz Vrátit se změnami.

  2. Pokud se zobrazí dotaz, zda chcete vrátit hlavní nebo dílčí verzi, klepněte na přepínač Dílčí verze, pokud jste provedli malé změny, a na přepínač Hlavní verze, jestliže soubor obsahuje rozsáhlé změny.

  3. Do pole Komentář k verzi zadejte poznámky, které chcete uvést k provedeným změnám.

    Tyto poznámky se stanou součástí historie verzí souboru v knihovně aplikace SharePoint a budou užitečné pro všechny uživatele, kteří budou potřebovat zobrazit údaje o předchozích verzích.

  4. Pokud chcete po vrácení na souboru dále pracovat, zaškrtněte políčko Chcete po vrácení změn uložených v dokumentu ponechat dokument rezervovaný? (je-li k dispozici).

    Políčko je dostupné v případě, že v knihovně není zapnuto sledování verzí, že všechny verze jsou sledovány stejným způsobem nebo když vracíte dílčí verzi. Políčko není k dispozici, pokud vracíte hlavní verzi nebo soubor publikujete.

Začátek stránky

Změna pracovní složky pro rezervované soubory

Tímto nastavením lze změnit umístění, ve kterém budete pracovat s dalším rezervovaným souborem. Nové nastavení se neuplatní pro rezervovaný soubor, se kterým aktuálně pracujete.

V aplikacích sady Office 2007 postupujte takto:

Aplikace Word, Excel a PowerPoint

  1. Klikněte na Tlačítko Microsoft Office Obrázek tlačítka a klikněte na požadované možnosti pro váš program: Možnosti aplikace Word, Možnosti aplikace Excel nebo Možnosti aplikace PowerPoint.

  2. V zobrazeném dialogovém okně klepněte na tlačítko Uložit.

  3. Ve skupinovém rámečku Možnosti offline úprav pro soubory serveru správy dokumentů proveďte některou z následujících akcí:

    • Chcete-li pracovat s rezervovanými souboru na pevném disku nebo v síťovém umístění, postupujte takto:

      1. V části Umístění pro ukládání rezervovaných souboru klepněte na položku Umístění serverových konceptů v tomto počítači.

      2. Do pole Umístění serverových konceptů zadejte umístění na místním pevném disku, ve kterém chcete pracovat s rezervovanými soubory, nebo klepněte na tlačítko Procházet a složku vyhledejte.

    • Chcete-li pracovat s rezervovanými soubory na webovém serveru, klepněte ve skupinovém rámečku Umístění pro ukládání rezervovaných souborů na přepínač Webový server.

      Po výběru tohoto přepínače budete pracovat s rezervovanými soubory na webovém serveru nebo na webu, kde jsou soubory uloženy. Umístění souborů můžete změnit.

  4. Klepněte na tlačítko OK.

Aplikace Visio

  1. V nabídce Nástroje klepněte na příkaz Možnosti.

  2. V dialogovém okně Možnosti klepněte na kartu Obecné a pak klepněte na tlačítko Možnosti služby.

  3. V zobrazeném dialogovém okně klepněte na položku Možnosti offline úprav.

  4. Ve skupinovém rámečku Možnosti offline úprav pro soubory serveru správy dokumentů proveďte některou z následujících akcí:

    • Chcete-li pracovat s rezervovanými soubor na pevném disku nebo v síťovém umístění, postupujte podle následujících pokynů:

      1. Jestliže chcete pracovat s rezervovanými soubory na pevném disku, klepněte v části Umístění pro ukládání rezervovaných souborů na položku Umístění serverových konceptů v tomto počítači.

      2. Do pole Umístění serverových konceptů zadejte umístění na místním pevném disku, ve kterém chcete pracovat s rezervovanými soubory, nebo klepněte na tlačítko Procházet a složku vyhledejte.

    • Chcete-li pracovat s rezervovanými soubory na serveru, klepněte ve skupinovém rámečku Umístění pro ukládání rezervovaných souborů na přepínač Webový server.

      Po výběru tohoto přepínače budete pracovat s rezervovanými soubory na webovém serveru nebo na webu, kde jsou soubory uloženy. Umístění souborů můžete změnit.

  5. Klepněte na tlačítko OK.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Sdílení Facebook Facebook Twitter Twitter E-mail E-mail

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×