Replikovanou databázi nelze uložit ve formátu aplikace Access 2007

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Příznaky

V Microsoft Office Access 2007 replikace databáze, které byly vytvořeny v předchozích verzích aplikace Access (. Formát MDB) nelze uložit v nové. Formát souborů ACCDB. Možnost zobrazuje šedě (jako nedostupná) při pokusu o pomocí příkazu Uložit databázi jako (klikněte na Tlačítko Microsoft Office Obrázek tlačítka Office a potom klikněte na šipku vedle Uložit jako ).

Příčina

Formát souboru ACCDB nepodporuje replikaci.

Řešení

Použití replikované databáze ve formátu MDB

Replikovanou databázi ve formátu MDB lze nadále používat. Funkce replikace je ve formátu MDB i nadále podporována,

Ruční vytvoření nové databáze ve formátu souboru aplikace Office Access 2007

Pokud usoudíte, že výhody nového formátu souboru převažují nad výhodami, které byste získali replikací, lze vytvořit novou databázi ve formátu aplikace Office Access 2007 a replikovanou databázi znovu vytvořit ručně.

Poznámka : Tento způsob je funkční u všech replikovaných databází, ale pokud nepracujete s úplnou replikou, která byla synchronizována se všemi ostatními replikami v sadě replik, nebude nová databáze obsahovat žádná data a projekty, které dosud nejsou v replice.

Než začnete databázi znovu vytvářet, měli byste zkontrolovat, zda jsou v replice viditelné všechny skryté a systémové objekty. Tím zajistíte přístup k určitým polím specifickým pouze pro danou repliku po jejím opětovném vytvoření.

  1. Otevřete repliku, kterou chcete převést. Repliku je nutné otevřít ve stejné verzi aplikace Access, která byla použita při jejím původním vytvoření, aby se zobrazila skrytá a systémová pole.

  2. V nabídce Nástroje klepněte na příkaz Možnosti. Zobrazí se dialogové okno Možnosti.

  3. Zaškrtněte na kartě Zobrazení v části Zobrazit políčka Skryté objekty a Systémové objekty. Klepnutím na tlačítko OK použijte nové nastavení a zavřete dialogové okno Možnosti.

Nové ruční vytvoření databáze

  1. Vytvořte prázdnou databázi a otevřete ji.

    Poznámka : Aplikace Access vytvoří novou prázdnou tabulku s názvem Table1. Tuto tabulku byste měli odstranit – to lze provést jejím okamžitým zavřením dříve, než v ní provedete jakékoli změny. Klepněte pravým tlačítkem myši na její kartu objektu a poté v místní nabídce klepněte na příkaz Zavřít.

  2. Na kartě Externí data klepněte ve skupině Importovat na položku Access.

    Zobrazí se dialogové okno Načíst externí data - Databáze aplikace Access.

  3. Klepněte na tlačítko Procházet a vyhledejte replikovanou databázi.

  4. Klepněte na replikovanou databázi obsahující databázové objekty, které chcete znovu vytvořit v nové databázi, a potom klepněte na tlačítko Otevřít.

  5. V dialogovém okně Načíst externí data - Databáze aplikace Access klepněte na přepínač Importovat tabulky, dotazy, formuláře, makra a moduly do aktuální databáze a potom na tlačítko OK.

  6. Klepněte na objekty databáze, které chcete importovat do nové databáze. Pokud chcete importovat všechny objekty, klepněte na každé kartě na tlačítko Vybrat vše.

    Důležité:    Nevybírejte v tuto chvíli žádné tabulky. Tabulky budete znovu vytvářet později.

  7. Po dokončení výběru importujte objekty klepnutím na tlačítko OK.

    Na poslední stránce průvodce máte možnost uložit kroky importu pro budoucí použití. Chcete-li to provést, zaškrtněte políčko Uložit kroky importu, zadejte příslušné údaje a klepněte na tlačítko Uložit import.

  8. Otevřete replikovanou databázi v aplikaci Office Access 2007. Pro každou tabulku v replikované databázi vytvořte vytvářecí dotaz, který přebere všechna data ze staré tabulky a v nové databázi vytvoří novou tabulku se stejnými daty.

    Poznámka : Pokud s_GUID je primární klíč (a cizích klíčů v jiných tabulkách odkazují), měli byste pole s_GUID zahrnout do nové tabulky. Pokud pole s_GUID není použit jako primární klíč, není důvod uchovávat v nové tabulce. Pole s_Lineage a s_Generation nechcete kopírovat do nové tabulky.

    Ve výchozím nastavení jsou pole s_GUID, s_Lineage a s_Generation skrytá. Chcete-li tato pole zobrazit, postupujte následujícím způsobem:

    1. Zkontrolujte, zda jsou v replikované databázi všechny tabulky zavřené.

    2. Klepněte pravým tlačítkem myši v horní části navigačního podokna a poté klepněte na příkaz Možnosti navigace. Zobrazí se dialogové okno Možnosti navigace.

    3. Zaškrtněte v části Možnosti zobrazení políčko Zobrazit systémové objekty a klepněte na tlačítko OK.

      Jak toho docílit?

      1. Vytvořte dotaz a vyberte tabulky obsahující záznamy, jež chcete vložit do nové tabulky.

        Jak toho docílit?

        1. Ve skupině Jiné na kartě Vytvořit klikněte na Návrh dotazu.

        2. V dialogovém okně Zobrazit tabulku klepněte na kartu, která obsahuje seznam tabulek, se kterými chcete pracovat.

        3. Poklepejte na název každého objektu, který chcete přidat do dotazu, a potom klepněte na tlačítko Zavřít.

        4. Přidejte pole do řádku Pole v Návrhová mřížka.

        5. Klepnutím na příkaz Zobrazení datového listu v nabídce Zobrazit zobrazte výsledky dotazu.

      2. V Návrhové zobrazení dotazu klepněte na kartě Návrh na tlačítko Vytvořit tabulku ve skupině Typ dotazu. Zobrazí se dialogové okno Vytvořit tabulku.

      3. Do pole Název tabulky zadejte název tabulky, kterou chcete vytvořit nebo nahradit.

      4. Klepněte na přepínač Jiná databáze a poté buď zadejte cestu k databázi, do které chcete umístit novou tabulku, nebo určete požadovanou databázi klepnutím na tlačítko Procházet.

      5. Klepněte na tlačítko OK.

      6. Na kartě Návrh ve skupině výsledky na příkaz Spustit. Bude k vytvoření nové tabulky.

        Poznámka : Nově vytvořená tabulka nedědí vlastnosti polí ani nastavení Primární klíč z původní tabulky.

  9. Pro každou tabulku v nové databázi vytvořte stejný Index a primární klíč, který byl použit v tabulce repliky.

    Jak toho docílit?

    1. Otevřete tabulku v návrhovém zobrazení.

    2. V horní části okna klepněte na pole, pro které chcete vytvořit Index.

    3. V dolní části okna klepněte do pole vlastnosti Indexovat a poté klepněte na položku Ano (duplicita povolena) nebo Ano (bez duplicity).

    4. Vyberte pole, které obsahuje (obsahují) primární klíč.

    5. Na kartě Návrh klikněte ve skupině Nástroje na Primární klíč.

  10. Pro každou tabulku v nové databázi vytvořte relace, která existují pro tabulky otevřené.

    Jak toho docílit?

    Vytvoření relace mezi tabulkami souvisejících polí nemusíte mít stejný název. Však související pole musí mít stejný Datový typ není-li pole primárním klíčem pole typu Automatické číslo. Pole typu Automatické číslo s polem Číslo můžete porovnat jenom v případě, že vlastnost Velikost pole obou odpovídající pole je stejný. Můžete třeba párování poli typu Automatické číslo a u pole číslo, pokud je vlastnost Velikost pole obou polí Dlouhé celé číslo. I když jsou oba odpovídající pole typu číslo, musí mít stejný nastavení vlastnosti Velikost pole.

    Definování-n nebo relaci

    1. Zavřete všechny otevřené tabulky. Relaci mezi otevřenými tabulkami nelze vytvořit ani upravit.

    2. Na kartě Databázové nástroje klikněte ve skupině Zobrazit či skrýt na Relace.

    3. Pokud jste ještě v databázi nedefinovali žádné relace, zobrazí se automaticky dialogové okno Zobrazit tabulku.

      Potřebujete-li přidat tabulky, mezi kterými má být relace vytvořena, a dialogové okno Zobrazit tabulku není zobrazeno, je nutné jej vyvolat: Na kartě Návrh klepněte ve skupině Zobrazit či skrýt na tlačítko Zobrazit tabulku.

    4. Poklepejte na názvy požadovaných tabulek a poté zavřete dialogové okno Zobrazit tabulku. Chcete-li vytvořit relaci v rámci téže tabulky, přidejte tuto tabulku dvakrát.

    5. Přetáhněte požadované pole z jedné tabulky na související pole v druhé tabulce.

      Chcete-li přetáhnout více polí zároveň, stiskněte a podržte klávesu CTRL a postupně klepněte na všechna požadovaná pole. Poté je přetáhněte.

      Většinou se k vytvoření relace používá pole primárního klíče (zobrazené tučně) z jedné tabulky a podobné pole (často se shodným názvem) z druhé tabulky. Pole z druhé tabulky se označuje jako Cizí klíč.

    6. Zobrazí se dialogové okno Upravit relace. Zkontrolujte názvy polí zobrazené v obou sloupcích. V případě potřeby proveďte požadované změny.

      V případě potřeby nastavte možnosti relace.

    7. Klepnutím na tlačítko Vytvořit potvrďte vytvoření relace.

    8. Kroky 4 až 7 zopakujte pro každou dvojici tabulek, které mají být v relaci.

      Při zavření Okno Relace se zobrazí dotaz, zda chcete uložit nové rozložení. Vytvořené relace jako takové jsou však uloženy vždy, bez ohledu na odpověď.

    Definování vztahu n: n

    1. Vytvořte dvě tabulky, mezi nimiž chcete definovat Relace N.

    2. Vytvořte třetí (tzv. spojovací) tabulku. Do této spojovací tabulky přidejte nová pole, jejichž definice je shodná s definicí polí primárních klíčů obou spojovaných tabulek. Pole primárních klíčů přebírají ve spojovací tabulce funkci cizích klíčů. V případě potřeby můžete do spojovací tabulky přidat i další pole, stejně jako u jakékoli jiné tabulky.

    3. Primární klíč spojovací tabulky nastavte tak, aby obsahoval všechna pole primárních klíčů spojovaných tabulek. Například ve spojovací tabulce Rozpis objednávek by primární klíč obsahoval pole ČísloObjednávky a ČísloVýrobku.

      Jak toho docílit?

      1. Otevřete tabulku v návrhovém zobrazení.

      2. Vyberte jedno nebo více polí, která chcete použít k definici primárního klíče.

        Chcete-li vybrat samostatné pole, klepněte na jeho Volič řádku.

        Chcete-li vybrat několik polí, stiskněte a podržte klávesu CTRL a poté klepněte na odpovídající voliče řádků.

      3. Na kartě Návrh klikněte ve skupině Nástroje na Primární klíč.

        Poznámka : Chcete-li, aby pořadí polí v primárním klíči tvořeném více poli bylo jiné, než je pořadí těchto polí v tabulce, klepněte na tlačítko Indexy ve skupině Nástroje. Zobrazí se Okno Indexy a v něm změňte pořadí názvů polí pro Index s názvem PrimaryKey.

    4. Definování Relace 1:N mezi každé dvě primární tabulky a spojená tabulka.

  11. Uložte novou databázi.

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×