Publikování sešitu na SharePointovém webu v Excelu pro Windows

Sešit můžete publikovat do knihovny Microsoft SharePointu, aby ho uživatelé mohli zobrazit nebo upravovat ve webovém prohlížeči, aniž by museli mít na svém počítači nainstalovaný Excel. Publikování je v podstatě stejné jako ukládání, ale liší se v tom, že při něm můžete pomocí některých předdefinovaných možností určit, co uživatelé uvidí, když si sešit otevřou v prohlížeči.

Zavedení praxe ukládání nebo publikování sešitu na centrální sharepointový web pro celou organizaci může zajistit, aby po organizaci nekolovaly různé verze stejného sešitu, což se může stát, když se sešit rozesílá e-mailem.

Nastavením některých možností publikování můžete zvýraznit určité části sešitu, třeba grafy, a jiné části můžete skrýt, aby se nedaly zobrazit v prohlížeči. Můžete třeba nastavit, aby se zobrazil graf, ale ne jeho pokladová data. Můžete taky určit, že některé listy se mají zobrazit určitým lidem a ostatní listy se mají skrýt.

V tomto článku se dozvíte, jak publikovat sešit z Excelu pro Windows a že se nezabývá připojení dat sešitu nebo sešitu k webové části Excel Web Access na SharePointové stránce.

Když publikujete sešit na sharepointovém webu, uloží se na SharePoint celý sešit. Uživatel, který má požadovaná oprávnění SharePointu, si celý sešit může prohlédnout nebo s ním pracovat buď v prohlížeči, nebo v desktopové aplikaci Excel.

Pokud je na SharePointu nasazený Office pro web, můžete svoje data zobrazit a pracovat s nimi v prohlížeči podobným způsobem jako v desktopové verzi Excelu. Výhodou oproti desktopové verzi Excelu je to, že v prohlížeči může sešit zároveň upravovat víc uživatelů. Když máte sešit otevřený v prohlížeči a vidíte tam tlačítko Upravit v aplikaci Excel Online, znamená to, že můžete použít Office pro web.

Příkaz Upravit v Excelu Online v nabídce Upravit sešit

Příprava sešitu

Před publikováním sešitu můžete vybrat ty listy nebo prvky, které mají se mají zobrazovat v prohlížeči. Pamatujte ale na to, že sice můžete vybrat, co bude viditelné v tomto režimu, ale na server SharePointu se vždycky uloží celý obsah sešitu.

Pokud chcete zahrnout celý sešit jako položku společně s dalšími položkami, jako jsou grafy nebo kontingenční tabulky, nadefinujte celý sešit jako pojmenovanou oblast. Vyberte celý sešit a potom definujte pojmenovanou oblast. Tato pojmenovaná oblast se zobrazí jako dostupná položka v dialogovém okně Možnosti publikování, jakmile budete připraveni k publikování.

Pokud chcete uživatelům umožnit zadat do buňky hodnotu, aby mohli pracovat se vzorcem v jiné buňce, nastavte v Excelu před publikováním sešitu danou buňku jako definovaný název. Tento definovaný název pak můžete přidat jako parametr na kartě Parametry v dialogovém okně Možnosti zobrazení prohlížeče.

Na následujícím obrázku je třeba buňka D2, která má definovaný název Sazba. Uživatel v prohlížeči zadal hodnotu 5,625 do pole Sazba v podokně Parametry a potom kliknul na tlačítko Použít. Tato hodnota se následně zobrazí v buňce D2 a použije ji vzorec v buňce A2. Výsledek vzorce se přepočítá a zobrazí v buňce A2: 1 151,31 Kč.

Zadání parametru v podokně – použití v buňce D2

Poznámka: Když vytvoříte průřezy pro excelovou tabulku a definujete název pro oblast buněk obsahující tabulku a průřezy, nebudete moct použít průřezy k filtrování tabulky v prohlížeči, pokud publikujete definovanou oblast. Pokud publikujete tabulku nebo celý list nebo jeho sešit, průřezy budou v prohlížeči fungovat podle očekávání.

Publikování sešitu

  1. Na kartě Soubor klikněte na Uložit jako a potom na SharePoint.

  2. Pokud se vaše složka SharePointu zobrazuje v části aktuální, Poslednínebo starší, klikněte na požadovanou složku.

    Zobrazí se dialogové okno Uložit jako.


    V opačném případě klikněte na Procházet, zadejte webovou adresu sharepointového webu a pak přejděte do složky, ve které chcete sešit publikovat.

    Klikněte na složku služby SharePoint nebo na Procházet.
  3. Pokud chcete k publikování vybrat jednotlivé listy nebo položky v sešitu, klikněte na Možnosti zobrazení prohlížeče.

    V dialogu Uložit jako klikněte na Možnosti zobrazení prohlížeče

    Zobrazí se karta Zobrazit a karta Parametry.

  4. Pokud chcete publikovat celý sešit, klikněte na Uložit. Jinak udělejte některou z těchto věcí:

    • Pokud chcete v prohlížeči zobrazit celý sešit, vyberte na kartě Zobrazit ze seznamu možnost Celý sešit.

    • Pokud chcete v prohlížeči zobrazit jenom některé listy, vyberte na kartě Zobrazit ze seznamu možnost Listy a potom zrušte zaškrtnutí políček u listů, které nechcete v prohlížeči skrýt.

      Ve výchozím nastavení jsou vybrané všechny listy. Pokud chcete po zrušení zaškrtnutí některých políček znovu rychle zobrazit všechny listy, zaškrtněte políčko Všechny listy.

    • Pokud chcete v prohlížeči zobrazit jenom některé položky (například pojmenované oblasti, grafy, tabulky nebo kontingenční tabulky), vyberte na kartě Zobrazit ze seznamu možnost Položky v sešitu a potom zaškrtněte políčka u položek, které chcete zobrazit.

    • Na kartě Parametry přidejte libovolné definované názvy, které chcete použít k určení buněk, které uživatelé můžou upravovat při zobrazení sešitu v prohlížeči. Potom dialogové okno zavřete kliknutím na OK.

  5. Uložte sešit.

Poznámky: 

  • Pokud vyberete položky, které mají stejný název (třeba graf a tabulku s jeho podkladovými daty), v prohlížeči bude dostupná jenom jedna z těchto položek. Pokud chcete zobrazit všechny položky, zajistěte, aby všechny položky v sešitu měly jedinečné názvy.

  • Tabulky můžete přejmenovat na kartě Návrh ve skupině Vlastnosti, kontingenční tabulky můžete přejmenovat na kartě Možnosti ve skupině Kontingenční tabulka a grafy nebo kontingenční grafy můžete přejmenovat na kartě Rozložení ve skupině Vlastnosti. Jiné duplicitní položky, například pojmenované oblasti, můžete přejmenovat na kartě Vzorce ve skupině Definované názvy.

Pokud je na SharePointu nasazený Office pro web, můžete svoje data zobrazit a pracovat s nimi v prohlížeči podobným způsobem jako v desktopové verzi Excelu. Výhodou oproti desktopové verzi Excelu je to, že v prohlížeči může sešit zároveň upravovat víc uživatelů. Když máte sešit otevřený v prohlížeči a vidíte tam tlačítko Upravit v aplikaci Excel Online, znamená to, že můžete použít Office pro web.

Příkaz Upravit v Excelu Online v nabídce Upravit sešit

Další informace najdete v článku rozdíly mezi používáním sešitu v Excelu a ve službách Excel Services.

Příprava sešitu

Před publikováním sešitu můžete vybrat ty listy nebo prvky, které mají se mají zobrazovat v prohlížeči. Pamatujte ale na to, že sice můžete vybrat, co bude viditelné v tomto režimu, ale na server SharePointu se vždycky uloží celý obsah sešitu.

Pokud chcete zahrnout celý sešit jako položku společně s dalšími položkami, jako jsou grafy nebo kontingenční tabulky, nadefinujte celý sešit jako pojmenovanou oblast. Vyberte celý sešit a potom definujte pojmenovanou oblast. Tato pojmenovaná oblast se zobrazí jako dostupná položka v dialogovém okně Možnosti publikování, jakmile budete připraveni k publikování.

Pokud chcete uživatelům umožnit zadat do buňky hodnotu, aby mohli pracovat se vzorcem v jiné buňce, nastavte v Excelu před publikováním sešitu danou buňku jako definovaný název. Tento definovaný název pak můžete přidat jako parametr na kartě Parametry v dialogovém okně Možnosti zobrazení prohlížeče.

Na následujícím obrázku je třeba buňka D2, která má definovaný název Sazba. V prohlížeči zadá uživatel hodnotu 5,625, do pole v podokně parametry a na použít. Tato hodnota se následně zobrazí v buňce D2 a použije ji vzorec v buňce A2. Výsledek vzorce se přepočítá a zobrazí v buňce A2: 1 151,31 Kč.

Informace o tom, jak definovat rozsahy, najdete v nápovědě k Excelu.

Zadání parametru v podokně – použití v buňce D2

Poznámka: Když vytvoříte průřezy pro excelovou tabulku a definujete název pro oblast buněk obsahující tabulku a průřezy, nebudete moct použít průřezy k filtrování tabulky v prohlížeči, pokud publikujete definovanou oblast. Pokud publikujete tabulku nebo celý list nebo jeho sešit, průřezy budou v prohlížeči fungovat podle očekávání.

Publikování sešitu

  1. Klikněte na soubor > Uložit jako >SharePoint.

  2. Pokud máte složku SharePointu v částiaktuální složka nebo poslední složky, klikněte na požadovanou složku. Jinak klikněte na Procházet a zadejte webovou adresu sharepointového webu. Pak přejděte do složky, do které chcete sešit publikovat. Zobrazí se dialogové okno Uložit jako.

  3. Pokud chcete k publikování vybrat jednotlivé listy nebo položky v sešitu, klikněte na Možnosti zobrazení prohlížeče. Zobrazí se karta Zobrazit a karta parametry . Pokud chcete publikovat celý sešit, klikněte na Uložit. Jinak udělejte některou z těchto věcí:

    • Pokud chcete v prohlížeči zobrazit celý sešit, vyberte na kartě Zobrazit ze seznamu možnost Celý sešit.

    • Pokud chcete v prohlížeči zobrazit jenom určité listy, vyberte na kartě Zobrazit v seznamu listy a potom zrušte zaškrtnutí políček u listů, které nechcete v prohlížeči skrýt.

      Ve výchozím nastavení jsou vybrané všechny listy. Pokud chcete, aby se po zrušení zaškrtnutí některých políček znovu zobrazovaly všechny listy, zaškrtněte políčko všechny listy .

    • Pokud chcete v prohlížeči zobrazit jenom určité položky (například pojmenované oblasti, grafy, tabulky nebo kontingenční tabulky), vyberte na kartě Zobrazitpoložky v sešitu v seznamu a pak zaškrtněte políčka u položek, které chcete zobrazit.

    • Na kartě parametry přidejte všechny definované názvy, které chcete použít k určení buněk, které se dají upravit, když uživatelé zobrazí sešit v prohlížeči. Potom kliknutím na OK zavřete dialogové okno.

  4. Uložte sešit.

Poznámky: 

  • Pokud vyberete položky, které mají stejný název (třeba graf a tabulku s jeho podkladovými daty), v prohlížeči bude dostupná jenom jedna z těchto položek. Pokud chcete zobrazit všechny položky, zajistěte, aby všechny položky v sešitu měly jedinečné názvy.

  • Pokud vyberete položky, které mají stejný název (třeba graf a tabulku s jeho podkladovými daty), v prohlížeči bude dostupná jenom jedna z těchto položek. Pokud chcete zobrazit všechny položky, zajistěte, aby všechny položky v sešitu měly jedinečné názvy.

  • Tabulky můžete přejmenovat na kartě Návrh ve skupině Vlastnosti, kontingenční tabulky můžete přejmenovat na kartě Možnosti ve skupině Kontingenční tabulka a grafy nebo kontingenční grafy můžete přejmenovat na kartě Rozložení ve skupině Vlastnosti. Jiné duplicitní položky, například pojmenované oblasti, můžete přejmenovat na kartě Vzorce ve skupině Definované názvy.

  • Tabulky můžete přejmenovat na kartě Návrh ve skupině Vlastnosti, kontingenční tabulky můžete přejmenovat na kartě Možnosti ve skupině Kontingenční tabulka a grafy nebo kontingenční grafy můžete přejmenovat na kartě Rozložení ve skupině Vlastnosti. Jiné duplicitní položky, například pojmenované oblasti, můžete přejmenovat na kartě Vzorce ve skupině Definované názvy.

Další informace o webových částech aplikace Excel Web Access najdete v článku zobrazení sešitu ve webové části Excel Web Access.

Při publikování sešitu na SharePointovém serveru se celý obsah sešitu uloží na server a pokud ho otevřete v desktopové aplikaci Excel, můžete ho zobrazit a pracovat s ním. Pokud jsou na SharePoint serveru nasazené Office Web Apps, může být zobrazení a práce s daty ve webovém prohlížeči velmi podobná jako práce s daty v desktopové aplikaci Excel. Ve skutečnosti se při nasazení Office Web Apps může v mřížce prohlížeče souběžně upravovat sešit. Když zobrazíte sešit v prohlížeči, pokud je zobrazené tlačítko Upravit v prohlížeči , znamená to, že Office Web Apps je dostupný.

Tlačítko Upravit v prohlížeči

Další informace najdete v článku rozdíly mezi používáním sešitu v Excelu a ve službách Excel Services.

Příprava sešitu

Před publikováním sešitu máte příležitost (v dialogovém okně Možnosti publikování ) a vyberte listy nebo položky, které chcete zobrazit v prohlížeči, pokud nebyly úpravy povolené kliknutím na tlačítko Upravit v prohlížeči . Uvědomte si, že ačkoli je možné v tomto režimu vybrat, že je celý obsah sešitu uložený na SharePoint serveru.

Pokud chcete zahrnout celý sešit jako položku společně s dalšími položkami, jako jsou grafy nebo kontingenční tabulky, nadefinujte celý sešit jako pojmenovanou oblast. Vyberte celý sešit a potom definujte pojmenovanou oblast. Tato pojmenovaná oblast se zobrazí jako dostupná položka v dialogovém okně Možnosti publikování, jakmile budete připraveni k publikování.

Pokud chcete uživatelům povolit zadání parametru vzorce při prohlížení listu v prohlížeči, nastavte buňku jako definovaný název. Tento definovaný název pak můžete přidat jako parametr na kartě parametry v dialogovém okně Možnosti publikování .

Na následujícím obrázku, který zobrazuje list v prohlížeči, má buňka D2 definovanou sazbu názvu. V prohlížeči zadal uživatel hodnotu 5,625, do pole v podokně parametry a pak klikněte na použít. Tato hodnota se následně zobrazí v buňce D2 a použije ji vzorec v buňce A2. Výsledek vzorce se přepočítá a zobrazí v buňce A2: 1 151,31 Kč.

Použití parametru v prohlížeči

Informace o tom, jak definovat rozsahy, najdete v nápovědě k Excelu.

Publikování sešitu

  1. Klikněte na kartu soubor a potom na Uložit & odeslat.

  2. Klikněte na Uložit na SharePoint.
    Poznámka:    Pokud příkaz Uložit do SharePointu není dostupný, můžete sešit uložit na web SharePointu pomocí příkazu Uložit jako . Dialogové okno Možnosti publikování nebude k dispozici. Sešit můžete taky nahrát přímo z knihovny SharePointu. Uživatelé mohou prohlížet a upravovat obsah sešitu v prohlížeči tak, že přejdete přímo na web, na kterém je sešit uložený.

    Příkaz Uložit jako

  3. Pokud chcete vybrat jednotlivé listy nebo položky, které se mají publikovat, klikněte na tlačítko Možnosti publikování . Pokud ale chcete publikovat celý sešit, přejděte přímo ke kroku 4.
    Na kartě Zobrazit postupujte takto:

    • Pokud chcete zobrazit celý sešit v prohlížeči, vyberte v seznamu celý sešit .

    • Pokud chcete v prohlížeči zobrazit jenom určité listy, vyberte v seznamu listy a zrušte zaškrtnutí políček u listů, které nechcete zobrazit.
      Ve výchozím nastavení jsou vybrány všechny listy. Chcete-li, aby se všechny listy znovu zobrazovaly po zrušení některých zaškrtávacích políček, zaškrtněte políčko všechny listy .

    • Pokud chcete v prohlížeči zobrazit jenom určité položky (například pojmenované oblasti, grafy, tabulky nebo kontingenční tabulky), vyberte v seznamu položky a potom zaškrtněte políčka u položek, které chcete zobrazit.
      Poznámka: Pokud vyberete položky se stejným názvem (například graf a podkladová tabulka dat), bude v prohlížeči dostupná jenom jedna z těchto položek. Pokud chcete zobrazit všechny položky, musíte se ujistit, že každá položka v sešitu má jedinečný název. Tabulky můžete přejmenovat na kartě Návrh ve skupině Vlastnosti, kontingenční tabulky můžete přejmenovat na kartě Možnosti ve skupině Kontingenční tabulka a grafy nebo kontingenční grafy můžete přejmenovat na kartě Rozložení ve skupině Vlastnosti. Duplicitní položky, například pojmenované oblasti, se dají přejmenovat na kartě vzorce ve skupině definované názvy .
      Výběr listů nebo položek

    • Na kartě parametry přidejte všechny definované názvy, které chcete použít k určení buněk, které se dají upravit, když uživatelé zobrazí sešit v prohlížeči. Potom kliknutím na OK zavřete dialogové okno.
      Nastavení parametrů

  4. Zvolte umístění, do kterého chcete sešit publikovat.
    V aktuálním umístění, nedávných umístěníchnebo umístěních, ze kterých si můžete vybrat, už můžou být uložená umístění na serveru. Pokud neexistují žádná taková umístění nebo chcete uložit do nového umístění, poklikejte v části umístěnína Hledat umístění.

  5. V dialogovém okně Uložit jako zadejte webovou adresu sharepointového webu a pak přejděte na web nebo knihovnu, kam chcete sešit uložit.

  6. Pokud jste ještě nevybrali jednotlivé listy nebo položky, klikněte na tlačítko Možnosti publikování .

  7. V poli název souboru přijměte navrhovaný název sešitu nebo zadejte nový název.

  8. Pokud chcete zobrazit obsah sešitu v okně prohlížeče hned po dokončení operace publikování, ujistěte se, že je zaškrtnuté políčko otevřít v aplikaci Excel v prohlížeči .

  9. Klikněte na Uložit.

Poznámka:  Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát vědět, jestli vám informace pomohly? Pokud chcete, můžete se podívat na anglickou verzi článku.

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor! Pravděpodobně bude užitečné, když vás spojíme s některým z našich agentů podpory Office.

×