Publikování sešitu do sharepointové knihovny v Excelu 2016 pro Windows

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Sešit můžete publikovat do knihovny Microsoft SharePointu, aby ho uživatelé mohli zobrazit nebo upravovat ve webovém prohlížeči, aniž by museli mít na svém počítači nainstalovaný Excel. Publikování je v podstatě stejné jako ukládání, ale liší se v tom, že při něm můžete pomocí některých předdefinovaných možností určit, co uživatelé uvidí, když si sešit otevřou v prohlížeči.

Zavedení praxe ukládání nebo publikování sešitu na centrální sharepointový web pro celou organizaci může zajistit, aby po organizaci nekolovaly různé verze stejného sešitu, což se může stát, když se sešit rozesílá e-mailem.

Nastavením některých možností publikování můžete zvýraznit určité části sešitu, třeba grafy, a jiné části můžete skrýt, aby se nedaly zobrazit v prohlížeči. Můžete třeba nastavit, aby se zobrazil graf, ale ne jeho pokladová data. Můžete taky určit, že některé listy se mají zobrazit určitým lidem a ostatní listy se mají skrýt.

Tento článek ukazuje, jak publikovat sešit z Excelu 2016 pro Windows, a nepokrývá problematiku připojení sešitu nebo dat sešitu do webové části Excel Web Access na stránce SharePointu.

Když publikujete sešit na sharepointovém webu, uloží se na SharePoint celý sešit. Uživatel, který má požadovaná oprávnění SharePointu, si celý sešit může prohlédnout nebo s ním pracovat buď v prohlížeči, nebo v desktopové aplikaci Excel.

Pokud je na SharePointu nasazený Office Online, můžete svoje data zobrazit a pracovat s nimi v prohlížeči podobným způsobem jako v desktopové verzi Excelu. Výhodou oproti desktopové verzi Excelu je to, že v prohlížeči může sešit zároveň upravovat víc uživatelů. Když máte sešit otevřený v prohlížeči a vidíte tam tlačítko Upravit v aplikaci Excel Online, znamená to, že můžete použít Office Online.

Příkaz Upravit v Excelu Online v nabídce Upravit sešit

Příprava sešitu

Před publikováním sešitu můžete vybrat ty listy nebo prvky, které mají se mají zobrazovat v prohlížeči. Pamatujte ale na to, že sice můžete vybrat, co bude viditelné v tomto režimu, ale na server SharePointu se vždycky uloží celý obsah sešitu.

Pokud chcete zahrnout celý sešit jako položku společně s dalšími položkami, jako jsou grafy nebo kontingenční tabulky, nadefinujte celý sešit jako pojmenovanou oblast. Vyberte celý sešit a potom definujte pojmenovanou oblast. Tato pojmenovaná oblast se zobrazí jako dostupná položka v dialogovém okně Možnosti publikování, jakmile budete připraveni k publikování.

Pokud chcete uživatelům umožnit zadat do buňky hodnotu, aby mohli pracovat se vzorcem v jiné buňce, nastavte v Excelu před publikováním sešitu danou buňku jako definovaný název. Tento definovaný název pak můžete přidat jako parametr na kartě Parametry v dialogovém okně Možnosti zobrazení prohlížeče.

Na následujícím obrázku je třeba buňka D2, která má definovaný název Sazba. Uživatel v prohlížeči zadal hodnotu 5,625 do pole Sazba v podokně Parametry a potom kliknul na tlačítko Použít. Tato hodnota se následně zobrazí v buňce D2 a použije ji vzorec v buňce A2. Výsledek vzorce se přepočítá a zobrazí v buňce A2: 1 151,31 Kč.

Zadání parametru v podokně – použití v buňce D2

Poznámka : Když vytvoříte průřezy pro excelovou tabulku a definujete název pro oblast buněk obsahující tabulku a průřezy, nebudete moct použít průřezy k filtrování tabulky v prohlížeči, pokud publikujete definovanou oblast. Pokud publikujete tabulku nebo celý list nebo jeho sešit, průřezy budou v prohlížeči fungovat podle očekávání.

Publikování sešitu

  1. Na kartě Soubor klikněte na Uložit jako a potom na SharePoint.

  2. Pokud se zobrazí složce SharePoint v části aktuálníseznam nedávné a starší, klikněte na složku, kterou chcete.

    Zobrazí se dialogové okno Uložit jako.


    Jinak klikněte na tlačítko Procházet, zadejte webovou adresu webu služby SharePoint a potom přejděte do složky, ve které chcete publikovat sešit.

    Klikněte na složku služby SharePoint nebo na Procházet.
  3. Pokud chcete k publikování vybrat jednotlivé listy nebo položky v sešitu, klikněte na Možnosti zobrazení prohlížeče.

    V dialogu Uložit jako klikněte na Možnosti zobrazení prohlížeče

    Zobrazí se karta Zobrazit a karta Parametry.

  4. Pokud chcete publikovat celý sešit, klikněte na Uložit. Jinak udělejte některou z těchto věcí:

    • Pokud chcete v prohlížeči zobrazit celý sešit, vyberte na kartě Zobrazit ze seznamu možnost Celý sešit.

    • Pokud chcete v prohlížeči zobrazit jenom některé listy, vyberte na kartě Zobrazit ze seznamu možnost Listy a potom zrušte zaškrtnutí políček u listů, které nechcete v prohlížeči skrýt.

      Ve výchozím nastavení jsou vybrané všechny listy. Pokud chcete po zrušení zaškrtnutí některých políček znovu rychle zobrazit všechny listy, zaškrtněte políčko Všechny listy.

    • Pokud chcete v prohlížeči zobrazit jenom některé položky (například pojmenované oblasti, grafy, tabulky nebo kontingenční tabulky), vyberte na kartě Zobrazit ze seznamu možnost Položky v sešitu a potom zaškrtněte políčka u položek, které chcete zobrazit.

    • Na kartě Parametry přidejte libovolné definované názvy, které chcete použít k určení buněk, které uživatelé můžou upravovat při zobrazení sešitu v prohlížeči. Potom dialogové okno zavřete kliknutím na OK.

  5. Uložte sešit.

Poznámky : 

  • Pokud vyberete položky, které mají stejný název (třeba graf a tabulku s jeho podkladovými daty), v prohlížeči bude dostupná jenom jedna z těchto položek. Pokud chcete zobrazit všechny položky, zajistěte, aby všechny položky v sešitu měly jedinečné názvy.

  • Tabulky můžete přejmenovat na kartě Návrh ve skupině Vlastnosti, kontingenční tabulky můžete přejmenovat na kartě Možnosti ve skupině Kontingenční tabulka a grafy nebo kontingenční grafy můžete přejmenovat na kartě Rozložení ve skupině Vlastnosti. Jiné duplicitní položky, například pojmenované oblasti, můžete přejmenovat na kartě Vzorce ve skupině Definované názvy.

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×