Prezentace dat ve sloupcovém grafu

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Microsoft Office Excel 2007 můžete vytvořit sloupcový graf a dodá ještě nepracovali, přitažlivější vzhled. Mezi nejběžnější typy grafů je užitečný pro porovnání Datové body v jedné nebo více Datová řada sloupcový graf.

Formátovaný skládaný sloupcový graf

Po vytvoření sloupcovém grafu můžete změnit mezery mezi sloupci. Plovoucí sloupcový graf můžete vytvořit taky skrytím datové řady v grafu.

V tomto článku

Další informace o zakreslení dat ve sloupcovém grafu

Vytvoření komplikovanou sloupcový graf

Změna vzdálenosti mezi sloupci

Simulovat plovoucí sloupcový graf

Uložení grafu jako šablony

Další informace o zakreslení dat ve sloupcovém grafu

Data uspořádaná v listu do sloupců nebo řádků mohou být vykreslena ve sloupcovém grafu. Sloupcové grafy se hodí pro znázornění změn dat za časové období nebo pro znázornění porovnání položek.

Ve sloupcových grafech bývají obvykle kategorie uspořádány podél vodorovné osy a hodnoty podle svislé osy.

Skupinový sloupcový graf s prostorovým efektem

Zvažte použití sloupce s grafem při:

  • Máte jednu nebo více datových řad, které chcete zobrazit.

  • Data obsahují kladné, záporné a nulové (0) hodnoty.

  • Chcete porovnat data pro hodně kategorií vedle sebe.

Když vytvoříte sloupcový graf, můžete vybrat jednu z následujících podtypy sloupce:

  • Skupinový sloupcový graf a prostorový skupinový sloupcový graf:    Skupinové sloupcové grafy porovnávají hodnoty mezi různými kategoriemi. Skupinový sloupcový graf zobrazuje hodnoty jako dvojrozměrné svislé obdélníky. Prostorový skupinový sloupcový graf pouze zobrazuje data v trojrozměrné perspektivě. Třetí osa (hloubková) se nepoužívá.

    Skupinový sloupcový graf a prostorový skupinový sloupcový graf

    Skupinový sloupcový graf můžete použít pro kategorie, které představují:

    • Rozsahy hodnot (například počty položek)

    • Zvláštní uspořádání stupnice (například Likertova stupnice s položkami jako zásadní souhlas, souhlas, neutrální, nesouhlas, zásadní nesouhlas)

    • Názvy, které nejsou v určitém pořadí (například názvy položek, geografické názvy, jména osob)

      Poznámka : Chcete-li data prezentovat v trojrozměrném formátu používajícím 3 osy (vodorovnou, svislou a hloubkovou), které lze upravit, použijte místo toho prostorový sloupcový podtyp grafu.

  • Skládaný sloupcový graf a skládaný sloupcový graf v prostorovém zobrazení:    Skládané sloupcové grafy znázorňují vztah jednotlivých položek k celku s porovnáním podílu každé z hodnot na celkové hodnotě v různých kategoriích. Skládaný sloupcový graf zobrazuje hodnoty jako dvojrozměrné svislé skládané obdélníky. Skládaný sloupcový graf v prostorovém zobrazení pouze zobrazuje data v trojrozměrné perspektivě. Třetí osa (hloubková) se nepoužívá.

    Skládaný sloupcový graf a skládaný sloupcový graf v prostorovém zobrazení

    Skládaný sloupcový graf můžete použít v případě, kdy máte více datových řad a chcete zvýraznit součet.

  • 100% skládaný sloupcový graf a 100% skládaný sloupcový graf v prostorovém zobrazení:    100% skládané sloupcové grafy a 100% skládané sloupcové grafy v prostorovém zobrazení porovnávají procentuální podíl jednotlivých hodnot na celkové hodnotě v různých kategoriích. 100% skládaný sloupcový graf zobrazuje hodnoty jako dvojrozměrné svislé 100% skládané obdélníky. 100% skládaný sloupcový graf v prostorovém zobrazení pouze zobrazuje data v trojrozměrné perspektivě. Třetí osa (hloubková) se nepoužívá.

    100% skládaný sloupcový graf a 100% sloupcový graf v prostorovém zobrazení

    100% skládaný sloupcový graf můžete použít v případě, že máte 3 nebo více datových řad a chcete zdůraznit podíl jednotlivých hodnot na celkové hodnotě, zvláště pokud je celková hodnota ve všech kategoriích stejná.

  • Prostorový sloupcový graf:    V prostorových sloupcových grafech se používají 3 osy, které lze upravit (vodorovná, svislá a hloubková), a Datové body se porovnávají podél vodorovné a hloubkové osy.

    Prostorový sloupcový graf

    3D sloupcovým grafem můžete použít, když chcete data porovnat různé kategorie a řadu rovnoměrně z vnější, protože tento typ grafu zobrazenými kategoriemi podél vodorovné osy a na hloubkové ose během zobrazí hodnoty svislé osy.

  • Válcový, kuželový a obrázku    Válcové, kuželové a jehlanové grafy jsou dostupné ve stejné skupinové, skládané, 100 % skládaného a 3D typech grafů, které jsou k dispozici pro obdélníkový sloupcový graf a zobrazení a porovnání dat stejným způsobem. Jediný rozdíl je, že tyto typy grafů zobrazují válcové, kuželové a jehlanové tvary místo obdélníků.

    Válcový, kuželový a jehlanový graf

Začátek stránky

Vytvoření komplikovanou sloupcový graf

Formátovaný skládaný sloupcový graf

Ano jak jsme vytvořili sloupcový graf? Následující postup vám pomůže vytvořit sloupcový graf s podobných výsledků. Pro tento graf jsme použili vzorovými daty listu. Zkopírujte tato data do listu nebo můžete použít vlastní data.

  1. Do prázdného listu zkopírujte ukázková data listu nebo otevřete na list obsahující data, která chcete vykreslit sloupcový graf.

    Jak zkopírovat data ukázkového listu

    1. Vytvořte prázdný sešit nebo list.

    2. Vyberte příklad v tématu nápovědy.

      Poznámka : Nevybírejte záhlaví řádků ani sloupců.

      Výběr příkladu z nápovědy
      Výběr příkladu z nápovědy
    3. Stiskněte kombinaci kláves CTRL+C.

    4. Vyberte v listu buňku A1 a stiskněte klávesy CTRL+V.

1

2

3

4

5

6

A

B

C

D

E

Prodejní Territor y

Za. 1

Za. 2

Za. 3

Za. 4

Severozápad

3,767,341

3,298,694

2,448,772

1,814,281

Severovýchod

2,857,163

3,607,148

1,857,156

1,983,931

Centrální

3,677,108

3,205,014

2,390,120

1,762,757

jihozápad USA

4,351,296

3,366,575

2,828,342

1,851,616

Jihočeský kraj

2,851,419

3,925,071

1,853,422

2,158,789

  1. Vyberte data, která chcete vynést do sloupcový graf.

  2. Na kartě Vložit ve skupině Grafy klepněte na možnost Sloupcový.

    Vzhled pásu karet aplikace Excel

  3. V části 3D sloupce vyberte Skládaný sloupcový v 3D.

  4. Klepněte na Oblast grafu grafu.

    Zobrazí se pás karet Nástroje grafu s kartami Návrh, RozloženíFormát.

  5. Na kartě Návrh vyberte ve skupině Rozložení grafu rozložení, které chcete použít.

    Vzhled pásu karet aplikace Excel

    Pro naše sloupcový graf jsme použili rozložení 3.

  6. Na kartě Návrh klepněte ve skupině Styly grafu na styl grafu, který chcete použít.

    Vzhled pásu karet aplikace Excel

    Pro naše sloupcový graf jsme použili styl 34.

  7. V grafu klikněte na název a potom zadejte text nadpisu, který chcete.

    Pro naše sloupcový graf jsme použili název Místní prodejů v Severní Americe.

  8. V grafu klikněte svislé osy (hodnoty) nebo vyberte ze seznamu prvků grafu (kartaFormát, skupina Aktuální výběr, prvky Grafu ).

  9. Na kartě Formát ve skupině Aktuální výběr klikněte na Formátovat výběr.

  10. V části Možnosti osy v poli jednotky zobrazení klikněte na miliony a potom klikněte na Zavřít.

  11. V grafu klikněte na datovou řadu nebo vyberte ze seznamu prvků grafu (kartaFormát, skupina Aktuální výběr, prvky Grafu ).

  12. Na kartě Formát klepněte ve skupině Styl obrazce na tlačítko Efekty obrazce a klepněte na tlačítko Zkosení.

    Skupina Styly obrazců na pásu karet aplikace Excel

  13. Klepněte na položku Možnosti 3-D a v části Zkosení klepněte na možnosti zkosení Nahoře a Dole, které chcete použít.

    Pro naše sloupcový graf jsme použili Měkké zaokrouhlit.

  14. Do polí Šířka a Výška u možností zkosení Nahoře a Dole zadejte požadovanou velikost v bodech.

    Pro naše sloupcový graf jsme použili 12 pt pro začátek šířku, 4 body horních výšku, 6 pt dolní šířka a 6 pt dolní výška.

  15. Ve skupinovém rámečku Povrch klepněte na možnost Materiál a potom klepněte možnost materiálu, který chcete použít.

    Pro naše sloupcový graf jsme použili plastové.

  16. V grafu klikněte na jiné datové řady a zopakujete kroky 13 až 16.

  17. Zachovat poslední datové řady vybraná a dialogovým oknem Otevřít po formátovány všech datových řad a potom klikněte na Možnosti řady v dialogovém okně Formát datové řady.

  18. V rozevíracím seznamu Šířka mezery přetáhněte posuvník na požadovanou šířku mezery.

    Pro naše sloupcový graf jsme posuvník přetažené do složky Bez mezer (0 %).

  19. Zachovat dialogovým oknem Otevřít a potom klikněte do oblasti grafu grafu.

  20. V dialogovém okně klikněte na Styly ohraničení a potom zaškrtněte políčko rohů zaoblený.

  21. Pokud chcete použít barvy motivu, které se liší od výchozího motivu, který se použije k sešitu, postupujte takto:

    1. Na kartě Rozložení stránky ve skupinovém rámečku Motivy klepněte na položku Motivy .

      Skupiny motivů na pásu karet aplikace Excel

    2. Ve skupinovém rámečku Předdefinované klepněte na motiv, který chcete použít.

      Pro naše sloupcový graf jsme použili Medián motiv.

Začátek stránky

Změna vzdálenosti mezi sloupci

Můžete zvětšení nebo zmenšení mezer mezi datové značky nebo sloupce ve sloupcovém grafu. V 2D sloupcový graf sloupce můžete dokonce překrývají.

  1. V grafu klepněte na Datová řada, kterou chcete změnit, nebo ji následujícím způsobem vyberte v seznamu prvků grafu:

    1. Klepněte na graf.

      Zobrazí se pás karet Nástroje grafu s kartami Návrh, RozloženíFormát.

    2. Na kartě Formát ve skupině Aktuální výběr klepněte na šipku vedle pole Prvky grafu a potom klepněte na datovou řadu.

      Skupina Aktuální výběr na pásu karet aplikace Excel

  2. Tip : Pro změnu velikosti mezer u všech datových řad stejného typu grafu stačí vybrat pouze jednu datovou řadu.

  3. Na kartě Formát ve skupině Aktuální výběr klikněte na Formátovat výběr.

  4. Ve skupinovém rámečku Možnosti řady proveďte jeden z následujících kroků:

    1. Pokud chcete změnit překrytí sloupce v 2D sloupcový graf, přetáhněte posuvník na požadovanou procentuální hodnotu překrytí řad, které chcete nebo zadejte procentuální hodnotu mezi -100 až 100 v poli Překrývat řady.

      Tip : Čím vyšší je tato hodnota, tím větší překrytí bude v této kategorii.

    2. Pokud chcete změnit mezery mezi kategoriemi datové značky 2D a 3D sloupcový graf, přetáhněte posuvník na požadované procento šířky mezery nebo zadejte hodnotu 0 (nula) až 500 do pole Šířka.

      Tip : Tato hodnota vyšší, tím větší mezery mezi sloupci.

    3. Pokud chcete změnit mezery mezi datových řad v 3D sloupcový graf, zadejte hodnotu 0 (nula) až 500 do pole Název hloubkové mezeru.

      Tip : Vyšší hodnota, tím větší vzdálenosti mezi sloupci.

Začátek stránky

Simulovat plovoucí sloupcový graf

Plovoucí grafy jsou užitečné, pokud chcete mít sloupce ve sloupcovém grafu popsat minimální a maximální hodnoty. Aplikace Excel neumožňuje plovoucí sloupcový graf. Však při vytváření skládaný sloupcový graf, který obsahuje datové řady (nejméně dvě) změníte první datovou řadu neviditelné dosáhnout druhý datové řady plovoucí sloupcový grafu.

Plovoucí sloupcový graf

  1. Na listu vyberte data, která chcete vykreslit plovoucí sloupcový graf.

  2. Na kartě Vložit ve skupině Grafy klepněte na možnost Sloupcový.

    Vzhled pásu karet aplikace Excel

  3. V části 2D sloupce klikněte na Skládaný sloupcový.

    Efekt 3D 3D sloupce, klikněte na Skládaný sloupcový v 3D.

  4. V grafu klepněte na první datovou řadu nebo ji vyberte v seznamu prvků grafu (karta Formát, skupina Aktuální výběr, pole Prvky grafu).

  5. Na kartě Formát ve skupině Aktuální výběr klikněte na Formátovat výběr.

    Skupina Aktuální výběr na pásu karet aplikace Excel

  6. Klepněte na tlačítko Výplň a potom na možnost Bez výplně.

Začátek stránky

Uložení grafu jako šablony

Pokud chcete vytvořit jiný graf podobný grafu, který jste právě vytvořili, můžete tento graf uložit jako šablonu, která slouží jako základ pro jiné podobné grafy.

  1. Klepněte na graf, který chcete uložit jako šablonu.

  2. Na kartě Návrh klepněte ve skupině Typ na možnost Uložit jako šablonu.

    Vzhled pásu karet aplikace Excel

  3. Do pole Název souboru zadejte název šablony.

    Tip : Pokud nezadáte jinou složku, bude soubor šablony (CRTX) uložen do složky Grafy a šablona bude k dispozici v části Šablony v dialogovém okně Vložit graf (karta Vložení, skupina Grafy, tlačítko Spouštění dialogového okna Obrázek tlačítka ) a v dialogovém okně Změnit typ grafu (karta Návrh, skupina Typ, tlačítko Změnit typ grafu).

    Další informace o způsobu použití šablony grafu najdete v tématu Opakované použití oblíbeného grafu pomocí šablony grafu.

Poznámka : Šablona grafu obsahuje formátování a uloží barvy, které jsou použity při uložení grafu jako šablony. Pokud použijete šablonu grafu k vytvoření grafu v jiném sešitu, použije nový graf barvy šablony, spíše než barvy motivu dokumentu aktuálně použitého u sešitu. Pro použití barvy motivu dokumentu namísto barvy šablony grafu klepněte pravým tlačítkem myši na Oblast grafu a v místní nabídce klepněte na tlačítko Obnovit a srovnat se stylem.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Sdílení Facebook Facebook Twitter Twitter E-mail E-mail

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×