Prezentace dat v bodovém nebo spojnicovém grafu

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Bodové grafy a spojnicové grafy vypadají velmi podobné, zejména při zobrazení bodového grafu s e spojovacími čarami. Existuje však velký rozdíl ve způsobu, jakým každý z těchto grafů zobrazuje data podél vodorovné osy (která je označována jako osa x) a svislé osy (která je označována jako y).

Formátovaný bodový graf
Tento formátovaný bodový graf zobrazuje číselné hodnoty podél vodorovné a svislé osy a kombinuje tyto hodnoty do jednotlivých datových bodů, které jsou zobrazeny v nesouměrných intervalech.
Formátovaný spojnicový graf
Tento formátovaný spojnicový distribuuje data kategorií (v tomto případě časový interval) rovnoměrně podél vodorovné osy a všechny číselné hodnoty rovnoměrně podél svislé osy.

Než vyberete některý z těchto typů grafů, je vhodné získat další informace o rozdílech a zjistit, kdy je vhodnější použít bodový graf namísto spojnicového grafu, nebo naopak.

V tomto článku:

Informace o rozdílech mezi bodovými a spojnicovými grafy

Kdy použít bodový a kdy spojnicový graf

Informace o typech bodových a spojnicových grafů

Vytvoření bodového grafu

Vytvoření spojnicového grafu

Uložení grafu jako šablony

Informace o rozdílech mezi bodovými a spojnicovými grafy

Hlavní rozdíl mezi bodovými a spojnicovými grafy je způsob jejich vynesení dat na vodorovné ose. Pokud například použijete následující data listu k vytvoření bodového a spojnicového grafu, uvidíte, že data jsou distribuována jinak.

Obrázek dat listu s denními úhrny srážek

V bodovém grafu jsou hodnoty denních úhrnů srážek ze sloupce A zobrazeny jako hodnoty x na vodorovné ose (x) a částice ze sloupce B jsou zobrazeny jako hodnoty na svislé ose (y). Bodový graf, často označovaný jako graf xy, nikdy nezobrazuje kategorie na vodorovné ose.

Obrázek bodového grafu

Bodový graf vždy má dvě osy zobrazující jednu sadu číselných dat na vodorovné ose (hodnot) a jinou sadu číselných hodnot na svisle ose (hodnot). Graf zobrazí body v průsečíku číselných hodnot x a y kombinací těchto hodnot do jednoho datového bodu. Tyto datové body mohou být distribuovány rovnoměrně nebo nerovnoměrně na vodorovné ose, v závislosti na datech.

První datový bod, který se zobrazí v bodovém grafu, představuje hodnotu y 137 (částice) a hodnotu x 1,9 (denní srážkový úhrn). Tyto hodnoty představují hodnoty buněk A9 a B9 v listu.

Ve spojnicovém grafu však jsou stejné hodnoty denních srážkových úhrnů a částic zobrazeny jako dva různé datové body, které jsou rovnoměrně distribuovány na vodorovné ose. Je to proto, že spojnicový graf obsahuje pouze jednu osu hodnot (svislou osu). Vodorovná osa spojnicového graf zobrazuje pouze rovnoměrně rozmístěná seskupení dat (kategorie). Protože v datech nebyly uvedeny kategorie, byly vygenerovány automaticky, například 1, 2, 3 atd..

Toto je dobrý příklad, kdy není vhodné použít spojnicový graf.

Obrázek spojnicového grafu

Spojnicový graf distribuuje kategorie dat rovnoměrně na vodorovné ose (kategorií) a distribuuje všechna data číselných hodnot na svislé ose (hodnot).

Hodnota částic y, která činí 137 (buňka B9), a hodnota denního srážkového úhrnu x, která činí 1,9 (buňka A9), jsou ve spojnicovém grafu zobrazeny jako samostatné datové body. Žádný z těchto datových bodů není první datový bod zobrazený v grafu — místo toho první datový bod, který obsahuje každá datová řada, odkazuje na hodnoty v prvním řádku dat v listu (buňka A2 a B2).

Typ osy a rozdíly měřítka

Vzhledem k tomu, že vodorovná osa bodového grafu je vždy osa hodnot, může zobrazovat číselná data nebo hodnoty dat (například dny nebo hodiny), které jsou znázorněny jako číselné hodnoty. Pokud chcete zobrazit číselné hodnoty podél vodorovné osy s větší flexibilitou, můžete změnit možnosti měřítka této osy stejným způsobem, jako možnosti měřítka svislé osy.

Vzhledem k tomu, že vodorovná osa spojnicového grafu je osa kategorií, může být pouze osa textu nebo osa data. Osa textu zobrazí pouze text (data jiná než čísla nebo číselné kategorie, které však nejsou hodnoty) ve stejně vzdálených intervalech. Osa data zobrazuje kalendářní data v chronologickém pořadí v určitých intervalech nebo základních jednotkách, například jako počet dní, měsíců nebo roků, i v případě, že data v listu nejsou ve stejném pořadí nebo ve stejných základních jednotkách.

Možnosti měřítka osy kategorií jsou omezené v porovnání s možnostmi měřítka osy hodnot. Dostupné možností měřítka také závisí na typu osy, kterou používáte.

Začátek stránky

Kdy použít bodový a kdy spojnicový graf

Bodové grafy obvykle slouží k zobrazení a porovnání číselných hodnot, například vědeckých, statistických a inženýrských dat. Tyto grafy jsou vhodné k zobrazení vztahů mezi číselnými hodnotami v několika datových řadách a mohou zobrazit dvě skupiny čísel jako jednu řadu souřadnic XY.

Spojnicové grafy mohou zobrazit souvislá data v průběhu času a jejich srovnání se společným měřítkem, a jsou proto ideální pro zobrazení trendů v datech v pravidelných intervalech nebo v průběhu času. Ve spojnicovém grafu je kategorie dat distribuována rovnoměrně podél vodorovné osy a všechny údaje hodnoty jsou rozloženy rovnoměrně na svislé ose. Jako obecné pravidlo platí použít spojnicový graf, pokud data obsahují nečíselné hodnoty x – pro číselné hodnoty x je většinou vhodnější použít bodový graf.

Zvažte použití spojnicového graf namísto bodového grafu, chcete-li:

  • Změnit měřítko vodorovné osy:    Vzhledem k tomu, že vodorovná osa bodového grafu je osa hodnot, jsou k dispozici další možnosti měřítka.

  • Použít logaritmické měřítko na vodorovné ose:    Vodorovnou osu můžete změnit na logaritmické měřítko.

  • Zobrazit data z listu obsahující dvojice nebo seskupené sady hodnot:    V bodovém grafu můžete nastavit nezávislá měřítka os, aby se objevilo více informací o seskupených hodnotách.

  • Zobrazit vzorky ve velkých sadách dat:    Bodové grafy jsou užitečné pro ilustraci vzorků v datech, například zobrazením lineárních nebo nelineárních trendů, clusterů a extrémních hodnot.

  • Porovnat velké množství datových bodů bez ohledu na čas:    Čím více dat zahrnete do bodového grafu, tím lepší mohou být jejich porovnání.

Zvažte použití spojnicového grafu namísto bodového, chcete-li:

  • Použít textové popisky podél vodorovné osy:    Tyto textové popisky mohou představovat rovnoměrně rozložené hodnoty, například měsíce, čtvrtletí nebo fiskální roky.

  • Použít malý počet číselných popisků podél vodorovné osy:    Pokud máte několik rovnoměrně rozložených číselných popisků, které představují časový interval, například roky, můžete použít spojnicový graf.

  • Použít časové měřítko podél vodorovné osy:    Jestliže chcete zobrazit data v chronologickém pořadí v určitých intervalech nebo základních jednotkách, například počet dnů, měsíců nebo let, i když data na listu nejsou ve stejném pořadí nebo ve stejných základních jednotkách, použijte spojnicový graf.

Začátek stránky

Informace o typech bodových a spojnicových grafů

Bodové grafy mohou používat následující podtypy grafu.

  • Bodový pouze se značkami:    Tento typ grafu porovnává dvojice hodnot. Použijte bodový graf s datovými značkami, ale bez čar, pokud používáte více datových bodů a spojovací čáry by ztížily čtení těchto dat. V případě, že není nutné zobrazit připojení datových bodů, použijte tento typ grafu.

    Bodový graf pouze se značkami

  • Bodový s vyhlazenými spojnicemi a bodový s vyhlazenými spojnicemi a značkami:    Tento typ grafu zobrazí plynulou křivku spojující datové body. Vyhlazené spojnice se dají zobrazit se značkami nebo bez značek. Pokud je počet datových bodů velký, použijte vyhlazené čáry bez značek.

    Bodový s vyhlazenými spojnicemi se značkami a bez značek

  • Bodový s rovnými spojnicemi a bodový s rovnými spojnicemi a se značkami:    Tento typ grafu zobrazí rovné čáry mezi datovými body. Rovné čáry lze zobrazit se značkami nebo bez značek.

    Bodový s rovné čárami se značkami a bez značek

Spojnicové grafy mohou používat následující podtypy grafů.

  • Spojnicový a spojnicový se značkami:    Spojnicové grafy zobrazené se značkami označujícími jednotlivé datové hodnoty nebo bez nich jsou užitečné pro zobrazení trendů v průběhu času nebo pořadí kategorií, zvlášť pokud je počet datových bodů velký a pořadí, v jakém jsou uvedené, je důležité. Pokud existuje mnoho kategorií nebo jsou hodnoty jenom přibližné, použijte spojnicový graf bez značek.

    Spojnicové grafy se značkami a bez značek

  • Skládaný spojnicový a skládaný spojnicový se značkami    Skládané spojnicové grafy zobrazené se značkami označujícími jednotlivé datové hodnoty nebo bez nich lze použít k zobrazení trendů příspěvku jednotlivých hodnot vzhledem k času nebo seřazeným kategoriím, ale protože skládané čáry je obtížné sledovat, zvažte místo něj použití jiného typu spojnicového grafu nebo skládaného plošného grafu.

    Skládané spojnicové grafy se značkami a bez značek

  • 100% skládaný spojnicový a 100% skládaný spojnicový se značkami:    100% skládané spojnicové grafy zobrazené se značkami označujícími jednotlivé datové hodnoty nebo bez nich jsou vhodné k zobrazení trendů příspěvku jednotlivých hodnot vzhledem k času nebo seřazeným kategoriím v procentech. Pokud existuje mnoho kategorií nebo jsou hodnoty jenom přibližné, použijte 100% skládaný spojnicový graf bez značek.

    Tip : Pro lepší prezentaci tohoto typu dat zvažte použití 100% skládaného plošného grafu.

    100% skládaný spojnicový graf se značkami a bez nich

  • Prostorový spojnicový:    Prostorové spojnicové grafy zobrazují každý řádek nebo sloupec dat jako pásku s prostorovým efektem. Prostorový spojnicový graf má vodorovnou, svislou a hloubkovou osu, které můžete upravovat.

    3-D spojnicový graf

Začátek stránky

Vytvoření bodového grafu

Formátovaný bodový graf

Jak jsme tedy tento bodový graf vytvořili? Následující postup vám pomůže vytvořit bodový graf s podobnými výsledky. V tomto grafu jsou použita data ukázkového listu. Tato data můžete zkopírovat do listu nebo můžete použít vlastní data.

  1. Zkopírujte data listu příkladu do prázdného listu nebo otevřete list obsahující data, která chcete v bodovém grafu zobrazit.

    Jak zkopírovat data ukázkového listu

    1. Vytvořte prázdný sešit nebo list.

    2. Vyberte příklad v tématu nápovědy.

      Poznámka : Nevybírejte záhlaví řádků ani sloupců.

      Výběr příkladu z nápovědy
      Výběr příkladu z nápovědy
    3. Stiskněte kombinaci kláves CTRL+C.

    4. Vyberte v listu buňku A1 a stiskněte klávesy CTRL+V.

1

2

3

4

5

6

7

8

9

10

A

B

Denní srážkový úhrn l

Částice

4,1

122

4,3

117

5,7

1120

5,4

114

5,9

110

5,0

114

3,6

128

1,9

137

7,3

104

  1. Vyberte data, která chcete zobrazit v bodovém grafu.

  2. Na kartě Vložit klepněte ve skupině Grafy na tlačítko Bodový.

    Vzhled pásu karet aplikace Excel

  3. Klepněte na položku Bodový pouze se značkami.

    Tip : Zastavením myši na libovolném typu grafu zobrazíte jeho název.

  4. Klepněte na Oblast grafu grafu.

    Zobrazí se pás karet Nástroje grafu s kartami Návrh, RozloženíFormát.

  5. Na kartě Návrh klepněte ve skupině Styly grafu na styl grafu, který chcete použít.

    Styly grafu na pásu karet aplikace Excel

    Pro náš bodový graf jsme použili Styl 26.

  6. Klepněte na nadpis grafu a zadejte požadovaný text.

    Pro náš bodový graf jsme zadali Úrovně částic ve srážkách.

  7. Pokud chcete zmenšit název grafu, klepněte na něj pravým tlačítkem myši a potom zadejte požadovanou velikost do pole Velikost písma v místní nabídce.

    Pro náš bodový graf jsme nastavili hodnotu 14.

  8. Klepněte na oblast grafu.

  9. Na kartě Rozložení klepněte ve skupinovém rámečku Popisky na tlačítko Názvy os a potom proveďte následující:

    1. Chcete-li přidat nadpis vodorovné osy, klepněte na položku Název hlavní vodorovné osy a klepněte na tlačítko Název pod osou.

    2. Chcete-li přidat nadpis svislé osy, klepněte na položku Název hlavní svislé osy a potom klepněte na požadovaný typ svislé osy.

      Pro náš bodový graf jsme nastavili hodnotu Otočený název.

      Vzhled pásu karet aplikace Excel

    3. Klepněte na každý název, zadejte požadovaný text a potom stiskněte klávesu ENTER.

      Pro náš bodový graf jsme zadali Denní srážkový úhrn jako název vodorovné osy a Úroveň částic jako název svislé osy.

  10. Klepněte na Oblast grafu nebo vyberte Oblast grafu ze seznamu prvků grafu (karta Rozložení, skupina Aktuální výběr, pole Prvky grafu).

  11. Na kartě Formát ve skupině Styl obrazce klepněte na tlačítko Upřesnit Obrázek tlačítka a poté klepněte na efekt, který chcete použít.

    Pro náš bodový graf jsme použili možnost Jemný efekt – Zvýraznění 3.

    Skupina Styly obrazců na pásu karet aplikace Excel

  12. Klepněte na oblast grafu.

  13. Na kartě Formát ve skupině Styl obrazce klepněte na tlačítko Upřesnit Obrázek tlačítka a poté klepněte na efekt, který chcete použít.

    Pro náš bodový graf jsme použili možnost Jemný efekt – Zvýraznění 1.

  14. Pokud chcete použít odlišné barvy motivu od výchozího motivu použitého u sešitu, proveďte následující kroky:

    1. Na kartě Rozložení stránky ve skupinovém rámečku Motivy klepněte na položku Motivy .

      Vzhled pásu karet aplikace Excel

    2. Ve skupinovém rámečku Předdefinované klepněte na motiv, který chcete použít.

      V našem spojnicovém grafu je použit motiv Kancelář.

Začátek stránky

Vytvoření spojnicového grafu

Formátovaný spojnicový graf

Jak jsme tedy tento spojnicový graf vytvořili? Následující postup vám pomůže vytvořit spojnicový graf s podobnými výsledky. V tomto grafu jsou použita data ukázkového listu. Tato data můžete zkopírovat do listu nebo můžete použít vlastní data.

  1. Zkopírujte data listu příkladu do prázdného listu nebo otevřete list obsahující data, která chcete ve spojnicovém grafu zobrazit.

    Jak zkopírovat data ukázkového listu

    1. Vytvořte prázdný sešit nebo list.

    2. Vyberte příklad v tématu nápovědy.

      Poznámka : Nevybírejte záhlaví řádků ani sloupců.

      Výběr příkladu z nápovědy
      Výběr příkladu z nápovědy
    3. Stiskněte kombinaci kláves CTRL+C.

    4. Vyberte v listu buňku A1 a stiskněte klávesy CTRL+V.

1

2

3

4

5

6

7

8

9

10

A

B

C

Datum

Denní srážkový úhrn l

Částic e

1.1.07

4,1

122

1.2.07

4,3

117

1.3.07

5,7

1120

1.4.07

5,4

114

1.5.07

5,9

110

1.6.07

5,0

114

1.7.07

3,6

128

1.8.07

1,9

137

1.9.07

7,3

104

  1. Vyberte data, která chcete zobrazit ve spojnicovém grafu.

  2. Na kartě Vložit klepněte ve skupině Grafy na tlačítko Spojnicový.

    Vzhled pásu karet aplikace Excel

  3. Klepněte na položku Spojnicový se značkami.

  4. Klepněte na Oblast grafu grafu.

    Zobrazí se pás karet Nástroje grafu s kartami Návrh, RozloženíFormát.

  5. Na kartě Návrh klepněte ve skupině Styly grafu na styl grafu, který chcete použít.

    Styly grafu na pásu karet aplikace Excel

    Pro náš spojnicový graf jsme použili Styl 2.

  6. Na kartě Rozložení ve skupinovém rámečku Popisky klepněte na položku Název grafu a klepněte na tlačítko Nad grafem.

    Vzhled pásu karet aplikace Excel

  7. Klepněte na nadpis grafu a zadejte požadovaný text.

    Pro náš spojnicový graf jsme zadali Úrovně částic ve srážkách.

  8. Chcete-li zmenšit velikost názvu grafu, klepněte pravým tlačítkem myši na název a zadejte požadovanou velikost v poli Velikost v místní nabídce.

    Pro náš spojnicový graf jsme nastavili hodnotu 14.

  9. V grafu klepněte na legendu nebo ji vyberte ze seznamu prvků grafu (karta Rozložení, skupina Aktuální výběr pole Prvky grafu ).

  10. Na kartě Rozložení klepněte ve skupině Popisky na položku Legenda a potom klepněte na požadované umístění.

    Pro náš spojnicový graf jsme použili možnost Zobrazit legendu nahoře.

  11. Chcete-li zobrazit jednu datovou řadu podél sekundární svislé osy, klepněte na datovou řadu Srážkového úhrnu nebo ji vyberte ze seznamu prvků grafu (karta Rozložení, skupina Aktuální výběr, pole Prvky grafu).

  12. Na kartě Rozložení klepněte ve skupině Aktuální výběr na tlačítko Výběr formátu.

    Skupina Aktuální výběr na pásu karet aplikace Excel

  13. Ve skupinovém rámečku Možnosti řady vyberte možnost Vedlejší osa a klepněte na tlačítko Zavřít.

  14. Na kartě Rozložení klepněte ve skupinovém rámečku Popisky na tlačítko Názvy os a potom proveďte následující:

    1. Chcete-li přidat nadpis hlavní svislé osy, klepněte na položku Název hlavní svislé osy a potom klepněte na požadovaný typ svislé osy.

      Pro náš spojnicový graf jsme nastavili hodnotu Otočený název.

    2. Chcete-li přidat nadpis vedlejší svislé osy, klepněte na položku Název vedlejší svislé osy a potom klepněte na požadovaný typ svislé osy.

      Pro náš spojnicový graf jsme nastavili hodnotu Otočený název.

    3. Klepněte na každý název, zadejte požadovaný text a potom stiskněte klávesu ENTER.

      Pro náš spojnicový graf jsme zadali Úroveň částic jako název hlavní svislé osy a Denní srážkový úhrn jako název vedlejší svislé osy.

  15. Klepněte na Oblast grafu grafu nebo ji vyberte ze seznamu prvků grafu (karta Rozložení, skupina Aktuální výběr, pole Prvky grafu).

  16. Na kartě Formát ve skupině Styl obrazce klepněte na tlačítko Upřesnit Obrázek tlačítka a poté klepněte na efekt, který chcete použít.

    Pro náš spojnicový graf jsme použili možnost Jemný efekt - tmavý 1.

    Skupina Styly obrazců na pásu karet aplikace Excel

  17. Klepněte na oblast grafu.

  18. Na kartě Formát ve skupině Styl obrazce klepněte na tlačítko Upřesnit Obrázek tlačítka a poté klepněte na efekt, který chcete použít.

    Pro náš spojnicový graf jsme použili možnost Jemný efekt - Zvýraznění 3.

  19. Pokud chcete použít odlišné barvy motivu od výchozího motivu použitého u sešitu, proveďte následující kroky:

    1. Na kartě Rozložení stránky ve skupinovém rámečku Motivy klepněte na položku Motivy .

      Vzhled pásu karet aplikace Excel

    2. Ve skupinovém rámečku Předdefinované klepněte na motiv, který chcete použít.

      V našem spojnicovém grafu je použit motiv Kancelář.

Začátek stránky

Uložení grafu jako šablony

Pokud chcete vytvořit jiný graf podobný grafu, který jste právě vytvořili, můžete tento graf uložit jako šablonu, která slouží jako základ pro jiné podobné grafy.

  1. Klepněte na graf, který chcete uložit jako šablonu.

  2. Na kartě Návrh klepněte ve skupině Typ na možnost Uložit jako šablonu.

    Vzhled pásu karet aplikace Excel

  3. Do pole Název souboru zadejte název šablony.

    Tip : Pokud nezadáte jinou složku, bude soubor šablony (CRTX) uložen do složky Grafy a šablona bude k dispozici v části Šablony v dialogovém okně Vložit graf (karta Vložení, skupina Grafy, tlačítko Spouštění dialogového okna Obrázek tlačítka ) a v dialogovém okně Změnit typ grafu (karta Návrh, skupina Typ, tlačítko Změnit typ grafu).

    Další informace o způsobu použití šablony grafu najdete v tématu Opakované použití oblíbeného grafu pomocí šablony grafu.

Poznámka : Šablona grafu obsahuje formátování a uloží barvy, které jsou použity při uložení grafu jako šablony. Pokud použijete šablonu grafu k vytvoření grafu v jiném sešitu, použije nový graf barvy šablony, spíše než barvy motivu dokumentu aktuálně použitého u sešitu. Pro použití barvy motivu dokumentu namísto barvy šablony grafu klepněte pravým tlačítkem myši na Oblast grafu a v místní nabídce klepněte na tlačítko Obnovit a srovnat se stylem.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×