Použití aplikace Excel Starter 2010 a starších verzí aplikace Excel

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Použití Microsoft Excel Starter 2010, pokud chcete vědět, jak můžete pokračovat v práci s sešity, které jsou vytvořené v dřívější verzi aplikace Excel, jak můžete ponechat tyto sešity dostupné pro uživatele, kteří nemají aktuální verzi nainstalovanou aplikaci Excel a jak rozdílů mezi verzemi ovlivňují, kdy pracujete.

Poznámka : Zpětná kompatibilita se staršími verzemi aplikace Excel je odlišná od kompatibility mezi aplikací Excel Starter a úplnou verzí aplikace Excel. Informace o tom, jakým způsobem jsou funkce aplikace Excel podporovány v aplikaci Excel Starter, naleznete v tématu Podpora funkcí aplikace Excel Starter.

Pokud chcete zajistit zpětnou kompatibilitu se staršími verzemi Excelu, například aplikací Excel 97-2003 nebo Excel 2007, může použít jeden z několika způsobů používání sešitů v různých verzích Excelu.

  • Práce v režimu kompatibility:    Sešit vytvořený ve starší verzi Excelu můžete otevřít a pracovat s ním v režimu kompatibility. Soubor tak zůstane ve formátu, který potom můžete znovu snadno otevřít v dřívější verzi. Režim kompatibility není k dispozici u sešitů vytvořených v aplikaci Excel 2007.

  • Stažení převaděčů souborů:    K otevření sešitu aplikace Excel 2010 v dřívější verzi Excelu můžete použít převaděče souborů, které jsou k dispozici ke stažení.

  • Kontrola kompatibility sešitu:    Chcete-li pracovat s aktuálním formátem souborů, ale současně potřebujete sešit sdílet s uživateli, kteří používají starší verze aplikace Excel, můžete zkontrolovat, zda jsou data kompatibilní se staršími verzemi aplikace Excel. Potom můžete provést potřebné změny, abyste předešli ztrátě dat nebo přesnosti při otevření daného sešitu ve starší verzi aplikace Excel.

V tomto článku

Práce v režimu kompatibility v aplikaci Excel Starter 2010

Otevření sešitu aplikace Excel 2010 pomocí převaděčů souborů ve starších verzích aplikace Excel

Funkce aplikace Excel Starter 2010, které nejsou podporovány ve starších verzích aplikace Excel

Převod sešitu do formátu souboru aplikace Excel 2010

Funkce aplikací Excel 2007 a Excel 97–2003, které nejsou podporovány v aplikaci Excel Starter 2010

Ověření kompatibility sešitů se staršími verzemi aplikace Excel

Práce v režimu kompatibility v Excel Starter 2010

V Excel Starter 2010 při otevření sešitu, který byl vytvořený v Excelu 97 – 2003 se automaticky otevře v režimu kompatibility a zobrazí Text režim kompatibility v hranatých závorkách vedle názvu souboru v aplikaci Excel Záhlaví. Protože Excel 2007 používá jako Excel 2010 stejný formát souborů založený na jazyce XML (.xlsx nebo XLSM), sešit webové aplikace Excel 2007 neotevře v režimu kompatibility.

Formát souborů v režimu kompatibility

V režimu kompatibility nejsou při otevření sešitu k dispozici žádné nové nebo vylepšené funkce aplikace Excel 2010, aby při otevření sešitu v dřívější verzi Excelu nedošlo ke ztrátě dat a přesnosti. Namísto použití aktuálního formátu souborů (XLSX) je sešit taky uložený ve formátu souborů Excelu 97-2003 (XLS), který můžete otevřít v dřívějších verzích Excelu.

Automatizace režimu kompatibility

Na rozdíl od Microsoft Word Starter 2010, kde můžete ručně zapnutí režimu kompatibility, v aplikaci Excel Starter automaticky pracujete v režimu kompatibility při otevření sešitu ve formátu souboru dřívější verze. Nemáte možnost zahrnout všechny nové funkce při práci v sešitu v režimu kompatibility.

Ukončení režimu kompatibility

Pokud již nechcete pracovat v režimu kompatibility, můžete sešit převést do aktuálního formátu souborů. Potřebné informace naleznete v části Převod sešitu do formátu souboru aplikace Excel 2010.

Začátek stránky

Otevření sešitu aplikace Excel 2010 pomocí převaděčů souborů v dřívějších verzích Excelu

Konkrétní aktualizace a převaděče souborů jsou dostupné na Microsoft Office.com, které vám můžou pomoct otevření sešitu aplikace Excel 2010 v dřívějších verzích aplikace Excel (Excel 97 – 2003). Pokud jste ještě nenainstalovali aktualizace a převaděče, když se pokusíte otevřít sešit Excel 2010, můžete být vyzváni k tomuto.

Po instalaci aktualizací a převaděčů se všechny Excel 2010 sešity se dá otevřít tak, aby se daly upravovat a ukládat, aniž by bylo nutné upgradovat vaše verze aplikace Excel na Excel 2010. Excel 2010-specifických funkcí a formátování se nemusí zobrazit v dřívějších verzích aplikace Excel, ale při uložení sešitu a jeho opětovném otevření v Excel Starter 2010 jsou pořád dostupné. Další informace o funkcích a formátování, které se nezobrazily najdete v článku Aplikace Excel 2007 a Excelu 97 – 2003 funkce, které nejsou podporovány v aplikaci Excel Starter 2010.

Stažení a použití převaděčů souborů

  1. Na počítači, který má dřívější verzi aplikace Excel nenainstalovali stáhněte si sadu Microsoft Office Compatibility Pack z webu Stažení Microsoft Office a nainstalujte aktualizace a převaděče, které musíte mít k otevření sešitů Excel 2010.

  2. Otevřete sešit Excel 2010 ve starší verzi aplikace Excel (Excel 97 – 2003).

Začátek stránky

funkce Excel Starter 2010, které nejsou podporovány v dřívějších verzích aplikace Excel

Ne všechny Excel Starter 2010 jsou však podporovány ve starších verzích Excelu. Při práci v režimu kompatibility nebo chcete uložit sešit webové aplikace Excel 2010 do formátu souboru dřívější verze Excelu, nástroj Kontrola kompatibility vám může pomoct zjistit problémy, které způsobují významnou ztrátu funkčnosti nebo k menší ztrátě přesnosti v dřívější verzi aplikace Excel. Chcete-li předejít ztrátě dat nebo funkcí v dřívějších verzích aplikace Excel, můžete můžete proveďte potřebné změny k Excel 2010 sešitu.

Když uložíte Excel 2010 formátu souboru Excelu 97 – 2003, nástroj Kontrola kompatibility spustí automaticky. Však při ukládání sešitu do formátu souboru Excel 2007 poprvé, musíte spustit kontrolu kompatibility ručně. Pak zadáte, že se kontrola kompatibility spustí automaticky při každém uložení tohoto sešitu.

Poznámka : Chcete-li spustit nástroj Kontrola kompatibility ručně, klikněte na kartu Soubor, klikněte na položku Informace a v části Připravit na sdílení klikněte na tlačítko Zkontrolovat problémy a potom na položku Zkontrolovat kompatibilitu.

Nástroj Kontrola kompatibility zobrazí seznam zjištěných problémů s kompatibilitou a u většiny problémů zobrazí tlačítko Najít a Nápověda. Kliknutím na tato tlačítka můžete potom vyhledat všechny výskyty daného problému a získat informace o způsobech jeho řešení. Při automatickém spuštění nástroj Kontrola kompatibility uvede také verzi aplikace Excel, v níž k potenciálnímu problému s kompatibilitou dochází.

Kontrola kompatibility se zvýrazněnými verzemi

Nepodporované funkce listu

Nepodporované funkce listu mohou způsobovat následující problémy s kompatibilitou a vést k významné ztrátě funkčnosti nebo k menší ztrátě přesnosti.

Významná ztráta funkčnosti

Možné řešení

Tento sešit obsahuje data v buňkách mimo podporovanou oblast řádků a sloupců vybraného formátu souborů. Nebudou uložena žádná data mimo oblast 256 sloupců (IV) na 65 536 řádků. Odkaz vzorců na data v této oblasti vrátí chybu #ODKAZ!.

V Excel Starter 2010 velikost listu je 16 384 sloupců na 1 048 576 řádků, ale velikost listu dřívějších verzích aplikace Excel pouze 256 sloupců 65 536 řádků. V dřívějších verzích aplikace Excel dojde ke ztrátě dat v buňkách mimo limit tento sloupec a řádek.

Kliknutím na tlačítko Najít v nástroji Kontrola kompatibility vyhledejte buňky a oblasti spadající mimo omezení počtu řádků a sloupců, vyberte je a potom je pomocí příkazů Vyjmout a Vložit umístěte do sloupců a řádků, které spadají do omezení aplikace, nebo do jiného listu.

Sešit obsahuje data ve formátu kalendáře, který není ve vybraném formátu souboru podporován. Tato kalendářní data budou zobrazena ve formátu gregoriánského kalendáře.

V Excel Starter 2010 můžete vytvořit vlastní kalendáře formáty, jako jsou hebrejština lunárního japonské lunárního, čínština lunárního, Šaka, čínský, korejština zvěrokruh, Rokuyou lunárního a korejština lunárního. Tyto formáty kalendáře však nejsou podporovány v dřívějších verzích aplikace Excel.

Chcete-li předejít ztrátě funkčnosti, budete chtít pravděpodobně změnit formát kalendáře na jazyk (nebo národní prostředí) podporovaný ve starších verzích aplikace Excel.

Tento sešit obsahuje data ve formátu kalendáře, který není ve vybraném formátu souborů podporován. Úpravy těchto dat je nutné provést pomocí gregoriánského kalendáře.

V Excel Starter 2010 můžete použít typ kalendáře bez západního, například thajský buddhistický nebo hidžra arabština. V předchozích verzích aplikace Excel můžete tyto typy kalendářů upravovat pouze v gregoriánský kalendář.

Chcete-li předejít ztrátě funkčnosti, budete chtít pravděpodobně změnit formát kalendáře na jazyk (nebo národní prostředí) podporovaný ve starších verzích aplikace Excel.

Tento sešit obsahuje více buněk s daty, než je počet podporovaný ve starších verzích aplikace Excel. Ve starších verzích aplikace Excel nebude možné tento sešit otevřít.

V Excel Starter 2010 celkový počet dostupných bloků buněk (bloků buněk) omezený dostupnou pamětí. V dřívějších verzích aplikace Excel však celkový počet dostupných bloků buněk se omezí na 64 000 bloků buněk v instanci aplikace Excel.

Blok buněk obsahuje 16 řádků listu. Pokud všechny řádky v listu obsahují data, bude v daném listu 4 096 bloků buněk a v jedné instanci aplikace Excel může být pouze 16 takovýchto listů (bez ohledu na počet sešitů otevřených v aplikaci Excel).

Abyste měli jistotu, že sešit nepřekročí Překročeno omezení 64 000 a lze otevřít v dřívějších verzích aplikace Excel, měli byste pracovat v režimu kompatibility v Excel Starter 2010 po uložení sešitu do formátu souboru Excelu 97 – 2003. V režimu kompatibility Excel sleduje počet bloků buněk v aktivním sešitu.

Menší ztráta přesnosti

Možné řešení

Předchozí verze aplikace Excel nepodporují formátování barev v textu záhlaví a zápatí. Informace s formátováním barev budou ve starších verzích aplikace Excel zobrazeny jako prostý text.

V Excel Starter 2010 můžete použít formátování textu v záhlaví a zápatí. Nelze použít formátování barev v záhlaví a zápatí v dřívějších verzích aplikace Excel.

Kliknutím na tlačítko Opravit v nástroji Kontrola kompatibility můžete formátování barev odebrat.

Tento sešit obsahuje listy se záhlavími a zápatími sudých stránek nebo první stránky. Tato záhlaví a zápatí stránek nelze ve starších verzích aplikace Excel zobrazit.

V Excel Starter 2010 máte možnost zobrazení různých záhlaví a zápatí na sudých stránkách nebo na první stránce. Tato možnost není k dispozici v dřívějších verzích aplikace Excel. Sudé stránky nebo první záhlaví a zápatí stránky nelze zobrazit ve starších verzích, ale zůstanou dostupné pro zobrazení, při dalším otevření sešitu v Excel Starter 2010.

Pokud sešit otevíráte ve formátu souboru starší verze aplikace Excel často, doporučujeme záhlaví a zápatí sudých stránek a první stránky pro daný sešit přestat používat.

Některé buňky nebo styly v tomto sešitu obsahují formátování, které není vybraným formátem souborů podporováno. Tyto formáty budou převedeny na nejblíže odpovídající formát, který je k dispozici.

V Excel Starter 2010 jsou k dispozici, například zvláštní efekty a stínování formátování jiné buňky nebo možnosti stylu buňky. Tyto možnosti nejsou k dispozici v dřívějších verzích aplikace Excel.

Před uložením sešitu ve formátu souboru předchozí verze aplikace Excel můžete přijmout nejblíže odpovídající formát, který bude použit při uložení sešitu, nebo změnit či odebrat styl buňky, který není podporován.

Tento sešit obsahuje více jedinečných formátů buňky, než je ve vybraném formátu souborů podporováno. Některé formáty buňky nebudou uloženy.

V Excel Starter 2010 můžete použít 64 000 jedinečných formátů buňky, ale v dřívějších verzích aplikace Excel, můžete použít jenom až 4 000 jedinečných formátů buněk. Jedinečných formátů buňky zahrnout konkrétní kombinací formátování, které je použité v sešitu.

Tento sešit obsahuje více jedinečných formátů písma, než je ve vybraném formátu souborů podporováno. Některé formáty písma nebudou uloženy.

V Excel Starter 2010 1 024 globálních typů písem jsou k dispozici a můžete maximálně 512 sešitu jich.

Začátek stránky

Nepodporované funkce tabulky aplikace Excel

Nepodporované funkce tabulky aplikace Excel mohou způsobit následující problémy s kompatibilitou a vést k menší ztrátě přesnosti.

Menší ztráta přesnosti

Možné řešení

Tabulka obsahuje vlastní vzorec nebo text v řádku souhrnů. Ve starších verzích aplikace Excel se data zobrazí bez tabulky.

V Excel Starter 2010 můžete použít vlastní vzorců a text v řádku Celkem tabulky, ale to není podporováno v dřívějších verzích aplikace Excel. I když bude platit vzorce, oblast již nebude možné tabulky. Pokud chcete v tabulce v dřívějších verzích aplikace Excel, můžete odebrat vlastního textu a použít pouze vzorce, které jsou k dispozici v řádku celkem.

Kliknutím na tlačítko Najít v nástroji Kontrola kompatibility vyhledejte tabulku obsahující vlastní vzorec nebo text a odeberte vzorec nebo text z řádku souhrnů.

V tabulce tohoto sešitu není zobrazen řádek záhlaví. Ve starších verzích aplikace Excel se data zobrazí bez tabulky, pokud nebude zaškrtnuto políčko Se záhlavím (Nástroje tabulky, karta Návrh, skupina Možnosti stylů tabulek).

V Excel Starter 2010 máte možnost zobrazit nebo skrýt řádek záhlaví tabulky. V dřívějších verzích aplikace Excel má tabulky vždy řádek záhlaví.

Kliknutím na tlačítko Najít v nástroji Kontrola kompatibility vyhledejte tabulku bez zobrazeného řádku záhlaví a řádek záhlaví zobrazte.

Tento sešit obsahuje tabulku s použitým stylem tabulky. V předchozích verzích aplikace Excel nelze formátování stylu tabulky zobrazit.

V Excel Starter 2010 můžete rychle formátovat tabulku použitím stylu tabulky založené na motivu. V předchozích verzích aplikace Excel můžete tabulku formátovat pouze ručně.

Kliknutím na tlačítko Najít v nástroji Kontrola kompatibility vyhledejte tabulku se stylem tabulky a styl odstraňte.

Tabulka v tomto sešitu je připojena k externímu zdroji dat. Funkce tabulky budou ztraceny, ale data zůstanou připojena. Pokud jsou řádky tabulky skryty filtrem, zůstanou skryty i ve starší verzi aplikace Excel.

Funkce tabulky budou ve starší verzi aplikace Excel ztraceny, ale data zůstanou připojena.

Začátek stránky

Nepodporované funkce kontingenční tabulky

I když v aplikaci Excel Starter nejde vytvořit kontingenční tabulky, můžete při otevření sešitu, které byly uložené v Excel 2010, včetně nových funkcí kontingenční tabulky aplikace Excel Starter. Nepodporované funkce kontingenční tabulky mohou způsobit následující problémy kompatibility a vést k významné ztrátě funkčnosti nebo k menší ztrátě přesnosti.

Významná ztráta funkčnosti

Possi řešení tabulku

Kontingenční tabulka v tomto sešitu překračuje omezení předchozích verzí a v případě jejího uložení ve starších formátech souborů dojde ke ztrátě dat. Ve starších verzích aplikace Excel budou správně fungovat pouze kontingenční tabulky vytvořené v režimu kompatibility.

V Excel Starter 2010 podporuje kontingenční tabulka 1 048 576 jedinečných položek v poli, ale v dřívějších verzích aplikace Excel je podporovaných jenom 32 500 položek v poli.

Kliknutím na tlačítko Najít v nástroji Kontrola kompatibility vyhledejte kontingenční tabulku, která překračuje omezení předchozích verzí. Uložíte-li sešit ve formátu aplikace Excel 97–2003, můžete potom tuto kontingenční tabulku znovu vytvořit v režimu kompatibility.

Kontingenční tabulka tohoto sešitu obsahuje pravidla podmíněného formátování, která jsou použita u buněk ve sbalených řádcích nebo sloupcích. Chcete-li ztrátě těchto pravidel ve starších verzích aplikace Excel zabránit, rozbalte uvedené řádky či sloupce.

Pravidla podmíněného formátování v kontingenční tabulce budou ve starší verzi aplikace Excel ztracena.

Menší ztráta přesnosti

Možné řešení

Tento sešit obsahuje kontingenční tabulku s nastaveným stylem. Ve starších verzích aplikace Excel nelze formátování stylu kontingenční tabulky zobrazit.

Ve starších verzích aplikace Excel lze kontingenční tabulku formátovat pouze ručně. Kontingenční tabulka nebude ve starší verzi aplikace Excel zobrazena.

Kontingenční tabulka v tomto sešitu je vytvořena v aktuálním formátu souborů a ve starších verzích aplikace Excel nebude fungovat. Ve starších verzích aplikace Excel budou fungovat pouze kontingenční tabulky vytvořené v režimu kompatibility.

Kontingenční tabulky vytvořenou ve formátu Excel 2010 se nedá aktualizovat ve starších verzích Excelu. .

Začátek stránky

Nepodporované funkce řazení a filtrování

Nepodporované funkce řazení a filtrování mohou způsobit následující problémy s kompatibilitou a vést k menší ztrátě přesnosti.

Menší ztráta přesnosti

Možné řešení

List v tomto sešitu obsahuje řazení definované více než třemi podmínkami. Ve starších verzích aplikace Excel dojde ke ztrátě těchto informací.

V Excel Starter 2010 jehož aplikováním řazení státy s až 64 podmínek řazení řadit data podle, ale dřívější verze Excelu podporují řazení definované až tři podmínky. Chcete-li předejít ztrátě řazení informací v dřívějších verzích aplikace Excel, můžete změnit řazení, které používá více než tři podmínky. V dřívějších verzích aplikace Excel uživatelů můžete taky seřadit data ručně.

Všechny informace o stavu řazení však zůstávají k dispozici v sešitu a použijí se při dalším otevření sešitu v Excel Starter 2010, pokud nebyly upravené informace o stavu řazení v dřívější verzi aplikace Excel.

V nástroji Kontrola kompatibility vyhledejte kliknutím na tlačítko Najít data seřazená pomocí více než tří podmínek a použijte u nich řazení definované maximálně třemi podmínkami.

List v tomto sešitu obsahuje řazení definované podmínkou s vlastním seznamem. Ve starších verzích aplikace Excel dojde ke ztrátě těchto informací.

V Excel Starter 2010 můžete seřadit podle vlastního seznamu. Získat podobných výsledků řazení v dřívějších verzích aplikace Excel, můžete seskupovat data, která chcete seřadit a seřaďte data ručně.

Všechny informace o stavu řazení však zůstávají k dispozici v sešitu a použijí se při dalším otevření sešitu v Excel Starter 2010, pokud nebyly upravené informace o stavu řazení v dřívější verzi aplikace Excel.

Kliknutím na tlačítko Najít v nástroji Kontrola kompatibility vyhledejte data seřazená podle vlastního seznamu a upravte řazení tak, aby neobsahovalo vlastní seznam.

List tohoto sešitu obsahuje řazení používající podmínku, která určuje informace o formátování. Ve starších verzích aplikace Excel dojde ke ztrátě těchto informací.

V Excel Starter 2010 řazení dat podle určitého formátu, jako je barva buňky, barvu písma nebo sady ikon. V předchozích verzích aplikace Excel můžete řadit pouze text.

Všechny informace o stavu řazení však zůstávají k dispozici v sešitu a použijí se při dalším otevření sešitu v Excel Starter 2010, pokud nebyly upravené informace o stavu řazení v dřívější verzi aplikace Excel.

Kliknutím na tlačítko Najít v nástroji Kontrola kompatibility vyhledejte data seřazená podle určitého formátu a změňte řazení tak, aby neobsahovalo informace o formátování.

Některá data v tomto sešitu jsou filtrována způsobem, který není ve starších verzích aplikace Excel podporován. Řádky skryté pomocí takového filtru zůstanou ve starších verzích aplikace Excel skryté, ale samotný filtr nebude zobrazen správně.

V Excel Starter 2010 můžete použít filtry, které nejsou podporovány v dřívějších verzích aplikace Excel. Chcete-li předejít ztrátě funkcí filtru, je vhodné filtr vymazat, před uložením sešitu ve starším formátu souboru aplikace Excel. V dřívějších verzích aplikace Excel uživatelé mohou potom filtrovat data ručně.

Všechny informace o stavu filtru ale zůstávají dostupná v sešitu a, použijí se při dalším otevření sešitu v Excel Starter 2010, pokud nebyly upravené informace o stavu filtru v dřívější verzi aplikace Excel.

Kliknutím na tlačítko Najít v nástroji Kontrola kompatibility vyhledejte filtrovaná data a vymazáním filtru zobrazte skryté řádky. Na kartě Domů klikněte ve skupině Úpravy na tlačítko Seřadit a filtrovat a kliknutím na příkaz Vymazat filtr vymažte.

Některá data v tomto sešitu Filtrovat podle barvy buňky. Řádky, které jsou skryté filtrem zůstane skrytá, ale samotný filtr se nezobrazují správně v dřívějších verzích aplikace Excel.

V Excel Starter 2010 můžete filtrovat podle barev buněk, barev písma nebo sady ikon, který není podporován v dřívějších verzích aplikace Excel. Chcete-li předejít ztrátě funkcí filtru, je vhodné filtr vymazat, před uložením sešitu ve starším formátu souboru aplikace Excel. V dřívějších verzích aplikace Excel uživatelé mohou potom filtrovat data ručně.

Všechny informace o stavu filtru ale zůstávají k dispozici v sešitu a použijí se při dalším otevření sešitu v Excel Starter 2010, pokud nebyly upravené informace o stavu filtru v dřívější verzi aplikace Excel.

Kliknutím na tlačítko Najít v nástroji Kontrola kompatibility vyhledejte filtrovaná data a vymazáním filtru zobrazte skryté řádky. Na kartě Domů klikněte ve skupině Úpravy na tlačítko Seřadit a filtrovat a kliknutím na příkaz Vymazat filtr vymažte.

Některá data v tomto sešitu jsou filtrována podle barvy písma. Řádky skryté pomocí takového filtru zůstanou ve starších verzích aplikace Excel skryté, ale samotný filtr nebude zobrazen správně.

V Excel Starter 2010 můžete filtrovat podle barev buněk, barev písma nebo sady ikon, který není podporován v dřívějších verzích aplikace Excel. Chcete-li předejít ztrátě funkcí filtru, je vhodné filtr vymazat, před uložením sešitu ve starším formátu souboru aplikace Excel. V dřívějších verzích aplikace Excel uživatelé mohou potom filtrovat data ručně.

Všechny informace o stavu filtru ale zůstávají dostupná v sešitu a, použijí se při dalším otevření sešitu v Excel Starter 2010, pokud nebyly upravené informace o stavu filtru v dřívější verzi aplikace Excel.

Kliknutím na tlačítko Najít v nástroji Kontrola kompatibility vyhledejte filtrovaná data a vymazáním filtru zobrazte skryté řádky. Na kartě Domů klikněte ve skupině Úpravy na tlačítko Seřadit a filtrovat a kliknutím na příkaz Vymazat filtr vymažte.

Některá data v tomto sešitu jsou filtrována podle ikony buňky. Řádky skryté pomocí takového filtru zůstanou ve starších verzích aplikace Excel skryté, ale samotný filtr nebude zobrazen správně.

V Excel Starter 2010 můžete filtrovat podle barev buněk, barev písma nebo sady ikon, který není podporován v dřívějších verzích aplikace Excel. Chcete-li předejít ztrátě funkcí filtru, je vhodné filtr vymazat, před uložením sešitu ve starším formátu souboru aplikace Excel. V dřívějších verzích aplikace Excel uživatelé mohou potom filtrovat data ručně.

Všechny informace o stavu filtru ale zůstávají k dispozici v sešitu a použijí se při dalším otevření sešitu v Excel Starter 2010, pokud nebyly upravené informace o stavu filtru v dřívější verzi aplikace Excel.

Kliknutím na tlačítko Najít v nástroji Kontrola kompatibility vyhledejte filtrovaná data a vymazáním filtru zobrazte skryté řádky. Na kartě Domů klikněte ve skupině Úpravy na tlačítko Seřadit a filtrovat a kliknutím na příkaz Vymazat filtr vymažte.

Tento sešit obsahuje data filtrovaná podle více než dvou kritérií. Řádky skryté pomocí takového filtru zůstanou ve starších verzích aplikace Excel skryté, ale samotný filtr nebude zobrazen správně.

V Excel Starter 2010 můžete data filtrovat podle víc než dvou kritérií. Chcete-li předejít ztrátě funkcí filtru, je vhodné filtr vymazat, před uložením sešitu ve starším formátu souboru aplikace Excel. V dřívějších verzích aplikace Excel uživatelé mohou potom filtrovat data ručně.

Však všechny informace o stavu filtru zůstávají k dispozici v sešitu a použijí se při dalším otevření sešitu znovu v Excel Starter 2010, pokud filtr uveďte informace upravené v dřívější verzi aplikace Excel.

Kliknutím na tlačítko Najít v nástroji Kontrola kompatibility vyhledejte filtrovaná data a vymazáním filtru zobrazte skryté řádky. Na kartě Domů klikněte ve skupině Úpravy na tlačítko Seřadit a filtrovat a kliknutím na příkaz Vymazat filtr vymažte.

Tento sešit obsahuje data filtrovaná podle seskupené hierarchie kalendářních dat, jejímž výsledkem jsou více než dvě kritéria. Řádky skryté pomocí takového filtru zůstanou ve starších verzích aplikace Excel skryté, ale samotný filtr nebude zobrazen správně.

V Excel Starter 2010 můžete filtrovat data podle seskupené hierarchie. Protože to není podporován v dřívějších verzích aplikace Excel, je vhodné oddělit hierarchie kalendářní data. Chcete-li předejít ztrátě funkcí filtru, je vhodné filtr vymazat, před uložením sešitu ve starším formátu souboru aplikace Excel.

Všechny informace o stavu filtru ale zůstávají k dispozici v sešitu a použijí se při dalším otevření sešitu v Excel Starter 2010, pokud nebyly upravené informace o stavu filtru v dřívější verzi aplikace Excel.

Kliknutím na tlačítko Najít v nástroji Kontrola kompatibility vyhledejte filtrovaná data a vymazáním filtru zobrazte skryté řádky. Na kartě Domů klikněte ve skupině Úpravy na tlačítko Seřadit a filtrovat a kliknutím na příkaz Vymazat filtr vymažte.

Seskupování dat lze také vypnout na kartě Upřesnit v dialogovém okně Možnosti aplikace Excel. (Soubor karta Možnosti v části aplikace Excel). V části Zobrazit možnosti pro tento sešit zrušte zaškrtnutí políčka Seskupit data v nabídce Automatický filtr.

Začátek stránky

Nepodporované funkce pro vzorce

Nepodporované funkce pro vzorce mohou způsobovat následující problémy s kompatibilitou a vést k významné ztrátě funkčnosti nebo k menší ztrátě přesnosti.

Významná ztráta funkčnosti

Možné řešení

Některé listy obsahují více maticových vzorců odkazujících na jiné listy, než je ve vybraném formátu souborů podporováno. Některé z těchto maticových vzorců nebudou uloženy a budou převedeny na chyby #HODNOTA!.

V Excel Starter 2010 maticové vzorce v sešitu, které odkazují na jiné sešity omezený dostupnou pamětí, ale v dřívějších verzích aplikace Excel může obsahovat listy pouze až 65,472 maticové vzorce v sešitu, které odkazují na jiné sešity. Maticové vzorce v sešitu mimo maximální limit budou převedeny na a zobrazit #VALUE! chyby.

Kliknutím na tlačítko Najít v nástroji Kontrola kompatibility vyhledejte buňky obsahující maticové vzorce, které odkazují na jiný list, a proveďte potřebné změny, které zabrání chybám #HODNOTA!.

Některé vzorce obsahují více hodnot, odkazů nebo názvů, než je ve vybraném formátu souborů podporováno. Tyto vzorce nebudou uloženy a budou převedeny na chyby #HODNOTA!.

V Excel Starter 2010 maximální délka obsahu vzorce je 8 192 znaků a maximální vnitřní délka vzorce 16 384 bajtů. V předchozích verzích aplikace Excel maximální délka obsahu vzorce je jenom 1 024 znaků, a maximální vnitřní délka vzorce pouze 1 800 bajtů. Pokud kombinaci argumentů vzorce (včetně hodnoty, odkazy a/nebo názvů) vyšší než maximální limity dřívějších verzích aplikace Excel, vzorce výsledkem bude #VALUE! chyby při uložení sešitu na starší formát souborů aplikace Excel.

Kliknutím na tlačítko Najít v nástroji Kontrola kompatibility vyhledejte buňky obsahující vzorce překračující omezení předchozích verzí aplikace Excel a proveďte potřebné změny, které zabrání chybám #HODNOTA!.

Některé vzorce zahrnují více úrovní vnoření, než je ve vybraném formátu souborů podporováno. Vzorce s více než sedmi úrovněmi vnoření nebudou uloženy a budou převedeny na chyby #HODNOTA!.

V Excel Starter 2010 může vzorec obsahovat až 64 úrovní vnoření, ale v dřívějších verzích aplikace Excel úrovní vnoření pouze 7.

Kliknutím na tlačítko Najít v nástroji Kontrola kompatibility vyhledejte buňky obsahující vzorce s více než sedmi úrovněmi vnoření a proveďte potřebné změny, které zabrání chybám #HODNOTA!.

Další informace:

Některé vzorce obsahují funkce s více argumenty, než je ve vybraném formátu souborů podporováno. Vzorce s více než 30 argumenty na funkci nebudou uloženy a budou převedeny na chyby #HODNOTA!.

V Excel Starter 2010 může vzorec obsahovat až 255 argumentů, ale v dřívějších verzích aplikace Excel maximální počet argumentů ve vzorci omezen na 30.

Kliknutím na tlačítko Najít v nástroji Kontrola kompatibility vyhledejte buňky obsahující vzorce s více než 30 argumenty a proveďte potřebné změny, které zabrání chybám #HODNOTA!.

Některé vzorce používají více operandů, než je ve vybraném formátu souborů povoleno. Tyto vzorce nebudou uloženy a budou převedeny na chyby #HODNOTA!.

V Excel Starter 2010 je maximální počet operandy, které lze použít ve vzorcích použít až 1 024, ale v dřívějších verzích aplikace Excel maximální limit operandy ve vzorcích maximálně 40.

Kliknutím na tlačítko Najít v nástroji Kontrola kompatibility vyhledejte buňky obsahující vzorce s více než 40 operandy a proveďte potřebné změny, které zabrání chybám #HODNOTA!.

Jedna či více funkcí tohoto sešitu není ve starších verzích aplikace Excel k dispozici. Při přepočtu ve starších verzích vrátí tyto funkce místo aktuálních výsledků chybu #NÁZEV?.

Excel Starter 2010 obsahuje nové funkce, které nejsou k dispozici v dřívějších verzích aplikace Excel.

Při uložení sešitu ve formátu souborů aplikace Excel 97-2003 nebo Excel 2007 a otevřít v dřívější verzi aplikace Excel, zobrazí se všechny nové funkce zobrazí se chybová zpráva. V některých případech je ke vzorec, nebo příklad, přidána předpona _xlfn = _xlfn. IFERROR (1, 2). V ostatních případech vrátí nepodporované vzorec #NAME? došlo k chybě.

V nástroji Kontrola kompatibility klikněte na tlačítko Najít vyhledejte buňky obsahující funkce, které jsou nové v Excel Starter 2010 a proveďte potřebné změny, které zabrání #NAME? chyby.

Některé vzorce obsahují odkazy na tabulky, které nejsou ve vybraném formátu souborů podporovány. Tyto odkazy budou převedeny na odkazy na buňky.

V Excel Starter 2010 můžete použít strukturované odkazy aby bylo jednodušší a intuitivnější pracovat s tabulkou dat při použití vzorců, které odkazují na tabulku, částí tabulky nebo celou tabulku. Tato funkce není podporováno v dřívějších verzích Excelu a strukturované odkazy se převedou na odkazy na buňky.

Kliknutím na tlačítko Najít v nástroji Kontrola kompatibility vyhledejte buňky obsahující vzorce se strukturovanými odkazy na tabulky a změňte je na odkazy na buňky.

Některé vzorce obsahují odkazy na tabulky v jiných sešitech, které nejsou v této instanci aplikace Excel aktuálně otevřeny. Tyto odkazy budou při uložení do formátu aplikace Excel 97–2003 převedeny na chyby #ODKAZ, protože je nelze převést na odkazy na list.

V Excel Starter 2010 můžete použít strukturované odkazy aby bylo jednodušší a intuitivnější pracovat s tabulkou dat při použití vzorců, které odkazují na tabulku, částí tabulky nebo celou tabulku. Tato funkce není podporováno v dřívějších verzích Excelu a strukturované odkazy se převedou na odkazy na buňky. Ale pokud strukturovaných odkazů přejděte na tabulky v jiných sešitech, které nejsou aktuálně otevřené, se budou převedeny na a chyby #REF.

Kliknutím na tlačítko Najít v nástroji Kontrola kompatibility vyhledejte buňky obsahující vzorce se strukturovanými odkazy na tabulky v jiných sešitech a proveďte potřebné změny, které zabrání chybám #ODKAZ.

Menší ztráta přesnosti

Možné řešení

Některé maticové vzorce tohoto sešitu odkazují na celý sloupec. Ve starších verzích aplikace Excel budou pravděpodobně tyto vzorce při přepočtu převedeny na chyby #ČÍSLO!.

Maticové vzorce, které odkazují na celý sloupec Excel Starter 2010 budou převedeny na a zobrazí jako #NUM! chyby při přepočtu v dřívějších verzích aplikace Excel.

Kliknutím na tlačítko Najít v nástroji Kontrola kompatibility vyhledejte maticové vzorce, které odkazují na celý sloupec, a proveďte potřebné změny, které zabrání chybám #NUM.

Jeden nebo více definovaných názvů v tomto sešitu obsahuje více než 255 znaků povolených ve vybraném formátu souborů. Tyto vzorce budou uloženy, ale při úpravách ve starších verzích aplikace Excel budou zkráceny.

Pokud pojmenované oblasti ve vzorcích obsahují více než 255 znaků, což je maximální počet podporovaný ve starších verzích aplikace Excel, budou vzorce pracovat správně, ale v dialogovém okně Název budou zkráceny a nebude je možné upravit.

Kliknutím na tlačítko Najít v nástroji Kontrola kompatibility vyhledejte buňky obsahující vzorce s pojmenovanými oblastmi a proveďte potřebné změny, aby uživatelé mohli upravovat vzorce ve starších verzích aplikace Excel.

Některé vzorce tohoto sešitu jsou propojeny s jinými sešity, které jsou zavřené. Jestliže nejsou propojené sešity otevřené, je ve starších verzích aplikace Excel při přepočtu vzorců vráceno maximálně 255 znaků.

Pokud jsou vzorce v sešitu propojeny s jinými sešity, které jsou zavřené, lze při jejich přepočtu ve starších verzích aplikace Excel zobrazit maximálně 255 znaků. Výsledky vzorce mohou být zkráceny.

Kliknutím na tlačítko Najít v nástroji Kontrola kompatibility vyhledejte buňky obsahující vzorce odkazující na jiné sešity, které jsou zavřené. Tyto odkazy ověřte a proveďte potřebné změny, které zabrání zkrácení výsledků vzorců ve starších verzích aplikace Excel.

Vzorec ověření dat obsahuje více než 255 znaků.

Pokud vzorec ověření dat obsahuje více než 255 znaků, což je maximální počet podporovaný ve starších verzích aplikace Excel, bude vzorec pracovat správně, ale bude zkrácen a nebude možné jej upravit.

Kliknutím na tlačítko Najít v nástroji Kontrola kompatibility vyhledejte buňky obsahující vzorce ověření dat a snižte počet znaků ve vzorcích, aby bylo možné vzorce upravovat ve starších verzích aplikace Excel.

Začátek stránky

Nepodporované funkce podmíněného formátování

Nepodporované funkce podmíněného formátování mohou způsobit následující problémy s kompatibilitou a vést k významné ztrátě funkčnosti.

Významná ztráta funkčnosti

Možné řešení

U některých buněk je použito více typů podmíněného formátování, než je ve vybraném formátu souborů podporováno. Ve starších verzích aplikace Excel se zobrazí pouze první tři podmínky.

V Excel Starter 2010 může podmíněné formátování obsahovat až 64 podmínek, ale v Excelu 97 – 2003 podporuje pouze tři podmínky.

V předchozích verzích aplikace Excel uživatelům se zobrazí jenom první tři podmínky. Všechna pravidla podmíněného formátování ale zůstávají dostupná v sešitu a použijí se při dalším otevření sešitu v Excel Starter 2010, pokud jsou upravena v dřívější verzi aplikace Excel.

Kliknutím na tlačítko Najít v nástroji Kontrola kompatibility vyhledejte buňky s podmíněným formátováním s více než třemi podmínkami a proveďte potřebné změny.

Některé buňky obsahují překrývající se oblasti podmíněného formátování. Ve starších verzích aplikace Excel nebudou vyhodnocena všechna pravidla podmíněného formátování v překrývajících se buňkách. V uvedených buňkách se zobrazí jiné podmíněné formátování.

V Excel Starter 2010 oblastmi podmíněného formátování v buňce můžete překrývat, ale to není podporováno v dřívějších verzích Excelu a nezobrazuje podmíněné formátování podle očekávání.

V dřívějších verzích aplikace Excel se zobrazí uživatelům jiné podmíněné formátování než byste čekali. Všechna pravidla podmíněného formátování ale zůstávají dostupná v sešitu a použijí se při dalším otevření sešitu v Excel Starter 2010, pokud jsou upravena v dřívější verzi aplikace Excel.

Kliknutím na tlačítko Najít v nástroji Kontrola kompatibility vyhledejte buňky s překrývajícími se oblastmi podmíněného formátování a proveďte potřebné změny.

Nejméně jedna buňka v tomto sešitu obsahuje typ podmíněného formátování, který není ve starších verzích aplikace Excel podporován (například datové pruhy, barevné škály nebo sady ikon).

Excel Starter 2010 poskytuje následující typy podmíněného formátování, které nejsou podporované v Excelu 97 – 2003:

  • Barevné škály

  • Datové pruhy

  • Sady ikon

  • Hodnoty zařazené jako první nebo poslední

  • Hodnoty větší nebo menší, než je průměr

  • Jedinečné nebo duplicitní hodnoty

  • Porovnání sloupců tabulek určující buňky k formátování

Ve starších verzích Excelu nebude uvidí podmíněné formátování, například datové pruhy, barevné škály nebo ikonu sady. Všechna pravidla podmíněného formátování ale zůstávají dostupná v sešitu a použijí se při dalším otevření sešitu v Excel Starter 2010, pokud jsou upravena v dřívější verzi aplikace Excel.

V nástroji Kontrola kompatibility klikněte na tlačítko Najít vyhledejte buňky s typy podmíněného formátování, které jsou nové v Excel Starter 2010 a proveďte potřebné změny.

Některé buňky obsahují podmíněné formátování, u kterého není zaškrtnuto políčko Zastavit, pokud platí. Starší verze aplikace Excel tuto možnost nerozpoznají a zastaví po první pravdivé podmínce.

V Excel Starter 2010 můžete použít podmíněné formátování bez splnění krátkou zprávu, pokud je podmínka. To není podporováno v dřívějších verzích aplikace Excel.

Kliknutím na tlačítko Najít v nástroji Kontrola kompatibility vyhledejte buňky obsahující podmíněné formátování, u kterého není zaškrtnuto políčko Zastavit, pokud platí, a kliknutím na tlačítko Opravit problém s kompatibilitou vyřešte.

V dřívějších verzích aplikace Excel podmíněné formátování výsledky se nebudou stejné jako v Excel Starter 2010, protože podmíněné formátování se použije už není po první podmínka pravdivá. Všechna pravidla podmíněného formátování ale zůstávají dostupná v sešitu a použijí se při dalším otevření sešitu v Excel Starter 2010, pokud jsou upravena v dřívější verzi aplikace Excel.

Nejméně jedna buňka v tomto sešitu obsahuje typ podmíněného formátování v nesousedící oblasti (jako například prvních či posledních N položek, prvních či posledních N %, nižší nebo vyšší než průměr, nižší nebo vyšší než standardní odchylka). Takové formátování není ve starších verzích aplikace Excel podporováno.

V Excel Starter 2010 můžete použít podmíněné formátování oblastí, které nejsou sousedních. To není podporováno v dřívějších verzích aplikace Excel.

Ve starších verzích Excelu nebudou uvidí podmíněné formátování nesousedících buněk. Všechna pravidla podmíněného formátování ale zůstávají dostupná v sešitu a použijí se při dalším otevření sešitu v Excel Starter 2010, pokud jsou upravena v dřívější verzi aplikace Excel.

Kliknutím na tlačítko Najít v nástroji Kontrola kompatibility vyhledejte buňky obsahující podmíněné formátování v nesousedících oblastech a proveďte potřebné změny.

Některé kontingenční tabulky v tomto sešitu obsahují podmíněné formátování, které pravděpodobně nebude ve starších verzích aplikace Excel pracovat správně. Pravidla podmíněného formátování nezobrazí stejné výsledky, pokud použijete tyto kontingenční tabulky ve starších verzích aplikace Excel.

Podmíněné formátování, které se použije pro Excel Starter 2010 kontingenční tabulky nezobrazuje stejných výsledků v kontingenčních tabulkách v dřívějších verzích aplikace Excel.

Ve starších verzích Excelu nebudou výsledky podmíněného formátování v kontingenčních tabulkách stejný jako Excel Starter 2010. Všechna pravidla podmíněného formátování ale zůstávají dostupná v sešitu a použijí se při dalším otevření sešitu v Excel Starter 2010, pokud jsou upravena v dřívější verzi aplikace Excel.

Kliknutím na tlačítko Najít v nástroji Kontrola kompatibility vyhledejte pole kontingenční tabulky s pravidly podmíněného formátování a proveďte potřebné změny.

Začátek stránky

Nepodporované objekty a grafické objekty

Nepodporované objekty a grafické objekty mohou způsobit následující problémy s kompatibilitou a vést k významné ztrátě funkčnosti.

Významná ztráta funkčnosti

Řešení

Všechny efekty použité u tohoto objektu budou odebrány. Jakýkoli text přetékající mimo hranice grafiky se zobrazí oříznutě.

V Excel Starter 2010 můžete použít zvláštní efekty, například průhledné stíny, které nejsou podporovány v dřívějších verzích aplikace Excel. Zvláštní efekty se odeberou. Také v Excel Starter 2010 při vkládání textu v obrazci, který je delší než obrazec, text politím mimo hranice obrazce. V dřívějších verzích aplikace Excel tento text bude zkrácen. Chcete-li předejít zkrácené textové, můžete upravit velikost obrazce vešel.

Kliknutím na tlačítko Najít v nástroji Kontrola kompatibility vyhledejte objekty se zvláštními efekty a podle potřeby tyto zvláštní efekty odeberte.

Vložený objekt tohoto listu je vytvořen v novější verzi systému Office. Ve starší verzi aplikace Excel jej nelze upravit.

Vložené objekty vytvořené v Excel Starter 2010 nejde upravovat v dřívějších verzích aplikace Excel.

Začátek stránky

Převod sešitu do formátu souboru Excel 2010

Pokud otevřete sešit vytvořený v Excelu 97 – 2003 a už plánovat všem uživatelům tohoto sešitem pracovat v dřívější verzi, můžete převést sešit na aktuální formát souboru Excel 2010. Když převedete na aktuální formát souboru, bude mít přístup k všechny nové a vylepšené funkce a funkce, které Excel Starter 2010 nabízí a velikost souboru bude menší.

Při převodu sešitu můžete postupovat následujícími způsoby:

  • Převod sešitu do aktuálního formátu souboru:    Při převodu je sešit nahrazen kopií sešitu v aktuálním formátu souboru (XLSX nebo XLSM). Sešit v původním formátu již nebude po převodu k dispozici.

    Poznámka : V aplikaci Excel Starter můžete sešit uložit ve formátu souboru XLM. Aplikace Excel Starter uloží makra, ale nemůže je načíst.

    Chcete-li převést sešit do aktuálního formátu souboru, postupujte podle následujících kroků:

    1. Otevřete sešit, který chcete převést do aktuálního formátu souboru.

      Poznámka : Sešit je otevřen v režimu kompatibility.

    2. Na kartě Soubor klikněte na položku Informace a potom v části Režim kompatibility klikněte na tlačítko Převést.

    3. Pokud se zobrazí zpráva o převodu sešitů, klikněte na tlačítko OK.

      Tip:    Nechcete-li, aby se zpráva o převodu sešitů zobrazovala, zaškrtněte políčko Již příště nezobrazovat dotaz na převedení sešitů.

    4. Chcete-li pracovat s aktuálním formátem souboru, kliknutím na tlačítko Ano sešit zavřete a znovu otevřete.

  • Uložení sešitu v aktuálním formátu souboru:    Pokud chcete zachovat kopii sešitu v původním formátu, sešit nepřevádějte, ale uložte jej v formátu aplikace Excel 2010 (XLSX).

    Chcete-li uložit sešit v aktuálním formátu souboru, postupujte podle následujících kroků:

    1. Na kartě Soubor klikněte na tlačítko Uložit jako.

    2. Do pole Název souboru zadejte nový název sešitu nebo použije navržený název.

    3. V seznamu Uložit jako typ proveďte některou z následujících akcí:

      • Chcete-li sešit uložit v aktuálním formátu sešitu aplikace Excel, klikněte na formát XLSX.

      • Chcete-li soubor uložit v novém binárním formátu, klikněte na formát XLSB.

      • Chcete-li sešit uložit jako šablonu, klikněte na formát XLTX.

      • Obsahuje-li sešit makra, která chcete zachovat, klikněte na formát XLSM.

      • Obsahuje-li sešit makra, která chcete zachovat, a chcete sešit uložit jako šablonu, klikněte na formát XLTM.

    4. Klikněte na tlačítko Uložit.

Začátek stránky

Excel Starter 2010 a funkce aplikace Excel 97-2003, které nejsou podporovány v Excel Starter 2010

Při otevření sešitu v Excel Starter 2010, který byl vytvořený v Excelu 97 – 2003 nejsou podporované některé funkce dřívější verzi aplikace Excel v sešitu. Nepodporované funkce buď nahrazena nových funkcí nebo mohly být odebrány protože byla použita jen zřídka.

Následující funkce aplikace Excel 97–2003 se mohou chovat odlišně, mohly být odebrány nebo nejsou k dispozici na pásu karet.

Nepodporované funkce listu

V Excel 97-200 3

In Excel Starter 2010

Pomocí funkce Automatický formát je možné použít jeden z několika automatických formátů a rychle tak naformátovat oblast dat.

Galerie stylů pro tabulky, buňky a kontingenční tabulky poskytují sadu profesionálních formátů, které lze rychle použít. Můžete vybírat z mnoha předdefinovaných stylů nebo podle potřeby vytvořit vlastní styly. Styly nahrazují funkci Automatický formát jako nejjednodušší způsob použití formátování u oblasti buněk.

Začátek stránky

Nepodporované funkce tabulky

V Excel 97-200 3

In Excel Starter 2010

Můžete vytvořit Seznam aplikace Excel, který usnadňuje správu a analýzu skupin souvisejících dat na listu.

Seznamy aplikace Excel se nyní označují jako tabulky aplikace Excel, aby tato funkce odpovídala jiným aplikacím systému Microsoft Office, jako jsou aplikace Word a PowerPoint.

Pomocí řádku vložení (zvláštní řádek v seznamech aplikace Excel) můžete rychle přidat nový řádek dat na konec seznamu.

Řádek vložení již není k dispozici. Chcete-li do tabulky přidat nové řádky, stiskněte klávesu TAB nebo zadejte či vložte data, která chcete zahrnout, přímo pod tabulku. Můžete také vložit řádky pro umístění dalších řádků dat.

Můžete definovat názvy pro seznamy.

Při vytvoření tabulky je současně pro danou oblast vytvořen definovaný název. Tento název lze použít k odkazování na tabulku ve vzorcích, které využívají novou funkci strukturovaného odkazování.

Názvy, které se používají pro seznamy ve starších verzích Excelu nesplňuje požadavky pro názvy oblastí v Excel Starter 2010 a proto je nelze použít pro odkazování na tabulky, vzorce, jejichž pomocí nové funkce strukturovaných odkazující. Použít názvy tabulek v strukturované odkazy, musíte změnit definované názvy.

Začátek stránky

Nepodporované funkce pro vzorce

V Excel 97-200 3

In Excel Starter 2010

Odkazy na celé řádky nebo sloupce použité v sešitu umožňují zahrnout data v buňkách, které se nacházejí v rámci celého řádku nebo sloupce v aplikaci Excel 97–2003.

Celý řádek odkazy nebo sloupce automaticky vzít v úvahu buněk v části Excel Starter 2010 větší velikost tabulky. To znamená, že odkaz = oddělíte, který odkazuje na A1:A65536 buněk v dřívějších verzích aplikace Excel, odkazuje A1:A1048576 buněk ve formátu Excel 2010.

V případě převodu sešitu ze starší verze Excelu do formátu souboru aplikace Excel 2010 může dojít k potížím, pokud se v daném sešitu používají odkazy na celé řádky nebo sloupce a do buněk přesahujících maximální počet řádků nebo sloupců ve starší verzi Excelu byla zadaná data, která se neměla do odkazů zahrnout.

Pokud určitých funkcí sloužících ke zjištění počtu buněk, řádků nebo sloupců v odkazované používaly (například COUNTBLANKřádkya sloupce) a tyto funkce odkazuje celé řádky nebo sloupce, výsledky, jejichž výsledkem je tato funkce může být jinak, než očekáváte.

Konkrétní názvy, které použijete kombinaci funkcí písmena a číslice (například USA1FOO100a MGR4) můžete definované a použít ve vzorcích v Excelu 97 – 2003, protože nedošlo ke konfliktu s odkazy na buňky.

Pomocí nové limit 16 384 sloupců rozšířit sloupce v Excel Starter 2010 sloupec XFD. To znamená, že bude platný odkazy na buňky v Excel Starter 2010 konfliktu konkrétní názvy (například USA1FOO100a MGR4), které můžete definovat v dřívějších verzích aplikace Excel. Kromě toho Excel Starter 2010 si vyhrazuje názvy, které začínají písmenem XL pro interní potřebu.

Pokud jsou při převodu sešitu z dřívější verze Excelu do formátu souboru aplikace Excel 2010 nalezeny nekompatibilní názvy, budete na tento konflikt upozornění. Pro odlišení těchto nekompatibilních názvů od odkazů na buňky se jako jejich předpona automaticky přidá znak podtržení (_).

Externí sešit odkazy a funkce, které přijímají řetězcové odkazy (například nepřímý.odkaz), aktualizovány nebudou – tyto odkazy a funkce je třeba změnit ručně.

Excel Starter 2010 také nezmění definovaných názvů, které se odkazuje pomocí jazyka Microsoft Visual Basic kódem Applications (VBA). Kód jazyka VBA, který odkazuje kompatibilní názvy nefunguje a musí být aktualizovány.

Začátek stránky

Nepodporované funkce pro práci s grafy

V Excel 97-200 3

In Excel Starter 2010

K vytvoření grafu můžete použít Průvodce grafem.

Graf vytvoříte kliknutím na požadovaný typ grafu na pásu karet (karta Vložení, skupina Graf). Jakmile graf vytvoříte, můžete jej upravovat a formátovat pomocí Nástrojů grafu.

Můžete změnit velikost více grafů najednou.

Velikost každého grafu je nutné změnit samostatně.

Je-li vybrán existující list s grafem, který obsahuje data, můžete stisknout klávesu F1, čímž vytvoříte list s grafem se stejnými daty.

Listy s grafem, které obsahují data, již nelze duplikovat stisknutím klávesy F11.

Stisknutím klávesy F11 v případě, že je vybrán existující list s grafem obsahující data, vytvoříte nový list s grafem bez dat.

Otočení prostorového grafu můžete změnit pomocí myši.

Ke změně otočení prostorového grafu nelze použít myš.

Otočení prostorového grafu můžete změnit pouze zadáním nastavení v kategorii Otočení v prostoru v dialogovém okně Formát oblasti grafu.

U prvků grafu můžete použít vzorkové výplně.

Namísto vzorkových výplní můžete u prvků grafu použít obrázkové a texturové výplně.

Grafy s vzorkové výplně vytvořených v dřívějších verzích aplikace Excel zobrazí stejná při otevření v Excel Starter 2010, ale nemůžete použít vzorek paměť zaplní za jiné prvky grafu.

Pomocí příkazu Velikost podle okna můžete nastavit automatickou změnu velikosti grafů umístěných na listech s grafem při změně velikosti okna.

Namísto příkazu Velikost podle okna můžete podobných výsledků dosáhnout pomocí příkazu Přejít na výběr.

V okamžiku, kdy kliknete na libovolné místo v grafu a začnete psát, se automaticky vytvoří textové pole.

Textové pole nelze vytvořit kliknutím na libovolné místo v grafu a zahájením psaní.

Chcete-li do grafu přidat textové pole, použijte příkaz Vložit textové pole.

Kopírovaný graf je ve výchozím nastavení vložen jako obrázek do dokumentu aplikace Word nebo prezentace aplikace PowerPoint.

Kopírovaný graf je ve výchozím nastavení vložený do dokumentu Word Starter 2010 jako objekt, který je propojená s daným Excelovým grafem.

Způsob vložení zkopírovaného grafu můžete změnit kliknutím na tlačítko Možnosti vložení, které se zobrazí při vložení grafu, a následným vložením grafu jako obrázku nebo celého sešitu.

Tabulku aplikace Word můžete použít jako data pro nový graf.

Tabulky v Word Starter 2010 nelze použít jako data pro nový graf.

Při vytvoření grafu v Word Starter 2010 uslyšíte listu s ukázkovými daty místo dat v tabulce vybrané slovo. Pokud chcete vykreslit nový graf data v tabulce aplikace Word, budete muset zkopírujte tato data do listu, nahrazení existující ukázková data.

Velikost vytištěného grafu a možnosti měřítka můžete zadat na kartě Graf dialogového okna Vzhled stránky. Karta Graf je k dispozici pouze v případě, že je graf vybraný (nabídka Soubor, příkaz Vzhled stránky).

Velikost vytištěného grafu a možnosti měřítka již nejsou k dispozici na kartě Graf dialogového okna Vzhled stránky. Karta Graf je k dispozici pouze v případě, že je graf vybraný (karta Rozložení stránky, skupina Vzhled stránky, ikona pro otevření dialogového okna Obrázek tlačítka ).

Přidání dat do grafu tak, že vyberete data v listu a přetáhnete ho na graf.

Data již nelze přetahovat z listu do grafu.

Data lze do grafu přidat pomocí jiných metod.

Je možné přetahovat Datové body v grafu a měnit tím jejich zdrojové hodnoty v listu.

Přetahování datových bodů s cílem změnit zdrojové hodnoty v listu již není podporováno.

Obrazce jsou nakreslené ve formátu, který se liší od formátu používaného v Excel Starter 2010.

Obrazce, které jsou nakreslené ve starších verzích Excelu nejde seskupené s obrazci, které jsou nakreslené ve Excel Starter 2010, i když obrazce jsou upgradovat na aktuální verzi. Se nedají vybrat obrazce, které jsou vytvořené v různých verzích Excelu ve stejnou dobu. Obrazce, které jsou vytvořené v různých verzích aplikace Excel jsou vrstvy nad aktuálním obrazce.

Podobně jako obrazce grafy, které jsou vytvořené v Excel Starter 2010 nelze vrstvy přes listy dialogů vytvořených v dřívějších verzích aplikace Excel a nedají se zobrazit grafy, které jsou vrstvy pod tyto listy dialogů.

Chcete-li vybrat aktuální grafy, použijte pole pro výběr prvků grafu (Nástroje grafu, karta Formát, skupina Aktuální výběr).

Začátek stránky

Nepodporované formáty souborů

Podpora pro následující formáty souborů byla odebrána z Office Starter 2010. Nebudete moct otevřít nebo Uložit sešity v těchto formátech souborů.

Formáty souborů nepodporované v aplikaci Excel 2010

WK1, ALL (1-2-3)

WK4 (1-2-3)

WJ1 (1-2-3, japonština) (WJ1)

WJ3 (1-2-3, japonština) (WJ3)

WKS (1-2-3)

WKS (Works, japonština) (WKS)

WK3, FM3 (1-2-3)

WK1, FMT (1-2-3)

WJ2 (1-2-3, japonština) (WJ2)

WJ3, FJ3 (1-2-3, japonština) (WJ3)

DBF 2 (dBASE II)

WQ1 (Quattro Pro/DOS)

Graf aplikace Microsoft Excel (XLC)

Podpora následujících formátů souborů se změnila.

Formát souboru

In Excel Starter 2010

Webová stránka (HTM, HTML)

Office Starter 2010 Neukládat excelových funkcí informace v tomto formátu. Otevření souboru v tomto formátu zachování všechny Excel funkcím vytvořených v dřívějších verzích aplikace Excel. V tomto formátu souboru pro publikování pouze však můžete uložit do souboru (nebo jiném sešitu).

Webová stránka tvořená jedním souborem (MHT, MHTML)

Office Starter 2010 Neukládat excelových funkcí informace v tomto formátu. Otevření souboru v tomto formátu zachování všechny Excel funkcím vytvořených v dřívějších verzích aplikace Excel. V tomto formátu souboru pro publikování pouze však můžete uložit do souboru (nebo jiném sešitu).

Začátek stránky

Ověření kompatibility sešitů se staršími verzemi aplikace Excel

Chcete-li se ujistit, zda v sešitu nedochází k problémům s kompatibilitou, které způsobují ve starších verzích aplikace Excel významné ztráty funkčnosti nebo menší ztráty přesnosti, spusťte nástroj Kontrola kompatibility. Nástroj Kontrola kompatibility zjišťuje možné problémy s kompatibilitou a pomáhá vytvořit sestavu, aby bylo možné tyto problémy řešit.

Důležité:    Pokud pracujete v režimu kompatibility se sešitem, který není v novém formátu aplikace Excel 2010 založeném na jazyce XML (XLSX) nebo v binárním formátu (XLSB), ale je ve formátu souboru Excelu 97-2003 (XLS), spustí se kontrola kompatibility automaticky při každém uložení sešitu.

  1. V Excel Starter 2010 otevřete sešit, který chcete zkontrolovat kompatibilitu.

  2. Na kartě Soubor klikněte na položku Informace.

  3. Klikněte na tlačítko Zkontrolovat problémy a potom na položku Zkontrolovat kompatibilitu.

    Dialogové okno Kontrola kompatibility

  4. Chcete-li kontrolovat kompatibilitu při každém uložení sešitu, zaškrtněte políčko Zkontrolovat kompatibilitu při uložení tohoto sešitu.

  5. Chcete-li vytvořit samostatný list se sestavou všech problémů uvedených v poli Souhrn, klikněte na tlačítko Kopírovat do nového listu.

    Tip:    Pokud jsou k dispozici, můžete kliknout na tlačítko Najít a vyhledat problémy v listu, nebo kliknout na tlačítko Opravit a vyřešit jednoduché problémy. Další informace potřebné k řešení složitějších problémů získáte kliknutím na tlačítko Nápověda.

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Byly tyto informace užitečné?

Jak ji můžeme vylepšit?

Jak ji můžeme vylepšit?

Pokud si chcete chránit soukromí, nedávejte do zpětné vazby kontaktní informace. Ohodnoťte aplikaci zásady ochrany osobních údajů.

Děkujeme vám za zpětnou vazbu.