Použití vzorců v tabulkách aplikací Word a Outlook

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Pomocí vzorců můžete v tabulkách provádět výpočty a logické operace. Příkaz Vzorec se nachází na kartě Nástroje tabulky - Rozložení ve skupině Data.

Skupina Data karty Nástroje tabulky - Rozložení na pásu karet v aplikaci Word 2010

Vzorec v aplikaci Word je automaticky aktualizován při otevření dokumentu, který ho obsahuje. Výsledek vzorce je ale také možné aktualizovat ručně. Další informace naleznete v části Aktualizace výsledků vzorce.

Poznámka :  Vzorce v tabulkách Wordu nebo Outlooku fungují na principu kódů polí. Další informace o kódech polí najdete v části Viz také.

V tomto článku:

Vložení vzorce do buňky v tabulce

Aktualizace výsledků vzorců

Aktualizace výsledku konkrétních vzorců

Aktualizace všech výsledků vzorce v tabulce

Aktualizace všech vzorců v dokumentu

Uzamknutí a odemknutí vzorce

Příklady: Součet čísel v tabulce pomocí argumentů pozice

Dostupné funkce

Používání názvů záložek (odkazů na buňky) ve vzorci

Odkazy typu RnCn

Odkazy A1

Vložení vzorce do buňky v tabulce

  1. Vyberte buňku tabulky, ve které chcete zobrazit výsledek. Pokud buňka není prázdná, odstraňte její obsah.

  2. Na kartě Nástroje tabulky - Rozložení ve skupině Data klikněte na tlačítko Vzorec.

  3. Pomocí dialogového okna Vzorec vytvořte vzorec. Můžete zadat požadovaný vzorec do pole Vzorec, vybrat formát čísla ze seznamu Formát čísla a vložit funkce a záložky pomocí možností Vložit funkci a Vložit záložku.

Aktualizace výsledků vzorců

Ve Wordu se výsledek vzorce vypočítá při jeho vložení a při otevření dokumentu obsahujícího vzorce. V Outlooku se výsledek vzorce vypočítá jenom při jeho vložení a příjemce e-mailu ho nemůže upravit.

Máte také možnost výsledky aktualizovat ručně. Ručně lze aktualizovat:

  • Výsledek jednoho nebo více konkrétních vzorců

  • Výsledky všech vzorců v konkrétní tabulce

  • Všechny kódy polí v dokumentu, včetně vzorců

Aktualizace výsledku konkrétních vzorců

  1. Vyberte vzorce, které chcete aktualizovat. Pokud chcete vybrat více vzorců, podržte klávesu CTRL a postupně vyberte požadované vzorce.

  2. Proveďte jeden z následujících kroků:

    • Klikněte na vzorec pravým tlačítkem myši a potom klikněte na možnost Aktualizovat pole.

    • Stiskněte klávesu F9.

Aktualizace všech výsledků vzorce v tabulce

  • Vyberte tabulku obsahující výsledky vzorce, které chcete aktualizovat, a stiskněte klávesu F9.

Aktualizace všech vzorců v dokumentu

Důležité :  Pomocí tohoto postupu aktualizujete kromě vzorců taky všechny ostatní kódy polí v dokumentu.

  1. Stiskněte kombinaci kláves CTRL+A.

  2. Stiskněte klávesu F9.

Příklady: Součet čísel v tabulce pomocí argumentů pozice

Argumenty pozice (LEFT, RIGHT, ABOVE, BELOW) lze používat s následujícími funkcemi:

  • AVERAGE

  • COUNT

  • MAX

  • MIN

  • PRODUCT

  • SUM

V následujícím příkladu sečtete čísla pomocí funkce SUM a argumentů pozice.

Důležité :  Aby při součtu v tabulce při použití argumentů pozice nedošlo k chybě, zadejte do všech prázdných buněk, které budou součástí výpočtu, hodnotu nula (0).

  1. Vyberte buňku tabulky, ve které chcete zobrazit výsledek. Pokud buňka není prázdná, odstraňte její obsah.

  2. Na kartě Nástroje tabulky - Rozložení ve skupině Data klikněte na tlačítko Vzorec.

  3. V dialogovém okně Vzorec proveďte některou z následujících akcí:

Sečtení čísel…

Zadejte do pole Vzorec následující text.

Nad buňkou

=SUM(ABOVE)

Pod buňkou

=SUM(BELOW)

Nad a pod buňkou

=SUM(ABOVE;BELOW)

Nalevo od buňky

=SUM(LEFT)

Napravo od buňky

=SUM(RIGHT)

Nalevo a napravo od buňky

=SUM(LEFT;RIGHT)

Nalevo od buňky a nad buňkou

=SUM(LEFT;ABOVE)

Napravo od buňky a nad buňkou

=SUM(RIGHT;ABOVE)

Nalevo od buňky a pod buňkou

=SUM(LEFT;BELOW)

Napravo od buňky a pod buňkou

=SUM(RIGHT;BELOW)

  1. Klikněte na OK.

Dostupné funkce

Poznámka :  Vzorce, ve kterých se používají argumenty pozice (například LEFT), nezahrnují hodnoty v řádcích záhlaví.

Ve vzorcích tabulek Wordu a Outlooku jsou k dispozici následující funkce:

Funkce

Akce

Příklad

Vrácená hodnota

ABS()

Vypočítá absolutní hodnotu hodnoty uzavřené v závorkách.

=ABS(-22)

22

AND()

Vyhodnotí, zda jsou všechny argumenty v závorkách pravdivé (TRUE).

=AND(SUM(LEFT)<10;SUM(ABOVE)>=5)

Pokud je součet hodnot nalevo od buňky se vzorcem (na stejném řádku) menší než 10 a součet hodnot nad vzorcem (ve stejném sloupci, přičemž vzorec nepočítá buňky v řádcích záhlaví) je větší než nebo roven hodnotě 5, je výsledkem hodnota 1. V opačném případě je výsledkem hodnota 0.

AVERAGE()

Vypočítá průměr položek uvedených v závorkách.

=AVERAGE(RIGHT)

Průměr všech hodnot napravo od buňky se vzorcem (ve stejném řádku)

COUNT()

Vypočítá počet položky uvedených v závorkách.

=COUNT(LEFT)

Počet hodnot nalevo od buňky se vzorcem (ve stejném řádku)

DEFINED()

Vyhodnocuje, zda je argument v závorkách definován. Pokud argument definován byl, je vyhodnocen jako bez chyby a vrátí hodnotu 1. V případě, že argument definován nebyl, vrátí hodnotu 0, což znamená chybu.

=DEFINED(hruby_prijem)

Pokud byl argument hruby_prijem definován, vrací hodnotu 1 bez chyby. V opačném případě vrátí hodnotu 0.

FALSE

Používá se bez argumentů. Vždy vrací hodnotu 0.

=FALSE

+

IF()

Vyhodnocuje první argument. Pokud je první argument pravdivý (TRUE), vrátí druhý argument. Jestliže první argument pravdivý nebyl (FALSE), vrací třetí argument.

Poznámka :  Je nutné používat právě se třemi argumenty.

=IF(SUM(LEFT)>=10;10;0)

Pokud je součet hodnot nalevo od buňky se vzorcem rovna alespoň hodnotě 10, vrátí hodnotu 10. V opačném případě vrátí hodnotu 0.

INT()

Zaokrouhlí hodnotu v závorkách dolů na nejbližší celé číslo.

=INT(5,67)

17

MAX()

Vrátí maximální hodnotu z položek uvedených v závorkách.

=MAX(ABOVE)

Maximální hodnota nacházející se v buňkách nad vzorcem (vzorec nepočítá buňky v řádcích záhlaví)

MIN()

Vrátí minimální hodnotu z položek uvedených v závorkách.

=MIN(ABOVE)

Minimální hodnota nacházející se v buňkách nad vzorcem (vzorec nepočítá buňky v řádcích záhlaví)

MOD()

Používá se se dvěma argumenty (musí být čísla nebo musí být vyhodnocovány jako čísla). Vrátí zbytek poté, co je druhý argument vydělen prvním. Pokud je zbytek 0 (nula), vrátí hodnotu 0,0.

=MOD(4;2)

0,0

NOT()

Používá se s jedním argumentem. Vzorec vyhodnocuje, zda je argument pravdivý (TRUE). Pokud pravdivý je, vrací hodnotu 0. Jestliže je nepravdivý (FALSE), vrací hodnotu 1. Používá se většinou uvnitř vzorce IF.

=NOT(1=1)

+

OR()

Používá se se dvěma argumenty. Pokud je jeden z nich pravdivý (TRUE), vrací hodnotu 1. Pokud jsou oba nepravdivé (FALSE), vrací hodnotu 0. Používá se většinou uvnitř vzorce IF.

=OR(1=1;1=5)

2,5

PRODUCT()

Vypočítá součin položek uvedených v závorkách.

=PRODUCT(LEFT)

Součin všech hodnot nacházejících se v buňkách nalevo od buňky se vzorcem

ROUND()

Používá se se dvěma argumenty (první argument musí být číslo nebo musí být vyhodnocován jako číslo; druhý argument musí být celé číslo nebo musí být vyhodnocován jako celé číslo). Zaokrouhlí první argument na počet číslic uvedený ve druhém argumentu. Pokud je druhý argument větší než nula (0), je první argument zaokrouhlen dolů na zadaný počet číslic. Pokud je druhý argument nula (0), je první argument zaokrouhlen dolů na nejbližší celé číslo. Jestliže je druhý argument záporný, je první argument zaokrouhlen dolů na číslo vlevo od desetinné čárky.

=ROUND(123,456;2)

=ROUND(123,456;0)

=ROUND(123,456;-2)

123,46

123

1000

SIGN()

Používá se s jedním argumentem, který musí být buď číslo, nebo musí být vyhodnocován jako číslo. vyhodnocuje, zda je položka uvedená v závorkách větší než, menší než nebo rovna nule (0). Pokud je výsledek větší než nula, vrátí hodnotu 1, pokud je výsledek nula, vrátí hodnotu 0, a pokud je výsledek menší než nula, vrátí hodnotu -1.

=SIGN(-11)

-1

SUM()

Vypočítá součet položek uvedených v závorkách.

=SUM(RIGHT)

Součet hodnot buněk napravo od buňky se vzorcem

TRUE()

Používá se s jedním argumentem. Vzorec vyhodnocuje, zda je argument pravdivý (TRUE). Pokud pravdivý je, vrací hodnotu 1. Jestliže je nepravdivý (FALSE), vrací hodnotu 0. Používá se většinou uvnitř vzorce IF.

=TRUE(1=0)

+

Používání názvů záložek (odkazů na buňky) ve vzorci

Na buňku se záložkou lze ve vzorci odkazovat pomocí názvu dané záložky. Pokud jste například vytvořili záložku pro buňku obsahující nebo vyhodnocovanou na číslo s názvem záložky hruby_prijem, zaokrouhlí vzorec =ROUND(hruby_prijem;0) hodnotu dané buňky dolů na nejbližší celé číslo.

Ve vzorcích lze také používat odkazy na sloupce a řádky. Používají se dva styly odkazů: RnCn a A1.

Poznámka :  Buňka obsahující vzorec není zahrnuta do výpočtu, ve kterém se daný odkaz používá. Jestliže je buňka součástí odkazu, je ignorována.

Odkazy typu RnCn

Pomocí pojmenovávací konvence RnCn můžete odkazovat na řádek tabulky, sloupec tabulky nebo buňku vzorce. V rámci této konvence se Rn používá k označení n-tého řádku a Cn k označení n-tého sloupce. Například zápis R1C2 odkazuje na buňku, která je v prvním řádku a druhém sloupci. Příklady tohoto stylu odkazování najdete v následující tabulce.

Cíl odkazu

…použitý styl odkazu

Celý sloupec

Cn

Celý řádek

Rn

Konkrétní buňka

RnCn

Řádek obsahující vzorec

R

Sloupec obsahující vzorec

C

Všechny buňky mezi dvěma zadanými buňkami

RnCn:RnCn

Buňka v tabulce se záložkou

název_záložky RnCn

Oblast buněk v tabulce se záložkou

název_záložky RnCn:RnCn

Odkazy A1

Na buňku, sadu buněk či oblast buněk můžete odkazovat pomocí pojmenovávací konvence pro odkazy typu A1. V rámci této konvence písmeno označuje sloupec buňky a číslo označuje řádek buňky. Prvním sloupcem v tabulce je sloupec A, prvním řádkem v tabulce je řádek 1. Příklady tohoto stylu odkazování najdete v následující tabulce.

Cíl odkazu

…použitý odkaz

Buňka v prvním sloupci a druhém řádku

A2

První dvě buňky v prvním řádku

A1;B1

Všechny buňky v prvním sloupci a první dvě buňky ve druhém sloupci

A1:B2

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Viz taky

Kódy polí ve Wordu a Outlooku

Sdílení Facebook Facebook Twitter Twitter E-mail E-mail

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×