Použití maticových konstant v maticových vzorcích

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

Když zadáváte maticový vzorec, nejčastěji použijete oblast buněk v listu, ale nemusíte. Můžete použít maticové konstanty – hodnoty, které zadáte v řádku vzorců do složených závorek: {}. Potom konstantu můžete pojmenovat, aby šla jednodušeji použít.

Konstanty můžete používat v maticových vzorcích nebo samostatně.

  1. V maticovém vzorci zadejte levou složenou závorku, požadované hodnoty a pravou složenou závorku. Tady je příklad: =SUMA(A1:E1*{1;2;3;4;5})

    Konstanta je uvnitř složených závorek ({}) – a máte pravdu, tyhle závorky musíte zadávat ručně.

  2. Zadejte zbytek vzorce a stiskněte Ctrl+Shift+Enter.

    Vzorec bude vypadat asi takhle: {=SUMA(A1:E1*{1;2;3;4;5})}. Výsledek bude vypadat asi takhle:


    Maticová konstanta vnořená do vzorce SUMA

    Tenhle vzorec vynásobil buňku A1 hodnotou 1, buňku B1 hodnotou 2 atd., a tím vám ušetřil práci s vkládáním hodnot 1, 2, 3, 4, 5 do buněk listu.

Použití konstanty k zadání hodnot do sloupce

Pokud chcete zadat hodnoty do jednoho sloupce, třeba do 3 buněk ve sloupci C, postupujte takhle:

  1. Vyberte buňky, které chcete použít.

  2. Zadejte symbol rovnítka a konstantu. Oddělte hodnoty v konstantě pomocí svislic, ne středníků, a pokud zadáváte text, uzavřete ho do uvozovek. Například: ={"Čtvrtletí 1"|"Čtvrtletí 2"|"Čtvrtletí 3"}

  3. Stiskněte Ctrl+Shift+Enter. Konstanta vypadá takhle:

    Svislá maticová konstanta využívající text

    V jazyce matematiky se jedná o jednorozměrnou svislou konstantu.

Použití konstanty k zadání hodnot do řádku

Pokud chcete rychle zadat hodnoty do jednoho řádku, jako jsou buňky F1, G1 a H1, postupujte takhle:

  1. Vyberte buňky, které chcete použít.

  2. Zadejte symbol rovnítka a svou konstantu. Tentokrát ale hodnoty oddělte středníky, ne svislicemi. Příklad: ={1;2;3;4;5}

  3. Stiskněte Ctrl+Shift+Enter a konstanta bude vypadat takhle:

    Jednorozměrná vodorovná maticová konstanta

    V jazyce matematiky se jedná o jednorozměrnou vodorovnou konstantu.

Použití konstanty k zadání hodnot do několika sloupců a řádků

  1. Vyberte požadované buňky.

    Počet vybraných řádků a sloupců musí odpovídat počtu hodnot ve vaší konstantě. Pokud třeba bude vaše konstanta zapisovat data do čtyř sloupců a tří řádků, vyberte stejný počet sloupců a řádků.

  2. Zadejte symbol rovnítka a konstantu. V tomhle případě oddělte hodnoty v každém řádku středníky a na konci každého řádku použijte svislici. Například:

    ={1;2;3;4|5;6;7;8|9;10;11;12}

  3. Stiskněte Ctrl+Shift+Enter a dostanete:

    Dvourozměrná maticová konstanta

    V jazyce matematiky se jedná o dvourozměrnou konstantu, protože vyplňuje sloupce a řádky. Pokud vás to napadlo, tak třírozměrnou konstantu vytvořit nejde. To znamená, že konstanty do sebe nejde vnořovat.

Použití konstanty ve vzorci

Když teď umíte pracovat s maticovými konstantami, tady máte konkrétní příklad.

  • Do libovolné prázdné buňky A3 zadejte (nebo zkopírujte a vložte) tenhle vzorec a stiskněte Ctrl+Shift+Enter:

    =SUMA(A1:E1*{1;2;3;4;5})

    V buňce A3 se zobrazí hodnota 85.

    Co se stalo? Vynásobili jste hodnotu v buňce A1 hodnotou 1, hodnotu v buňce B2 hodnotou 2 atd. Funkce SUMA potom tyto výsledky sečetla. Tenhle vzorec taky můžete zadat jako =SUMA(A1*1;B1*2;C1*3;D1*4;E1*5)

Kdybyste chtěli, můžete taky obě množiny hodnot zadat jako maticové konstanty:

=SUMA({3;4;5;6;7}*{1;2;3;4;5})

Zkuste to – zkopírujte vzorec, vyberte prázdnou buňku, vložte vzorec do řádku vzorců a stiskněte Ctrl+Shift+Enter. Uvidíte ten samý výsledek.

Poznámky : Pokud vaše konstanty nefungují, zjistěte, jestli nedošlo k těmhle problémům:

  • Hodnoty musí být oddělené správným znakem. Pokud vynecháte středník nebo znak | nebo pokud je umístíte na nesprávném místě, maticová konstanta nemusí vypadat správně nebo se může zobrazit výstražná zpráva.

  • Je možné, že jste vybrali oblast buněk, která neodpovídá počtu prvků v konstantě. Pokud třeba pro použití s 5buňkovou konstantou vyberete sloupec šesti buněk, zobrazí se v prázdné buňce chybová hodnota #NENÍ_K_DISPOZICI. Pokud nevyberete dostatečné množství buněk, Excel hodnoty, které nemají odpovídající buňku, vynechá.

  • Další informace o maticových vzorcích:

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Sdílení Facebook Facebook Twitter Twitter E-mail E-mail

Byly tyto informace užitečné?

Výborně! Je ještě něco dalšího, co byste nám chtěli dát vědět?

Jak bychom ho mohli vylepšit?

Děkujeme vám za zpětnou vazbu.

×