Používání vnořených funkcí ve vzorcích

Důležité :  Tento článek je strojově přeložený – přečtěte si toto upozornění. Anglickou verzi tohoto článku pro referenci najdete tady.

V argumentech vzorců, které používají funkce, je možné používat další funkce. Této činnosti se říká vnořování funkcí a takovéto funkce se nazývají vnořené. Vnoříme-li například funkce PRŮMĚR a SUMA do argumentů funkce KDYŽ, sečte následující vzorec množinu čísel (G2:G5), pouze pokud bude průměr jiné množiny čísel (F2:F5) větší než 50. V opačném případě vrátí 0.

Vnořené funkce

1. na funkce průměr a SUMA jsou vnořené funkce když.

Do jednoho vzorce lze vnořit až 64 úrovní funkcí.

  1. Klikněte na buňku, do které chcete zadat vzorec.

  2. Chcete-li do vzorce vložit funkci, klikněte na tlačítko Vložit funkci  Obrázek tlačítka na řádku vzorců  Obrázek tlačítka .

    Aplikace Excel automaticky vloží symbol rovná se (=).

  3. V poli se seznamem Vybrat kategorii vyberte položku Vše.

    Máte-li zkušenosti s kategoriemi funkcí, můžete také vybrat kategorii.

    Pokud si nejste jisti tím, kterou funkci chcete použít, můžete do pole Vyhledat funkci zadat dotaz, který vystihuje, co si přejete udělat (například text „sečíst čísla“ vrátí funkci SUMA).

    Tipy : 

  4. Pokud chcete jako argument zadat jinou funkci, zadejte ji do požadovaného pole argumentu.

    Části vzorce zobrazené v dialogovém okně Argumenty funkce odpovídají funkci vybrané v předchozím kroku.

    Kliknete-li například na funkci KDYŽ, budou v dialogovém okně Argumenty funkce zobrazeny argumenty funkce KDYŽ. Další funkci vnoříte jednoduše tím, že ji vepíšete do pole s argumenty. Můžete například zadat SUMA(G2:G5) do pole Ano u funkce KDYŽ.

  5. Zadejte další argumenty, které jsou potřebné k dokončení vzorce.

    Namísto zadávání odkazů na buňky stačí vybrat buňku, na kterou chcete odkazovat. Kliknutím na tlačítko Obrázek tlačítka minimalizujte dialogové okno, vyberte buňky, na které chcete odkazovat, a kliknutím na tlačítko Obrázek tlačítka dialogové okno znovu rozbalte.

    Tip : Další informace o funkci a jejích argumentech more získáte kliknutím na položku Nápověda k této funkci.

  6. Po zadání argumentů pro vzorec klikněte na tlačítko OK.

Příklady

Na následujícím obrázku je příklad použití vnořené když testování funkcí k přiřazení oznámkování testu číselného skóre.

Zkopírujte vzorová data v následující tabulce a vložte je do buňky A1 nového excelového sešitu. Aby vzorce zobrazily výsledky, vyberte je, stiskněte F2 a potom stiskněte Enter. Pokud potřebujete, můžete přizpůsobit šířky sloupců a zobrazit si všechna data.

Skóre

45

90

78

Vzorec

Popis

Výsledek

'=KDYŽ(A2>89,"A",KDYŽ(A2>79,"B", KDYŽ(A2>69,"C",KDYŽ(A2>59,"D","F"))))

Použije vnořené podmínky KDYŽ k přiřazení oznámkování testu ke skóre v buňce A2.

=KDYŽ(A2>89,"A",KDYŽ(A2>79,"B",KDYŽ(A2>69,"C",KDYŽ(A2>59,"D","F"))))

'=KDYŽ(A3>89,"A",KDYŽ(A3>79,"B", KDYŽ(A3>69,"C",KDYŽA3>59,"D","F"))))

Použije vnořené podmínky KDYŽ k přiřazení oznámkování testu ke skóre v buňce A3.

=KDYŽ(A3>89,"A",KDYŽ(A3>79,"B",KDYŽ(A3>69,"C",KDYŽ(A3>59,"D","F"))))

'=KDYŽ(A4>89,"A",KDYŽ(A4>79,"B", KDYŽ(A4>69,"C",KDYŽ(A4>59,"D","F"))))

Použije vnořené podmínky KDYŽ k přiřazení oznámkování testu ke skóre v buňce A4.

=KDYŽ(A4>89,"A",KDYŽ(A4>79,"B",KDYŽ(A4>69,"C",KDYŽ(A4>59,"D","F"))))

Začátek stránky

Poznámka : Upozornění ke strojovému překladu: Tento článek přeložil počítačový systém bez zásahu člověka. Společnost Microsoft nabízí tyto strojové překlady proto, aby umožnila uživatelům, kteří nemluví anglicky, získat informace o produktech, službách a technologiích této společnosti. Protože je tento článek strojově přeložený, může obsahovat slovní, syntaktické nebo gramatické chyby.

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×